14:01:17 <jbernard> #startmeeting cinder
14:01:17 <opendevmeet> Meeting started Wed Jul  9 14:01:17 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <opendevmeet> The meeting name has been set to 'cinder'
14:01:21 <jbernard> #topic roll call
14:01:23 <jbernard> o/
14:01:24 <Sai> o/
14:01:37 <harsh> o/
14:01:46 <Luzi> o/
14:01:52 <rosmaita> o/
14:02:21 <hvlcchao1> o/
14:03:48 <gireesh> o/
14:05:17 <jbernard> welcome everyone
14:05:26 <jbernard> #topic annoucements
14:05:27 <tosky_> o/
14:05:32 <hvlcchao1> o/
14:05:48 <jbernard> membership (openinfra) renewal
14:06:00 <jbernard> #link https://openinfra.org/a/renew-membership
14:06:09 <jbernard> this seems to be important
14:06:19 <harsh> done :)
14:06:40 <jbernard> there was a mail earlier this week, deadline is in about 10 days
14:06:44 <rosmaita> i couldn't find the email, but it was easy to renew with the link
14:07:21 <jbernard> mail subject is "Action Required: Renew Your OpenInfra Individual Membership by July 19"
14:07:40 <rosmaita> word on the street is that if your foundation membership had already lapsed, you won't get an email
14:07:45 <jbernard> ahhj
14:08:21 <jbernard> so in summary, fixup your memberships :)
14:08:27 <rosmaita> :D
14:09:17 <jbernard> #topic followup
14:09:31 <jbernard> simondodsley asked about missing sdk commands in teh last meeting
14:09:32 <Vivek__> o/
14:09:49 <jbernard> #link https://etherpad.opendev.org/p/cinder-openstacksdk-gaps
14:10:14 <jbernard> i think rajat would probably know best but I haven't gotten any feedback yet
14:10:24 * jungleboyj sneaks in late
14:10:27 <jbernard> rosmaita: ^ any insights that i may have missed?
14:11:10 <rosmaita> not really, what was the source of that etherpad?
14:11:39 <jbernard> #link https://docs.google.com/spreadsheets/d/1yetPti2XImRnOXvvJH48yQogdKDzRWDl-NYbjTF67Gg/edit?pli=1&gid=1463660729#gid=1463660729
14:11:58 <jbernard> rosmaita: i thinkm simon created it, listing the ones he noticed were missing
14:12:17 <rosmaita> ok, just curious
14:12:18 <jbernard> i haven't had any time to look at the sdk/cli recently
14:12:49 <jbernard> in summary, this is still something i need to followup on
14:14:14 <jbernard> #topic image encryption tempest tests
14:14:22 <jbernard> #link https://review.opendev.org/c/openstack/barbican-tempest-plugin/+/952699
14:14:35 <jbernard> this is very nice to have
14:15:27 <Luzi> mhen finished his work on this
14:15:29 <jbernard> we would like to land the image encryption patch
14:15:32 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/926298
14:15:46 <jbernard> i was able to test it sucessfully locally
14:16:04 <jbernard> but I think now others can review without having to do that, as we now have coverage in the gate
14:16:14 <jbernard> Luzi: am I accurate about that^ ?
14:17:09 <Luzi> am i don't know about patches that depend on each other
14:17:55 <Luzi> i mean the tempest patch clearly depends on the cinder patch, the cinder patch currently does not depend on the tempest patch
14:18:01 <Luzi> is that correct?
14:18:33 <Luzi> btw: the glance patch is needed for this too
14:18:42 <jbernard> that's what im seeing also
14:19:18 <jbernard> basically, we'd like to get this code in sooner as opposed to later in the cycle, so please review if you have the time
14:19:52 <jbernard> Luzi: what is the glance status?
14:20:12 <Luzi> https://review.opendev.org/c/openstack/glance/+/926295 there is 2x +1
14:22:09 <jbernard> #topic ibm driver phone-home
14:22:16 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/951829
14:22:27 <jbernard> im not sure who added this
14:22:48 <Vivek__> hi jbernard
14:23:38 <Vivek__> This is vivek, Im part of IBM SVf cinder driver team. I have recently started contributing to the community.
14:23:48 <jbernard> Vivek__: welcome
14:23:48 <Vivek__> One of my team mate uploaded the patch
14:23:54 <Vivek__> thanks
14:24:27 <jbernard> I took a look at this recently, and i think brian did as well
14:24:35 <rosmaita> yep
14:24:44 <Vivek__> We can discuss on setting the callhome as disabled
14:24:52 <jbernard> im not personally a fan of phone-home, but the enabled-by-default is difficult for me
14:25:23 <Vivek__> We are enabling Callhome support since we are not capturing any sensitive data. The metadata collected includes the OS version, Cinder driver version, deployment type, PBHA status, and replication feature usage.
14:26:26 <rosmaita> It's good that it's not sensitive, but i think it should be "off" by default
14:26:54 <Vivek__> This information helps us understand which features are actively being used by customers, allowing us to better prioritize future enhancements for our driver.
14:27:20 <rosmaita> Yes, and i imagine that most of your customers will decide to opt-in
14:27:34 <rosmaita> but it would be good to give them a choice
14:27:50 <jungleboyj> rosmaita:  ++
14:28:32 <rosmaita> are you thinking that if you ship with it "off", no one will bother to turn it on, and hence you won't get any data?
14:28:43 <Vivek__> Yes, we have introduced a toggle switch in conf to turn it "off".
14:29:31 <jbernard> one issue is that the toggle as written has no discoverability, you have to read the code to know how to do that
14:30:55 <rosmaita> yes, i talked about that in my comment also ... this needs to be defined like a "real" option
14:31:18 <harsh> Hi.. i am Vivek's colleague. his connection seems to have disconnected.
14:31:37 <harsh> rosmaita : yes. thats why we want to ship it with enabled. so that if a customer is unsure about data sharing, can turn it off.
14:31:53 <harsh> jbernard : yes, as there is no readibility except from the code, we want to ship it as enabled and update our driver document : https://docs.openstack.org/cinder/latest/configuration/block-storage/drivers/ibm-storwize-svc-driver.html
14:32:17 <rosmaita> harsh: i think it needs to be documented like any other option
14:32:56 <harsh> correct. we will add it in the documents.
14:33:17 <rosmaita> not just the documentation, it should show up in the sample config file
14:33:28 <jungleboyj> ++
14:33:30 <rosmaita> see my comment from yesterday on the patch
14:33:47 <harsh> we dont want to miss out on the customer info to ma
14:33:54 <jbernard> i am personally against on-by-default, i think packagers/vendors can set it differently, but the upstream/opensource version should not default to enabled
14:34:13 <rosmaita> personally, i do not like the opt-out model ... i suggest that you ship with it off by default, but all your sample docs can show turning it on
14:34:15 <harsh> to enhance the driver as per the features that are actually being utiliised by the user.
14:35:14 <Vivek__> sorry my chat session got disconnected due to some network issue.
14:35:18 <harsh> okay.. thanks for your suggestions rosmaita and jbernard . I will take your inputs to my team
14:35:19 <rosmaita> i guess a key issue here is, do we have any other examples of a vendor call-home feature in openstack that is shipped "on" by default
14:36:13 <harsh> We don't have that info as of now. anyone else has any idea ?
14:36:49 <jungleboyj> I am not aware of any.
14:36:59 <rosmaita> i am not aware of anything in cinder, but neutron and manila have third party backends too
14:37:52 <rosmaita> i'm mentioning it because i think without a precedent, it will be a difficult sales job to the community to have this thing "on" by default
14:38:11 <harsh> i understand
14:38:23 <rosmaita> ok
14:38:29 <harsh> we try to find out if there is any precedent..
14:39:06 <Vivek__> Netapp have activeIQ and Dell have Unisphere / Telemetry, we may need to check how they are enabling it
14:39:47 <rosmaita> that would be good info to have
14:39:54 <rosmaita> anyone here today from netapp or dell?
14:42:33 <Anoop_Shukla> Yes. NetApp telemetry is pushed to ONTAP via EMS and when we collect ASUP data, traces of telemetry can be mined out.
14:43:00 <Anoop_Shukla> ASUP - AutoSupport
14:44:08 <Vivek__> So support for NetApp telemetry is set to enabled or disabled while driver init ?
14:44:49 <jbernard> #link https://github.com/openstack/cinder/blob/master/cinder/volume/drivers/netapp/utils.py#L570
14:46:03 <Anoop_Shukla> As far as I know, customers can toggle ASUP on ONTAP storage or be on dark sites. Cinder/Manila would always post EMS to ONTAP.
14:47:10 <harsh> So cinder is on-by-default as i understand..
14:47:11 <Vivek__> Similarly we are setting it to "on" in order we can capture the metadata and derive the feature details.
14:51:49 <jbernard> ok, i at least need some time to look at netapp and think on things, lets revisit this in the next meeting.  we may need to take a vote, or elevate this to the TC for input, more thought is needed
14:52:19 <jbernard> i do understand the argument
14:52:43 <jbernard> #action sdk gaps
14:52:51 <harsh> yes sure.. thankyou :) we can have a followup in the next meeting.
14:52:56 <jbernard> #action call home defaults followup
14:53:26 <Vivek__> thanks
14:53:49 <jbernard> #topic powerscale driver rename in manilla
14:53:52 <jbernard> #link https://review.opendev.org/c/openstack/manila/+/952736
14:54:17 <jbernard> im not clear on how this relates to cinder, can someone take this?
14:55:01 <jbernard> i suspect a similar rename is needed in cinder
14:55:33 <jbernard> which shouldn't be a problem
14:55:44 <jbernard> so this may not need discussion
14:56:37 <rosmaita> hopefully not, these renames are a real PITA
14:58:46 <gireesh> https://www.irccloud.com/pastebin/AuzWFywF/
14:59:29 <gireesh> There are couple of review pending for NetApp driver please have a look into those
14:59:37 <gireesh> https://www.irccloud.com/pastebin/Fov4BdmM/
15:00:15 <jbernard> we're nearly at time, last call
15:01:25 <jbernard> ok, thanks everyone, i know there are reviews waiting, we've been getting to some of them, still many to go but we're makign progress, appreciate the patience
15:01:28 <jbernard> #endmeeting