14:48:53 <enriquetaso> #startmeeting cinder_bs
14:48:54 <openstack> Meeting started Wed Apr 7 14:48:53 2021 UTC and is due to finish in 60 minutes. The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:48:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:48:57 <openstack> The meeting name has been set to 'cinder_bs'
14:49:02 <enriquetaso> #link https://etherpad.opendev.org/p/cinder-bug-squad-meeting
14:49:07 <enriquetaso> #topic roll call
14:49:15 <rosmaita> o/
14:49:18 <eharney> hey
14:49:36 <enriquetaso> We have 5 new bugs this week. Lucky half of them have already a fix proposed.
14:49:42 <rosmaita> nice
14:49:45 <enriquetaso> not much on the agenda today, only one bug and then we can continue with the open discussion in case something comes up.
14:50:00 <enriquetaso> #topic bug_1: " Top-level client doesn't support auth v3"
14:50:06 <enriquetaso> #link https://bugs.launchpad.net/python-cinderclient/+bug/1922749
14:50:07 <openstack> Launchpad bug 1922749 in python-cinderclient "Top-level client doesn't support auth v3" [Low,New]
14:50:14 <enriquetaso> Summary: The top-level client (cinderclient.v3.Client) doesn't support auth v3 when it uses the HTTPClient: the user_domain_name and project_domain_name parameters can be propagated to the HTTPClient.
14:50:32 <enriquetaso> My concern here is I'm not sure if this is a valid bug. As far as I know, we support v3 https://docs.openstack.org/api-ref/identity/v3/
14:50:49 <rosmaita> i thought so too
14:50:51 <eharney> it does seem like there may be additional details needed
14:50:52 <enriquetaso> what are your thoughts?
14:51:23 <enriquetaso> "Note this client is used by Glance via the glance_store library."
14:51:34 <enriquetaso> yep, looks like I could ask for more details
14:51:35 <rosmaita> it could be that we never implemented the domain stuff
14:51:49 <eharney> have we not tested glance's cinder driver w/ keystone v3?
14:52:12 <rosmaita> "it works in devstack"
14:52:18 <enriquetaso> I think we added a ci job for that
14:52:28 <tosky> rosmaita: and tripleo
14:52:55 <openstackgerrit> Eric Harney proposed openstack/cinder master: Update to pylint 2.7.4 https://review.opendev.org/c/openstack/cinder/+/785193
14:52:58 <rosmaita> enriquetaso: i think it's reasonable to ask for more details about what's missing
14:53:12 <enriquetaso> sure
14:53:29 <enriquetaso> #action (enriquetaso) ask for more details in the report bug case
14:53:50 <enriquetaso> #topic Open Discussion
14:55:01 <enriquetaso> Maybe it's a good time to say that the 'encryption header' related bugs keep coming
14:55:14 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1922408
14:55:16 <openstack> Launchpad bug 1922408 in Cinder " create volume from snapshot will lose encrypted head when source volume is encrypted in RBD." [Medium,In progress] - Assigned to haixin (haixin77)
14:55:27 <enriquetaso> but this time it's related to snapshots
14:55:58 <enriquetaso> but there's already a patch proposed
14:56:09 <eharney> yeah, it's worth noting that these behave a little differently on RBD (and maybe NFS) vs most other drivers/areas
14:56:24 <eharney> silently truncating data rather than failing
14:56:53 <eharney> we need some tempest tests that do a bit more i/o and data testing on volumes/snapshots than what we have currently
14:56:58 <rosmaita> i wonder if we should add a "Known Issues" to the wallaby release notes?
14:57:07 <eharney> i might end up writing one if nobody else volunteers before i get to it
14:57:07 <rosmaita> silently truncating data is bad
14:57:20 <eharney> probably not a bad idea
14:57:57 <enriquetaso> #action add tempest tests that do a bit more i/o and data testing on volumes/snapshots than what we have currently
14:58:03 <eharney> it shows up at least on a) image->volume with the RBD volume driver and certain permutations of encryption and b) snap->clone volume with the RBD driver
14:58:15 <enriquetaso> #action add a "Known Issues" to the wallaby release notes
14:58:32 <eharney> i don't know if there are other situations where it may be silently broken, but nfs needs a look
15:00:24 <enriquetaso> Yes, nfs as well
15:00:42 <enriquetaso> I think that would be it for this week.
15:01:10 <enriquetaso> if no one else has a topic to discuss :)
15:02:56 <rosmaita> i'll draft a release note about the rbd encryption issues, and you two can add comments to it to make it accurate
15:03:08 <enriquetaso> thanks rosmaita
15:03:40 <rosmaita> np, i will ping you in a half hour or so
15:03:58 <enriquetaso> OK, i'm going to close the mtg
15:04:08 <enriquetaso> end*
15:04:27 <enriquetaso> #endmeeting