15:00:41 <enriquetaso> #startmeeting cinder_bs
15:00:42 <openstack> Meeting started Wed Apr 14 15:00:41 2021 UTC and is due to finish in 60 minutes.  The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <openstack> The meeting name has been set to 'cinder_bs'
15:00:52 <enriquetaso> #link https://etherpad.opendev.org/p/cinder-bug-squad-meeting
15:01:08 <rosmaita> o/
15:01:11 <enriquetaso> Hello
15:01:15 <enriquetaso> quick one today
15:01:27 <enriquetaso> We have 4 bugs related to quotas - as you can see in today's email, but luckily assigned and probably in progress- and one that I can't completely figure out but I think it's invalid.
15:01:46 <enriquetaso> #topic bug_1 "Volume backup deletion leaves orphaned files on object storage"
15:01:51 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1922939
15:01:53 <openstack> Launchpad bug 1922939 in Cinder "Volume backup deletion leaves orphaned files on object storage" [Undecided,New]
15:01:57 <enriquetaso> Summary: Ceph  backup driver -  deleting a volume backup for a project within a domain (such as a customer domain+project), deletes the cinder record in the database, but leaves the backup files orphaned on the object storage. This leaves quite a mess when trying to clean up old backups.
15:02:16 <enriquetaso> As far as I know, It's correct that Cinder only deletes the record in the database, right? But I'm not sure about the reason I can give the reporter to close the bug, maybe harney may help me and have better paraphraser than I do.
15:02:25 <enriquetaso> eharney, ^
15:02:43 <eharney> well, it needs to delete the files on the backend when the backup is deleted
15:02:52 <eharney> but the bug doesn't say what backup driver is being used so not sure what is going on there
15:03:36 <eharney> oh, i guess it's the ceph backup driver
15:03:43 <enriquetaso> i think so
15:03:47 <rosmaita> and we should ask for a debug output from openstackclient so we can see what api calls it's making
15:04:22 <eharney> if it fails to delete the data from the backend, the cinder backup log should show something
15:04:30 <enriquetaso> #action enriquetaso ask for debug output from openstackclient
15:04:49 <enriquetaso> sounds good, so I won't close it as invalid then
15:05:09 <rosmaita> also ask for lines from the c-bak log, like eric said
15:05:09 <enriquetaso> next one
15:05:18 <enriquetaso> ++
15:06:05 <enriquetaso> #topic bug_2 "iSCSI: Flushing issues when multipath config has changed"
15:06:10 <enriquetaso> #link https://bugs.launchpad.net/os-brick/+bug/1921381
15:06:12 <openstack> Launchpad bug 1921381 in os-brick ussuri "iSCSI: Flushing issues when multipath config has changed" [Critical,In progress] - Assigned to Luigi Toscano (ltoscano)
15:06:16 <enriquetaso> I know Brian mentioned it  several times, but we'd like this patch merged in stable/queens, right?
15:06:22 <enriquetaso> I've proposed a backport for stable/stein that need update:
15:06:23 <enriquetaso> #link https://review.opendev.org/c/openstack/os-brick/+/785383
15:07:04 <rosmaita> i think we want to merge as far back as it can go
15:07:52 <enriquetaso> sounds good
15:07:55 <rosmaita> how the heck are we getting pep8 problems in stein that didn't show up in train through wallaby?
15:08:10 <enriquetaso> good question
15:08:24 <eharney> incorrect merge conflict resolution
15:08:27 <eharney> <<< lines
15:08:55 <rosmaita> i should've looked at the output!
15:09:03 <rosmaita> yeah, that is unsafe at any speed
15:09:11 <enriquetaso> yes... used the opendev tool to backport and I hadn't manually correct them
15:09:32 <rosmaita> did the train patch merge?
15:09:43 <enriquetaso> yes
15:09:48 <enriquetaso> #link https://review.opendev.org/c/openstack/os-brick/+/784097
15:10:52 <rosmaita> ok, i was a little worried about that one because train supports py2 and py3 (though i didn't see anything specific to make me worry)
15:11:15 <rosmaita> as we get into the older branches, we'll have to be more and more careful
15:11:41 <enriquetaso> true
15:12:36 <enriquetaso> i'll do the backports manually to avoid this in the future
15:13:08 <rosmaita> that's ok, only one way to find out that there will be a problem!
15:13:13 <rosmaita> and you found it out
15:13:38 <enriquetaso> thanks Brian
15:13:45 <enriquetaso> OK, nothing else so far
15:13:46 <enriquetaso> #topic Open Discussion
15:14:01 <enriquetaso> I've been looking for old patches but I'm still working on them
15:15:26 <enriquetaso> I'll end the meeting as I think it's all for today
15:15:58 <openstackgerrit> Jon Bernard proposed openstack/cinder master: RBD: use correct stripe size in clone operation  https://review.opendev.org/c/openstack/cinder/+/786260
15:16:07 <enriquetaso> #endmeeting