15:01:21 <enriquetaso> #startmeeting cinder_bs
15:01:21 <opendevmeet> Meeting started Wed Mar  9 15:01:21 2022 UTC and is due to finish in 60 minutes.  The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:21 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:21 <opendevmeet> The meeting name has been set to 'cinder_bs'
15:01:29 <enriquetaso> Welcome to Cinder Bug Meeting
15:01:29 <enriquetaso> Cinder has 2 bugs reported this week.
15:01:29 <enriquetaso> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-March/027625.html
15:02:14 <enriquetaso> #topic [powerstore driver]: no volume caching after 35 volumes.
15:02:14 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1962824
15:02:14 <enriquetaso> The driver needs to add a "SnapshotLimitReached" to invalidate cache on the limit. Looks valid and needs a patch.
15:03:06 <enriquetaso> Moving on.
15:03:17 <enriquetaso> #topic Don't require control-location for creating encrypted volume types.
15:03:17 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1964145
15:03:17 <enriquetaso> Summary: We shouldn't require "control-location" on encrypted type creation -- just default to "front-end" if one is not supplied.
15:03:30 <enriquetaso> The full discussion and work is going on the patch.
15:03:30 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/677862
15:03:35 <eharney> this doesn't have a patch proposed for it
15:04:00 <eharney> but, basically, we require specifying control-location when creating an encrypted type, even though everyone always wants "front-end", so we should do that by default
15:04:17 <eharney> (and probably drop support for back-end IMO but that's a whole additional project)
15:05:01 <enriquetaso> OK, I've misunderstood the bp
15:06:17 <enriquetaso> thanks eharney for clarifying
15:07:08 <dc_arunkv> Thanks rosmaita, I will do it.
15:07:22 <rosmaita> that's a widening change, so won't require a new microversion
15:07:25 <rosmaita> dc_arunkv: ty
15:07:45 <rosmaita> the "widening change" was about the control-location
15:07:52 <enriquetaso> if we would like to drop support for back-end, should we create a new bp or use that one eharney ?
15:08:09 <eharney> that bug is just about setting a default control-location behavior
15:08:20 <eharney> i don't know if we need a bp
15:08:44 <enriquetaso> sorry, not a bp, a new bug..
15:08:51 <eharney> i'm not sure if any drivers attempt to implement backend encryption any more, at one point i think one did
15:09:01 <eharney> i'll have to look around at that
15:09:41 <enriquetaso> #action: drop support for back-end ?
15:09:50 <enriquetaso> thanks
15:10:22 <enriquetaso> Moving on..
15:10:32 <enriquetaso> #topic Open Discussion
15:10:59 <rosmaita> i can't believe i reviewed that patch 2 years ago
15:11:55 <enriquetaso> OK
15:12:01 <enriquetaso> thanks for attending!
15:13:40 <enriquetaso> oh, i'll be on PTO, so no meeting next week!
15:13:58 <rosmaita> ok, enjoy your PTO
15:14:03 <enriquetaso> #endmeeting