15:02:21 <enriquetaso> #startmeeting cinder_bs
15:02:21 <opendevmeet> Meeting started Wed Apr 13 15:02:21 2022 UTC and is due to finish in 60 minutes.  The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:21 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:21 <opendevmeet> The meeting name has been set to 'cinder_bs'
15:02:30 <enriquetaso> Welcome to the Cinder Bug Meeting
15:02:32 <whoami-rajat> Hi
15:02:37 <enriquetaso> hi
15:02:38 <enriquetaso> Four new bugs reported in this period of two weeks. Not bad.
15:02:45 <rosmaita> o/
15:02:49 <enriquetaso> You can check the full report here:
15:02:49 <enriquetaso> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-April/028171.html
15:02:58 <enriquetaso> #topic Encryptor connect_volume not changing the symlink
15:03:04 <enriquetaso> #link https://bugs.launchpad.net/os-brick/+bug/1967790
15:03:23 <enriquetaso> This is a high importance bug that we discussed last week.
15:03:23 <enriquetaso> Feel free to review geguileo patch::
15:03:23 <enriquetaso> #link https://review.opendev.org/c/openstack/os-brick/+/836391
15:04:21 <eharney> i'll be reviewing it
15:04:51 <enriquetaso> thanks eharney
15:05:06 <enriquetaso> moving on..
15:05:15 <enriquetaso> #topic cinder-manage db sync fails due to row size too large
15:05:20 <opendevreview> Francesco Pantano proposed openstack/devstack-plugin-ceph master: Deploy with cephadm  https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/826484
15:05:21 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1968746
15:05:29 <rosmaita> i've been thinking about this one
15:05:35 <enriquetaso> Running the cinder-manage db sync to upgrade to Xena from Wallaby resulted in error. The reporter has cluster since Kilo and  fix the problem manually changing row_format from 'Compact' to 'Dynamic' by running: ALTER TABLE volumes ROW_FORMAT=DYNAMIC;
15:05:39 <rosmaita> probably a "won't fix"
15:05:43 <enriquetaso> Not sure if this is a particular case or if I should close the bug.
15:05:46 <enriquetaso> thanks rosmaita
15:06:09 <rosmaita> i think maybe the thing to do is put a statement somewhere in our docs about what versions we test with/support
15:06:21 <rosmaita> basically the db versions packaged with the supported operating systems
15:06:30 <eharney> because new versions of mysql don't hit this?
15:06:36 <rosmaita> right
15:06:47 <eharney> makes sense to me
15:07:17 <enriquetaso> #action: add statement of the mysql version supported
15:07:26 <rosmaita> but, it's good to have the bug because it does bring up some issues that maybe we need to pay attention to
15:07:37 <rosmaita> enriquetaso: assign the bug to me and i will follow up
15:08:04 <enriquetaso> done
15:08:07 <enriquetaso> thanks brian!
15:08:11 <rosmaita> thanks!
15:08:15 <enriquetaso> #topic Concurrent migration of vms with the same multiattach volume fails
15:08:21 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1968645
15:08:30 <enriquetaso> Attaching one volume to multiple vms and trying to migrate all the vms at the same time fails. The report mentioned that the reason for the failure of vm migration is that the multiattach volume status changes to attaching after the vm migration process. At this time, when another vm migrates, it is judged that the volume status is attaching, which leads to the execution of attachment_create fail.
15:08:30 <enriquetaso> No fix proposed to master yet.
15:09:07 <enriquetaso> I'm not sure if we have a tempest test for a case like this one
15:09:57 <rosmaita> i suspect not, that's quite a scenario
15:10:16 <rosmaita> though kind of a common scenario, i guess, when you look at it
15:10:28 <eharney> i suspect that a fix stopping this from the Nova side might be a better short term goal than a Cinder fix, but not sure
15:11:07 <enriquetaso> stopping the migration ?
15:11:16 <geguileo> eharney: +1
15:11:19 <eharney> this happens because our state management with multiattach volumes is stretched in odd ways when using multiattach
15:11:26 <geguileo> enriquetaso: not allowing 2 concurrent migrations that share a volume
15:11:27 <eharney> i'm not sure we can do much about it without large API changes
15:11:53 <tosky> enriquetaso: I confirm we don't have a tempest test for that
15:12:05 <eharney> right, a more tactical fix in Nova like what geguileo suggests seems much easier
15:12:15 <geguileo> we may be able to make it work with current API, but it would still be a Nova fix
15:12:40 <enriquetaso> cool, maybe I can add a comment with all this discussion on the bug report and see what nova team thinks
15:13:00 <enriquetaso> +1
15:13:11 <eharney> this should probably also be documented a known issue somewhere since it would be a problem for evacuations etc
15:13:16 <geguileo> enriquetaso: I would literally either kick it to the nova component or add the nova component to the bug
15:13:40 <enriquetaso> geguileo, the nova component is already added
15:13:56 <geguileo> because I think it may just be an issue that Nova needs to wait a second and then it would work
15:14:00 <geguileo> enriquetaso: ok
15:14:18 <enriquetaso> #action: document this as known issue
15:14:27 <geguileo> it may just be that there's a race condition between the 2...
15:14:43 <geguileo> or maybe not...
15:14:58 <geguileo> I don't remember clearly the state transitions of the volume in that case  :-(
15:15:45 <enriquetaso> excellent
15:16:11 <enriquetaso> I'll add a comment on the bug report  tho
15:16:16 <enriquetaso> Last one
15:16:21 <enriquetaso> #topic reimage_volume failure message action does not exist
15:16:28 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1968170
15:16:36 <eharney> so, one note on this one
15:16:51 <enriquetaso> sure
15:17:05 <eharney> it's just broken code, and i found this trivially with pylint
15:17:16 <eharney> we are missing out on finding such things because our pylint gate job is not very useful
15:17:17 <geguileo> pylint++
15:17:30 <eharney> i might change it soon to make it do what it actually should do
15:17:51 <enriquetaso> #action: update pylint job
15:18:08 <enriquetaso> Marked as low-hanging-fruit in case interns are looking for small bugs.
15:18:10 <eharney> the behavior of it only looking at files that your patch touches is just confusing to people, and it means that we merge broken things and then never see the messages
15:18:32 <enriquetaso> that's bad :(
15:18:40 <eharney> and then someone touches a file two years later and sees a bunch of failures unrelated to what they were actually doing
15:18:44 <eharney> it's not great
15:19:44 <enriquetaso> We have a plan to fix it then, thanks Eric
15:19:53 <enriquetaso> #topic Open Discussion
15:20:08 <enriquetaso> Feel free to proposed any bug here
15:25:24 <enriquetaso> OK, nothing. See you next week!
15:25:35 <enriquetaso> #endmeeting