15:07:46 <enriquetaso> #startmeeting cinder_bs
15:07:46 <opendevmeet> Meeting started Wed Apr 27 15:07:46 2022 UTC and is due to finish in 60 minutes.  The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:46 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:46 <opendevmeet> The meeting name has been set to 'cinder_bs'
15:07:55 <enriquetaso> 12 new bugs reported this period! I'll try to cover all of them today.
15:07:55 <enriquetaso> Please check full report:
15:07:55 <enriquetaso> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-April/028332.html
15:08:03 <enriquetaso> #topic  backport of the fix for bug #1947370 make lock_path a requird config option when prvisouls it was optional
15:08:12 <enriquetaso> #link https://bugs.launchpad.net/os-brick/+bug/1969794
15:08:12 <enriquetaso> Please keep an eye on this bug.
15:08:41 <enriquetaso> as part of a os-brick bugfix made the external lock_path config option required with no default provided
15:08:41 <enriquetaso> #link https://review.opendev.org/c/openstack/os-brick/+/814139
15:09:00 <enriquetaso> However, Please read Sean comment #1 becasue he proposed a solution to this.
15:09:45 <enriquetaso> #topic Simultaneous volume creation with the same image in multi-attach mode returns error
15:09:56 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1969373
15:11:43 <enriquetaso> #topic  NetApp NFS Storage Migration between backends is Failing
15:11:51 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1969531
15:13:45 <enriquetaso> #topic  Wrong property to look up remote address
15:13:55 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1967683
15:13:55 <enriquetaso> The webob.Request class does not have the remote_address attribute but
15:13:55 <enriquetaso> the remote_addr attribute. We need to update the attribute accordingly.
15:13:55 <enriquetaso> Fix proposed to maste https://review.opendev.org/c/openstack/cinder/+/836247
15:13:55 <enriquetaso> #topic Complex config formula evaluation causes RecursionError
15:13:57 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1966904
15:14:17 <geguileo> whoami-rajat: I added a comment on the original bug report https://bugs.launchpad.net/cinder/+bug/1940466/comments/9
15:14:27 <whoami-rajat> rosmaita, should we stop sharing etherpad?
15:14:38 <geguileo> some time ago, explaining why it was still relevant for Cinder
15:14:42 <geguileo> (to add the doc)
15:14:57 <whoami-rajat> geguileo, oh ok, totally forgot about the doc part, thanks for mentioning it
15:15:03 <geguileo> np
15:15:50 <enriquetaso> Fix proposed to master
15:15:50 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/835635
15:16:20 <enriquetaso> #topic  RBD: Unable to delete a volume which has snapshot/volume children
15:16:36 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1969643
15:17:09 <enriquetaso> Tempest test for this
15:17:09 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/823719
15:18:45 <whoami-rajat> jfyi, I've also proposed a patch for recursion limit thing but currently failing on CI if anyone wants to take a look -- https://review.opendev.org/c/openstack/cinder/+/835553
15:20:03 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/838757
15:20:10 <eharney> https://review.opendev.org/c/openstack/cinder/+/835384
15:20:55 <enriquetaso> #topic [Documentation] Migration in cinder, lvm-rbd example is not correct
15:21:09 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1969913
15:21:10 <enriquetaso> The bug report says that lvm to rbd migration for live VMs  works fine so the documentation is not accurate.
15:21:10 <enriquetaso> #link https://opendev.org/openstack/cinder/src/commit/3e068b5ce0990a576b55fea952319884c5c0ed6d/doc/source/contributor/migration.rst
15:21:10 <enriquetaso> Maybe we can have a volunteer to try this out and see if we should update the documentation.
15:23:19 <enriquetaso> #action: move to incomplete and ask what's the goal of this?
15:23:40 <enriquetaso> #topic [RBD] Multiple full backups cannot be created from one snapshot
15:23:44 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1970237
15:26:11 <enriquetaso> #topic [rebranding] Dell EMC will be renamed to Dell
15:26:17 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1970208
15:26:32 <whoami-rajat> who would've thought?
15:26:33 <enriquetaso> Fix proposed to master
15:26:33 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/839223
15:28:18 <enriquetaso> #topic [Enhancement] No way to disable image conversion.
15:28:34 <whoami-rajat> I assume there will be a patch changing the directory name -- https://github.com/openstack/cinder/tree/master/cinder/volume/drivers/dell_emc
15:30:13 <rosmaita> https://bugs.launchpad.net/cinder/+bug/1970114
15:30:28 <whoami-rajat> https://bugs.launchpad.net/cinder/+bug/1970114
15:31:24 <enriquetaso> #topic  [Enhancement] Image conversion with RBD is not efficient
15:31:34 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1970114
15:31:39 <enriquetaso> thanks!
15:31:58 <enriquetaso> #topic  [Pure Storage] Replicated arrays communication failure not handled correctly
15:32:10 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1969784the loss of one of the arrays - be it primary or secondary, network issue (e.g. no reachability) or storage issue (e.g. pod down) - causes the Cinder driver to stop working in some or even all aspectsThe ugly workaround is to reconfigure cinder-volume and restart it each time there was a problem with storage array, which isinflexible and prevents automatic failure recovery.No fix
15:32:10 <enriquetaso> proposed to master yet.
15:34:59 <enriquetaso> #endmeeting