15:03:42 <enriquetaso> #startmeeting cinder_bs
15:03:42 <opendevmeet> Meeting started Wed Nov 16 15:03:42 2022 UTC and is due to finish in 60 minutes.  The chair is enriquetaso. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:42 <opendevmeet> The meeting name has been set to 'cinder_bs'
15:03:59 <enriquetaso> ganso, whoami-rajat
15:04:07 <enriquetaso> do you want to discuss the topic now?
15:04:15 <enriquetaso> It will be recorded on the bug meeting
15:04:16 <ganso> yea very quick
15:04:28 <ganso> it is just an FYI on https://review.opendev.org/c/openstack/cinder/+/812685
15:04:30 <whoami-rajat> I've no issues now or later
15:04:50 <enriquetaso> #topic Filter reserved image properties
15:04:55 <ganso> we had a lot of interesting discussion on that patch, at some point we intended to have a discussion here
15:04:57 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/812685
15:05:13 <ganso> but it seems that yesterday we ended up agreeing on the approach
15:05:19 <rosmaita> ganso: what's your real name? (are you Rodrigo or Rafael?)
15:05:22 <ganso> so it might need not a discussion
15:05:28 <ganso> rosmaita: I'm Rodrigo
15:05:32 <rosmaita> ok, thanks
15:06:13 <ganso> so I suppose Rafael is changing the patch to have the metadata removed only on upload-back-to-glance
15:06:40 <ganso> if anyone disagrees or would like to discuss it further, we can do so, otherwise, might not need any further discussing
15:06:58 <whoami-rajat> I also kind of agree on that approach
15:07:16 <whoami-rajat> if glance doesn't want to supply some metadata to the consumer (nova, cinder) then glance should not supply it in the first place
15:07:32 <whoami-rajat> if glance is supplying it then it makes sense to keep it and only filter out when it creates issues
15:08:19 <rosmaita> not surprisingly, i agree with that
15:09:02 <whoami-rajat> that provides us flexibility, since once metadata is removed, we can't recover it but if it stays, we can always filter it later
15:10:58 <whoami-rajat> so +1 to rosmaita's suggestion
15:11:09 <whoami-rajat> ganso, anything else on this? don't want to block enriquetaso's meeting for long :)
15:11:28 <ganso> whoami-rajat: nothing else =)
15:11:41 <ganso> thanks enriquetaso for this meeting
15:11:45 <whoami-rajat> great, thanks
15:11:49 <enriquetaso> cool
15:11:56 <whoami-rajat> thanks enriquetaso !
15:11:59 <enriquetaso> OK, Only one bug for today's meeting. List of bugs:
15:12:05 <enriquetaso> no worries
15:12:06 <enriquetaso> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-November/031212.html
15:12:09 <enriquetaso> #topic Cinderlib Gate broken in Zed
15:12:15 <enriquetaso> #link https://bugs.launchpad.net/cinderlib/+bug/1996738
15:12:18 <enriquetaso> As discussed last week at the cinder meeting. I've opened a bug for the cinderlib gate failures.
15:12:24 <enriquetaso> whoami-rajat, rosmaita
15:12:26 <enriquetaso> ^
15:12:30 <enriquetaso> Let me know if the description is wrong so I can update it.
15:12:49 <rosmaita> looks good, thank you for filing the bug
15:13:02 <whoami-rajat> i don't see "horribly broken" in title but it should be fine
15:13:08 <enriquetaso> lol
15:13:15 <enriquetaso> i can update the title :P
15:13:22 <rosmaita> enriquetaso: you should!
15:13:30 <whoami-rajat> looks good, thanks for reporting it
15:13:38 <enriquetaso> #action: (enriquetaso) update the titel
15:13:42 <enriquetaso> title*
15:13:45 <enriquetaso> OK, moving on
15:13:57 <rosmaita> ok, i will assign it to myself with the goal of reporting status at the festival of bugs on friday
15:14:25 <enriquetaso> thanks
15:14:28 <whoami-rajat> rosmaita++
15:14:36 <enriquetaso> #topic "[OpenStack Yoga] Creating a VM fails when stopping only one rabbitmq.
15:14:44 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1990257
15:14:52 <enriquetaso> I've removed cinder from that bug
15:15:12 <enriquetaso> it doesn't look like a cinder bug, but if you think it should, please let me know
15:15:20 <enriquetaso> #topic open discussion
15:15:45 <enriquetaso> any bugs to discuss ?
15:15:53 <rosmaita> circling back to that cinderclient snapshot-create fix, i think we should backport it as far as xena
15:15:56 <rosmaita> that's bug https://bugs.launchpad.net/python-cinderclient/+bug/1995883
15:16:25 <whoami-rajat> we need more info on 1990257, if they're creating the instance BFV then it might be a cinder problem
15:16:42 <rosmaita> i think we need to un-target from Wallaby, and add Zed, Yoga, and Xena instead
15:16:44 <enriquetaso> ture
15:16:46 <enriquetaso> true
15:17:04 <whoami-rajat> i will add a comment there
15:17:44 <enriquetaso> #action(enriquetaso): un-target wallaby and add zed, yoga and xena for bug1990257
15:17:51 <enriquetaso> thanks whoami-rajat
15:18:59 <enriquetaso> thanks for updating rosmaita
15:19:29 <rosmaita> np, i actually brought it up becasue i didn't know if you've used the "target to series" functionality in launchpad?
15:19:44 <enriquetaso> i'm trying to use them yes
15:20:02 <rosmaita> cool, we have an action item for jon bernard on this
15:20:18 <enriquetaso> jbernard :)
15:20:38 <rosmaita> it's showing that you can nominate kilo through wallaby ... x, y, z aren't available
15:20:59 <enriquetaso> #action: add a comment in 1990257 asking if they are using intance BFV
15:21:12 <enriquetaso> :/
15:21:13 <whoami-rajat> enriquetaso, added a comment
15:21:21 <rosmaita> oh, that may be because you already did the targeting
15:21:33 <enriquetaso> i've updated it rosmaita
15:21:38 <enriquetaso> yes, sorry
15:21:42 <rosmaita> not sure why it picked Zed as the tracking branch, though
15:22:01 <enriquetaso> yes.. that's wrong
15:22:21 <enriquetaso> i'll let you do it, maybe multiple updates from diff people confuses launchpad
15:22:45 <rosmaita> no, it's a launchpad thing, nothing you did
15:23:05 <enriquetaso> thanks!
15:23:10 <rosmaita> the 2023.1 series isn't defined for cinderclient yet
15:23:27 <rosmaita> and Zed is showing as the focus of development ... so that's why the bug is tracking zed
15:24:18 <enriquetaso> the fix is in master tho
15:24:55 <rosmaita> yeah, but launchpad only knows about the releases we tell it about
15:25:07 <enriquetaso> u.u OK
15:25:18 <enriquetaso> Do we have any other bug to discuss?
15:27:20 <enriquetaso> OK, closing the meeting then :)
15:27:23 <enriquetaso> thank you!!
15:27:28 <whoami-rajat> thanks enriquetaso
15:27:31 <enriquetaso> #endmeeting