17:00:11 <ildikov> #startmeeting cinder-nova-api-changes
17:00:22 <openstack> Meeting started Thu Feb 16 17:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is ildikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <openstack> The meeting name has been set to 'cinder_nova_api_changes'
17:00:32 <ildikov> scottda DuncanT ameade cFouts johnthetubaguy jaypipes takashin alaski e0ne jgriffith tbarron andrearosa hemna erlon mriedem gouthamr ebalduf patrickeast smcginnis diablo_rojo gsilvis  xyang1 raj_singh lyarwood
17:00:51 <smcginnis> ildikov: Sorry, gotta miss today. Will catch up on logs later today.
17:00:53 <hemna> yough
17:01:04 <breitz> o/
17:01:18 <mriedem> o/
17:01:43 <ildikov> smcginnis: np
17:02:37 <ildikov> let's wait a bit, although as we're so close to the PTG we might not have that many attendees today
17:03:59 <ildikov> all right, let's start
17:04:10 <hemna> on your marks....get set.....
17:04:17 <ildikov> hemna: :)
17:04:34 * jungleboyj is lurking.
17:04:50 <ildikov> so we have the spec on the Nova side to capture how to get Nova to work with the new Cinder API
17:05:14 <ildikov> #link https://review.openstack.org/#/c/373203/
17:05:51 <ildikov> it would be great to check on the problematic items in it and figure out the preferred way forward next week
17:05:54 <hemna> lots of mriedem feedback there.
17:06:17 <ildikov> we are looking into a few cases, like breitz is working on BfV and I try to look into shelve
17:06:33 <hemna> the Cinder API is in place, so isn't it just a matter of talking about how to use it and adjusting on v2 vs v3 availability?
17:06:57 <ildikov> hemna: yep, there's quite some, I hope johnthetubaguy will have some time too to check the comments
17:07:13 * jgriffith sneaks in the back of the room
17:07:20 * johnthetubaguy sneaks in too
17:07:25 * scottda sneaks in, hiding behind jgriffith and johnthetubaguy
17:07:32 <ildikov> hemna: switching to v3 is one thing, using the new attach/detach API is another
17:07:40 <mriedem> i need johnthetubaguy to approve https://review.openstack.org/#/c/424428/
17:07:44 <hemna> you know, the kids in the back of the class always get called on first.....
17:07:52 <ildikov> jgriffith: johnthetubaguy: scottda: I'm not biting ya know ;)
17:08:49 <jungleboyj> I lurked at the front and haven't been bitten yet.  ;-)
17:08:52 <ildikov> johnthetubaguy: did you have a chance to look into the comments on the Nova spec?
17:10:45 <ildikov> I guess that's a no :)
17:11:24 <ildikov> #action homework to all kids in the room to check the spec and comments to have a common ground for discussion next week
17:12:52 <ildikov> as we have multi-attach as one of the goals here we also need to look into what needs to be done on the Cinder side
17:13:06 <mriedem> my hope for the PTG session is,
17:13:19 <ildikov> jgriffith: do you think we need a slot for this next week or it's less difficult than that?
17:13:21 <mriedem> johnthetubaguy can give us the high-level on th spec since a lot of nova cores won't have read it yet,
17:13:42 <mriedem> and then we can dig into the sticking points that i've -1ed on the spec, which can lead to discussion about what we need out of the cinder API, if anything
17:14:01 <ildikov> mriedem: +1
17:14:03 <jgriffith> ildikov I think that's up to the Nova reps, IMHO it's not that difficult
17:14:18 <mriedem> we already have a nova/cinder slot on thursday morning
17:14:27 <ildikov> mriedem: I will sync up with johnthetubaguy so we have some items on an etherpad as a starting point
17:14:29 <mriedem> because we have other tihngs than multiattach to talk about
17:14:38 <jgriffith> I just need solid guidance on the whole api version thing, and I think mriedem 's plan on that may be the best way to go
17:14:48 <jgriffith> mriedem yes, yes WE do :)
17:14:52 <ildikov> jgriffith: I meant more how to handle detach on the Cinder side for instance with the different back ends
17:15:11 <jgriffith> ildikov so that's a Cinder problem only IMO
17:15:29 <jgriffith> ildikov and I we've pretty much got a design on how that needs to work
17:15:34 <ildikov> jgriffith: sorry, I meant whether we need a slot on the Cinder agenda or not
17:15:46 <jgriffith> ildikov oh
17:15:47 <jgriffith> sorry
17:15:49 <jgriffith> YES
17:16:05 <jgriffith> I want to make sure we're all on the same page, and in face2face is the best way to do that
17:16:15 <jgriffith> and it means I can use a whiteboard :)
17:16:17 <ildikov> jgriffith: ok, I will add it somewhere on the Cinder etherad then, tnx :)
17:16:56 <ildikov> jgriffith: lol :)
17:17:01 <hemna> ildikov, I have my multi-attach patch up in Cinder
17:17:04 <jungleboyj> jgriffith: Bingo!
17:17:11 <jgriffith> hemna wait.. what?
17:17:16 <hemna> https://review.openstack.org/#/c/428365/
17:17:20 <hemna> it makes it work :P
17:17:45 <jgriffith> oh, capabilities clean-slate
17:17:45 <ildikov> mriedem: my hope is that we don't need to talk that much about the multi-attach parts during the Cinder-Nova session, maybe don't need to talk about it at all
17:17:49 <jungleboyj> hemna: :-p
17:17:58 <hemna> jgriffith, yah I think that's what we wanted right ?
17:18:02 <hemna> at least from the last meeting
17:18:06 <jgriffith> hemna indeed!
17:18:08 <jgriffith> thanks!
17:18:12 <hemna> coolio
17:18:13 <mriedem> ildikov: we will because only like 1 other person in nova has read john's spec
17:18:17 <mriedem> john garbutt's i mean
17:18:35 <mriedem> we have all sorts of issues to work out wrt upgrades, evacuate, live migration, etc
17:19:16 <ildikov> that's true, although that's more about how to make the new attach/detach calls work
17:19:26 <mriedem> ildikov: hemna: also in case you haven't noticed yet, i completely molested https://review.openstack.org/#/c/335358/ last night
17:19:47 <hemna> that sounds dirty
17:19:48 <ildikov> mriedem: I need to take a few more breaths before going into that... ;)
17:20:11 <mriedem> hemna: that was the idea :)
17:20:20 <ildikov> mriedem: I haven't check all the comments yet, but frankly I hope I don't need to write a spec to clean up some mess in the soon to be old flow
17:20:22 <jungleboyj> *smh*
17:20:32 <ildikov> *checked
17:21:23 <ildikov> mriedem: we can live without that patch, but I think it will make it even harder to have a clean new attach flow
17:21:37 <mriedem> ildikov: it's gotten much more complicated than i originally though, and it's an api behavior change, so i think a short spec just to get other nova cores on the same page might be prudent
17:21:51 <mriedem> ildikov: but we could hold off on that until next week
17:22:07 <mriedem> i think it's the correct long-term direction, to reserve in the API,
17:22:13 <mriedem> but the mechanics are difficult
17:22:21 <ildikov> mriedem: API behavior change in case of failure you mean?
17:22:31 <mriedem> ildikov: no, that we reserve the volume in the API now
17:22:36 <mriedem> rather than not at all for BFV
17:22:53 <mriedem> it's an internal change, but it might be noticeable
17:23:00 <ildikov> mriedem: so with the new flow we will have attachment-create for reserve and that's how the PoC is implemented today
17:23:09 <mriedem> i just want more people (like dansmith and jaypipes) in the know on that idea
17:23:43 <ildikov> mriedem: it was a BfV case where we didn't, but for everything else I think the volume was always reserved in the API
17:24:06 <jgriffith> le sigh
17:24:31 <ildikov> mriedem: so that patch is about to remove check_attach as the functionality is  in the current reserve_volume
17:24:51 <mriedem> yes i know
17:24:58 <mriedem> i'm aware :) from the molesting, remember?
17:25:13 <ildikov> mriedem: and it turned out that reserve as a matter of fact is missing from BfV, not all the cases but one or maybe two
17:25:29 <mriedem> in the case that we are given a volume, that's the change
17:25:39 <mriedem> if nova creates the volume during BFV, there is no reserve to be done
17:25:55 <mriedem> but you'll see more comments about that inline
17:26:19 <ildikov> mriedem: if you would've molested my patch about 9 months ago, I wouldn't have reacted like this ;)
17:27:22 <ildikov> mriedem: ok, I will check all the comments in line and we can have a 10 minutes chat about it next week
17:27:38 <ildikov> mriedem: and I hope a Launchpad blueprint will do as a "worst case scenario"
17:27:49 <ildikov> mriedem: does it sound ok?
17:29:04 <mriedem> we can talk about the spec next week, a bp doesn't give the level of detail or doc artifact that a spec does for a big change
17:29:21 <mriedem> before any of that though, we can talk about the general idea with the nova group
17:29:26 <mriedem> that's the main thing i want
17:29:28 <mriedem> more visibility
17:30:50 <ildikov> so this started as a bug fix and I'm happy to quick update the whole core team about it next week in like 3 minutes and then talk about it at most 7 so we can move to the more complex things like migrate or evacuate or upgrade
17:31:24 <ildikov> or we can add a separate slot for it next week to not eat up the time of the Cinder-Nova slot with this marginal item
17:31:47 <ildikov> mriedem: is there 10 minutes in the Nova agenda for this?
17:32:49 <mriedem> ildikov: it's going to take however long it's going to take
17:33:03 <mriedem> i don't want to get into a fight about what you consider a 10 minute issue
17:33:06 <mriedem> this is not a trivial change
17:33:23 <mriedem> and if we screw it up we'll have volumes left in attaching state
17:33:28 <mriedem> that the admin will have to reset on the cinder side
17:33:35 <ildikov> mriedem: sure, my point was more to have it on the pure Nova agenda so we can discuss the interaction related things on the joint session
17:33:55 <mriedem> it's related to cinder so we can talk about it at that time
17:33:58 <mriedem> can we move on?
17:34:05 <mriedem> i'm trying to get ocata GA'ed today
17:35:22 <ildikov> mriedem: ok, let's not go down the rabbit hole of how much it's related to what
17:35:57 <ildikov> hopefully next week face2face will make this easier
17:37:08 <ildikov> I think we are mainly clear on what needs to be discussed next week
17:37:08 <mriedem> yes i hope so, i need other cores in the know about this, but we've all been heads down on getting ocata out the door and the things that were priorities for that release
17:37:31 * jungleboyj mic comes from the ceiling "Let's Get Ready to RRRRRRRRUMBLE!!!!!!!!!!"
17:38:00 <ildikov> mriedem: sure, I get that part
17:38:53 <ildikov> mriedem: jgriffith: do you have any items in mind we would need to touch on today in prep for next week?
17:38:55 <mriedem> what else do we need to discuss in this meeting?
17:39:17 <jgriffith> ildikov nah, nothing worth going in to here
17:39:39 <ildikov> I will add the multi-attach slot to the Cinder etherpad and sync up with johnthetubaguy about having the summary up for the spec and prepare a short draft agenda of items we need to to touch on
17:39:58 <ildikov> I will also add the remove check_attach topic to the Cinder-Nova slot
17:40:06 <ildikov> I think these are the main big items
17:40:15 <johnthetubaguy> yeah, got dragged into other things today, but was hoping to do the cinder spec today/yesterday
17:40:24 <ildikov> please shout now if I missed anything
17:41:11 <ildikov> johnthetubaguy: if there isn't one yet we can create an etherpad for the cross-porject slot and add some notes there for people who're not aware of the  whole spec (yet)
17:42:09 <mriedem> there isn't a xp etherpad, it's just in https://etherpad.openstack.org/p/nova-ptg-pike
17:44:12 <ildikov> mriedem: I will create one then if you don't mind and will add the link to the Nova and Cinder etherpads too
17:44:59 <mriedem> that's fine
17:45:08 <ildikov> mriedem: cool, tnx
17:45:36 <ildikov> ok, if nothing else we can wrap up here
17:46:38 <ildikov> thanks everyone
17:46:43 <ildikov> safe travels! :)
17:46:51 <ildikov> see you next week! :)
17:47:19 <ildikov> #endmeeting