14:01:35 <jbernard> #startmeeting ciner
14:01:35 <opendevmeet> Meeting started Wed Jun 11 14:01:35 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:35 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:35 <opendevmeet> The meeting name has been set to 'ciner'
14:01:58 <jbernard> #topic roll call
14:02:00 <jbernard> o/
14:02:06 <agalica> o/
14:02:09 <Luzi> o/
14:02:15 <mhen> o/
14:02:19 <hvlcchao1> o/
14:04:03 <rosmaita> o/
14:07:48 <jbernard> hello everyone, thanks for joining
14:07:54 <jbernard> #topic annoucements
14:07:57 <jbernard> #link https://etherpad.opendev.org/p/cinder-flamingo-meetings
14:08:42 <jbernard> really quickly, here's our schedule for flamingo
14:08:45 <jbernard> #link https://releases.openstack.org/flamingo/schedule.html
14:09:12 <jbernard> I have registered us for the PTG in october
14:09:18 <jbernard> #link https://ptg.openinfra.org
14:09:30 <jbernard> it will be the week of october 27
14:09:39 <Sai> o/
14:09:53 <harsh_> o/
14:10:17 <jbernard> you're supposed to "buy" a ticket as an individual, but it's 0 USD, i think they do this for counting purposes
14:11:29 <jbernard> we will have a midcycle this summer, I'll try to nail down a time and schedule for that soon
14:12:38 <jbernard> that's all for general status
14:12:59 <jbernard> mhen: what's happening with pipeline failures?
14:13:10 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/926298
14:13:22 <mhen> hi
14:13:24 <mhen> as agreed on in https://meetings.opendev.org/meetings/cinder/2025/cinder.2025-02-19-14.01.log.html#l-79 I repeatedly triggered Zuul runs on the image encryption patchset for Cinder and observed the 3rd party pipelines to discern consistently failing ones from occasionally succeeding ones
14:13:39 <mhen> my results so far:
14:13:45 <mhen> failed once and not reacting to rechecks: HPE Nimble Storage CI, HPMSA CI
14:13:53 <mhen> failing only occasionally (at least one success): Pure Storage Third-Party CI, StorPool OpenStack CI
14:13:59 <mhen> failing consistently (so far): NetApp-CI
14:14:15 <mhen> (any others are more or less consistently succeeding so far)
14:14:23 <mhen> it seems not all 3rd party CIs are reacting to a "recheck", HPE Nimble and HPMSA only show up once across all rechecks
14:15:48 <mhen> some (NetApp) don't seem to react to *every* recheck but have seen more often than once
14:15:58 <jbernard> interesting
14:17:01 <mhen> I'm not sure how I should proceed from here
14:17:05 <jbernard> mhen: zuul currently fails on integrated storage?
14:17:16 <jbernard> (tempest)
14:18:03 <mhen> right, "tempest-integrated-storage-ubuntu-jammy" does seem to fail consistently too but is not part of the 3rd party CIs, it's another topic
14:19:30 <jbernard> mhen: do you know if that failure is related to the changes in the patch?
14:20:00 <mhen> that one (Zuul) is a timeout in cinder-backup as far as I can tell and seems unrelated
14:20:25 <mhen> oh and I made a wrong statement
14:20:37 <mhen> the "tempest-integrated-storage-ubuntu-jammy" does not fail consistently
14:20:42 <jbernard> mhen: for 3rd party ci, thank you for reporting those results, i will reach out to folks to try to improve the responses and reporting consistency (that's not something you need to worry about)
14:20:43 <mhen> there is a run where it succeeded
14:21:33 <jbernard> rosmaita: ^ do you happen to know if that test is failing elsewhere?
14:22:00 <jbernard> rosmaita: didn't we have a logstash thing that we could query for this kind of thing?
14:22:01 <rosmaita> not off the top of my head
14:22:47 <rosmaita> https://zuul.opendev.org/t/openstack/builds?job_name=tempest-integrated-storage-ubuntu-jammy&skip=0
14:23:18 <rosmaita> looks like it's mostly passing
14:23:58 <jbernard> yeah
14:25:15 <jbernard> mhen: the next step is to make zuul happy, other reviewers are almost certain to wait if zuul yields a -1
14:25:30 <mhen> should I continue triggering regular rechecks then?
14:26:02 <jbernard> mhen: how often does it fail in your earlier experiements?
14:27:17 <mhen> can't really tell as I have been focusing on the 3rd party CIs mostly, so I have no data on that Zuul one
14:27:41 <rosmaita> slightly off-topic, cinder-tempest-plugin-lvm-lio-barbican is failing consistently on stable/2025.1
14:28:00 <rosmaita> melwitt has a fix posted, but it hasn't merged yet: https://review.opendev.org/c/openstack/barbican/+/949096
14:28:03 <jbernard> rosmaita: i noticed that too
14:28:41 <jbernard> rosmaita: it's failing the gate, is help needed?
14:28:56 <rosmaita> her patch keeps hitting an octavia test failure
14:30:02 <jbernard> i think the clear takeaway is that we're doing way too much testing :)
14:30:25 <jbernard> mhen: recheck, and see if it fails again, and in the same way, i would be curious
14:30:49 <jbernard> mhen: test volume boot test has historically been a difficult one
14:32:27 <jbernard> rosmaita: we're going to need that if we want to do backports, that will block everything before 2025.1 as well
14:33:23 <jbernard> request timeouts are my favorite
14:34:15 <jbernard> rosmaita: is it possible for me to do anything to raise awareness, or are we just waiting?
14:34:23 <rosmaita> not sure about the older branches, they might be ok
14:35:01 <rosmaita> would be helpful to get an octavia person to take a look
14:36:28 <jbernard> do we know any octavia persons?
14:36:37 <rosmaita> thoctavia-v2-dsvm-tls-barbican is also failing in master
14:37:06 <rosmaita> mjohnson used to be PTL
14:38:34 <jbernard> ok, ill see if i can get someone to take a look after the meeting
14:38:49 <jbernard> rosmaita: thanks for bringing that up
14:38:58 <rosmaita> np
14:40:00 <jbernard> we have at least one new driver that's ready for review, VAST:  https://review.opendev.org/c/openstack/cinder/+/939005
14:41:42 <jbernard> #topic open discussion
14:41:59 <harsh_> Hello.. I have a query regarding the blueprint: https://blueprints.launchpad.net/cinder/+spec/ibm-svf-volumegroup
14:42:09 <harsh_> This was created long back but we were unable to submit the reviews for this feature due to organizational changes.
14:42:21 <harsh_> but now we have the code reviews ready and would like to know how to get this approved for Flamingo release.
14:42:38 <harsh_> Also, this blueprint was created when i was using my old ID (haailani@in.ibm.com) but now i have migrated to a new ID (harsh.ailani@ibm.com). So i would like to know i can change the "assignee" of this blueprint to my new ID so that i can update the description for it ?
14:43:41 <harsh_> please let me know how to proceed in this situation :)
14:45:45 <jbernard> rosmaita: did you require blueprints for driver features when you were PTL? just curious about precedent
14:46:31 <rosmaita> yes, mainly just for awareness to prioritize reviews before M3
14:46:42 <rosmaita> or whenever the driver feature freeze is
14:47:27 <jbernard> ok, im not sure ive adequately adhered to that, but i can update this one
14:47:45 <rosmaita> harsh_: looks like launchpad uses your Launchpad ID ... maybe you can edit your profile?
14:47:54 <rosmaita> https://launchpad.net/~haailani
14:48:24 <jbernard> harsh_: check the assignee, it should be fixed now
14:49:18 <harsh_> rosmaita: it requires me to login with that ID but i don't have the access to that email anymore. hence i can't access the profile to edit it.
14:49:39 <rosmaita> bummer
14:49:57 <harsh_> jbernard: thanks, its updated now with my new ID.
14:51:11 <harsh_> I am getting the option for 2025.1 as the series goal for the blueprint. should i select that?
14:51:41 <jbernard> harsh_: oh, i need to do some launchpad curation, ill get that sorted
14:51:57 <harsh_> sure. thanks.
14:52:02 <jbernard> #action jbernard to update lp and fixup harsh's blueprint
14:52:39 <jbernard> #action jbernard to contact octavia about failing melwitt patch (blocking stable/2025.1)
14:52:44 <harsh_> for the upcoming driver features, do we need to create the blueprints? or a spec?  or both ?
14:53:28 <jbernard> rosmaita: ^ i think at least a bp for tracking, if im understanding the process correctly, no?
14:53:52 <rosmaita> yes
14:54:37 <harsh_> Great ! thanks for the info :) I would be creating 2 more blueprints in a few days :D
14:55:04 <jbernard> harsh_: ok, i need to update the series goals, so hold for that
14:55:17 <rosmaita> sounds good ... i thought we had this written down somewhere, but i can't find it
14:55:31 <harsh_> yup, will wait
14:55:43 <jbernard> rosmaita: i dont' have anything related in my personal notes, if you find it let me know
14:55:53 <rosmaita> ok
14:56:03 <jbernard> thanks
14:56:27 <jbernard> 4 minutes remain, anything else needing attention?
14:59:34 <jbernard> thank you everyone, have a good rest of your day!
14:59:38 <jbernard> #endmeeting