10:00:07 <bauzas> #startmeeting climate
10:00:08 <openstack> Meeting started Mon Oct 28 10:00:07 2013 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:11 <openstack> The meeting name has been set to 'climate'
10:00:21 <bauzas> morning all
10:00:27 <bauzas> who's there ?
10:00:28 <DinaBelova> Hello
10:00:42 <Nikolay_St> hello
10:00:45 <DinaBelova> me, Nick
10:01:22 <scroiset> o/
10:02:00 <bauzas> here is the agenda for today :
10:02:03 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Climate#Agenda_for_October.2C_28
10:02:45 <bauzas> ok, starting w/o francois
10:03:12 <bauzas> #topic reviews triaging
10:04:08 <DinaBelova> Francois is trying, but I see some troubles...
10:04:11 <bauzas> we currently have 13 open reviews
10:04:12 <bauzas> https://review.openstack.org/#/q/status:open+project:stackforge/climate,n,z
10:04:17 <bauzas> #link https://review.openstack.org/#/q/status:open+project:stackforge/climate,n,z
10:04:25 <f_rossigneux> Ok I am here.
10:04:37 <DinaBelova> I think second point in agenda seems to be a part of tis one
10:04:42 <DinaBelova> this*
10:05:28 <bauzas> I just would like to quickly go through all open reviews by order of dependencies
10:05:35 <bauzas> get feedback from owners
10:05:40 <bauzas> and move ahead
10:06:03 <DinaBelova> ok, let's start with Manager https://review.openstack.org/#/c/45600/
10:06:07 <bauzas> the 2nd point is more a design discussion about the prolong API
10:06:10 <bauzas> for sure
10:06:19 <bauzas> Manager is close to be released
10:06:22 <bauzas> correct ?
10:06:30 <DinaBelova> yes, I think so
10:06:36 <bauzas> nice to hear that
10:06:45 <DinaBelova> I think I'll do what Swann said
10:06:52 <bauzas> apart of the prolong_for discussion, do you plan any improvements ?
10:06:53 <DinaBelova> and we can merge it
10:07:03 <DinaBelova> not now, really :)
10:07:11 <bauzas> ok, let's then stick to this code
10:07:12 <DinaBelova> if there will be something needed
10:07:13 <scroiset> DinaBelova :  +
10:07:15 <DinaBelova> later
10:07:21 <bauzas> ok
10:07:40 <DinaBelova> the next one is https://review.openstack.org/#/c/52296/
10:07:46 <bauzas> DinaBelova: when will you have time for releasing patch #42 ?
10:07:52 <bauzas> by eob today ?
10:07:53 <DinaBelova> Today
10:07:55 <bauzas> cool
10:07:57 <DinaBelova> yep
10:08:04 <bauzas> ok
10:08:11 <bauzas> https://review.openstack.org/#/c/52296/
10:08:17 <DinaBelova> yes
10:08:24 <bauzas> I saw you rebased the patch ?
10:08:34 <DinaBelova> yes, and here you may use API v2
10:08:40 <DinaBelova> for Keystone
10:08:49 <bauzas> ok, we take action for testing it
10:09:01 <bauzas> we need to glue all our stuff
10:09:08 <DinaBelova> ok
10:09:15 <DinaBelova> There is only one flag
10:09:21 <bauzas> https://review.openstack.org/#/c/52294/ is using it
10:09:38 <DinaBelova> yes, and I think you need to rebase it
10:09:57 <bauzas> yup
10:09:57 <DinaBelova> Or I may do it myself, if you wish
10:10:11 <scroiset> I'll do it when manager is ok
10:10:18 <DinaBelova> ok
10:10:22 <DinaBelova> ok
10:10:23 <bauzas> hold on, which rebase of which patch ?
10:10:24 <bauzas> :)
10:10:27 <DinaBelova> oops
10:10:36 <bauzas> 52296 ?
10:10:58 <bauzas> 52296 will need to get updated as well
10:11:05 <bauzas> as there is a dep on the Manager
10:11:18 <DinaBelova> They all are now, I suppose
10:11:30 <bauzas> DinaBelova: could you please both release the new Manager and provide an updated patch for the utils review  ?
10:11:42 <DinaBelova> Today - yes
10:11:46 <bauzas> ok cool
10:11:56 <bauzas> let's move on then
10:12:00 <bauzas> https://review.openstack.org/#/c/52294/
10:12:01 <DinaBelova> but closer to the end because we have several meetings today soon
10:12:10 <bauzas> ok, that's not blocker for us
10:12:18 <bauzas> https://review.openstack.org/#/c/52294/ will need to get rebasesd
10:12:29 <bauzas> scroiset: could you please take action of rebasing it ?
10:12:38 <scroiset> bauzas: k
10:12:41 <DinaBelova> that would be nice, yes
10:12:42 <bauzas> cool
10:12:59 <bauzas> DinaBelova: Nikolay_St: could you please begin to review it ?
10:13:06 <DinaBelova> sure
10:13:12 <bauzas> cool
10:13:44 <bauzas> https://review.openstack.org/#/c/52396/
10:13:53 <bauzas> also needs to be reviewed
10:14:24 <Nikolay_St> okay
10:14:27 <bauzas> and https://review.openstack.org/#/c/49363/ needs to be reviewed
10:14:35 <DinaBelova> yes, we'll do it (but I think not all today)
10:14:43 <bauzas> DinaBelova: agreed
10:14:48 <bauzas> we can move on
10:15:03 <bauzas> just giving visibility on which reviews are the first to glance
10:15:04 <DinaBelova> Also I think Yuriy will take part there in reviews
10:15:29 <bauzas> ok
10:15:34 <bauzas> nice to hear that :)
10:15:39 <DinaBelova> Nikolay, what do you have for https://review.openstack.org/#/c/52903/ ?
10:15:50 <DinaBelova> Nikolay_St
10:16:04 <DinaBelova> We need to rebase it, i suppose
10:16:19 <DinaBelova> what status do you have now for it?
10:16:54 <Nikolay_St> so
10:17:07 <Nikolay_St> I'm working on it and it close to the end
10:17:29 <bauzas> Nikolay_St: when do you please to deliver the next patchset ?
10:17:42 <Nikolay_St> today
10:17:45 <bauzas> cool
10:18:17 <DinaBelova> Also Nick is working now on Manager's test
10:18:23 <bauzas> ok
10:18:25 <DinaBelova> tests
10:18:27 <Nikolay_St> on Friday
10:18:30 <bauzas> nice to hear that
10:18:44 <Nikolay_St> and I suppose tomorrow I'll publish it
10:18:52 <bauzas> ok
10:19:14 <DinaBelova> As for https://review.openstack.org/#/c/48002/
10:19:25 <DinaBelova> It is trust support
10:19:32 <bauzas> yep
10:19:39 <DinaBelova> It should be only rebased, I think
10:19:45 <bauzas> ok
10:19:46 <DinaBelova> as far as I remember
10:20:19 <bauzas> ok, then I let you provide a rebase and we'll review it by end of the week
10:20:30 <DinaBelova> And then https://review.openstack.org/#/c/49142/ - also with Swann's comments
10:20:48 <Nikolay_St> https://review.openstack.org/#/c/50696/ - what about it?
10:21:09 <DinaBelova> Nikolay_St, there are errors now there
10:21:18 <DinaBelova> because of nova dependency
10:21:28 <DinaBelova> And I'm looking for the solution now
10:21:40 <bauzas> for this week, I would stick to focus on delivering the Manager code and review the patches we mentioned earlier
10:21:44 <DinaBelova> oh
10:21:56 <DinaBelova> no error I see
10:22:16 <DinaBelova> bauzas, of cource
10:22:19 <DinaBelova> course*
10:22:27 <bauzas> ok, cool
10:22:47 <bauzas> btw, please note Friday is a French day off
10:22:53 <Nikolay_St> bauzas: sounds good
10:23:10 <DinaBelova> As for events handling
10:23:11 <DinaBelova> https://review.openstack.org/#/c/50332/
10:23:17 <bauzas> this one is validated
10:23:20 <DinaBelova> I think I'll rebase it
10:23:27 <bauzas> yup, we need to
10:23:35 <DinaBelova> and we'll merge it?
10:23:45 <bauzas> yup
10:23:54 <bauzas> I already gave a +2
10:23:55 <DinaBelova> cool,
10:24:00 <DinaBelova> sounds nice
10:24:06 <DinaBelova> ok
10:24:20 <bauzas> ok, let's close the reviews triage then
10:24:25 <bauzas> just putting an action
10:24:34 <bauzas> no other urgent reviews to discuss ?
10:24:48 <DinaBelova> #topic Summit agenda
10:24:49 <DinaBelova> mmm
10:25:01 <DinaBelova> ok, Sylvain do it please
10:25:32 <bauzas> #action Manager review to be delivered EOB todays and deps being rebased
10:25:57 <DinaBelova> As we've finished with 1st and 2nd point
10:26:22 <DinaBelova> yep
10:26:52 <bauzas> #action Reviews of 52296, 52294, 52903, 52396 and 49363 this week as priority
10:27:17 <bauzas> #topic Update API
10:27:36 <bauzas> sounds there is a confusion for the Update API capability
10:27:53 <bauzas> with the prolong_for parameter
10:28:11 <bauzas> what do we agree ?
10:28:11 <DinaBelova> I think we've finished with it - i'll fix Swann's comments
10:28:14 <bauzas> ok
10:28:30 <bauzas> thanks
10:28:36 <DinaBelova> So I suppose today that will be fixed
10:28:45 <DinaBelova> and new patch will be on review
10:28:50 <bauzas> ok
10:28:51 <DinaBelova> 42nd :D
10:29:03 <bauzas> no action to be done then
10:29:09 <bauzas> #topic Summit agenda
10:29:12 <DinaBelova> let's move to the summit agenda
10:29:14 <DinaBelova> yep
10:29:29 <bauzas> so, Francois and I will be present at the Summit
10:29:37 <bauzas> Patrick will also be part of
10:29:47 <bauzas> unfortunately, Swann can't :(
10:29:48 <DinaBelova> Yes, we know about it
10:30:04 <DinaBelova> Nick and are are preparing unconference talk
10:30:09 <DinaBelova> and I *
10:30:11 <bauzas> I saw your email
10:30:21 <DinaBelova> good
10:30:34 <bauzas> I can also talk to Francois and Julien
10:30:39 <bauzas> oops
10:30:44 <bauzas> Thierry and Julien
10:30:59 <bauzas> do you have some slides to share with me ?
10:31:04 <DinaBelova> --> <bauzas>	 unfortunately, Swann can't :( - yeah, sorry to read it
10:31:18 <scroiset> DinaBelova: next time :)
10:31:27 <DinaBelova> I think we'll share them in a few days
10:31:32 <DinaBelova> scroiset, yep
10:31:38 <DinaBelova> :)
10:31:49 <bauzas> ok, my concern is just to make sure we're on the same page :)
10:32:08 <bauzas> I want to prevent duplicate work :)
10:32:09 <DinaBelova> I thing I'll share them with you on Google Drive
10:32:15 <bauzas> that would be nice :)
10:32:29 <DinaBelova> and we'll fix all moments we have different thoughts on
10:32:55 <bauzas> I think that shouldn't be hard, we are quite having the same ideas
10:33:15 <bauzas> but my concern is more likely, whick kind of audience do you target ?
10:33:19 <bauzas> users or developers ?
10:33:26 <DinaBelova> If you have some already written ideas, I may include them to slides
10:33:41 <jd__> o/
10:33:42 <DinaBelova> i think that it should be less development. really
10:33:43 <bauzas> I was planning to talk about our use cases
10:33:51 <bauzas> hi jd__
10:34:04 <DinaBelova> because unconference audience is almost random
10:34:07 <DinaBelova> jd__, hello
10:34:10 <bauzas> ok, we're then on the same page :)
10:34:20 <DinaBelova> cool
10:34:20 <Nikolay_St> jd__: hi
10:34:46 <bauzas> but yep, I can put my thoughts on your g docs
10:34:49 <jd__> we had a pretty good audience last time we did an unconference about Climate
10:34:59 <bauzas> cool
10:35:09 <jd__> that may be better than nothing, it can be announce on openstack-dev when we have a slot
10:35:23 <DinaBelova> bauzas, that's cool
10:35:24 <bauzas> jd__: that sounds reasonable :)
10:35:26 <DinaBelova> jd__, great
10:35:41 <bauzas> DinaBelova: when do you target to put your slides on Google ?
10:36:06 <DinaBelova> as i said before, few days. I hope tommorow evening
10:36:13 <bauzas> DinaBelova: ok
10:36:26 <bauzas> maybe we could do a phonecall on Thur
10:36:49 <DinaBelova> Sounds good
10:36:50 <bauzas> so as to quickly go on right before the Summit
10:36:52 <bauzas> ok
10:37:17 <DinaBelova> bauzas, i think we'll look on what page we'll be on to Thur
10:37:38 <bauzas> #action DinaBelova bauzas Prepare unconference talk about Climate
10:37:49 <jd__> I'll check if I can pre-book an unconference slot
10:37:52 <bauzas> DinaBelova: ok, let me know by email
10:37:58 <DinaBelova> ok
10:38:01 <bauzas> that would be awesome jd__
10:38:12 <DinaBelova> thank you, jd__
10:38:30 <bauzas> any other topics to discuss about the Summit ?
10:38:41 <DinaBelova> i think that's it with summit
10:38:43 <bauzas> I can give you my Sched.orh agenda
10:38:52 <Nikolay_St> I want to remember you that we also have some sort of live demo to the summit
10:38:53 <DinaBelova> would be nice
10:39:13 <DinaBelova> for virtual instances use case, of cource
10:39:15 <DinaBelova> course*
10:39:24 <bauzas> yup
10:40:05 <bauzas> ok, I think we're done with this topic
10:40:19 <bauzas> any other things to discuss about ?
10:40:26 <DinaBelova> Do we have something else to discuss?
10:40:28 <DinaBelova> oh
10:40:28 <DinaBelova> :)
10:40:37 <bauzas> #topic Open  discussion
10:41:00 <DinaBelova> bauzas, I think we've done with almost everything
10:41:15 <DinaBelova> do you have something else?
10:41:20 <bauzas> just a fyi, we're planning to POC the physical host reservation by mid-end november
10:42:05 <DinaBelova> Would be great
10:42:32 <DinaBelova> bauzas, will you publish meeting minutes or I'll do it myself?
10:42:46 <bauzas> no need, eavesdrop is doing it pretty well :)
10:42:58 <DinaBelova> ok
10:43:46 <bauzas> when do you plan to arrive in HK ?
10:44:10 <DinaBelova> November, 4th
10:44:29 <DinaBelova> about 11 AM in HK
10:44:40 <DinaBelova> as far as I remember
10:44:53 <DinaBelova> and you, guys?
10:44:59 <bauzas> around 3pm
10:45:02 <bauzas> local time
10:45:06 <f_rossigneux> November, 4th, at 11:50
10:45:08 <bauzas> on 4th too
10:45:21 <DinaBelova> ok, nice
10:45:36 <bauzas> ok, it would be nice if we could still have an IRC meeting
10:45:56 <DinaBelova> i think we'll try at least :D
10:46:31 <bauzas> the point is, Monday the 11st of November is also day off for French ppl
10:46:47 <DinaBelova> ok, got it
10:47:05 <bauzas> meaning that if we can't do a weekly talk by next week, it will postpone our meeting by 3 weeks
10:47:19 <bauzas> from now
10:47:25 <DinaBelova> ok, understood
10:47:41 <DinaBelova> I think we'll organise it
10:47:50 <DinaBelova> and hold like today
10:48:02 <DinaBelova> I think that's it
10:48:10 <DinaBelova> something else to discuss?
10:48:31 <bauzas> let's discuss that off, you're right
10:48:36 <bauzas> nope, that's it for me
10:48:39 <bauzas> others ?
10:48:46 <DinaBelova> f_rossigneux, scroiset?
10:49:02 <scroiset> nope
10:49:10 <bauzas> ok, closing the meeting then
10:49:12 <bauzas> thanks all
10:49:14 <bauzas> #endmeeting