09:59:46 <bauzas> #startmeeting climate
09:59:46 <openstack> Meeting started Wed Nov 13 09:59:46 2013 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:59:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:59:50 <openstack> The meeting name has been set to 'climate'
09:59:57 <bauzas> morning all
10:00:14 <bauzas> could you please raise hands when present ? o/
10:01:43 <bauzas> s/o there ?
10:02:29 <scroiset> o/
10:02:52 <f_rossigneux> Hi!
10:03:08 <bauzas> ok, seems like Dina and Nikolay are absent
10:03:14 <bauzas> let's wait 10 mins
10:03:33 <bauzas> and if not present, we will close the room
10:07:51 <bauzas> Nikolay_St: you there ?
10:09:10 <Nikolay_St> bauzas: yeap
10:09:17 <bauzas> Nikolay_St: cool
10:09:26 <bauzas> Nikolay_St: do you know if Dina's present ?
10:09:44 <Nikolay_St> she's taking PTO today
10:10:09 <bauzas> what do you mean by PTO ?
10:10:27 <bauzas> ah ok
10:10:30 <bauzas> gotcha
10:10:46 <Nikolay_St> she's take a day off
10:10:51 <bauzas> ok, then quickly review the agenda
10:11:19 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Climate#Agenda_for_November.2C_13
10:11:30 <bauzas> #topic Summit review
10:11:51 <bauzas> as Dina is not there, we won't discuss about actions to do
10:12:51 <Nikolay_St> bauzas: mm... okay
10:13:53 <bauzas> on an overall note, I would say there are various Oslo libs we need to integrate in Climate
10:14:12 <bauzas> I noted Pecan/WSME (which is not yet part of Oslo)
10:14:17 <bauzas> Oslo.messaging.rpc
10:14:44 <bauzas> that's all I noted
10:14:48 <Nikolay_St> can you give me first explonation about it?
10:14:54 <bauzas> yup
10:15:16 <bauzas> we're currently running Flask as WSGI fremework
10:15:43 <bauzas> there is a global move to Pecan for most of the Openstack projects, excl. Marconi
10:15:55 <bauzas> that should be investigated on our side
10:16:54 <bauzas> re: oslo.messaging.rpc, it's only about making sure we're using the latest Oslo version for RPC proxying
10:17:04 <Nikolay_St> I think that's a good point
10:17:07 <bauzas> which is not yet the case
10:17:21 <Nikolay_St> both of it
10:18:22 <bauzas> #idea Investigate use of Pecan/WSME for API
10:18:43 <bauzas> #idea Investigate move to oslo.messaging.rpc for RPC proxying
10:18:53 <Nikolay_St> or
10:19:40 <bauzas> there was also a discussion about two other concerns :
10:20:08 <bauzas> 1/ for virtual leases, instead of modifying Nova code, use Nova V3 extension called "shielved instances"
10:20:39 <bauzas> we have to dig in and look what's doing what
10:21:26 <bauzas> but on a first glance, it seems it does exactly the same thing as you wish : wipe an instance but keep it in database and do a snapshot before stopping it
10:21:35 <Nikolay_St> I think I can do it after I finish with tests to API (it's very close to end I think) and manager
10:21:51 <Nikolay_St> Dina said me about 'shielved instances'
10:23:01 <bauzas> #link https://github.com/openstack/nova/blob/master/nova/api/openstack/compute/plugins/v3/shelve.py
10:23:22 <bauzas> Nikolay_St: cool
10:24:29 <Nikolay_St> bauzas: also, I think we need to think about roadmap
10:24:47 <Nikolay_St> bauzas: what do you think about it?
10:25:30 <bauzas> I think that's a good idea
10:26:12 <bauzas> #action POC using shelved instances
10:26:35 <bauzas> about roadmap, I think that should be discussed by email
10:26:40 <bauzas> on openstack-dev@
10:26:47 <Nikolay_St> mmm
10:26:56 <bauzas> so, people interested in Climate could contribute
10:27:19 <Nikolay_St> may be it's better to discuss draft of roadmap inside Climate team
10:27:19 <bauzas> at first, we need to put all our needs in blueprints
10:28:01 <bauzas> well, as said, we first need to collect all our ideas as blueprints
10:28:55 <bauzas> once done, we'll triage those
10:29:04 <bauzas> it should raise a roadmpa
10:29:08 <bauzas> roadmap
10:29:54 <bauzas> #action to_all : make sure all the blueprints match the needs, if one is missing, create it
10:30:21 <bauzas> one last point about physical host reservations, we reviewed the pcloud framework
10:30:40 <bauzas> choice is made to switch to AZ instead of Pclouds
10:31:10 <bauzas> #action Change implementation of ReservationPools from Pclouds to AZ
10:31:26 <bauzas> I think we're done with this topic
10:31:33 <bauzas> any other comments about Summit ?
10:31:43 <Nikolay_St> nope
10:32:03 <Nikolay_St> I don't think we loose anything
10:32:45 <bauzas> #topic Reviews follow-up
10:33:40 <bauzas> so we had previous actions http://eavesdrop.openstack.org/meetings/climate/2013/climate.2013-10-28-10.00.html
10:33:55 <bauzas> Manager review to be delivered EOB todays and deps being rebased
10:33:55 <bauzas> Reviews of 52296, 52294, 52903, 52396 and 49363 this week as priority
10:34:17 <bauzas> I would say the Manager review (45600) is still top priority
10:35:20 <bauzas> I'm taking the action to review the #49 patchset by this week, and if OK, merge it to trunk
10:35:41 <bauzas> #action bauzas Review Manager code (45600) and if OK, merge it to trunk by end of the week
10:36:23 <bauzas> Nikolay_St: do you have other changes to be reviewed as prioritary ?
10:36:49 <Nikolay_St> bauzas: api tests as soon as I finish them
10:36:56 <Nikolay_St> and then manager test
10:36:59 <bauzas> ok
10:37:08 <Nikolay_St> I think it'll be ok in 2 days
10:37:10 <bauzas> when do you expect to finish the tests ? By this week ?
10:37:11 <bauzas> ok
10:37:27 <bauzas> let's take it as action but for the week after then
10:37:40 <Nikolay_St> okay
10:38:20 <Nikolay_St> #action Review https://review.openstack.org/#/c/52903/ https://review.openstack.org/#/c/53896/ till 25 of November
10:39:09 <bauzas> https://review.openstack.org/#/c/52296/ needs to be rebased
10:39:31 <bauzas> who can do that ?
10:40:00 <Nikolay_St> almost done
10:40:24 <bauzas> yup, but I would like to review it quickly and add it to trunk
10:40:43 <bauzas> and I don't want to both commit and review on the same patchset :)
10:41:38 <bauzas> scroiset: would you mind doing it ?
10:41:53 <Nikolay_St> we need to merge manager service first
10:42:23 <bauzas> Nikolay_St: oh, just saw you did it
10:42:25 <bauzas> yep
10:42:49 <bauzas> but I will probably review both Manager and utils at the same time
10:43:07 <bauzas> #action bauzas Review 52296 by end of the week
10:43:45 <bauzas> ok, I think we're done with the review priorities
10:44:14 <bauzas> the next step would be to review pcloud support (52294) but it will be refactored this week by scroiset
10:44:33 <bauzas> so Nikolay_St and Dina, you won't have to review our code by this week
10:45:00 <bauzas> next week, we would have probably to ask you to review a huge number of reviews thou
10:45:11 <bauzas> make sure you dedicate enough time about it
10:45:29 <Nikolay_St> oh, sorry about it
10:45:47 <bauzas> no pb
10:46:54 <bauzas> #info Physical use-cases reviews will need to be done intensively by next week, make sure dedicating enough time for it
10:47:05 <bauzas> ok, I think w're done with this topic
10:47:18 <bauzas> any other reviews to discuss ?
10:48:15 <bauzas> ok, last topic then
10:48:21 <bauzas> #topic open discussion
10:48:30 <bauzas> any other concerns to raise, folks ?
10:48:43 <Nikolay_St> I don't think so
10:48:46 <bauzas> me too
10:48:50 <scroiset> nop
10:48:55 <Nikolay_St> Can't remember anything to discuss
10:49:07 <bauzas> ok, closing the conf then, thanks all for your presence
10:49:15 <bauzas> #endmeeting