10:04:00 <bauzas> #startmeeting climate
10:04:01 <openstack> Meeting started Mon Nov 18 10:04:00 2013 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:04:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:04:04 <openstack> The meeting name has been set to 'climate'
10:04:08 <bauzas> morning people
10:04:11 <DinaBelova> hello
10:04:18 <Nikolay_St> hi
10:04:20 <bauzas> sorry for being late, I was having trouble with my IRC client
10:04:28 <DinaBelova> I was thinking you decided to leave us
10:04:31 <DinaBelova> :)
10:04:43 <bauzas> who else is in the meeting ?
10:05:09 <DinaBelova> o/
10:05:19 <DinaBelova> Nikolay is here too
10:05:35 <bauzas> DinaBelova: yup, saw
10:05:41 <bauzas> waiting for scroiset
10:06:08 <bauzas> francois can't attend the meeting today, he is at the SuperComputing conference
10:07:01 <DinaBelova> Swann did not say he has some things to do?
10:07:32 <bauzas> I missed that point
10:07:38 <scroiset> o/
10:07:43 <DinaBelova> Oh, hello!
10:07:46 <bauzas> ah cool, we can begin :)
10:07:51 <scroiset> sorry
10:08:20 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Climate#Agenda_for_November.2C_18
10:08:20 <DinaBelova> Sylvain, please set the first topic
10:08:42 <bauzas> #topic meeting chair rotation
10:09:11 <bauzas> as discussed with Dina, she explained me she would like to host the meeting for today
10:09:15 <bauzas> I'm not against
10:09:36 <scroiset> I'm ok
10:09:44 <DinaBelova> Nikolay?
10:09:50 <bauzas> as said to Dina, I even feel OK with any people wanting to take that role on a meeting
10:10:01 <Nikolay_St> i'm here
10:10:03 <bauzas> like a Scrum Master can be a rotating position
10:10:29 <DinaBelova> Ok, so everybody is ok with this idea?
10:10:33 <bauzas> +1
10:10:39 <scroiset> +1
10:10:50 <DinaBelova> Nikolay, Sergey?
10:11:07 <SergeyLukjanov> ooops, missed start of meeting
10:11:28 <SergeyLukjanov> notification for "Sergey" :)
10:11:31 <SergeyLukjanov> no objections from my side
10:11:39 <Nikolay_St> +1
10:11:48 <DinaBelova> Ok, that's nice
10:11:49 <bauzas> one last thing before we go on with Dina for this meeting
10:12:09 <SergeyLukjanov> it's really cool to have several guys who can chair the meeting
10:12:17 <jd__> o/
10:12:30 <bauzas> we will begin on a rotation with Dina for that position on a weekly basis
10:13:04 <SergeyLukjanov> btw I don't think that she'll be able to use #topic because of bauzas starts the meeting
10:13:08 <bauzas> anyone who wants to take the position could propose him at the summit agenda
10:13:16 <bauzas> SergeyLukjanov: will give her the rights
10:13:21 <bauzas> oops
10:13:27 <bauzas> not the summit agenda
10:13:33 <SergeyLukjanov> :)
10:13:33 <bauzas> the meeting agenda sorry
10:13:38 <DinaBelova> But the meeting one, yes
10:13:42 <bauzas> and then we vote
10:13:48 <bauzas> ok
10:14:01 <DinaBelova> If it's that it let's change roles :)
10:14:04 <bauzas> #agreed DinaBelova to host as chairman for this meeting
10:14:06 <DinaBelova> And go to the next topic.
10:14:18 <DinaBelova> #topic Action items from the last meeting
10:14:28 <bauzas> hold on
10:14:31 <bauzas> #chair DinaBelova
10:14:32 <openstack> Current chairs: DinaBelova bauzas
10:14:38 <bauzas> now you can :)
10:14:39 <DinaBelova> #topic Action items from the last meeting
10:14:48 <DinaBelova> #topic Action items from the last meeting
10:14:55 <SergeyLukjanov> (y)
10:14:57 <DinaBelova> wow, that' difficult :D
10:15:12 <DinaBelova> Ok, last meeting there were a lot of things decides to do
10:15:14 <bauzas> DinaBelova: just keep in mind the commands :)
10:15:31 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2013/climate.2013-11-13-09.59.html
10:15:58 <bauzas> yup
10:16:00 <DinaBelova> We may go through Action items, by person part and look what's done and so on
10:16:11 <bauzas> sure
10:16:24 <DinaBelova> As for 45600 review it was merged, but not really as it should
10:16:27 <bauzas> actually, there was only me as owner of an action :D
10:16:41 <DinaBelova> that's why now we have critical bug about tests implementing
10:16:55 <DinaBelova> Nikolay, what's the status for it?
10:17:34 <Nikolay_St> i'm waiting for the patch one of Mirantis guys are working on
10:18:03 <Nikolay_St> you this patch is about jd__ comment on my test for REST API
10:18:09 <DinaBelova> That will impplement tetsts modules separation to the right structure?
10:18:12 <DinaBelova> ok, see it
10:18:16 <Nikolay_St> yeap
10:18:18 <Nikolay_St> so
10:18:22 <bauzas> could you please give us the review ?
10:18:41 <Nikolay_St> bauzas: is soon is it'll be ready
10:18:46 <DinaBelova> There is no one now, today I'll give you link
10:18:59 <bauzas> ah ok
10:19:03 <DinaBelova> ok, and as for 52296 review
10:19:10 <Nikolay_St> so I'll continue that it'll be done
10:19:28 <DinaBelova> bauzas, you have planned to review it
10:19:38 <DinaBelova> #link https://review.openstack.org/#/c/52296
10:19:47 <bauzas> DinaBelova: yup
10:20:15 <bauzas> I'm nearly done with the review
10:20:28 <bauzas> no precise objection to make
10:20:34 <DinaBelova> ok, I suppose Nikolay should rebase it and you'll have the opportunity to review it as the last version
10:20:39 <bauzas> exactly
10:20:43 <DinaBelova> because now it is outdated anyway
10:20:48 <bauzas> yup
10:21:00 <jd__> I'll try to do a pass on reviews FWIW
10:21:04 <bauzas> now the Manager is merged, this one is the next to be validated
10:21:05 <DinaBelova> #action Nikolay_St Rebase https://review.openstack.org/#/c/52296
10:21:19 <Nikolay_St> done
10:21:24 <DinaBelova> Great :)
10:21:42 <Nikolay_St> i miss you new patches. my bad
10:21:46 <bauzas> ok, you can put me an action for reviewing
10:21:47 <DinaBelova> Ok, the next action item was about tests for the API and Manager
10:22:00 <DinaBelova> #action bauzas Review https://review.openstack.org/#/c/52296
10:22:21 <DinaBelova> Review https://review.openstack.org/#/c/52903/ https://review.openstack.org/#/c/53896/ till 25 of November
10:22:28 <DinaBelova> I think we need to hurry up this moment, if that’s possible.
10:22:40 <DinaBelova> Because these tests are now a real problem
10:22:45 <bauzas> well, btw. sth was unclear about how many +2 need to be done for merging code
10:22:57 <DinaBelova> 2 +2, as far as I remember
10:23:05 <DinaBelova> jd__, can you comment this?
10:23:24 <jd__> yes, you need two +2
10:23:29 <bauzas> I was still on only one +2, coming from the other team
10:23:34 <jd__> the second person setting +2 is authorized to put Approved
10:23:40 <DinaBelova> ok, agreed
10:23:50 <bauzas> jd__: then we need to modify Gerrit for this :)
10:24:04 <jd__> bauzas: there's no hard-coded rule in Gerrit for that
10:24:20 <DinaBelova> bauzas, that's unwritten rule
10:24:20 <jd__> it's just a social convention in all OpenStack projects
10:24:22 <bauzas> atm, only one +2 is needed for Gerrit
10:24:36 <bauzas> I know that for other projects, a 2nd +2 is needed
10:24:44 <jd__> having the ability to fast-approve is also handy when you need to unbreak the gate quickly (that happens once a year :)
10:25:02 <bauzas> I will double-check that :)
10:25:03 <jd__> bauzas: nothing in Gerrit blocks that
10:25:31 <bauzas> so you mean that provided I'm a Nova core-reviewer, I can send a patch to trunk only with my +2 ?
10:25:44 <DinaBelova> bauzas, yes
10:25:44 <bauzas> I was thinking Gerrit was blocking if no second +2
10:25:58 <DinaBelova> but that's really a bad type of behaviour
10:26:00 <bauzas> ok, good to know
10:26:08 <SergeyLukjanov> there are no rules in gerrit
10:26:11 <bauzas> only a social convention, gotcha
10:26:13 <SergeyLukjanov> for checking +2s
10:26:18 <jd__> bauzas: that's what I mean
10:26:27 <bauzas> ok, agreed then
10:26:30 <DinaBelova> Ok, as for unassigned actions
10:26:37 <DinaBelova> We had POC using shelved instances
10:26:53 <DinaBelova> I suppose that's virtual part of research
10:26:53 <bauzas> good to see this :)
10:26:58 <bauzas> yup
10:27:13 <DinaBelova> Nikolay, I've heard you started looking on it?
10:27:45 <DinaBelova> If no, won't you mind to start working on it after tests finishing?
10:28:40 <DinaBelova> It seems that Nikolay has some troubles with irc client now...
10:28:56 <bauzas> ok waiting for him then :)
10:29:13 <DinaBelova> #action DinaBelova POC using shelved instances
10:29:19 <Nikolay_St> u
10:29:22 <Nikolay_St> ou
10:29:44 <DinaBelova> Nikolay_St, we'll decide together who'll be wotking on it :)
10:29:50 <DinaBelova> sorry, working*
10:29:51 <Nikolay_St> yeap
10:29:58 <Nikolay_St> fine :)
10:30:18 <DinaBelova> Ok, about blueprints - I've saw we have written some of them
10:30:21 <bauzas> ok
10:30:23 <bauzas> me too
10:30:31 <DinaBelova> So I think it's ok with this part
10:30:38 <bauzas> think so as well
10:30:48 <DinaBelova> I'm not quite sure about the last action item
10:30:50 <DinaBelova> Change implementation of ReservationPools from Pclouds to AZ
10:30:59 <DinaBelova> bauzas, may you comment it?
10:31:02 <bauzas> scroiset: ?
10:31:19 <DinaBelova> ops, sorry. Yes, Swann, please
10:31:22 <bauzas> as you saw, swann abandoned his patch about patches
10:31:27 <bauzas> pclouds, sorrty
10:31:29 <scroiset> yes, we're using nova aggregate  to manage a pool of hosts
10:31:49 <bauzas> the status is under review, correct ?
10:31:50 <scroiset> pclouds are not more used
10:31:59 <scroiset> yes, under review
10:32:05 <bauzas> coolio
10:32:06 <scroiset> there are some unittest in :)
10:32:11 <bauzas> cool (bis)
10:32:12 <DinaBelova> ok, so that's https://review.openstack.org/#/c/56424/
10:32:17 <DinaBelova> correct?
10:32:35 <bauzas> most of the phys part changes need to be rebased consequently
10:32:48 <bauzas> DinaBelova: yup
10:32:49 <scroiset> DinaBelova: yes. I'll look your comments
10:33:07 <DinaBelova> #action Please rebase all changes to the current code state (for all contributors)
10:33:27 <DinaBelova> ok, I suppose we may go to the next part
10:33:34 <bauzas> ok
10:33:37 <DinaBelova> #topic High priority issues
10:33:55 <DinaBelova> We have discussed already tests changes
10:34:11 <DinaBelova> Still they have main priority
10:34:20 <DinaBelova> As for other things
10:34:43 <DinaBelova> Do you have, guys, some other high priority thing to discuss?
10:34:55 <bauzas> I'm finishing up Policy implementation in Climate
10:35:02 <DinaBelova> bauzas, great!
10:35:09 <bauzas> needed for https://review.openstack.org/#/c/52396/
10:35:22 <bauzas> as these endpoints need to be admin only
10:35:37 <bauzas> the review would then be prioritary
10:35:42 <DinaBelova> #action DinaBelova review https://review.openstack.org/#/c/52396/
10:35:46 <bauzas> should be proposed by eob today
10:35:57 <DinaBelova> Ok, great
10:36:08 <bauzas> https://review.openstack.org/#/c/52396/ is still needing policy implementation, and also needs rebase
10:36:19 <bauzas> as pcloud support has been abandoned
10:36:26 <bauzas> shouldn't be an hard thing thou
10:36:27 <DinaBelova> Agreed
10:36:48 <bauzas> https://review.openstack.org/#/c/56424/ is top prio for us
10:36:55 <bauzas> for reviewing I mean
10:37:16 <DinaBelova> Ok, I've left some comments on it (for the first sight)
10:37:21 <bauzas> yup
10:37:28 <DinaBelova> I'll take a deeper look on it today too
10:37:33 <bauzas> I'm just saying please focus to that review :)
10:37:43 <DinaBelova> Ok :)
10:37:58 <bauzas> there are also a few great patches from mstill and SergeyLukjanov to merge
10:38:04 <bauzas> will review them
10:38:35 <DinaBelova> #action Review infrastructure patches for Climate
10:38:40 <DinaBelova> Ok
10:38:45 <DinaBelova> I think we may go to the next interesting topic
10:38:52 <bauzas> sure, the roadmap
10:38:53 <DinaBelova> About further roadmap
10:39:03 <DinaBelova> #topic Draft roadmap for Climate
10:39:08 <DinaBelova> Ok
10:39:19 <bauzas> well, that's a huge thing
10:39:38 <DinaBelova> yep, we have three branches of work
10:39:44 <DinaBelova> 1/ core things
10:39:54 <DinaBelova> 2/ physical patches
10:39:58 <DinaBelova> 3/ virtual ones
10:40:22 <DinaBelova> As for 1/
10:40:31 <SergeyLukjanov> are there any plans to patch horizon to support reservations in it?
10:40:44 <DinaBelova> SergeyLukjanov, sure
10:40:46 <bauzas> well, I would not say these ones are "branches", but I get your point :)
10:41:05 <DinaBelova> But we did not discuss this point before
10:41:15 <DinaBelova> bauzas, sure, sorry
10:41:21 <bauzas> do we have resources for it?
10:41:58 <DinaBelova> I think we may try to find them and discuss results on the next meeting
10:42:14 <bauzas> well, I still think we're missing BPs for what we plan "next"
10:42:14 <bauzas> :)
10:42:40 <DinaBelova> #action DinaBelova create BP for Horizon support
10:42:45 <DinaBelova> okay
10:42:48 <Nikolay_St> neutron implementation
10:43:04 <DinaBelova> Nikolay_St, that's 3/, let's wait for it
10:43:38 <DinaBelova> As for 1/ we have: Pecan integration, Oslo-messaging integration nad support for different reservarion types
10:44:05 <DinaBelova> I think that's the high priority things
10:44:18 <bauzas> https://blueprints.launchpad.net/climate
10:44:24 <DinaBelova> What do you think guys?
10:45:06 <bauzas> I would rephrase api-extension, pecan-wsme and oslo-messaging as "high" priority
10:45:20 <bauzas> and to be planned for the first milestone :)
10:45:40 <bauzas> but do we have milestones yet ? :D
10:45:51 <DinaBelova> bauzas, I think that's nice idea
10:46:09 <bauzas> ok, modifying the blueprints accordingly
10:46:35 <SergeyLukjanov> are you guys planning to use common OpenStack release cycle?
10:46:52 <SergeyLukjanov> I mean to make some milestone releases like i1, i2
10:47:00 <bauzas> SergeyLukjanov: that's a really good question
10:47:08 <DinaBelova> SergeyLukjanov, I'd like to work on this direction
10:47:19 <bauzas> in terms of velocity, I can't say if we can
10:47:28 <bauzas> but I would say we're aiming to
10:47:29 <SergeyLukjanov> the i1 is Dec 5
10:47:44 <SergeyLukjanov> so, the main question are you ready to release smth at Dec 5
10:47:45 <bauzas> far too short for what we said
10:48:01 <bauzas> nope, was more likely thinking of icehouse-2
10:48:32 <DinaBelova> I think i2 is more reachable thing too
10:48:40 <scroiset> +1 for i2
10:48:41 <Nikolay_St> I agree
10:49:00 <SergeyLukjanov> on the other side I'm personally like to release more frequently to have some flexibility before some 'stable' version
10:49:23 <DinaBelova> #action Everyone Think about what should be delivered for i2 release
10:49:35 <SergeyLukjanov> for example you can release several 0.X release each 4-6 weeks and then adjust release cycle by release Icehouse
10:49:47 <SergeyLukjanov> mid April
10:50:09 <bauzas> SergeyLukjanov: it would be cool if we could target blueprints completions by Openstack milestones
10:50:14 <SergeyLukjanov> I think everyone shouldthink about proc/cons on it and just put item to the next meeting
10:50:31 <DinaBelova> I think supporting of OpenStack release cycle is a good point of discussion
10:50:34 <DinaBelova> SergeyLukjanov, +1
10:50:36 <bauzas> of course, that doesn't mean we can't rollout on a shorter basis
10:50:45 <SergeyLukjanov> OpenStack milestones means that you'll be tested and integrated with the specified milestone
10:50:57 <SergeyLukjanov> it could be difficult during the active dev
10:51:13 <bauzas> SergeyLukjanov: well, something is unclear
10:51:22 <jd__> it shouldn't be hard to release milestone and start following the release cycle with starting at i2
10:51:26 <jd__> might be short for i1
10:51:39 <bauzas> agreed
10:51:58 <DinaBelova> #action Everyone think about proc/cons on using OpenStack release cycle and more frequent releases
10:52:10 <bauzas> let's discuss it by email
10:52:12 <DinaBelova> I think that's it for core part roadmap
10:52:20 <DinaBelova> bauzas, ok
10:52:24 <bauzas> that's for overall roadmap
10:52:37 <bauzas> unless you think about extensions
10:52:48 <bauzas> which isn't the case yet
10:53:04 <DinaBelova> That's overall and about things not depending on physical or virtual topict
10:53:09 <DinaBelova> topics*
10:53:32 <bauzas> my point is that I think we should also cope with the milestones, even for subprojects
10:53:52 <DinaBelova> bauzas, I think so too
10:54:08 <DinaBelova> Do you have some thoughts about physical roadmap?
10:54:16 <DinaBelova> We do not have much time now
10:54:25 <bauzas> yup, we're running out of time
10:54:28 <DinaBelova> so we need to hurry up
10:54:38 <bauzas> let's discuss that by email or later in IRC
10:54:50 <bauzas> and again, create BPs accordingly
10:55:12 <bauzas> ok, maybe last topic ?
10:55:26 <bauzas> 'cause I opened the conf at 1003
10:55:35 <DinaBelova> As for virtual roadmap, we are planning to get POC for shelved instances, volumes and Neutron resources
10:55:37 <bauzas> and we are only having 8 mins lefy
10:55:38 <DinaBelova> for Icehouse
10:55:52 <bauzas> ok, good to know
10:56:02 <DinaBelova> #topic Open discussion
10:56:11 <DinaBelova> Ok, last minutes
10:56:22 <DinaBelova> do we have something to discuss?
10:56:27 <bauzas> as said, working on policy aspects
10:56:31 <bauzas> hard thing
10:56:34 <DinaBelova> Not connected with already mentioned topics?
10:56:41 <DinaBelova> bauzas, yes, sure...
10:56:42 <Nikolay_St> we want to discuss move out parts of scheduler and nova
10:56:57 <Nikolay_St> from climate
10:57:10 <DinaBelova> I think that's great topic to discuss by emails
10:57:18 <DinaBelova> because it's quite huge
10:57:25 <bauzas> yup, let's discuss by email
10:57:37 <DinaBelova> and really important for physical part of our team
10:57:43 <DinaBelova> ok, I suppose, that's it
10:57:49 <Nikolay_St> okay
10:57:57 <bauzas> on another note, I'm discussing with Nova folks about how we interact
10:58:16 <DinaBelova> bauzas, is that on mailing list?
10:58:20 <Nikolay_St> #action test_nova_scheduler email discussion
10:58:20 <bauzas> yup
10:58:40 <DinaBelova> Ok, we will check it
10:58:53 <DinaBelova> I think we may end meeting because of lack of time
10:59:19 <DinaBelova> Goodbye, guys
10:59:37 <Nikolay_St> bye
10:59:40 <scroiset> bye
10:59:46 <DinaBelova> #endmeeting