15:00:16 <bauzas> #startmeeting climate
15:00:17 <openstack> Meeting started Fri Jan 10 15:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'climate'
15:00:27 <bauzas> hi folks
15:00:33 <DinaBelova> hello o/
15:00:35 <bauzas> s/o there ?
15:00:37 <bauzas> o/
15:01:06 <SergeyLukjanov> o/
15:01:15 <DinaBelova> Nikolay_1t?
15:01:43 <DinaBelova> scroiset, f_rossigneux :) you here?
15:01:52 <bauzas> scroiset should be around
15:01:56 <bauzas> I'm wfh
15:02:05 <DinaBelova> Nikolay_1t, I know you are somewhere here too :)
15:02:05 <bauzas> let me ping him
15:02:07 <f_rossigneux> Hi Dina!
15:02:16 <DinaBelova> f_rossigneux, hello)
15:02:31 <scroiset> o/
15:02:32 <bauzas> waiting 1 min for scroiset and then we start
15:02:35 <bauzas> oki doki
15:02:38 <bauzas> let's start !
15:02:41 <scroiset> Hi everyone
15:02:45 <scroiset> Happy new year
15:02:57 <DinaBelova> and merry Xmas))
15:03:00 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Climate#Agenda_for_January_10_2014
15:03:15 <bauzas> Merry Xmas and Happy New Year btw !
15:03:47 <bauzas> #topic PTL election follow-up
15:03:55 <bauzas> so, congrats to DinaBelova !
15:04:10 <bauzas> #info 80% of participation
15:04:17 <DinaBelova> :) that's all you, guys :) Thank you)
15:04:19 <SergeyLukjanov> DinaBelova, congrats!
15:04:25 <scroiset> congrats!
15:04:32 <bauzas> #info DinaBelova wins vs. bauzas 5-3
15:04:49 <bauzas> consequently :
15:05:23 <bauzas> DinaBelova  will be responsible for hosting the meetings
15:05:34 <bauzas> that's a PTL duty
15:05:44 <DinaBelova> :)
15:05:52 <bauzas> we will stop rotating, unless DinaBelova can't attend the meeting
15:06:12 <bauzas> all leads to this :
15:06:57 <bauzas> DinaBelova, I'm giving you the chair for today :)
15:07:04 <bauzas> #chair DinaBelova
15:07:04 <openstack> Current chairs: DinaBelova bauzas
15:07:09 <DinaBelova> ok, so
15:07:20 <DinaBelova> let's move to actual topics to discuss
15:07:30 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:07:44 <DinaBelova> hopefully, we've got not many action items
15:07:45 <DinaBelova> :)
15:08:02 <bauzas> :)
15:08:03 <DinaBelova> and the only one was completely ended by SergeyLukjanov :)
15:08:11 <DinaBelova> so thank you)
15:08:20 <bauzas> ty SergeyLukjanov :)
15:08:20 <DinaBelova> as for reviews
15:08:27 <DinaBelova> #link https://review.openstack.org/#/q/status:open+project:stackforge/climate,n,z
15:08:52 <DinaBelova> we need to do everything to complete all neede for 0.1 changes on time
15:09:00 <DinaBelova> needed*
15:09:35 <DinaBelova> also we've got climate-client changes https://review.openstack.org/#/q/status:open+project:stackforge/python-climateclient,n,z
15:09:39 <bauzas> fyi, our subteam focused on delivering the latest features for 0.1 this week
15:09:55 <DinaBelova> bauzas, great.
15:10:01 <bauzas> so, we will focus on reviewing and patchsetting urgent reviews next week
15:10:22 <DinaBelova> I've spent some my vacation time on reviewing
15:10:33 <bauzas> I'm only concerned about some WIP patches still needed for 0.1
15:10:42 <DinaBelova> so now I've wrote some comments
15:10:51 <DinaBelova> bauzas, completely agree with you
15:11:28 <bauzas> we need to have a clear view of what needs to be done, to be reviewed and close to be pushed
15:11:38 <DinaBelova> but as you see. Nick has posted new patch sets today - he fixed 3 WIPs, as i see
15:11:44 <bauzas> DinaBelova: yep
15:12:11 <bauzas> ok, so, could you please tell us which CRs are mandatory for 0.1 ?
15:12:11 <DinaBelova> I'll add new patch sets on my -1'ed reviews today or Monday
15:12:34 <bauzas> we're only 5 days left from the code freeze :(
15:12:48 <DinaBelova> 6, actually) \
15:12:55 <bauzas> oh correct :)
15:12:56 <DinaBelova> we'll have one Monday too
15:13:02 <bauzas> code freeze in on Tues :)
15:13:09 <DinaBelova> #link https://launchpad.net/climate/+milestone/0.1.0
15:13:19 <bauzas> I made some cleanup on BPs
15:13:31 <bauzas> some of them were not properly set as implemented
15:13:43 <bauzas> albeit the CR was merged...
15:13:49 <DinaBelova> in the whiteboard of all these essential BPs that should be implemented to have 0.1
15:13:58 <DinaBelova> bauzas, thanks
15:14:12 <bauzas> I made only focus on PR usecase
15:14:19 <bauzas> could you please check on your own ?
15:14:38 <bauzas> (PR = physical reservation, much shorter to write :D)
15:14:45 <DinaBelova> I got it)
15:14:52 <DinaBelova> bauzas, sure, will look
15:14:56 <bauzas> thanks
15:15:15 <bauzas> ok, let's agree that the top reference link for reviewing is the BP one
15:16:12 <DinaBelova> #action DinaBelova make sure all work that has been done is properly stored in Launchpad activity - for better Climate management
15:16:21 <DinaBelova> bauzas, you mean?
15:16:36 <bauzas> nah ok
15:16:45 <bauzas> was looking at the dashboard
15:17:00 <DinaBelova> ok
15:17:16 <DinaBelova> we are almost about to finish with all these changes
15:17:26 <DinaBelova> but we should work hard next week
15:17:40 <bauzas> well, think so...
15:17:40 <DinaBelova> f_rossigneux, did you see my comments?
15:17:51 <f_rossigneux> Yes, I am fixing my code.
15:18:20 <DinaBelova> f_rossigneux, just great! Because your changes are really important for PR 0.1 part
15:18:32 <bauzas> that's it indeed :)
15:18:36 <DinaBelova> looking forward on merging them ;)
15:18:43 <bauzas> we discussed about that with f_rossigneux
15:18:53 <DinaBelova> ok, nice
15:19:00 <bauzas> next week will be focusing on that
15:19:20 <bauzas> I'm only worried about client package
15:19:40 <bauzas> I yet hadn't time to provide a patch for PR
15:19:42 <DinaBelova> bauzas, because of?
15:19:45 <DinaBelova> oh
15:19:52 <DinaBelova> yes, I noticed that
15:20:06 <bauzas> the nova Filter is there
15:20:07 <DinaBelova> but I believe you'll have a chance next week?
15:20:11 <bauzas> I hope so :)
15:20:32 <bauzas> but provided you need to review it, that means I have to publish it by Monday at last
15:20:43 <bauzas> or we will have to descope some BPs
15:20:57 <DinaBelova> I hope too, because in case you won't we'll have Climate  0.1, and it's client 0.1 will be without some really important things
15:21:08 <DinaBelova> if so, we'll need 0.1.1 for client)
15:21:23 <DinaBelova> I think we'll see next week
15:21:28 <bauzas> yup
15:21:35 <bauzas> https://bugs.launchpad.net/bugs/1256117 will probably be descoped to 0.1.1
15:22:40 <bauzas> PR is almost ready
15:22:49 <bauzas> all the patches are there
15:22:51 <DinaBelova> bauzas, I think I may +2 it, but we should then do some work on tenant->project cleaning
15:22:56 <DinaBelova> bauzas, sure
15:23:04 <bauzas> or we leave it for 0.1.1
15:23:09 <DinaBelova> yep
15:23:12 <DinaBelova> will see
15:23:14 <DinaBelova> ok
15:23:15 <bauzas> yep
15:23:17 <DinaBelova> ok, I suppose that's it for this topic
15:23:23 <bauzas> agree
15:23:33 <DinaBelova> #topic Current status for the Climate 0.1.0
15:23:49 <DinaBelova> It seems that we may do everything on time
15:24:00 <bauzas> hard work tho :)
15:24:09 <DinaBelova> but one more time - there will be much to do
15:24:22 <DinaBelova> bauzas, exactly
15:24:52 <DinaBelova> but still it's possible, so now I don't wont speak about new date or something like that
15:24:57 <bauzas> could we consider doing a quick meeting at the middle of next week ?
15:24:58 <DinaBelova> want***
15:25:09 <DinaBelova> bauzas, I think that's possible
15:25:31 <DinaBelova> about Wednesday 10:00 UTC in our channel?
15:25:39 <bauzas> well, we have to check
15:25:42 <bauzas> take an action
15:25:52 <bauzas> but I'm fine with this time
15:26:24 <DinaBelova> #action everyone decide in ML about next short meeting about Wednesday
15:26:24 <bauzas> I think 0.1 is reachable on time, but with high probability of some features descoping
15:26:41 <bauzas> in this meeting we should agree what to descope and what to keep
15:26:49 <bauzas> based on the progress on Mondays and Tues
15:27:25 <bauzas> the oslo messaging stuff is appearing to me as low priority for 0.1
15:27:31 <DinaBelova> #agreed See progress of implementing 0.1 features on next short meeting to discuss probable features descoping for 0.1
15:27:36 <bauzas> and could be possibly descoped in case of short time
15:27:50 <bauzas> I prefer focusing reviews for your usecase
15:27:59 <DinaBelova> bauzas, we should focus on essential BPs and referring changes
15:28:07 <bauzas> agreed
15:28:22 <DinaBelova> all other stuff is not so important
15:28:23 <DinaBelova> ok
15:28:33 <bauzas> next topic ? :)
15:28:35 <DinaBelova> I think we may go further
15:28:36 <DinaBelova> yep
15:28:40 <DinaBelova> #topic Status for possible incubation request
15:29:15 <DinaBelova> okay, we should do several things to start thinking about incubation really
15:29:30 <DinaBelova> and the first one is good and understandable mission
15:29:50 <bauzas> lemme find the link for incubation checklist
15:30:35 <DinaBelova> we may prepare some kind of testing incubation (and program, if needed) proposal to have clear understanding of what has been done (due to this list) and what we should really do
15:31:14 <DinaBelova> the thing is that we have one really good and important thing, that's really nice to have for incubation projects
15:31:39 <DinaBelova> we have good company diversity - Climate is not about one company of one idea
15:32:06 <DinaBelova> it's about different people believing ind different ideas and doing one good thing together
15:32:07 <bauzas> I reviewed the checklist a few weeks ago, and only 3 things are left
15:32:16 <DinaBelova> I'm really proud of that
15:32:18 <bauzas> 1. we were needing a PTL
15:32:21 <DinaBelova> :)
15:32:24 <bauzas> check.
15:32:43 <bauzas> 2. Oslo.messaging should be implemented
15:32:48 <bauzas> in progress. :)
15:33:01 <bauzas> 3. mission statement
15:33:05 <bauzas> to be done :)
15:33:13 <DinaBelova> we'are doing well:)
15:33:16 <bauzas> Ok, I think we need to do some wiki stuff
15:33:23 <SergeyLukjanov> bauzas, oslo.msg is not very important, you're already using oslo/rpc, so, it's ok
15:33:33 <bauzas> cool to hear that :)
15:33:48 <SergeyLukjanov> yup, you should create project home page on wiki
15:34:03 <bauzas> as next week wil be quite busy, I just need to make sure all are aware of what needs to be done
15:34:05 <SergeyLukjanov> and I'm proposing to prepare an incubation application to the end of Jan
15:34:09 <bauzas> and that's it for next week
15:34:18 <SergeyLukjanov> and add some notes to it to make a useful roadmap
15:34:35 <bauzas> I also have to do a Climate Roadmap on my side for Bull =)
15:34:47 <DinaBelova> bauzas, I'll be working on wiki as soon as we'll have 0.1. After I'll complete some draft I'll ask some of you, guys (better all of you) to check it (especially pr use case)
15:35:10 <DinaBelova> ok, nice
15:35:19 <bauzas> DinaBelova: could you please put me an action for putting the checklist on Climate wiki ?
15:35:31 <bauzas> and communicate around this ?
15:35:43 <bauzas> SergeyLukjanov: you're not part of TC ?
15:35:43 <DinaBelova> #action bauzas add link to incubation checklist on our wiki
15:36:04 <SergeyLukjanov> bauzas, nope
15:36:15 <bauzas> ok
15:36:32 <bauzas> we have the chance to have 2 distinct PTLs helping Climate
15:36:46 <bauzas> that's good anyway =)
15:36:49 <DinaBelova> it seems like we may move to open discussion?
15:36:50 <DinaBelova> :)
15:36:55 <bauzas> ok
15:36:59 <SergeyLukjanov> bauzas, but we're already done incubation in savanna, so, know answers for some questions ;)
15:37:05 <bauzas> coolio
15:37:09 <DinaBelova> #topic Open discussion
15:37:13 <bauzas> and jd__ can be valuable help :)
15:37:33 <DinaBelova> bauzas, sure :) I'm glad we have such great support
15:37:46 <bauzas> I don't have specific things to discuss
15:38:10 <DinaBelova> my first working day will be next Monday so I'll have muuuuch to do:)
15:38:12 <DinaBelova> me too
15:38:15 <bauzas> :)
15:38:19 <DinaBelova> any other questions?
15:38:27 <bauzas> how are your holidays ? :D
15:38:51 <DinaBelova> nice! first time I could sleep as much as I wanted to :)
15:39:25 <DinaBelova> and all this Xmas and new year stuff at home always makesme happy)
15:40:21 <DinaBelova> although it's quite warm here (not really usual) - we always have much snow while New Year celebration
15:40:26 <DinaBelova> not this time :)
15:40:35 <DinaBelova> ok, bye, everyone!
15:40:48 <DinaBelova> nice to speak with you after long holidays :)
15:40:55 <jd__> how can I help?
15:41:16 <DinaBelova> jd__, we were just discussing that we have two PTLs helping us :)
15:41:22 <DinaBelova> you and SergeyLukjanov :)
15:41:38 <DinaBelova> and it was a nice though warming us :)
15:41:43 <DinaBelova> thought*
15:42:28 <DinaBelova> jd__, just thank you are near Climate and helping us to create it :)
15:43:15 <DinaBelova> one more time, goodbye!
15:43:22 <DinaBelova> #endmeeting