15:00:24 <DinaBelova> #startmeeting climate
15:00:26 <openstack> Meeting started Fri Jan 17 15:00:24 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <openstack> The meeting name has been set to 'climate'
15:00:36 <DinaBelova> o/
15:00:51 <DinaBelova> Climate guys, let's have our meeting :)
15:01:11 <DinaBelova> bauzas, f_rossigneux, Nikolay_St :)
15:01:15 <DinaBelova> u here?
15:01:19 <bauzas> o/
15:01:28 <f_rossigneux> Hi!
15:01:41 <Nikolay_St> o|
15:01:41 <DinaBelova> ok :)
15:02:01 <DinaBelova> it seems like Nick won't be able to be here today
15:02:08 <DinaBelova> oh :)
15:02:11 <DinaBelova> no :)
15:02:13 <DinaBelova> sorry
15:02:35 <DinaBelova> ok, so our today's agenda is #link https://wiki.openstack.org/wiki/Meetings/Climate
15:02:54 <DinaBelova> the first one is
15:03:01 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:03:21 <DinaBelova> last time we had the following action items
15:03:25 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-01-10-15.00.html
15:03:37 <DinaBelova> let's run through them quickly
15:04:12 <DinaBelova> fisrt one was my, I believe I've done it good :)
15:04:28 <DinaBelova> we also had small Wednesday meeting
15:04:45 <DinaBelova> and we've decided what BPs/bugs to descope from 0.1
15:04:52 <DinaBelova> that's also good
15:05:19 <DinaBelova> bauzas, have you added link of incubation check list to Climate wiki
15:05:20 <DinaBelova> ?
15:05:34 <bauzas> nope, had no time
15:05:46 <DinaBelova> ok, so let's move that to next one
15:05:57 <DinaBelova> #action bauzas add link to incubation checklist on our wiki
15:06:23 <DinaBelova> now we have still many changes on review
15:06:31 <DinaBelova> #link https://review.openstack.org/#/q/status:open+project:stackforge/climate,n,z
15:06:36 <bauzas> #info : Incubation checklist https://review.openstack.org/#/c/59454/2/reference/incubation-integration-requirements
15:06:46 <DinaBelova> bauzas, thank you
15:07:10 <DinaBelova> As for changes, I've checked almost all PH use case today on my lab :)
15:07:16 <DinaBelova> and then broken it :D
15:07:21 <bauzas> =)
15:07:30 <DinaBelova> so I'm fighting with it right now :)
15:07:36 <Nikolay_St> :D
15:07:51 <DinaBelova> If everything will be ok, I believe I'll add my other +2s asap
15:07:56 <bauzas> sure
15:08:16 <bauzas> we will address your issues off this meeting
15:08:27 <bauzas> I will be glad to help
15:08:29 <DinaBelova> bauzas, thanks
15:08:38 <DinaBelova> so we have some common / VR use case changes also
15:08:46 <bauzas> on my own, I'm currently reviewing VR use case
15:08:50 <bauzas> starting with utils
15:08:54 <bauzas> facing some 404s
15:09:10 <bauzas> will have to address the issue off topic too
15:09:14 <DinaBelova> +1
15:09:45 <DinaBelova> Nikolay_St, will you help bauzas with that?
15:10:06 <bauzas> I just gave a -1 about some details
15:10:13 <bauzas> but I need to test further
15:10:17 <Nikolay_St> DinaBelova: don't get the use case
15:10:27 <Nikolay_St> bauzas: but I'm ready to help
15:10:34 <DinaBelova> Nikolay_St there are some problems with utils chnage
15:10:52 <DinaBelova> ok
15:11:05 <bauzas> let's try to do this meeting as quick as possible so we can focus on bugs :)
15:11:27 <DinaBelova> also we have oslo.messaging change and Nova Extensions one
15:11:47 <bauzas> oslo.messaging is just awaiting upgrade
15:11:53 <DinaBelova> yep
15:12:07 <bauzas> if you don't have time for this, just tell me, I'll turn into +2 and you raise a bug
15:12:40 <bauzas> btw. we need to open a high-prio bug for unittests with pythonclient
15:12:45 <bauzas> they are horribly missing
15:12:53 <bauzas> must be top-prio for 0.1
15:12:58 <DinaBelova> bauzas, +1
15:12:58 <bauzas> with doc
15:13:02 <DinaBelova> will you create bug?
15:13:11 <bauzas> sure, my Karma will love it
15:13:27 <bauzas> please raise an action
15:13:30 <DinaBelova> #action bauzas Create bug about client unittests missing
15:13:50 <DinaBelova> bauzas, as for messaging I really have no time now for that
15:13:51 <scroiset> btw, we need unittests for climatenova filter .. I'll raise the bug
15:13:58 <DinaBelova> I think we may use your variant
15:14:00 <bauzas> ok, DinaBelova
15:14:12 <DinaBelova> scroiset, great
15:14:12 <bauzas> then I'm turning into +2
15:14:24 <DinaBelova> okay
15:14:33 <DinaBelova> I believe that's it with this topic
15:14:48 <DinaBelova> #topic Current status for the Climate 0.1.0
15:15:16 <DinaBelova> I suppose we still have good chances to finish all in time
15:15:36 <DinaBelova> so nothing more might be descoped or smth
15:15:44 <bauzas> DinaBelova: please take action of creating the bug for updating oslo.messaging
15:16:10 <DinaBelova> #action DinaBelova create bug for oslo.messaging upgrading
15:16:10 <bauzas> I just put a +2/A on the patch
15:16:16 <DinaBelova> ok
15:16:45 <DinaBelova> Do we have something to discuss as a part of this topic?
15:17:02 <bauzas> maybe about formal process
15:17:08 <DinaBelova> bauzas, ok :)
15:17:09 <bauzas> Tues : code freeze
15:17:14 <bauzas> Thur : tagging
15:17:23 <DinaBelova> and actual releasing, yes
15:17:31 <bauzas> if you tag, it will release :D
15:17:53 <DinaBelova> but I'll need to do some launchpad things too :)
15:17:59 <DinaBelova> to make this all look as is
15:18:03 <DinaBelova> from Tues to Tues - testing
15:18:12 <bauzas> and patchsets delivery in case of bugs: )
15:18:18 <DinaBelova> no new features, only bug fixes
15:18:20 <DinaBelova> yep
15:18:23 <JoelC> is there a roadmap to describe next few releases?  (if so where?)
15:18:37 <DinaBelova> JoelC, we are working on it right now :)
15:18:41 <bauzas> JoelC: that's something we need to address
15:18:58 <JoelC> is there an etherpad to collaborate on?
15:19:04 <DinaBelova> JoelC, we need to create scope for 0.2 and decide about dates
15:19:22 <DinaBelova> JoelC, I will create it after 0.1
15:19:40 <bauzas> JoelC: which timezone are you in ?
15:19:41 <JoelC> DinaBelova, Ok. Thanks.
15:19:46 <DinaBelova> because now we have real race with time/changes/etc. :)
15:19:54 <JoelC> bauzas, pacific
15:19:57 <bauzas> ok
15:20:19 <DinaBelova> yep, that will be more comfortable to use etherpad :)
15:20:26 <DinaBelova> ok
15:20:51 <DinaBelova> next topic? to start bug fixing earlier?
15:20:53 <DinaBelova> :)
15:21:04 <bauzas> DinaBelova: FYI, don't forget latest patch from f_rossigneux
15:21:09 <bauzas> lease update
15:21:19 <bauzas> if you folks have time of course :)
15:21:20 <DinaBelova> bauzas, I was going to test it :D
15:21:25 <DinaBelova> but ruined my lab
15:21:30 <DinaBelova> :)
15:21:40 <bauzas> I'll rescue you :)
15:21:45 <DinaBelova> :D
15:21:53 <DinaBelova> #topic Integration with Ceilometer
15:22:02 <bauzas> that's rather a FYI
15:22:36 <bauzas> we just discussed with jd__ about Climate integration with Ceilometer
15:22:42 <bauzas> in terms of metrics
15:22:45 <bauzas> for accountability
15:22:56 <bauzas> there will be 2 blueprints
15:22:59 <scroiset> s/metrics/meters/ ...
15:23:00 <DinaBelova> bauzas, may you share somehow results of your discussion?
15:23:20 <bauzas> one in Climate for pushing notifications on the bus...
15:23:21 <Nikolay_St> bauzas: it's interesting, yeah
15:23:57 <bauzas> one in Ceilo for aggregating meters
15:24:33 <DinaBelova> bauzas, when you'll deliver these BPs for better understanding of these discussion?
15:24:49 <bauzas> jd__ will be the owner
15:25:01 <bauzas> he's quite busy with icehouse-2 :)
15:25:13 <bauzas> so, we are planning to work on it end of next week
15:25:14 <DinaBelova> I can understand him :)
15:25:19 <DinaBelova> ok
15:25:21 <DinaBelova> gotcha
15:25:41 <DinaBelova> I'm glad you've raised this topic, btw :)
15:26:07 <DinaBelova> bauzas, something else we should know about it?
15:26:17 <bauzas> not really, it was a quick discussion :)
15:26:21 <DinaBelova> ok
15:26:24 <DinaBelova> #topic Open discussion
15:26:37 <DinaBelova> so the last meeting part
15:26:50 <Nikolay_St> well
15:27:04 <DinaBelova> I think we may almost pass it to start fixing everything quicker :)
15:27:10 <bauzas> +1
15:27:12 <DinaBelova> Nikolay_St, any questions?
15:27:17 <Nikolay_St> I have a question about freeze, actually.
15:27:20 <DinaBelova> ok
15:27:31 <DinaBelova> you're welcome :)
15:27:46 <Nikolay_St> Am I understand correctly that all changes should be merged on Tuesday?
15:27:55 <DinaBelova> yep, in the ideal case
15:27:58 <DinaBelova> :)
15:28:04 <Nikolay_St> And after that we should do bugfixes?
15:28:19 <DinaBelova> Nikolay_St, if they will be ;)
15:28:24 <Nikolay_St> The case is
15:28:33 <bauzas> Tues-Thur : testing, testing, testing :)
15:28:58 <Nikolay_St> should I rewrite my patches as soon as possible, and skip testing using devstack
15:29:00 <bauzas> we are actually already committed for code freeze :)
15:29:17 <bauzas> any patchset should be tested against devstack :)
15:29:18 <Nikolay_St> or I should work in usual way - writing and testing
15:29:25 <bauzas> yup
15:29:42 <DinaBelova> Nikolay_St, usual way is preferable
15:29:47 <bauzas> until we get Tempest, that's the only way for making sure it *does* work :)
15:29:57 <DinaBelova> also I believe u' have not so much work to end with
15:30:04 <bauzas> think so too
15:30:10 <bauzas> we're in a code closure
15:30:11 <DinaBelova> And also really to get all patches merged in Tues we need to get final versions of them European Monday
15:30:23 <DinaBelova> because of possible (and real) queues in gate
15:30:32 <DinaBelova> everyone is releasing now :)
15:30:39 <bauzas> there will be a serious contention, yes
15:30:51 <bauzas> we can already see the load increase
15:31:05 <bauzas> the good news is that we are not in the same gate pool than others :)
15:31:12 <DinaBelova> so the best way for us is having all tested and +2/+2/A European Monday evening
15:31:20 <DinaBelova> :)
15:31:26 <Nikolay_St> well
15:31:28 <Nikolay_St> okay
15:31:48 <bauzas> Nikolay_St: no worries, we can also understand the situation
15:31:48 <DinaBelova> ok. let's go and work :)
15:31:56 <bauzas> yup, end the meeting
15:31:57 <Nikolay_St> bye
15:32:09 <DinaBelova> bye
15:32:13 <DinaBelova> #endmeeting