15:00:01 <DinaBelova> #startmeeting climate
15:00:01 <openstack> Meeting started Fri Feb  7 15:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <openstack> The meeting name has been set to 'climate'
15:00:10 <DinaBelova> o/
15:00:16 <DinaBelova> hello folks
15:00:25 <DinaBelova> who's here?
15:00:47 <DinaBelova> casanch1, bauzas, swann, f_rossigneux, SergeyLukjanov, pafuent?
15:00:55 <casanch1> hi
15:01:08 <DinaBelova> hello :)
15:01:27 <DinaBelova> Nick has some troubles with irc client
15:01:38 <DinaBelova> but I dunno where are others :)
15:02:01 <DinaBelova> let's wait then
15:02:48 <SergeyLukjanov> o/
15:02:54 <DinaBelova> :)
15:03:20 <DinaBelova> we should wait bauzas anyway..
15:03:33 <casanch1> pafuent is joining
15:03:38 <DinaBelova> ok, great
15:05:32 <DinaBelova> hmm :)
15:05:44 <pafuent> Hi
15:05:48 <DinaBelova> hello
15:05:56 <DinaBelova> bauzas, you here?
15:06:16 <DinaBelova> it seems like his meeting lasts longer than he thought
15:06:56 <pafuent> Yeap
15:07:02 <DinaBelova> ok, I'll post today's agenda anyway
15:07:07 <DinaBelova> https://wiki.openstack.org/wiki/Meetings/Climate#Next_meetings
15:07:28 <DinaBelova> let's wait 3 more mins and then start discussion
15:10:24 <DinaBelova> okay, I'll start, let's see if other guys will join
15:10:29 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:10:37 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-02-04-15.02.html
15:10:51 <DinaBelova> last time we had not many action items, really :)
15:11:04 <DinaBelova> as for me, I've released 0.1 Climate
15:11:19 <DinaBelova> and I'm proud I did it with u, folks
15:11:47 <DinaBelova> while releasing several problems were found and I'll cover them later this meeting
15:12:12 <DinaBelova> also I've created several BPs for 0.2 release
15:12:23 <DinaBelova> due to #link https://etherpad.openstack.org/p/climate-0.2
15:12:38 <DinaBelova> still, we may add some more functionality to 0.2
15:12:44 <DinaBelova> if it'll be needed to
15:13:06 <DinaBelova> pafuent, casanch1 I want you to take a look on this page
15:13:23 <DinaBelova> and if you want to add something there - please, feel free
15:13:36 <pafuent> We look at them yesterday
15:13:49 <DinaBelova> ok, so you're ok with that proposals?
15:14:00 <casanch1> we think we can work on notification
15:14:17 <pafuent> And devstack thing, of course
15:14:33 <DinaBelova> ok, I saw you've started mailing thread with Joel
15:14:46 <DinaBelova> I dunno if it was some other letters
15:14:53 <DinaBelova> did you agreed on meeting time?
15:15:23 <DinaBelova> to discuss notification BP?
15:15:34 <DinaBelova> ok, we may discuss them on next topics
15:15:41 <DinaBelova> #topic Current 0.1.1 status
15:15:51 <DinaBelova> #link https://launchpad.net/climate/+milestone/0.1.1
15:15:55 <pafuent> We already have it. Joel will send an email with the result of the metting
15:16:05 <DinaBelova> pafuent, ok, great, thanks
15:16:23 <DinaBelova> we have already good progress for 0.1.1 release
15:16:44 <DinaBelova> cause we thought it would have bug fixes and several BPs u see there
15:17:04 <DinaBelova> I want to define at least draft date for 0.1.1
15:17:18 <pafuent> https://bugs.launchpad.net/bugs/1276638 This one was merged
15:17:21 <uvirtbot> Launchpad bug 1276638 in climate "Climate client can't handle correctly no-JSON responses" [Medium,Triaged]
15:17:35 <DinaBelova> pafuent, yep
15:17:40 <DinaBelova> that's  nice :)
15:17:53 <pafuent> lp didn't notice that
15:18:57 <DinaBelova> it seems like I have to do that manually
15:19:26 <DinaBelova> #action DinaBelova Fix https://bugs.launchpad.net/bugs/1276638 state
15:19:30 <uvirtbot> Launchpad bug 1276638 in climate "Climate client can't handle correctly no-JSON responses" [Medium,Triaged]
15:19:47 <DinaBelova> If 0.1.1 scope will look almost the same
15:19:49 <DinaBelova> as it's now
15:20:21 <DinaBelova> I think we may have 0.1.1 somewhen about first week of March or even earlier
15:20:38 <DinaBelova> anyway, we'll look on further progress
15:20:57 <DinaBelova> #topic Future plans for 0.2 (https://etherpad.openstack.org/p/climate-0.2) + special attention on notifications BP
15:21:18 <DinaBelova> as for 0.2, we have almost defined scope now for it
15:21:44 <DinaBelova> https://blueprints.launchpad.net/climate/0.2.x
15:21:48 <DinaBelova> #link https://blueprints.launchpad.net/climate/0.2.x
15:22:19 <DinaBelova> Pablo and Cristian - you'll be working on devstack + notifications?
15:22:55 <casanch1> yes!
15:22:55 <pafuent> Yeap
15:23:07 <bauzas> o/
15:23:21 <DinaBelova> bauzas, o/
15:23:29 <DinaBelova> casanch1, pafuent great
15:23:39 <bauzas> sorry, was previously in another meeting
15:23:58 <DinaBelova> casanch1, pafuent I'll wait results of your discussion with Joel
15:24:03 <DinaBelova> bauzas, never mind
15:24:21 <bauzas> about notifications
15:24:24 <DinaBelova> bauzas, please take a look on meeting minutes later
15:24:29 <DinaBelova> bauzas, yes
15:24:33 <bauzas> I did
15:24:44 <bauzas> so, there is a clear consensus with jd__
15:25:09 <bauzas> notifications have to ben sent to Ceilometer and then must be raised to customers there
15:25:15 <bauzas> s/ben/be
15:25:20 <DinaBelova> bauzas, yep, sure - but also we have two Intel teams that have real use case for that
15:25:28 <bauzas> DinaBelova: yup, we know
15:25:37 <casanch1> yes, Joel will also send the use cases
15:25:44 <DinaBelova> and Joel, Pablo and Cristian has discussed that internally
15:25:46 <bauzas> that needs to be discussed on how to do this the right way
15:25:58 <casanch1> bauzas: exactly
15:26:00 <DinaBelova> so we'll have use cases and then discuss :)
15:26:10 <casanch1> did you already have some discussions about it?
15:26:23 <bauzas> my personal opinion is that we have to leverage Ceilometer capabilities
15:26:36 <DinaBelova> that were some technical thought, yes
15:26:52 <bauzas> but in case of an operator wanting to deploy Climate only, we could consider some minimal actions
15:27:17 <DinaBelova> smth like climate -> notification to queue -> ceilometer -> real notification to user
15:27:25 <DinaBelova> bauzas, am I right?
15:27:27 <bauzas> DinaBelova: +1
15:27:34 <DinaBelova> that was idea
15:27:53 <casanch1> we have also discussed that the notifications could also trigger some workflows
15:28:04 <DinaBelova> I believe it's still good one - but we'll review it one more time anyway
15:28:05 <casanch1> additionally to the client notifications
15:28:21 <DinaBelova> casanch1, yep, I noticed idea about Mistral + Murano
15:28:26 <DinaBelova> Joel has written that
15:28:30 <DinaBelova> on BP
15:28:35 <casanch1> ok
15:28:37 <DinaBelova> https://blueprints.launchpad.net/climate/+spec/notifications
15:29:15 <DinaBelova> anyway, for Climate it will mostly look like sending notification to queue
15:29:20 <bauzas> would it makes sense to define a meeting for it ?
15:29:30 <bauzas> s/makes/make
15:29:33 <DinaBelova> the question is who and how will process that
15:29:45 <DinaBelova> bauzas, I suppose we'll take a look on use cases firstly
15:29:51 <DinaBelova> and then decide if needed
15:30:03 <bauzas> jd__ was committed on that
15:30:11 <DinaBelova> bauzas, sure
15:30:33 <ddutta> cyeoh: got a min?
15:30:44 <DinaBelova> we'll share use cases to all interested people. casanch1, pafuent - will it be ok for you?
15:30:51 <bauzas> +1
15:31:08 <pafuent> +1
15:31:10 <casanch1> +1
15:31:13 <DinaBelova> ok, nice
15:31:22 <DinaBelova> let's move on to the next topic then
15:31:32 <DinaBelova> #topic New name for Climate ('climate' repos already exist on PyPi and rtfd) (https://etherpad.openstack.org/p/climate-new-name) - ideas?
15:31:43 <DinaBelova> and we still have problems :)
15:31:51 <DinaBelova> as I said on last meeting
15:32:04 <DinaBelova> 'climate' name is already used almost everywhere
15:32:12 <DinaBelova> PyPi, readthedocts, ...
15:32:25 <DinaBelova> I'm not talking about trademarks
15:32:28 <DinaBelova> so-o-o
15:32:43 <DinaBelova> if we're thinking about next release and about possible incubation
15:32:46 <bauzas> so, I think we should vote for the renaming
15:32:50 <DinaBelova> we NEED new name
15:33:05 <DinaBelova> bauzas, first of all we need candidates :)
15:33:07 <pafuent> Why Climate was choose?
15:33:14 <pafuent> In the first place
15:33:16 <Nikolay_St> hi all
15:33:18 <Nikolay_St> sorry
15:33:21 <bauzas> DinaBelova: we first need to vote if Climate name needs to be changed :)
15:33:22 <DinaBelova> Nikolay_St, o/
15:33:35 <bauzas> and if agreed, we need to vote on the process :
15:33:36 <bauzas> :)
15:33:58 <pafuent> Change the name: +1
15:34:10 <casanch1> +1
15:34:24 <bauzas> I'm just saying we should *officially* vote ;)
15:34:27 <bauzas> DinaBelova:  ;)
15:34:43 <bauzas> so that it would appear in the minutes ;)
15:34:50 <DinaBelova> #startvote Change Climate project name? yes, no
15:34:51 <openstack> Begin voting on: Change Climate project name? Valid vote options are yes, no.
15:34:52 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:34:56 <bauzas> #vote yes
15:34:58 <DinaBelova> #vote yes
15:35:02 <casanch1> #vote yes
15:35:07 <pafuent> #vote yes
15:35:13 <DinaBelova> sorry, I was fighting with voting syntax :)
15:35:25 <DinaBelova> Nikolay_St?
15:35:38 <DinaBelova> SergeyLukjanov?
15:35:50 <SergeyLukjanov> #vote yes
15:36:00 <SergeyLukjanov> just cnange, no options?
15:36:15 <bauzas> SergeyLukjanov: we need to define a process
15:36:17 <casanch1> tobok = ToBook (with one less o)
15:36:19 <bauzas> with timelines
15:36:28 <DinaBelova> Nick has problems with irc
15:36:32 <DinaBelova> but he's ok
15:36:34 <DinaBelova> so
15:36:35 <DinaBelova> #endvote
15:36:37 <openstack> Voted on "Change Climate project name?" Results are
15:36:38 <openstack> yes (5): bauzas, casanch1, DinaBelova, SergeyLukjanov, pafuent
15:36:45 <SergeyLukjanov> it depends on your plans on sending incubation request
15:37:05 <DinaBelova> SergeyLukjanov, now we have voted we need that
15:37:33 <DinaBelova> Now I want to propose the following question: we have to define list of new names next week
15:38:06 <DinaBelova> and we need these names to be free on PyPi, readthedocs and trademarks
15:38:23 <bauzas> could I suggest two weeks for the proposal ?
15:38:32 <DinaBelova> bauzas, ok, good idea
15:39:10 <bauzas> and in case of nothing proposed in a 2 week delay, another week for finding at least one other name
15:39:41 <bauzas> you ok ?
15:39:46 <pafuent> Yes
15:39:49 <bauzas> 2 weeks + 1 week extra delay
15:40:00 <casanch1> +1
15:40:04 <bauzas> and if none found in 3 weeks, that's duty of PTL for choosing
15:40:04 <DinaBelova> #startvote Define list of new possible names in 2 weeks starting from Feb 10 (1 extra week if no new names will be proposed)?  yes, no
15:40:05 <openstack> Begin voting on: Define list of new possible names in 2 weeks starting from Feb 10 (1 extra week if no new names will be proposed)? Valid vote options are yes, no.
15:40:06 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:40:14 <DinaBelova> bauzas, ok :)
15:40:21 <DinaBelova> #vote yes
15:40:23 <bauzas> #vote yes
15:40:35 <pafuent> #vote yes
15:40:51 <casanch1> #vote yes
15:41:07 <DinaBelova> SergeyLukjanov, are you ok with that?
15:41:38 <DinaBelova> I suppose he is :)
15:41:43 <bauzas> close the vote
15:41:45 <SergeyLukjanov> #vote yes
15:41:46 <DinaBelova> I'll close voting
15:41:47 <DinaBelova> #endvote
15:41:48 <openstack> Voted on "Define list of new possible names in 2 weeks starting from Feb 10 (1 extra week if no new names will be proposed)?" Results are
15:41:49 <openstack> yes (5): bauzas, casanch1, DinaBelova, SergeyLukjanov, pafuent
15:41:58 <DinaBelova> SergeyLukjanov, u're quick :)
15:42:01 <DinaBelova> okay
15:42:09 <bauzas> ok, one last point about PTL responsibility for choosing the name if none proposed in 3 wks
15:42:18 <bauzas> PTL is DinaBelova
15:42:29 <DinaBelova> ok, I'll set voting for it too :)
15:43:24 <DinaBelova> #startvote Is PTL responsible for choosing name if no variant will be chosen during first 3 weeks?  yes, no
15:43:25 <openstack> Begin voting on: Is PTL responsible for choosing name if no variant will be chosen during first 3 weeks? Valid vote options are yes, no.
15:43:26 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:43:31 <DinaBelova> #vote yes
15:43:34 <bauzas> #vote yes
15:43:38 <pafuent> #vote yes
15:43:41 <SergeyLukjanov> #vote yes
15:43:43 <casanch1> #vote yes
15:43:50 <DinaBelova> #endvote
15:43:51 <openstack> Voted on "Is PTL responsible for choosing name if no variant will be chosen during first 3 weeks?" Results are
15:43:52 <openstack> yes (5): bauzas, casanch1, DinaBelova, SergeyLukjanov, pafuent
15:43:58 <DinaBelova> ok, great
15:43:59 <bauzas> one last point, about how we elect the names if proposed ?
15:44:03 <bauzas> CIVS ?
15:44:14 <DinaBelova> bauzas, I'm ok with that
15:44:14 <bauzas> which electors ?
15:44:22 <bauzas> open contributions ?
15:44:32 <bauzas> I would really love having open voting :)
15:44:45 <bauzas> as my team is really concerned about the name change :)
15:44:48 <DinaBelova> bauzas - all contributors who were taking part in climate/its client/climate-nova
15:44:54 <SergeyLukjanov> personally I prefer open voting
15:44:57 <DinaBelova> mmm
15:44:59 <DinaBelova> okay
15:45:01 <DinaBelova> that's good idea
15:45:05 <bauzas> we can vote on it
15:45:16 <bauzas> only contributors or open
15:45:17 <SergeyLukjanov> I mean open to see vote marks
15:45:29 <SergeyLukjanov> but I'm not sure how should be in electorate
15:45:34 <DinaBelova> SergeyLukjanov, mm, sorry?
15:45:49 <DinaBelova> personally
15:45:58 <SergeyLukjanov> for savanna I'm set the following process - only ATCs votes for the new name
15:46:00 <DinaBelova> I think that only contributors may take part here
15:46:07 <DinaBelova> SergeyLukjanov, +1
15:46:09 <SergeyLukjanov> with two round elections
15:46:24 <pafuent> ATCs?
15:46:24 <SergeyLukjanov> first round - filter out ~5 name options
15:46:26 <bauzas> I think that's not cool :(
15:46:28 <SergeyLukjanov> and discuss them
15:46:48 <SergeyLukjanov> the second round - voting to choose exactly the new name
15:46:49 <pafuent> CIVS?
15:46:54 <ddutta> Sergey: only ATCs for the project or ATCs
15:46:59 <bauzas> ATC = Active Tech Contrib
15:47:05 <SergeyLukjanov> pafuent, ATC == active tech contributor
15:47:14 <pafuent> Thanks
15:47:15 <SergeyLukjanov> ATCs for the project
15:47:18 <bauzas> CIVS = Condorcet voting systems
15:47:42 <DinaBelova> pafuent, CIVS is used in OS, for example, to choose PTLs
15:47:52 <pafuent> Ahh
15:47:52 <DinaBelova> ok
15:47:59 <DinaBelova> so variants are
15:47:59 <ddutta> I think you should have all ATCs :)
15:48:19 <DinaBelova> 1/ electorate == all ATCs
15:48:26 <DinaBelova> 2/ ATCs for climate related repos
15:48:31 <DinaBelova> 3/ anyone at all
15:48:41 <DinaBelova> I believe 1/ is good enough
15:48:49 <DinaBelova> SergeyLukjanov, your thoughts?
15:49:07 <DinaBelova> ddutta, so you are more likely to support 1/ too :)
15:49:12 <ddutta> :)
15:49:15 <ddutta> yes 1)
15:49:21 <bauzas> ok for the options, we can go to the vote
15:49:32 <SergeyLukjanov> enyone to propose the name and collect all folks votes and project's ATCs to vote for the new name
15:49:39 <SergeyLukjanov> anyone*
15:49:57 <bauzas> that's a 4th option
15:50:05 <DinaBelova> SergeyLukjanov, sorry, can't get your idea with "name and collect all folks votes and project's ATCs to vote for the new name"
15:50:10 <bauzas> 4/ anyone who proposes or is ATC
15:50:11 <DinaBelova> may you explain?
15:50:19 <DinaBelova> oh, ok
15:50:31 <bauzas> ok, then we can go to the vote
15:50:57 <bauzas> quite an hard vote to express :D
15:51:03 <DinaBelova> yeeep
15:51:25 <bauzas> give only figures, not names as choices, and explain the choices
15:51:33 <bauzas> so we could vote either 1, 2, 3 or 4
15:52:03 <ddutta> if you want another name for a lease project it could be charter
15:52:24 <bauzas> ddutta: we are having an etherpad :)
15:52:28 <DinaBelova> #startvote Who will be electorate? ATCs, climate_ATCs, everyone, ATCs_and_name_declarants
15:52:30 <openstack> Begin voting on: Who will be electorate? Valid vote options are ATCs, climate_ATCs, everyone, ATCs_and_name_declarants.
15:52:31 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:52:37 <bauzas> #vote ATCs_and_name_declarants
15:52:43 <DinaBelova> #vote ATCs_and_name_declarants
15:52:50 <pafuent> #vote ATCs_and_name_declarants
15:53:13 <DinaBelova> I did it :D I created vote! yay :)
15:53:35 <casanch1> #vote ATCs_and_name_declarants
15:53:47 <DinaBelova> SergeyLukjanov, ddutta?
15:53:51 <bauzas> DinaBelova: well done ;) :D
15:54:24 <ddutta> where is the etherpad
15:54:27 <ddutta> sorry ....
15:54:37 <DinaBelova> in topic name
15:54:44 <DinaBelova> but we have no variants now...
15:54:54 <DinaBelova> SergeyLukjanov? Vote?
15:55:04 <SergeyLukjanov> #vote ATCs_and_name_declarants
15:55:11 <bauzas> we need to be quick
15:55:21 <DinaBelova> ok, I'm closinf vote
15:55:23 <DinaBelova> #endvote
15:55:23 <bauzas> we're close to the end of the meeting :)
15:55:24 <openstack> Voted on "Who will be electorate?" Results are
15:55:25 <openstack> ATCs_and_name_declarants (5): bauzas, casanch1, DinaBelova, SergeyLukjanov, pafuent
15:55:27 <DinaBelova> yep
15:55:31 <bauzas> cool thanks people
15:55:47 <DinaBelova> we have some more important topic
15:55:51 <bauzas> one last point, about the number of rounds, I like SergeyLukjanov's proposal
15:55:59 <DinaBelova> yep, me too
15:56:06 <DinaBelova> I may use #agreed here
15:56:10 <DinaBelova> not to waiste time
15:56:11 <ddutta> DinaBelova: ether pad link?
15:56:12 <bauzas> ok with ti
15:56:21 <bauzas> ddutta: https://etherpad.openstack.org/p/climate-new-name
15:56:51 <DinaBelova> #agreed use 2 cycle name changing (leave 5 names after 1st round, 2nd - define name)
15:56:51 <bauzas> ok, agree for a 2nd round vote
15:56:56 <bauzas> ok
15:57:00 <bauzas> last topic ?
15:57:08 <bauzas> a big one
15:57:09 <DinaBelova> #topic Summit talks
15:57:12 <DinaBelova> yep
15:57:14 <bauzas> 3 mins to discuss it
15:57:17 <DinaBelova> I only want to meantion
15:57:19 <bauzas> way too short
15:57:31 <bauzas> oh, go ahead
15:57:31 <DinaBelova> that we'll have mostly like 2 topics there
15:57:47 <DinaBelova> about Climate itself and it's further steps
15:57:59 <bauzas> a 3rd one needs to be envisaged
15:58:05 <DinaBelova> and more oriented on physical reservations/thechnical staff
15:58:18 <DinaBelova> that was 1 :) and 2)
15:58:31 <DinaBelova> I'll create google drive doc
15:58:34 <DinaBelova> and share it
15:58:35 <bauzas> DinaBelova: +1
15:58:40 <DinaBelova> to create proposals
15:58:46 <DinaBelova> and send them next week
15:58:57 <DinaBelova> #topic Open discussion
15:59:01 <bauzas> we need to send them by Feb 14
15:59:07 <DinaBelova> i have nothng to discuss :)
15:59:10 <DinaBelova> yep
15:59:22 <bauzas> nothing special, I'm nearly done with the first patchset for Pecan :)
15:59:28 <bauzas> I'll promote it
15:59:29 <DinaBelova> good :)
15:59:31 <DinaBelova> bye!
15:59:34 <bauzas> bye !
15:59:37 <pafuent> bye
15:59:38 <casanch1> bye!
15:59:40 <DinaBelova> #endmeeting