15:00:06 <DinaBelova> #startmeeting climate
15:00:07 <openstack> Meeting started Fri Mar 21 15:00:06 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'climate'
15:00:16 <bauzas> \o
15:00:21 <DinaBelova> o/
15:00:41 <DinaBelova> casanch1 pcargnel dpamio pafuent casanch1 scroiset :)
15:00:42 <pafuent> o/
15:00:45 <DinaBelova> ok :)
15:00:58 <DinaBelova> let's wait others and then start
15:01:06 <casanch1> o/
15:01:08 <DinaBelova> o/
15:01:37 <DinaBelova> dpamio, scroiset - u here?
15:02:17 <DinaBelova> well :)
15:02:22 <DinaBelova> I'll start I think
15:02:44 <bauzas> yup
15:02:46 <DinaBelova> not to waste time
15:02:47 <DinaBelova> ok
15:03:00 <DinaBelova> so today's agenda is
15:03:05 <DinaBelova> #link https://wiki.openstack.org/wiki/Meetings/Climate
15:03:23 <DinaBelova> well, as usually, let's start with action items fro last meeting
15:03:36 <dpamio> I'm here sorry, biobreak
15:03:38 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:03:45 <DinaBelova> dpamio, don't worry
15:03:51 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-03-14-15.09.html
15:04:02 <DinaBelova> let's go quickly through action items
15:04:16 <DinaBelova> cmart is now a little bit busy this week
15:04:21 <DinaBelova> working on internal trainings
15:04:24 <DinaBelova> as he said to me
15:04:34 <bauzas> ok
15:04:40 <DinaBelova> so: he just started thinking about tempest integration
15:04:59 <DinaBelova> he asked little help -> I'll provide him some info about how it'll be better to implement that
15:05:14 <bauzas> he could take example of unittests for Pecan
15:05:20 <DinaBelova> #action DinaBelova help cmart to implement Tempest Climate Testing
15:05:36 <DinaBelova> bauzas, well, it's a little bit about infrastructure questions
15:05:38 <pafuent> Or use Manila as inspiration
15:05:41 <DinaBelova> like where to start
15:05:46 <DinaBelova> and how to do that
15:05:50 <DinaBelova> pafuent, great idea
15:05:59 <pafuent> https://github.com/stackforge/manila/tree/master/contrib/tempest
15:06:14 <DinaBelova> #info use Manila as example of how Tempest testing might be implemented in contrib
15:06:15 <pafuent> Is similar to devstack integration
15:06:20 <DinaBelova> pafuent, coolio
15:06:24 <DinaBelova> thanks much
15:06:37 <bauzas> anyway, we could discuss this in an etherpad
15:06:49 <DinaBelova> bauzas, good idea
15:06:52 <bauzas> if cmart doesn't feel enough confident
15:07:08 <bauzas> and that doesn't require to be all connected at a same time
15:07:14 <DinaBelova> #info discuss Tempest testing (if needed) on etherpad to help cmart
15:07:24 <bauzas> the best way would be to set the URL for description in the BP
15:07:28 <bauzas> to the etherpad
15:07:34 <DinaBelova> as for me and my action items - they were about assignments, so they were done quite easy :)
15:07:39 <DinaBelova> bauzas, yep
15:07:49 <DinaBelova> and about etherpads
15:08:01 <DinaBelova> bauzas, I guess you were quite busy this week
15:08:03 <DinaBelova> am I right?
15:08:07 <bauzas> :-)
15:08:09 <DinaBelova> I'm about your action item
15:08:16 <bauzas> is this smiley enough ? :-)
15:08:19 <DinaBelova> >>> create etherpad about designs and amend according BPs
15:08:19 <DinaBelova> :)
15:08:21 <DinaBelova> yes
15:08:26 <DinaBelova> ok, will you do that?
15:08:29 <bauzas> yup
15:08:33 <DinaBelova> ok, great
15:08:38 <bauzas> put me an action for this week
15:08:54 <DinaBelova> #action bauzas create etherpad about designs and amend according BPs and share links via ML
15:09:06 <DinaBelova> ok
15:09:13 <DinaBelova> so I guess that's it for this topic
15:09:19 <DinaBelova> any questions related to it?
15:09:25 <casanch1> yes
15:09:29 <DinaBelova> cool
15:09:32 <casanch1> which BPs?
15:09:53 <DinaBelova> about: new steps in lease-creation workflow
15:09:56 <bauzas> for the next architectures
15:09:57 <DinaBelova> and lease state
15:10:04 <DinaBelova> they were discussed last meeting
15:10:12 <DinaBelova> that's only reassignment for this week
15:10:21 <casanch1> oh, I remember those topics now
15:10:25 <DinaBelova> as bauzas had no opportunity to work on them this week :)
15:10:25 <casanch1> thanks,
15:10:28 <DinaBelova> casanch1, yep
15:10:29 <DinaBelova> np
15:10:33 <DinaBelova> #topic 0.1.1 status (proposal sbauza, TBC)
15:10:42 <DinaBelova> ok
15:10:47 <DinaBelova> #link https://launchpad.net/climate/+milestone/0.1.1
15:10:55 <DinaBelova> that's current state of 0.1.1 features
15:11:02 <DinaBelova> and just simple update
15:11:12 <DinaBelova> I've got from foundation lawyers
15:11:19 <DinaBelova> wait a minute
15:11:54 <bauzas> sure
15:12:02 <DinaBelova> >>> We’ll run the search. It typically takes a week to get results from the lawyers.
15:12:18 <DinaBelova> by Lauren from board of directories
15:12:35 <DinaBelova> actually they don't work with not incubated projects :)
15:12:40 <DinaBelova> so we're lucky :)
15:12:54 <DinaBelova> letter was ~2 days ago
15:13:00 <bauzas> ok
15:13:03 <DinaBelova> so we'll wait next Tuesday for result
15:13:11 <DinaBelova> and after that we'll have no blocker here
15:13:18 <DinaBelova> that's quite cool
15:13:30 <bauzas> ok
15:13:37 <DinaBelova> as for BPs / bugs for 0.1.1
15:14:03 <DinaBelova> we have 4 BPs and 2 bugs to be merged to upstream
15:14:14 <DinaBelova> to have all wanted for 0.1.1. released
15:14:38 <bauzas> Pecan is about to be done
15:14:38 <DinaBelova> well, I guess now that docs Bp is almost merged
15:14:48 <bauzas> unittests are in good progress
15:14:49 <DinaBelova> bauzas, yes, I'm ok with your impl
15:15:01 <bauzas> we're still missing some controllers
15:15:11 <casanch1> I'll upload the initial version of tenant->project today
15:15:18 <DinaBelova> casanch1, cool!
15:15:20 <DinaBelova> thanks
15:15:23 <casanch1> have been working on that, and I'm still testing it
15:15:29 <DinaBelova> bauzas, what controllers?
15:15:38 <DinaBelova> casanch1, yep, that's quite needed to be done :)
15:15:42 <bauzas> GET /leases is done
15:15:50 <bauzas> POST /leases is in progress
15:15:53 <DinaBelova> oh, ok
15:16:00 <casanch1> I also added the dependency to pafuet's BP about DB migrations
15:16:00 <DinaBelova> well, I love what we have now
15:16:06 <bauzas> I still need to do PUT/DELETE
15:16:08 <DinaBelova> and how are we moving further
15:16:14 <bauzas> and do the same for hosts
15:16:16 <DinaBelova> casanch1, yes
15:16:31 <DinaBelova> ok
15:16:40 <DinaBelova> i guess we're almost where we should be now
15:16:41 <DinaBelova> btw
15:16:54 <DinaBelova> Barbican is going to move from stackforge to openstack
15:17:01 <bauzas> saw that
15:17:05 <DinaBelova> that's our chance to rename, I guess
15:17:09 <bauzas> they're pretty lucky :)
15:17:12 <DinaBelova> :)
15:17:39 <bauzas> does it require a downtime ?
15:17:41 <DinaBelova> #info monitoring of Barbican moving to OpenStack repos to get our chance for renaming
15:17:47 <bauzas> I was thinking that no
15:17:47 <DinaBelova> bauzas, yes
15:17:50 <bauzas> oh
15:17:53 <DinaBelova> oh
15:17:54 <DinaBelova> well
15:18:01 <DinaBelova> Sergey said it is
15:18:11 <DinaBelova> well, if so, I need to check it one more time
15:18:26 <bauzas> ok, Sergey is our source of trust :)
15:18:39 <bauzas> I don't pretend to be as informative as Sergey ;)
15:18:47 <pafuent> Why Barbican moving is important for the renaming thing?
15:18:55 <DinaBelova> #action DinaBelova check one more time if Barbican folks need some maintenance for gerrit while their moving
15:19:02 <bauzas> because that could be a dowtime period
15:19:04 <DinaBelova> pafuent, because we need to stop gerrit
15:19:07 <bauzas> downtime
15:19:11 <DinaBelova> to rename / move some where
15:19:17 <DinaBelova> that's quite tough thing
15:19:18 <pafuent> Ok
15:19:28 <DinaBelova> so infra guys don't like doing it every time
15:19:36 <DinaBelova> so we need some packs of changes
15:19:40 <DinaBelova> to be done this time
15:19:48 <DinaBelova> like barbican + climate stuff
15:19:49 <DinaBelova> ok
15:19:58 <DinaBelova> any questions related to this topic?
15:20:18 <DinaBelova> well :)
15:20:22 <DinaBelova> i guess no :)
15:20:45 <DinaBelova> #topic Bugs on trunk
15:20:48 <bauzas> :)
15:20:58 <DinaBelova> bauzasm as you proposed agenda
15:20:59 <bauzas> ok, I'm currently being a bit busy
15:21:05 <DinaBelova> what did you want to discuss here?
15:21:20 <bauzas> because some of our Bull folks are trying to integrate Climate within another XLcloud portal
15:21:26 <DinaBelova> wow :)
15:21:29 <bauzas> which is Java-based
15:21:31 <DinaBelova> I guess that's tough :)
15:21:47 <bauzas> so they're currently working on delivering a Java SDK for Climate
15:21:54 <DinaBelova> did you find some bugs while that integration?
15:21:56 <bauzas> based on the REST API
15:22:01 <bauzas> indeed :)
15:22:02 <DinaBelova> due to topic :?
15:22:03 <DinaBelova> ok
15:22:06 <DinaBelova> cool :)
15:22:17 <bauzas> I'm deploying Climate against Havana
15:22:24 <bauzas> that works pretty fine
15:22:29 <DinaBelova> coool!
15:22:29 <bauzas> they're focusing on PR usecase
15:22:52 <DinaBelova> ok, will you file bugs?
15:22:58 <DinaBelova> that you found?
15:23:05 <DinaBelova> while that integration?
15:23:11 <DinaBelova> or I need to guess them :)
15:23:13 <DinaBelova> :D
15:23:23 <bauzas> that's the thing
15:23:34 <bauzas> I asked them to open lp bugs
15:23:40 <DinaBelova> and they?
15:23:42 <bauzas> that should be done in the next days
15:23:46 <DinaBelova> ok, cool
15:23:58 <bauzas> so, I'm just saying we'll have some bugs
15:24:08 <bauzas> volunteers are welcome for fixing them :)
15:24:12 <DinaBelova> #info new bugs filed in Launchpad soon due to Bull Climate testing
15:24:22 <DinaBelova> ok, when we'll see them
15:24:27 <DinaBelova> we'll assign them too :)
15:24:34 <bauzas> the good news is, our Bull team would be keen to fix some of them :)
15:24:39 <DinaBelova> :*
15:25:01 <bauzas> they are Polish, with the 2 meanings :D
15:25:02 <DinaBelova> I'll be *really glad*
15:25:07 <DinaBelova> :"D
15:25:14 <DinaBelova> ok
15:25:18 <DinaBelova> smth else to discuss here?
15:25:19 <DinaBelova> :)
15:25:22 <bauzas> so that was basically a FYI
15:25:27 <DinaBelova> ok
15:25:31 <DinaBelova> good to know
15:25:37 <DinaBelova> I'm going to the next topic
15:25:39 <bauzas> sure
15:25:41 <DinaBelova> #topic Juno Summit
15:25:42 <DinaBelova> well
15:25:45 <pafuent> Wait
15:25:47 <DinaBelova> I've got updates :)
15:25:48 <DinaBelova> oh
15:25:51 <DinaBelova> pafuent?
15:25:54 <pafuent> https://review.openstack.org/#/c/76830/
15:26:14 <DinaBelova> ok, I wanted to mention it while open discussion
15:26:21 <DinaBelova> will you wait a little?
15:26:21 <pafuent> Ok
15:26:23 <DinaBelova> ok
15:26:25 <pafuent> Yep
15:26:28 <DinaBelova> about Juno summit
15:26:43 <DinaBelova> unfortunately we have no session voted for
15:26:45 <DinaBelova> on summit
15:26:57 <DinaBelova> but be prepared for paste bomb
15:27:05 <bauzas> :)
15:27:11 <bauzas> my screen can support it
15:27:14 <casanch1> what is paste bomb?
15:27:19 <DinaBelova> There is, however, an opportunity to have a speaking platform at the Summit that you may want to pursue. New to the Atlanta Summit the #vbrownbag Tech Talks will be onsite. The TechTalks offer a forum for community members to give ten minute presentations. TechTalks have a small in-person audience and will be livestreamed in real time. Additionally the presentations are video recorded and published to YouTube. If you are interested in
15:27:19 <DinaBelova> participating in the #vbrownbag TechTalks please complete this submission form: >...<
15:27:27 <DinaBelova> from email letter :)
15:27:31 <DinaBelova> from foundation :)
15:27:34 <bauzas> that's not a paste bomb
15:27:34 <bauzas> :p
15:27:38 <DinaBelova> well, yes
15:27:42 <DinaBelova> I was prepared for more :)
15:27:42 <bauzas> 2 lines, I'm disappointed :p
15:27:47 <DinaBelova> :D:D:D
15:27:51 <DinaBelova> sorry :)
15:28:04 <DinaBelova> well, we have alternative :)
15:28:10 <bauzas> a paste bomb is when you paste something big generating a bunch of IRC lines
15:28:26 <DinaBelova> I'll fill some form to participate in that tech talks
15:28:34 <bauzas> that's worth it
15:28:41 <DinaBelova> so I hope we'll have some nice videos from Juno summit :)
15:28:58 <DinaBelova> #action DinaBelova fill form to participate in #vbrownbag Tech Talks
15:28:59 <DinaBelova> ok
15:29:13 <DinaBelova> well, I guess that's it for this topic...
15:29:17 <bauzas> maybe we could ask michael still to know why we haven't been selected
15:29:23 <DinaBelova> I have no more news I guess
15:29:29 <DinaBelova> bauzas, well, good point
15:29:33 <DinaBelova> I'll ask him
15:29:42 <bauzas> maybe that's because of the proximity with design summit
15:29:44 <DinaBelova> bauzas, why Michael btw?
15:29:49 <DinaBelova> is he responsible for it?
15:29:50 <bauzas> as per these discussions
15:29:52 <bauzas> yey
15:29:54 <DinaBelova> ok
15:29:59 <bauzas> didn't you know that ?
15:30:09 <bauzas> there were 3 chairs for that Related OSS track
15:30:14 <DinaBelova> they are all new responsible peaople every 6 months :D
15:30:19 <DinaBelova> oh, ok
15:30:28 <bauzas> OSS ^projects track
15:30:31 <bauzas> and mstill was one of those
15:30:43 <DinaBelova> #action DinaBelova ask Michael Still about reasons for rejecting of Climate talk
15:30:45 <DinaBelova> ok
15:30:47 <bauzas> there is a ML you can see
15:30:52 <DinaBelova> thanks for info
15:30:55 <DinaBelova> bauzas, yeeeees
15:31:03 <DinaBelova> well, forgot about it
15:31:03 <bauzas> summit-chairs or something like that
15:31:06 <DinaBelova> sorry
15:31:15 <DinaBelova> next topic?
15:31:19 <bauzas> archives are open
15:31:20 <bauzas> sure
15:31:24 <DinaBelova> #topic Open discussion
15:31:27 <DinaBelova> well :)
15:31:28 <bauzas> oh
15:31:30 <bauzas> one secf
15:31:32 <DinaBelova> pafuent:)
15:31:41 <DinaBelova> https://review.openstack.org/#/c/76830/
15:31:42 <DinaBelova> yes?
15:31:47 <bauzas> forgot to explicitely mention the track for climate at the design summit
15:32:00 <DinaBelova> bauzas, cross-[roject one?
15:32:04 <bauzas> yu
15:32:05 <bauzas> yup
15:32:07 <DinaBelova> yes
15:32:29 <DinaBelova> #info we'll try to have cross-project session on summit due to TC decision
15:32:45 <DinaBelova> btw Monty likes idea to have it :)
15:32:52 <DinaBelova> so I guess we'll hold one :)
15:33:00 <DinaBelova> and as for https://review.openstack.org/#/c/76830/
15:33:19 <DinaBelova> bauzas, am I right that Swann won't have possibility to continue working on it?
15:33:35 <pafuent> Yes, I need that patch in trunk in order to add the uses of trusts in PR
15:33:54 <DinaBelova> I've -1'ed it due to trusts discussion
15:33:57 <DinaBelova> needed for Pablo
15:34:07 <DinaBelova> bauzas, do you know if Swann will finisj it?
15:34:10 <DinaBelova> finish*
15:34:14 <bauzas> DinaBelova: good question
15:34:25 <DinaBelova> well, as he sits next table to u :)
15:34:27 <bauzas> he's currently not there
15:34:28 <bauzas> :p
15:34:35 <DinaBelova> probably u may ask when he'll :)
15:34:53 <DinaBelova> #action bauzas ask scroiiset status for https://review.openstack.org/#/c/76830/
15:34:57 <DinaBelova> well
15:34:59 <DinaBelova> typos..
15:35:02 <DinaBelova> anyway :)
15:35:15 <bauzas> oh, he's just going back
15:35:19 <DinaBelova> :D:D:
15:35:26 <DinaBelova> so you may ask him right now :)
15:35:33 <DinaBelova> we'll give u some time :)
15:35:35 <bauzas> I have even something better :)p
15:35:43 <DinaBelova> wow :)
15:35:45 <scroiset> o/
15:35:53 <DinaBelova> scroiset, o'/
15:36:01 <bauzas> scroiset: status of https://review.openstack.org/#/c/76830/ ?
15:36:01 <DinaBelova> some news about https://review.openstack.org/#/c/76830/ ???
15:36:07 <DinaBelova> I was first :P
15:36:16 <bauzas> nope, same sec :p
15:36:26 <DinaBelova> ah
15:36:27 <DinaBelova> :)
15:36:37 <scroiset> no update since last discussion
15:36:59 <DinaBelova> scroiset, am I right this change should be updated to work with trusts?
15:37:08 <DinaBelova> scroiset, what do you need for testing?
15:37:13 <DinaBelova> Paplo
15:37:16 <DinaBelova> :(
15:37:20 <scroiset> DinaBelova: yes, need to check with paplo
15:37:21 <DinaBelova> Pablo's change?
15:37:43 <DinaBelova> ok, pafuent, will you collaborate with scroiset for that aim?
15:37:43 <pafuent> I fix the bug using this patch as a base
15:38:00 <DinaBelova> well, quite nice
15:38:02 <pafuent> For me is ok in it actual state
15:38:07 <DinaBelova> anyway, please collaborate
15:38:11 <pafuent> Sure, no problem
15:38:15 <scroiset> sure :D
15:38:18 <pafuent> It's the idea
15:38:20 <DinaBelova> pafuent, ok, so publish your change
15:38:25 <DinaBelova> and we'll check it together
15:38:26 <DinaBelova> :)
15:38:27 <scroiset> yes please
15:38:30 <scroiset> publish
15:38:40 <DinaBelova> it's hard testing without change published :)
15:38:56 <pafuent> The thing is that I need another change in master, so scroiset: Could you rebase your patch?
15:39:04 <DinaBelova> #action pafuent publish fix for PR + trusts
15:39:09 <scroiset> pafuent: okay
15:39:10 <DinaBelova> #action scroiset rebase https://review.openstack.org/#/c/76830/
15:39:12 <DinaBelova> ok :)
15:39:13 <DinaBelova> nice :)
15:39:26 <DinaBelova> smth else to discuss here?
15:39:49 <DinaBelova> well :)
15:39:51 <pafuent> Reviews for alembic patch :)
15:39:53 <DinaBelova> I guess no :)
15:39:55 <DinaBelova> oh
15:39:56 <DinaBelova> yeees
15:40:21 <DinaBelova> #action scroiset, bauzas  - please take a look on https://review.openstack.org/#/c/75181/
15:40:29 <DinaBelova> now I'm ok with it :)
15:40:38 <DinaBelova> so I need other opinions here too :)
15:40:39 <casanch1> It'll be great if someone else can take a look at the notifications implementation
15:40:41 <casanch1> :)
15:40:43 <bauzas> :)
15:40:59 <DinaBelova> and yep :) casanch1, you're right
15:41:00 <scroiset> add me an action for the notification review
15:41:06 <DinaBelova> #action scroiset, bauzas  - please take a look on https://review.openstack.org/#/c/75189/
15:41:18 <DinaBelova> smth else?
15:41:27 <casanch1> thanks!
15:41:29 <DinaBelova> maybe I forgot about smth?
15:41:48 <scroiset> yep, what is the status of pecan wsme ?
15:42:04 <DinaBelova> bauzas, please repeat ^^
15:42:27 <DinaBelova> bauzas?
15:42:42 <scroiset> ok, I'll read the logs ..
15:42:57 <DinaBelova> ok, there are many things done and not so many needed to be done :)
15:43:02 <DinaBelova> that's the best answer :)
15:43:20 <DinaBelova> so I guess that's it :)
15:43:23 <DinaBelova> bye :)
15:43:27 <pafuent> bye
15:43:28 <bauzas> bye
15:43:30 <scroiset> bye
15:43:40 <casanch1> bye!
15:43:47 <DinaBelova> Argentina - have a nice day, France - have a nice weekend :)
15:43:49 <DinaBelova> #endmeeting