15:00:02 <DinaBelova> #startmeeting climate
15:00:03 <openstack> Meeting started Fri Mar 28 15:00:02 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'climate'
15:00:16 <bauzas> o/
15:00:16 <DinaBelova> Climate folks - you here? :)
15:00:19 <DinaBelova> \o
15:00:21 <DinaBelova> cool
15:00:48 <DinaBelova> casanch1, cmart, cmart_, dpamio, f_rossigneux, mkaminsk, pafuent, scroiset_, tomek_adamczewsk?
15:00:56 <pafuent> o/
15:01:00 <DinaBelova> Swann won't be here, sorry
15:01:05 <DinaBelova> pafuent, o/
15:01:12 <dpamio> Hi there
15:01:15 <casanch1> o/
15:01:22 <DinaBelova> \o folks
15:01:23 <mkaminsk> i'm here
15:01:27 <DinaBelova> coolio
15:01:40 <DinaBelova> mkaminsk, I guess tomek_adamczewsk is your collegue
15:01:44 <DinaBelova> will he be here?
15:01:54 <DinaBelova> f_rossigneux, you here?
15:02:15 <bauzas> don't know for f_rossigneux
15:02:26 <DinaBelova> yes, me too :)
15:02:28 <DinaBelova> well
15:02:33 <DinaBelova> I think I'll start
15:02:40 <DinaBelova> today's agenda is
15:02:40 <DinaBelova> https://wiki.openstack.org/wiki/Meetings/Climate
15:02:41 <mkaminsk> yes, tomek_adamczewsk is my collegue and will be in one moment
15:02:57 <DinaBelova> tomek_adamczewsk, o/
15:03:08 <tomek_adamczewsk> Hi all
15:03:25 <DinaBelova> first of all - let me introduce our new contributors)
15:03:44 <DinaBelova> mkaminsk and tomek_adamczewsk will help us working on PR use case)
15:03:59 <DinaBelova> and I'm really glad :)
15:04:16 <DinaBelova> these folks are from Poland :)
15:04:24 <bauzas> welcome, mkaminsk and tomek_adamczewsk :)
15:04:27 <DinaBelova> so our european tram is growing :)
15:04:37 <mkaminsk> hi for everyone :)
15:04:42 <pafuent> mkaminsk: tomek_adamczewsk: welcome
15:04:44 <DinaBelova> well - it was team, not tram)
15:04:56 <casanch1> welcome
15:05:03 <DinaBelova> anyway, as usually, I'll start with action items
15:05:08 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:05:17 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-03-21-15.00.html
15:05:33 <DinaBelova> so let's go through all of them by person
15:05:39 <DinaBelova> bauzas, let's start with you
15:05:48 <bauzas> sure
15:06:00 <bauzas> reviews are in progress
15:06:07 <bauzas> I had no time to do the etherpad
15:06:19 <DinaBelova> ok, so I'll add this action item to you today
15:06:24 <bauzas> sure thing
15:06:35 <DinaBelova> #action bauzas create etherpad about new designs and amend according BPs and share links via ML
15:06:43 <DinaBelova> ok, next one is me)
15:07:02 <DinaBelova> we have good progress with tempest testing with cmart)
15:07:10 <DinaBelova> is _cmart here?
15:07:26 <DinaBelova> cmart_ :S
15:07:31 <DinaBelova> wow, noone)
15:07:36 <DinaBelova> rare thing
15:07:48 <casanch1> he's not at his desk :(
15:08:00 <DinaBelova> but anyway - Christian published first change for that tempest BP
15:08:15 <DinaBelova> and I guess we'll merge it soon - just after minor fixes
15:08:22 <DinaBelova> and all comments fixed
15:08:47 <bauzas> yes, some nits to be done yet
15:08:52 <DinaBelova> as for Barbican folks I had no opportunity to check if they need maintenance for gerrit while their moving
15:09:01 <DinaBelova> so I'll pick that action item for me one more time
15:09:10 <DinaBelova> #action DinaBelova check one more time if Barbican folks need some maintenance for gerrit while their moving
15:09:20 <DinaBelova> I've filled  form to participate in #vbrownbag Tech Talks
15:09:27 <bauzas> cool
15:09:32 <DinaBelova> and I had small conversation with Michael Still
15:09:33 <bauzas> who will be at summit ?
15:09:37 <DinaBelova> about reasons for rejecting of Climate talk
15:09:44 <bauzas> oh cool
15:09:47 <DinaBelova> bauzas, one moment
15:09:55 <DinaBelova> sadly, he's is in trip now
15:10:01 <DinaBelova> with rare unternet connections
15:10:16 <DinaBelova> so he'll answer me in mail when he'll had opportunity to do that
15:10:29 <bauzas> have you all seen the agenda for OSS related projects ?
15:10:35 <DinaBelova> currently I still dunno if reason was in lack of voices or any other reasons
15:10:58 <DinaBelova> bauzas, I did take a look on summit schedule
15:11:07 <bauzas> #link http://openstacksummitmay2014atlanta.sched.org/overview/type/related+oss+projects
15:12:01 <DinaBelova> well, quite narrow, but interesting topics
15:12:08 <bauzas> well, I don't want to point out someone, but I'm a bit frustrating to see again some talks we have at Icehouse and Havana summits...
15:12:20 <DinaBelova> well...
15:12:22 <bauzas> like if it was something automatic
15:12:27 <DinaBelova> sometimes that happens
15:12:31 <bauzas> anywat
15:12:33 <bauzas> anyway
15:12:37 <DinaBelova> and we can do nothing with it
15:12:51 <bauzas> let's take the opportunity to use the vbrownbag session
15:13:14 <DinaBelova> as for Swann - he's in process of doing / just done his action items
15:13:26 <DinaBelova> and it was action item - pafuent publish fix for PR + trusts
15:13:29 <bauzas> yep
15:13:31 <pafuent> Yes
15:13:31 <DinaBelova> pafuent? :)
15:13:38 <pafuent> I'm still working on it
15:13:49 <DinaBelova> well, may you provide draft at least?
15:13:56 <DinaBelova> for us start looking on ut?
15:13:57 <DinaBelova> it*
15:13:58 <pafuent> I think is almost done. At this moment I'm doing some manual testing
15:14:08 <pafuent> I think
15:14:28 <DinaBelova> #action pafuent publish fix (at least draft for core-team) for PR + trusts
15:14:38 <DinaBelova> I'll really appreciate you'll do that today
15:14:54 <DinaBelova> pafuent, are you ok with it?
15:15:00 <pafuent> Ok, I'll try to do it
15:15:11 <DinaBelova> ok, great
15:15:16 <pafuent> Yes, I found that PR plugin doesn't work with PostgreSQL
15:15:29 <pafuent> I'm double checking that in order to fill a bug
15:15:30 <DinaBelova> pafuent, hm
15:15:34 <DinaBelova> ok
15:15:35 <bauzas> ?
15:15:46 <DinaBelova> I'm not really sure
15:15:51 <bauzas> ok, would be interesting to know the reason
15:15:58 <bauzas> as we leverage SQLA
15:15:58 <pafuent> Returning exception (ProgrammingError) operator does not exist: character varying = integer
15:15:58 <pafuent> LINE 4: WHERE computehosts.id = 1
15:15:59 <DinaBelova> bauzas, +1
15:16:05 <DinaBelova> oh
15:16:11 <DinaBelova> ni-i-ice
15:16:20 <DinaBelova> ok, we'll look on bug
15:16:20 <pafuent> The id is an uuid and in nova is an integer
15:16:34 <pafuent> Seems that PostgreSQL doesn't like that
15:16:42 <DinaBelova> well, anyway
15:16:49 <pafuent> MySQL seems to be more permissive
15:16:49 <DinaBelova> let's go further
15:16:50 <bauzas> ok, let's see your proposal then :)
15:17:01 <DinaBelova> #toppic Volume reservation concept
15:17:04 <DinaBelova> agrh
15:17:09 <DinaBelova> #topic Volume reservation concept
15:17:18 <DinaBelova> #link https://blueprints.launchpad.net/climate/+spec/basic-volume-plugin
15:17:36 <DinaBelova> casanch1, may you tell us current status for that?
15:17:37 <casanch1> that's me :)
15:17:46 <DinaBelova> I know ;)
15:18:02 <casanch1> I have just posted an etherpad in the BP whiteboard
15:18:09 <casanch1> cinder does support extensions
15:18:13 <DinaBelova> #link https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:18:32 <casanch1> so we will need to create a repo climate-cinder
15:18:40 <casanch1> to capture the API calls
15:18:59 <casanch1> so, for lease creations it is more or less ok, we can follow the same approach done for Nova
15:19:15 <casanch1> but... what should happen when the lease for a volume starts?
15:19:16 <DinaBelova> well, it looks so... as we have no opportunity to keep imports from nova/cinder in one repo due to oslo duplicate option hell
15:19:39 <casanch1> oh, one more thing: cinder API does not have hints
15:19:47 <DinaBelova> hm
15:19:50 <DinaBelova> not nice
15:19:54 <casanch1> but it supports arbitrary metadata
15:20:01 <bauzas> sounds like there is need to commit on cinder :)
15:20:18 <DinaBelova> well, I guess metadata is more than good
15:20:25 <casanch1> maybe we could use this metadata to send lease info
15:20:35 <casanch1> but... this will be stored in cinder db
15:20:46 <casanch1> and of course in Climate db when the lease is created
15:21:03 <casanch1> I think metadata is ok for now
15:21:09 <DinaBelova> in cinder db it'll be only lease-id, i guess
15:21:16 <DinaBelova> not all info really
15:21:41 <bauzas> casanch1: will you be at summit ?
15:21:47 <casanch1> yes I will
15:21:53 <DinaBelova> bauzas - casanch1 and pafuent
15:21:53 <bauzas> because I think we need to discuss on this at summit time
15:22:05 <bauzas> that's a really wide discussion
15:22:11 <DinaBelova> well, I propose to prepare ideas/drafts before)
15:22:12 <casanch1> ok
15:22:18 <bauzas> on etherpad yes
15:22:19 <DinaBelova> so casanch1 is working on it now)
15:22:24 <bauzas> the etherpad is created IIRC
15:22:38 <DinaBelova> bauzas ^^ - https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:22:53 <DinaBelova> ok, so we'll continue discussion there
15:22:55 <casanch1> my biggest question is what will happen when the lease starts...
15:22:56 <bauzas> yep
15:23:13 <DinaBelova> casanch1, we'll try to define that in etherpad
15:23:18 <casanch1> ok
15:23:29 <DinaBelova> #action everyone propose ideas in https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:23:38 * DinaBelova going further
15:23:42 <bauzas> casanch1: I personally think that the call should be placed from climate at first
15:23:45 <bauzas> like for PR
15:23:54 <DinaBelova> #topic Energy efficiency BP status (if Francois will come to meeting)
15:23:59 <casanch1> ok
15:24:12 <DinaBelova> bauzas, that will be done only after new lease-creation architecture
15:24:23 <DinaBelova> so we'll need your documents first ;)
15:24:29 <DinaBelova> as for energy efficiency
15:24:41 <DinaBelova> I had funny conversation with Francois :)
15:24:53 <DinaBelova> f_rossigneux, you here?
15:25:11 <DinaBelova> well, anyway
15:25:44 <bauzas> DinaBelova: what's the result of this discussion ? :D
15:25:46 <DinaBelova> he really started working with it - the only moment was that he did not discuss all that stuff with others Climate team.
15:25:47 <bauzas> trailers are good :)
15:25:57 <DinaBelova> I asked him to write letter to ML
15:26:01 <bauzas> sure thing
15:26:07 <DinaBelova> but well - he said he'll do that
15:26:09 <bauzas> he needs to share his thoughts
15:26:12 <DinaBelova> but no letter I see
15:26:26 <DinaBelova> for example. he created repo in his own github account
15:26:28 <DinaBelova> https://github.com/frossigneux/kwstandby
15:26:43 <DinaBelova> to start working on ipmi stuff and so one
15:27:19 <DinaBelova> as i really did not think it'll be other repo (and definitely not in his github accout) I asked him to share ideas and current status
15:27:22 <bauzas> well, I can't say  more than...
15:27:28 <DinaBelova> will continue pinging him
15:27:41 <DinaBelova> as currently I'm a little bit out of context
15:27:45 <DinaBelova> he was really busy before
15:27:56 <DinaBelova> that's why i thought he simply did not start yes
15:27:58 <bauzas> let's consider that if he doesn't follow the process, we give -2 to his changes
15:27:59 <DinaBelova> yet*
15:28:13 <DinaBelova> well, he's quite new to open source
15:28:16 <bauzas> well, he should have time now
15:28:24 <DinaBelova> so i prefer more gentle -1
15:28:25 <DinaBelova> anyway
15:28:26 <bauzas> he has 1 yr background :)
15:28:34 <DinaBelova> it looks like no
15:28:38 <DinaBelova> anyway
15:28:49 <DinaBelova> let's not discussing him without him here
15:29:07 <bauzas> sure thing
15:29:10 <DinaBelova> I'll do Francois will share his current status and ideas
15:29:17 <DinaBelova> and we'll discuss that public
15:29:39 <DinaBelova> well, Im moving on
15:29:48 <DinaBelova> #topic Open discussion
15:30:12 <DinaBelova> folks, do you have quesiotns to discuss?
15:30:16 <DinaBelova> questions*
15:30:17 <casanch1> I have just one
15:30:22 <DinaBelova> you're welcome
15:30:46 <casanch1> bauzas, could you please give +2 back to this: https://review.openstack.org/#/c/82192/
15:30:57 <bauzas> casanch1: ok
15:31:00 <DinaBelova> casanch1, I love the way you say it ;)
15:31:05 <casanch1> :)
15:31:16 <casanch1> thank you bauzas
15:31:18 <DinaBelova> #info casanch1 will have vacation 2 next weeks
15:31:25 <DinaBelova> am I right?
15:31:35 <casanch1> yes
15:31:39 <bauzas> for info as well, I'm moving from one position to another
15:31:40 <casanch1> the following 2 weeks
15:31:57 <bauzas> with a focus area on Nova mainly now
15:32:12 <bauzas> hence my currently dotting support
15:32:13 <DinaBelova> bauzas, may I info that about your new company?
15:32:20 <DinaBelova> for us to congrat you?
15:32:26 <bauzas> well, not yet :)
15:32:30 <DinaBelova> ok :)
15:32:45 <bauzas> I'll still continue to support Climate of course
15:32:53 <bauzas> but with less focus than previously
15:33:00 <bauzas> I'll still focus on reviewing code
15:33:05 <bauzas> but with less commits
15:33:10 <DinaBelova> ok, got it
15:33:24 <bauzas> that leads to my question
15:33:28 <DinaBelova> ok?
15:33:43 <bauzas> we had an election 4 months ago ^_^
15:33:49 <DinaBelova> and yes
15:34:20 <bauzas> I was wondering if we were planning to do another set of elections for the PTL position ?
15:34:20 <DinaBelova> we need to have #1 new PTL election and #2 take a look on current core team
15:34:34 <DinaBelova> well, I'll propose my candidate)
15:34:41 <DinaBelova> if there will be no others - well
15:34:48 <DinaBelova> possibly it's not useful here
15:34:54 <DinaBelova> do you have ideas?
15:35:17 <bauzas> I won't propose myself for obvious reasons :)
15:35:32 <DinaBelova> ok, so are we going to have one more election?
15:35:38 <bauzas> think so
15:35:59 <bauzas> let's ask our lovely sherpa to cornac this election :)
15:36:05 <bauzas> SergeyLukjanov ^^
15:36:13 <DinaBelova> >> sherpa to cornac ????
15:36:40 <bauzas> http://en.wikipedia.org/wiki/Sherpa_people
15:36:43 <DinaBelova> #info we need to organize new PTL elections
15:36:50 <SergeyLukjanov> bauzas, DinaBelova, I'm ready to do it
15:36:57 <DinaBelova> SergeyLukjanov, cool
15:37:09 <DinaBelova> so we'll have 1 week for candidates self proposal
15:37:18 <DinaBelova> and 1 week for voting itself
15:37:22 <DinaBelova> smth like that?
15:37:27 <bauzas> as for the other projects
15:37:34 <bauzas> see Anita e-mail
15:37:50 <SergeyLukjanov> so, you'd like to adjust elections with official programs schedule?
15:38:08 <bauzas> * March 28 - April 4, 05:59 UTC: Open candidacy to PTL positions * April 4 - April 11: PTL elections
15:38:15 <bauzas> I would love to do it, yes
15:38:24 <bauzas> unless there is a constraint, of course
15:38:30 <SergeyLukjanov> okay, I'll send an email today
15:38:36 <SergeyLukjanov> any objections?
15:38:41 <bauzas> we can vote :)
15:38:48 <DinaBelova> ok
15:39:15 <DinaBelova> #info start PTL elections with official programs schedule - * March 28 - April 4, 05:59 UTC: Open candidacy to PTL positions * April 4 - April 11: PTL elections
15:39:27 <DinaBelova> ok, cool
15:39:34 <DinaBelova> smth else here to discuss?
15:40:00 <pafuent> https://review.openstack.org/#/c/76830/
15:40:08 <DinaBelova> and yes
15:40:27 <pafuent> It's the scroiset_ patch
15:40:43 <bauzas> yup ?
15:40:53 <DinaBelova> I really wanted to ask Swann how he tested that) but anyway - I'll do some manual testing and find out if i can change my +1 to +2
15:40:58 <DinaBelova> will try to do that today
15:41:12 <DinaBelova> bauzas, pafuent need that change
15:41:22 <DinaBelova> for his one with PR and trusts
15:41:28 <DinaBelova> needs*
15:41:31 <pafuent> He changed the NovaBlaBla to not use singletons, which for me is ok (I did that change in my pathc)
15:41:39 <pafuent> s/pathc/patch
15:41:52 <DinaBelova> and it'll be cool we'll merge it
15:41:54 <DinaBelova> really
15:42:00 <bauzas> yup, understood the need
15:42:17 <DinaBelova> #action DinaBelova, bauzas - review https://review.openstack.org/#/c/76830/
15:42:21 <DinaBelova> ok
15:42:25 <pafuent> Thanks
15:42:30 <bauzas> I did test this review
15:42:36 <bauzas> I can already give a +2
15:42:42 <DinaBelova> it was a little changed
15:43:06 <DinaBelova> like no singleton -> it night cause issues with PR i guess...
15:43:15 <bauzas> well, ok
15:43:19 <pafuent> bauzas: Could you share how you test it? Because I need to do the same for my patch
15:43:21 <DinaBelova> although I guess it won't
15:43:34 <bauzas> you have to source the code by yourself
15:44:13 <pafuent> bauzas: I want to know how to test the PR plugin
15:44:28 <bauzas> that requires to setup a PR evn
15:44:32 <DinaBelova> pafuent, well, simply we need to test if it'll work ok with two original use cases (PR + VR) with different user/project combinations
15:44:45 <DinaBelova> as novaclient will use different tokens there
15:44:52 <pafuent> bauzas: I don't know If the steps that I'm doing are sufficient
15:44:53 <bauzas> DinaBelova: +1
15:45:14 <DinaBelova> pafuent, please list these steps :)
15:45:33 <pafuent> I'm creating the host, then creating a lease
15:46:42 <pafuent> I could not find a complete use case
15:46:46 <DinaBelova> you should check also if 1/ VMs are going to reserved hosts when lease starts 2/ updating lease (like end date changing) 3/ find out what happens when PR ends
15:47:03 <bauzas> pafuent: both steps are good
15:47:51 <pafuent> How I assign VMs to the host?
15:48:20 <DinaBelova> by passing --hint reservation= while VM creation
15:48:21 <bauzas> by passing a scheduler hint
15:48:26 <bauzas> +1
15:48:40 <pafuent> Ok
15:48:41 <DinaBelova> you may find it in nova-client repo
15:48:46 <DinaBelova> I mean filter itself
15:49:01 <DinaBelova> one moment
15:49:39 <DinaBelova> https://github.com/stackforge/climate-nova/blob/master/climatenova/scheduler/filters/climate_filter.py#L74
15:49:57 <DinaBelova> and there is nice doc in that method
15:50:10 <DinaBelova> well - smth else?
15:50:33 <DinaBelova> well, bye :)
15:50:39 <dpamio> Regarding https://review.openstack.org/#/c/79399/
15:50:39 <DinaBelova> have a nice weekend - all of you)
15:50:42 <DinaBelova> oh
15:50:56 <casanch1> bye :)
15:51:00 <DinaBelova> dpamio - yes?
15:51:14 <dpamio> just to clarify, bauzas, shall I move the #noqa fix to another bug?
15:51:44 <DinaBelova> it looks like bauzas is proposing to move all changes in that file to separated one
15:51:53 <dpamio> ok, will do
15:52:00 <DinaBelova> ok, cool
15:52:03 <dpamio> just wanted to check.
15:52:12 <DinaBelova> ok, bye!
15:52:13 <dpamio> thnks
15:52:15 <DinaBelova> :)
15:52:18 <DinaBelova> #endmeeting