15:01:59 <DinaBelova> #startmeeting climate
15:02:00 <openstack> Meeting started Fri Apr  4 15:01:59 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:03 <openstack> The meeting name has been set to 'climate'
15:02:08 <DinaBelova> o/
15:02:13 <DinaBelova> hello folks!
15:02:13 <bauzas_mob> Hi
15:02:13 <cmart> \o
15:02:18 <cmart> hello
15:02:21 <pafuent> o/
15:02:26 <DinaBelova> hello, guys)
15:02:44 <DinaBelova> ok
15:02:53 <DinaBelova> so today's agenda is the following
15:03:00 <DinaBelova> #link https://wiki.openstack.org/wiki/Meetings/Climate
15:03:11 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:03:20 <scroiset_> o/
15:03:22 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-03-28-15.00.html
15:03:25 <DinaBelova> Swann, o/
15:03:38 <DinaBelova> so, as for the action items
15:03:52 <DinaBelova> bauzas_mob, are you ok to give status?
15:03:54 <bauzas_mob> I got one :-)
15:04:20 <DinaBelova> well)
15:04:20 <bauzas_mob> so the etherpad is created
15:04:40 <bauzas_mob> feel free to comment it
15:04:43 <DinaBelova> ok, cool
15:04:57 <DinaBelova> may you publish the link&
15:04:59 <DinaBelova> here?
15:05:12 <DinaBelova> So I'll create action item
15:05:24 <bauzas_mob> Sure
15:05:48 <DinaBelova> ok, waiting for that)
15:06:04 <bauzas> https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:06:33 <DinaBelova> #action everyone take a look on https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:06:41 <bauzas> schizophrenia, bauzas_mob is my mobile device :)
15:06:50 <DinaBelova> we got it)
15:06:57 <cmart> two bauzas at the price of one :)
15:07:02 <DinaBelova> ok, as for the my action items
15:07:24 <DinaBelova> so Barbican folks seem to need maintenance)
15:07:33 <DinaBelova> so we can join them, I guess)
15:07:35 <DinaBelova> soo
15:08:01 <DinaBelova> #action DinaBelova write Barbican folks about one gerrit maintenance
15:08:02 <bauzas> cool :)
15:08:07 <DinaBelova> ok
15:08:22 <DinaBelova> as for the https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:08:33 <DinaBelova> I'm really sorry, but I ha dno time for it this week
15:08:55 <DinaBelova> So I'll take a look on it this one
15:09:13 <DinaBelova> #action DinaBelova view & comment https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:09:17 <pafuent> The same is for me
15:09:25 <DinaBelova> ok
15:09:52 <DinaBelova> and pafuent added https://review.openstack.org/#/c/84158/ on review)
15:09:56 <DinaBelova> that's quite cool
15:10:08 <DinaBelova> but as you see there is error now there
15:10:17 <DinaBelova> so pafuent please rebase this change
15:10:18 <bauzas> yup
15:10:24 <pafuent> OK
15:10:29 <pafuent> I'll do it
15:10:29 <DinaBelova> it looks like fast-forward merging did not work
15:10:31 <DinaBelova> ok
15:10:43 <DinaBelova> ok, so that's it for this topic
15:10:53 <DinaBelova> #topic Renaming status
15:11:12 <DinaBelova> I'm still waiting the response from the foundation...
15:11:18 <DinaBelova> I'll ping them one more time today
15:11:27 <DinaBelova> to find out results of their checks
15:11:40 <bauzas> ok
15:11:53 <cmart> cool
15:11:54 <DinaBelova> as if we'll be together with barbican, we need to know what name to use :D
15:12:05 <pafuent> :-D
15:12:11 <DinaBelova> well, they were silent, will ping them one more time
15:12:26 <DinaBelova> #action DinaBelova ping foundation about new name search status
15:12:30 <bauzas> ok
15:12:36 <DinaBelova> so, I'm moving further
15:12:42 <DinaBelova> #topic Cross-project session status
15:12:49 <DinaBelova> ok, so we have some news
15:13:16 <bauzas> #link http://summit.openstack.org/cfp/details/45
15:13:22 <DinaBelova> first of all, it was decided to set deadline for the cross-project sessions and 'other' sessions to the 10 April
15:13:24 <DinaBelova> so
15:13:30 <bauzas> (for convenience :) )
15:13:35 <DinaBelova> it'll be the last day for these topics proposal
15:13:37 <DinaBelova> ;)
15:14:09 <DinaBelova> and also it was decided to make decisions about what sessions to be spoken before mid April
15:14:27 <DinaBelova> so we'll know for sure about if there will it be ~15 April
15:14:40 <DinaBelova> currently chances are quite nice, btw
15:14:53 <bauzas> cool
15:15:02 <bauzas> I raised this topic during last Gantt meeting
15:15:02 <DinaBelova> so, that were some kind of news I wanted to tell on this topic
15:15:08 <DinaBelova> yep, saw that)
15:15:13 <bauzas> because there was some interest
15:15:17 <bauzas> lurker ! ;)
15:15:28 <DinaBelova> about gantt api?
15:15:39 <DinaBelova> this one?
15:15:40 <bauzas> nope, about cross-service scheduling
15:15:43 <DinaBelova> oh, ok
15:15:48 <DinaBelova> cool
15:15:56 <DinaBelova> so, I think we might move on
15:16:11 <bauzas> +1
15:16:16 <DinaBelova> #topic Energy efficiency BP status
15:16:29 <DinaBelova> f_rossigneux, you here?
15:16:46 <f_rossigneux> yes
15:16:49 <DinaBelova> ok, cool
15:16:57 <DinaBelova> please describe current status for this BP
15:17:02 <DinaBelova> in several words
15:17:56 * DinaBelova waiting :)
15:18:12 <f_rossigneux> This blueprint can be reviewed.
15:18:32 <DinaBelova> well, I was mostly about what had you already done
15:19:05 <DinaBelova> because, for example, for me it was quite a surprise to anderstand that you have started your work - without setting BP to the started phase
15:19:15 <DinaBelova> and to learn that you created separated repo, etc.
15:19:35 <DinaBelova> because I've looked through your etherpad
15:19:42 <DinaBelova> #link https://etherpad.openstack.org/p/climate-standby-modes
15:19:54 <DinaBelova> and I've got some questions
15:20:05 <scroiset_> f_rossigneux: did you take a look at the ironic api ?
15:20:10 <scroiset_> #link http://docs.openstack.org/developer/ironic/webapi/v1.html#nodestates
15:20:44 <f_rossigneux> Not yet, today I was finalizing the client to query my "kwstandby" module.
15:20:46 <scroiset_> if it's can be leveraged ... ?
15:21:31 <scroiset_> ok
15:21:44 <f_rossigneux> I have writte a module to put the host in standby modes. It in finished but not yet tested on a real infrastructure. Climate will use it, but I consider it as an external project. It could be merged in the future.
15:22:33 <bauzas> I would vote to put your plugin in the contrib repo then
15:22:34 <DinaBelova> I've got mostly questions about your events - for example, there is already pre-start events, etc. + I'm not sure that it 1/ should be separated repo 2/ it definately should not be on your github, but in the stackfoge, even if needed 3/ i definately don't like the idea of 3-rd party dependency for climate
15:22:43 <f_rossigneux> The most important feature to implement now is the reservation aggregation, in order to minimize the number of active hosts.
15:22:48 <DinaBelova> so ++ for bauzas
15:23:40 <DinaBelova> because simply we'll have no opportunity to say "import kwstandbyclient" in climate
15:23:50 <bauzas> +1
15:23:55 <DinaBelova> as we're still hoping for being separated project after summit
15:24:12 <DinaBelova> and there *can't* be such dependencies in incubated project, for instance
15:24:23 <scroiset_> +1 ^^^
15:24:39 <DinaBelova> I'll ask all of us to take a look on Francois' etherpad and to comment all unliked moments
15:24:39 <bauzas> we can imagine a plugin in contrib with appropriate instructions for adding it
15:25:12 <DinaBelova> f_rossigneux, sorry for that, but it would have been quite easier if we *knew* you started work
15:25:15 <DinaBelova> so
15:25:22 <bauzas> the bad is that we won't have the opportunity to leverage it within Climate directly :(
15:25:51 <DinaBelova> #action all comment https://etherpad.openstack.org/p/climate-standby-modes - find all naughty things and try to do that as quick as possible
15:26:00 <DinaBelova> ok
15:26:16 <DinaBelova> so, if that's it here, I'll set next topic
15:26:27 <f_rossigneux> ok
15:26:31 <DinaBelova> #topic Open discussion
15:26:47 <DinaBelova> so, folks, do you have some questions to be discussed here?
15:26:55 <pafuent> https://bugs.launchpad.net/climate/+bug/1301294
15:26:57 <uvirtbot> Launchpad bug 1301294 in climate "Physical reservations don't work when service name != hypervisor_name" [Undecided,New]
15:27:21 <DinaBelova> ok, looking on it
15:27:29 <pafuent> bauzas: I don't get why are you saying "Nova puts the host in the freepool agg and take use of service_name." Climate is passing the id or the name of the host to nova.
15:27:31 <bauzas> sure pafuent
15:27:45 <bauzas> so, let me show you the discrepancy
15:27:52 <pafuent> OK
15:27:54 <bauzas> that's happening with Havana
15:28:07 <bauzas> but there are possibilities to get it in also Icehouse
15:28:49 <bauzas> https://github.com/stackforge/climate/blob/master/climate/plugins/oshosts/reservation_pool.py#L194
15:29:02 <bauzas> agg.hosts is returning the name of the hosts
15:29:29 <bauzas> but the names are actually the service_name's :)
15:29:34 <bauzas> not the hypervisor ones
15:29:40 <bauzas> that's highly visible in Havana
15:29:44 <DinaBelova> wow, nice)
15:29:47 <bauzas> because on devstack
15:29:58 <bauzas> hypervisor_hostname is the FQDN
15:30:11 <bauzas> like foo.local
15:30:19 <bauzas> and service_name is only foo
15:30:31 <bauzas> test it on your own and you'll see
15:30:37 <cmart> sorry.. What's FQDN?
15:30:45 <bauzas> fully qualified domain name
15:30:53 <cmart> ah OK!
15:30:58 <DinaBelova> http://en.wikipedia.org/wiki/Fully_qualified_domain_name
15:31:00 <DinaBelova> ;)
15:31:07 <cmart> got it, thanks!
15:31:12 <scroiset_> and to cover all cases, the hostname can be set in nova.conf too
15:31:18 <bauzas> yep
15:31:21 <DinaBelova> ++
15:31:25 <bauzas> hence the problem
15:31:28 <DinaBelova> so, ok
15:31:35 <bauzas> the service_name will be set by nova.conf
15:31:39 <DinaBelova> pafuent, have you got the problem?
15:31:45 <bauzas> and possibly different from hypervisor_hosntame
15:32:10 <bauzas> so we need to rely on service_name
15:32:14 <bauzas> for the test
15:32:31 <DinaBelova> pafuent?
15:32:48 <bauzas> meaning that the arg 'host' must be coming from host['service_name']
15:32:59 <bauzas> and not host['hypervisor_hostname']
15:33:01 <DinaBelova> well, I guess that's it here
15:33:07 <DinaBelova> some other things?
15:33:12 <bauzas> so I was proposing to store it in DB
15:33:25 <bauzas> because we already obtain it when inventoring the host
15:33:35 * DinaBelova feeling bad because of catching a cold, please let's end this meeting :)
15:33:36 <bauzas> that's only a value we don't take
15:33:36 <pafuent> I'm a little lost, I need to read this carefully
15:34:20 <DinaBelova> folks, I'm going to die right now, let's continue this discussion in our channel
15:34:21 <scroiset_> just a quick work about notificaiton ...
15:34:23 <DinaBelova> ok
15:34:26 <DinaBelova> scroiset_?
15:34:27 <scroiset_> I'reviewed it
15:34:28 <bauzas> https://github.com/stackforge/climate/blob/master/climate/plugins/oshosts/reservation_pool.py#L194
15:34:48 <bauzas> I have to go in 5 mins anyway
15:34:51 <scroiset_> need a rebase and some words to document it but seems good :)
15:35:05 <bauzas> DinaBelova: if you feel bad, give me the chair
15:35:13 <bauzas> and go sleeping :-)
15:35:24 <DinaBelova> well, several minutes I'll be ok)
15:35:25 <bauzas> your health is much more important than our meeting :)
15:35:35 <pafuent> +1
15:35:36 <cmart> agree
15:35:39 <scroiset_> +1
15:35:49 <DinaBelova> well, as for the notifications, let's rebase it and review :)
15:36:07 <DinaBelova> and as for the pafuent 's bug -> continue in our channel
15:36:16 <DinaBelova> everyone ok with it?
15:36:19 <pafuent> Yes
15:36:21 <cmart> yes
15:36:31 <DinaBelova> cool, thanks)
15:36:32 <DinaBelova> bye!
15:36:37 <DinaBelova> #endmeeting