15:00:04 <DinaBelova> #startmeeting climate
15:00:05 <openstack> Meeting started Fri Apr 11 15:00:04 2014 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <openstack> The meeting name has been set to 'climate'
15:00:17 <DinaBelova> cmart, f_rossigneux, pafuent, scroiset, tomek_adamczewsk - you here? :)
15:01:06 <DinaBelova> fo-o-olks)
15:01:36 <cmart> I'm here!
15:01:39 <DinaBelova> cmart, o/
15:01:52 <DinaBelova> don't you know - will we be alone today? ;)
15:02:01 <cmart> o_O
15:02:10 <DinaBelova> I simply see no other reaction)
15:02:14 <cmart> what is going on??
15:02:14 <DinaBelova> from other guys)
15:02:17 <schwicke> I'm here as well
15:02:24 <cmart> let me chat pablo
15:02:43 <DinaBelova> schwicke, sorry - did not see you before on our meetings)
15:02:44 <cmart> DinaBelova, pafuent got disconnected..
15:02:48 <DinaBelova> okay
15:03:00 <schwicke> true
15:03:01 <cmart> he'll be here soon
15:03:02 <DinaBelova> we'll wait Pablo and start)
15:03:19 <VINOD_> hi
15:03:23 <pafuent> o/
15:03:26 <schwicke> I think we have a time zone shifting issue
15:03:37 <DinaBelova> oh
15:03:49 <VINOD_> Is it the metting about the Hierarchical Multitenancy
15:03:53 <DinaBelova> hm
15:03:55 <DinaBelova> strange
15:04:04 <pafuent> o/ (connection problems)
15:04:06 <DinaBelova> what time UTC is now?
15:04:19 <scroiset> o/
15:04:26 <cmart> 3 PM?
15:04:41 <VINOD_> yes 3 pm
15:04:46 <DinaBelova> https://wiki.openstack.org/wiki/Meetings/Climate - 3PM is Climate meeting
15:04:53 <VINOD_> ok, sorry
15:04:56 <DinaBelova> am I wrong?
15:05:20 <DinaBelova> https://wiki.openstack.org/wiki/Meetings#Climate_.28Reservations.29_team_meeting - still 3PM
15:05:30 <schwicke> nope I think you are right
15:05:39 <DinaBelova> okay, so I'll continue Climate meeting if so)
15:05:48 <DinaBelova> pafuent, cmart - you still here?
15:05:50 <schwicke> sorry for the noise
15:05:54 <cmart> yes!
15:05:57 <pafuent> Yes
15:05:59 <pafuent> ...
15:06:02 <cmart> schwicke, no problem!
15:06:03 <pafuent> :-D
15:06:06 <DinaBelova> okay)
15:06:12 <DinaBelova> so today's agenda is
15:06:14 <DinaBelova> #link https://wiki.openstack.org/wiki/Meetings/Climate
15:06:27 <DinaBelova> #topic Action items from the last meeting + reviews queries
15:06:46 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-04-04-15.01.html
15:06:59 <DinaBelova> okay
15:07:09 <DinaBelova> so as usually, let's start with the action items
15:07:19 <DinaBelova> as for my points
15:07:49 <DinaBelova> 1/ we definately need to coordinate with Barbican folks while gerrit maintenance
15:08:06 <DinaBelova> 2/ No answer from foundation about new name availability 0_0
15:08:19 <DinaBelova> although I pinged directly Lauren
15:08:30 <DinaBelova> so I'll try to find her asap...
15:08:37 <DinaBelova> so this action item still on me
15:08:48 <DinaBelova> #action DinaBelova ping foundation about new name search status
15:09:12 <DinaBelova> and also we have pack of etherpads related action items
15:09:16 <DinaBelova> for all of us
15:09:36 <DinaBelova> sadly, I see no bauzas here :(
15:09:46 <DinaBelova> So we can't discuss https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:10:02 <DinaBelova> as for the https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin
15:10:29 <DinaBelova> as far as I remember, it was Cristian's BP and overall idea
15:10:37 <DinaBelova> he's on vacation, afaik
15:10:40 <pafuent> Yes
15:11:07 <DinaBelova> and I'm really sorry, but I had not so much opportunity to take a look on https://etherpad.openstack.org/p/climate-standby-modes
15:11:21 <DinaBelova> pafuent, I guess you've looked on it?
15:11:25 <pafuent> Yes
15:11:31 <cmart> me too..
15:11:33 <pafuent> I added two comments
15:11:47 <DinaBelova> okay, folks..
15:12:00 <DinaBelova> as Francois forgot about us, I feel a little lost here)
15:12:02 <cmart> if I remember correctly, Cristian's main concern was around the volume start..
15:12:25 <DinaBelova> yes, and this question might be really connected with Sylvain's etherpad
15:12:46 <DinaBelova> as it'll provide new way of resource behaviour here
15:12:59 <cmart> agree
15:13:00 <DinaBelova> so Cristian & Sylvain need to coordinate here
15:13:33 <DinaBelova> #info https://etherpad.openstack.org/p/climate-resource-allocation-framework and https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin - quite connected BPs
15:13:36 <cmart> and they're busy guys.. :S
15:13:37 <DinaBelova> okay
15:13:41 <DinaBelova> :(
15:13:45 <DinaBelova> well, I guess yes :(
15:13:59 <pafuent> Sorry to ask, but: Will Sylvain implement something related to that etherpad?
15:14:13 <DinaBelova> pafuent, really good question!
15:14:17 <DinaBelova> as he really wanted to
15:14:21 <DinaBelova> but now...
15:14:27 <DinaBelova> as he has new focus on the nova..
15:14:28 <scroiset> pafuent: I know he's working on gantt ..
15:14:34 <scroiset> and nova ..
15:14:38 <DinaBelova> scroiset, o/
15:15:10 <pafuent> Ok
15:15:15 <DinaBelova> #action bauzas should say if he'll work on https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:15:25 <scroiset> sorry guys, I hadn't take a look on all etherpads ..
15:15:31 <DinaBelova> we'll understand this before next meeting
15:15:33 <DinaBelova> scroiset, np
15:15:46 <DinaBelova> so
15:15:49 <scroiset> regive me an action .. I'll do it next week
15:16:24 <DinaBelova> #action scroiset - take a look on https://etherpad.openstack.org/p/climate-resource-allocation-framework https://etherpad.openstack.org/p/climate-bp-basic-volume-plugin https://etherpad.openstack.org/p/climate-standby-modes
15:16:26 <DinaBelova> ;)
15:16:27 <cmart> that's the spirit! :)
15:16:35 <DinaBelova> cmart, +1
15:16:41 <DinaBelova> okay
15:16:42 <scroiset> :)
15:16:45 <DinaBelova> next topic)
15:16:55 <DinaBelova> #topic Summit session status
15:17:15 <DinaBelova> as for the summit session
15:17:24 <DinaBelova> I got that it won't be cross-project one
15:17:41 <DinaBelova> as there are not so many slots, and lots topics (more important ones) to be discussed there
15:17:43 <DinaBelova> but
15:17:58 <DinaBelova> we'll 98% have "other projects" session
15:18:17 <DinaBelova> where we'll discuss everything we want to with interested in folks)
15:18:31 <DinaBelova> so that were the news I wanted to share
15:18:48 <DinaBelova> does someone here knows smth else?
15:18:52 <DinaBelova> about this moment?
15:19:03 <pafuent> Sorry but I didn't get the "we'll 98% have "other projects" session"
15:19:09 <cmart> hmm.. not from my side
15:19:13 <DinaBelova> there are different threads
15:19:16 <DinaBelova> on summit
15:19:22 <DinaBelova> with different topics
15:19:29 <DinaBelova> I mean overall area
15:19:32 <DinaBelova> one moment
15:20:11 <DinaBelova> https://wiki.openstack.org/wiki/Summit/Juno#Topics
15:20:31 <DinaBelova> and there are not only "Official programs" topics there
15:20:46 <DinaBelova> but also "Cross-project workshops" and "Other projects"
15:21:07 <DinaBelova> first time TC suggested for me to create a request to have cross-project one
15:21:24 <DinaBelova> but currently they are deciding what sessions to choose
15:21:28 <scroiset> so seems this one will be scheduled : http://summit.openstack.org/cfp/details/142
15:21:37 <scroiset> iiuc
15:21:54 <DinaBelova> scroiset, yes
15:22:00 <DinaBelova> we'll see, but anyway
15:22:31 <DinaBelova> so TC is thinking now to move our discussion from http://summit.openstack.org/cfp/details/45 to the http://summit.openstack.org/cfp/details/142
15:22:47 <DinaBelova> we'll know for sure next week
15:23:02 <DinaBelova> where and how we'll discuss everything interesting for us
15:23:17 <DinaBelova> pafuent, cmart - is it clearer now?
15:23:25 <pafuent> Yes
15:23:30 <DinaBelova> okay, great)
15:23:54 * DinaBelova moving further
15:24:03 <cmart> yeahh
15:24:12 <DinaBelova> #topic Unassigned bugs and BPs
15:24:30 <DinaBelova> and I've got lots of nice things to be done)
15:24:37 <cmart> yes
15:24:38 <DinaBelova> I mean LOTS
15:24:41 <DinaBelova> :)
15:24:50 <DinaBelova> pafuent, you found many bugs, btw
15:24:53 <DinaBelova> great job!
15:24:56 <pafuent> Thanks
15:25:14 <DinaBelova> and now I simply want to, well, somehow assign at least some of them
15:25:25 <cmart> now.. it's time to fix them, pablo... :p
15:25:31 <pafuent> hahaha
15:25:35 <pafuent> Yeah
15:25:45 <DinaBelova> #info https://review.openstack.org/#/c/82192/ - we need to restore it, when Cristian will be back
15:25:47 <cmart> I can take all the bugs I found.. but I'm trying to end the tempest scenario test
15:25:56 <pafuent> But I won't to be greedy
15:26:02 <DinaBelova> one moment
15:26:13 <DinaBelova> let me publish here all things I wanted to mention
15:26:19 <cmart> OK
15:26:31 <DinaBelova> these are unassigned bugs/BPs
15:26:33 <DinaBelova> https://blueprints.launchpad.net/climate/+spec/create-plugin-api-endpoint
15:26:33 <DinaBelova> https://blueprints.launchpad.net/climate/+spec/before-end-notification-crud
15:26:33 <DinaBelova> https://bugs.launchpad.net/climate/+bug/1306622
15:26:33 <DinaBelova> https://bugs.launchpad.net/climate/+bug/1306234
15:26:33 <DinaBelova> https://bugs.launchpad.net/climate/+bug/1305149
15:26:34 <DinaBelova> https://bugs.launchpad.net/climate/+bug/1305129
15:26:34 <uvirtbot> Launchpad bug 1306622 in climate "Climate V2 API returns tenant_id with dashes" [Low,Confirmed]
15:26:35 <uvirtbot> Launchpad bug 1306234 in climate "Climate Client doesn't gracefully handle unsupported API versions" [Medium,Confirmed]
15:26:36 <uvirtbot> Launchpad bug 1305149 in climate "Could not delete lease when associated resource is missing" [Medium,Confirmed]
15:26:37 <uvirtbot> Launchpad bug 1305129 in climate "Prolong-for option for lease-update doesn't accept negative values" [Medium,Triaged]
15:26:43 <pafuent> PASTE BOMB
15:26:57 <DinaBelova> and here are things that are assigned, but untouched.... so we need to reassign them
15:26:59 <DinaBelova> https://bugs.launchpad.net/climate/+bug/1255106
15:26:59 <DinaBelova> https://review.openstack.org/#/c/73574/
15:26:59 <DinaBelova> https://blueprints.launchpad.net/climate/+spec/lease-state
15:27:00 <uvirtbot> Launchpad bug 1255106 in climate "API unittests coverage is unsufficient" [Medium,Confirmed]
15:27:06 <DinaBelova> pafuent, yes)
15:27:34 <DinaBelova> cmart, let me find reported by you
15:27:40 <DinaBelova> and I'll assign them to you
15:27:50 <cmart> OK thanks
15:28:43 <DinaBelova> done
15:29:04 <DinaBelova> so we have also two things found by Pablo)
15:29:27 <DinaBelova> pafuent, will you fix this one? https://bugs.launchpad.net/climate/+bug/1306622
15:29:28 <uvirtbot> Launchpad bug 1306622 in climate "Climate V2 API returns tenant_id with dashes" [Low,Confirmed]
15:29:41 <pafuent> Yes
15:29:45 <DinaBelova> this one I've picked for myself https://bugs.launchpad.net/climate/+bug/1306234
15:29:47 <uvirtbot> Launchpad bug 1306234 in climate "Climate Client doesn't gracefully handle unsupported API versions" [Medium,Confirmed]
15:29:47 <DinaBelova> okay
15:30:00 <DinaBelova> cool!
15:30:04 <DinaBelova> okay
15:30:14 <pafuent> The debug info for that bug is amazing
15:30:20 <DinaBelova> ;)
15:30:21 <pafuent> u'v2'
15:30:28 <pafuent> :)
15:30:34 <DinaBelova> as for the BPs that we can work on
15:30:37 <DinaBelova> before summit
15:30:55 <DinaBelova> https://blueprints.launchpad.net/climate/+spec/create-plugin-api-endpoint and https://blueprints.launchpad.net/climate/+spec/before-end-notification-crud
15:31:22 <DinaBelova> folks, don't you know if Critian or Diego will work on them?
15:31:38 <cmart> I don't think so..
15:32:01 <DinaBelova> okay, will they take part in Climate further?
15:32:08 <cmart> as far as I know, they will be busy with other stuff...
15:32:12 <DinaBelova> okay
15:32:21 <cmart> related to the 2nd question
15:32:35 <DinaBelova> okay
15:32:38 <cmart> I think that Cristian will, but I'm not sure about Diego..
15:32:46 <DinaBelova> cmart, gotcha
15:32:46 <cmart> I could ask them and let you know..
15:32:54 <DinaBelova> cmart, will be cool
15:33:17 <pafuent> Diego is about to join
15:33:26 <DinaBelova> dpamio, o/
15:33:28 <dpamio> Hi everybody…
15:33:31 <DinaBelova> hello
15:33:38 <dpamio> sorry, I missed the first half of the meeting.
15:33:51 <DinaBelova> dpamio, I just wanted to ask you if you'll continue working on Climate
15:33:58 <dpamio> I´ll be out of town (and Climate) the next two weeks.
15:33:58 <DinaBelova> I mean I lost you a little bit)
15:34:08 <DinaBelova> okay, got it
15:34:14 <DinaBelova> but will you join us later?
15:34:44 <DinaBelova> if you're not sure you may say so)))
15:35:01 <dpamio> I’m not sure what would happen then (I assume I’ll return to Climate), as the second week will be to work on a  PoC on a different subject.
15:35:16 <dpamio> ^workING
15:35:21 <DinaBelova> okay
15:35:23 <DinaBelova> thanks
15:35:30 <DinaBelova> I picked https://blueprints.launchpad.net/climate/+spec/create-plugin-api-endpoint for me
15:35:32 <dpamio> I’ll say 70% chances that I keep working in Climate
15:35:47 <DinaBelova> and I got https://blueprints.launchpad.net/climate/+spec/before-end-notification-crud unassigned)
15:35:54 <DinaBelova> I want to see hand up)))
15:36:03 <DinaBelova> dpamio, thanks! it'll be cool)
15:36:20 <cmart> mE! o/
15:36:29 <DinaBelova> :*
15:36:31 <DinaBelova> okay
15:36:35 <DinaBelova> will pick you now
15:36:51 <DinaBelova> done
15:37:08 <DinaBelova> okay, and the last moment here is pack of already assigned and lost things)
15:37:42 <DinaBelova> I'm about https://bugs.launchpad.net/climate/+bug/1255106 https://review.openstack.org/#/c/73574/ and https://blueprints.launchpad.net/climate/+spec/lease-state
15:37:43 <uvirtbot> Launchpad bug 1255106 in climate "API unittests coverage is unsufficient" [Medium,Confirmed]
15:38:09 <DinaBelova> as for the https://review.openstack.org/#/c/73574/ - it's almost done, we need just to finish it
15:38:27 <pafuent> I will take lease-state
15:38:33 <DinaBelova> pafuent, okay
15:38:40 <cmart> cool!
15:38:50 <DinaBelova> picked you
15:39:13 <DinaBelova> and we have two tests related things)
15:39:29 <DinaBelova> I guess we may leave them now
15:39:51 <DinaBelova> and see what will happen next week - when I'll ping Nick and Francois here
15:39:52 <cmart> yeah.. we have a lot on our shoulders right now.. :/
15:39:57 <DinaBelova> ;)
15:40:01 <DinaBelova> okay
15:40:04 <cmart> just kidding..
15:40:06 <cmart> one comment
15:40:15 <DinaBelova> yes?
15:40:21 <cmart> nevermind, please continue
15:40:25 <DinaBelova> oh, ok
15:40:27 * DinaBelova moving to the next topic
15:40:31 <pafuent> BTW, we need to start thinking on Tempest tests
15:40:45 <cmart> I'm having nightmares with them..
15:40:45 <DinaBelova> #topic Open discussion
15:40:46 <cmart> haha
15:40:49 <pafuent> hahaha
15:40:59 <DinaBelova> pafuent, what do you mean about starting thinking?
15:41:09 <DinaBelova> we have great cmart working on them)
15:41:20 <DinaBelova> he's doing excellent things)
15:41:33 <pafuent> Yes, I know
15:41:35 <dpamio> or worse, “what do you mean with having nightmares”?
15:41:38 <dpamio> :P
15:41:44 <scroiset> cmart nightmares about which test ?
15:41:53 <DinaBelova> scroiset - about tempest)
15:42:06 <pafuent> But after cmart patch we will need a lot of work writing a lot of tests
15:42:24 <DinaBelova> pafuent, yes, that's so
15:42:25 <pafuent> for writing a lot of test
15:42:31 <pafuent> Just that
15:43:02 <cmart> scroiset, I'm writing an scenario test and it's getting more time than I expected..
15:43:11 <DinaBelova> pafuent - won't you mind to register different BPs for different integration tests here?
15:43:26 <cmart> lot of timeouts and stuff to check..
15:43:30 <DinaBelova> I trust you here)
15:43:32 <pafuent> Ok, I'll do that
15:43:37 <DinaBelova> pafuent, cool)
15:43:52 <DinaBelova> cmart, well, I really appreciate what you're doing here
15:43:54 <cmart> I'll submit a patch today EOD..
15:44:01 <DinaBelova> cmart, cool!
15:44:06 <cmart> get your "-1's" ready
15:44:11 <DinaBelova> ;)
15:44:20 <DinaBelova> don't worry)
15:44:25 <DinaBelova> we always have them)
15:44:29 <DinaBelova> okay
15:44:29 <pafuent> Me too. I really need a safety net for my patches
15:44:33 <cmart> haha :)
15:44:34 <DinaBelova> ;)
15:44:39 <cmart> one question
15:44:43 <DinaBelova> do we have other topics to be discussed?
15:44:45 <DinaBelova> oh, ok
15:44:49 <cmart> about core reviewers..
15:44:52 <DinaBelova> yes
15:44:58 <DinaBelova> that's the problem now
15:45:07 <cmart> I mean, we have four of them.. and we have a lot of stuff to review
15:45:24 <cmart> Are we sure that we won't have delays with that?
15:45:44 <DinaBelova> Nick and scroiset are quite busy now... And bauzas is moving his focus from climate slowly, so I'm thinking about having one more core reviewer at least
15:46:02 <scroiset> DinaBelova +1
15:46:03 <cmart> +1 agree
15:46:09 <pafuent> +1
15:46:15 <DinaBelova> pafuent - I'm about you - you're working hard on Climate - both for reviews and bugs/bps management
15:46:55 <pafuent> :)
15:47:00 <DinaBelova> I love what you're doing, so let's discuss then privately what I want to see from you to become core reviewer)
15:47:10 <pafuent> Ok
15:47:13 <DinaBelova> okay
15:47:17 <DinaBelova> any other quesiotns?
15:47:22 <DinaBelova> questions*
15:47:33 <cmart> not from my side
15:47:34 <pafuent> https://bugs.launchpad.net/climate/+bug/1299122
15:47:35 <uvirtbot> Launchpad bug 1299122 in climate "Physical Resource plugin doesn't work with PostgreSQL" [Medium,New]
15:47:54 <DinaBelova> scroiset, may you take a look on this bug?
15:48:02 <DinaBelova> and say 1st or 2nd variant you love more
15:48:23 <pafuent> Or both
15:48:23 <DinaBelova> I've proposed my opinion to pafuent, but I also want other opinion here
15:48:30 <DinaBelova> pafuent, ;)
15:48:31 <scroiset> yep
15:48:35 <DinaBelova> okay, cool
15:48:51 <DinaBelova> any other things here?
15:48:51 <pafuent> https://bugs.launchpad.net/climate/+bug/1304435
15:48:52 <uvirtbot> Launchpad bug 1304435 in climate "Support query leases for project by the platform admin" [Medium,Confirmed]
15:49:12 <DinaBelova> it's connected with https://bugs.launchpad.net/climate/+bug/1306231
15:49:13 <uvirtbot> Launchpad bug 1306231 in climate "Climate V2 API lets a non admin user list all leases" [Medium,Confirmed]
15:49:14 <DinaBelova> btw
15:49:33 <pafuent> Are you Ok if I add a query param instead of the bug proposal?
15:49:51 <DinaBelova> pafuent, sorry, lost your point
15:49:55 <DinaBelova> may you explain?
15:50:19 <pafuent> One proposal is something like: /project_id/leases to filter by project
15:50:29 <pafuent> Mine is /leases?project_id=blah
15:51:01 <pafuent> For the firs one we will need to manage Projects as a resource in Climate
15:51:29 <DinaBelova> well, I guess your proposal is nice
15:51:42 <DinaBelova> may you publish it to the BP?
15:51:46 <pafuent> And Projects aren't a resource that Climate handle
15:52:05 <cmart> shouldn't that be considered as bp instead of a bug?
15:52:08 <pafuent> BP == Bug?
15:52:13 <DinaBelova> oh, yes
15:52:33 * DinaBelova trying to find one google drive table where I was thinking about this
15:53:31 <DinaBelova> it looks like I've lost it
15:53:33 <DinaBelova> :?
15:53:36 <DinaBelova> well, strange
15:54:28 <DinaBelova> one more moment
15:55:17 <DinaBelova> https://docs.google.com/spreadsheets/d/1teQ9Tta9UafV2j9AlkJwTwQIP4feT4vZSFOOn2-khjA/edit?usp=sharing
15:55:37 <DinaBelova> pafuent, please take a look on it
15:55:44 <DinaBelova> there is still two variants)
15:55:58 <DinaBelova> okay
15:56:01 <pafuent> Ok, I'll take a look on that
15:56:04 <DinaBelova> smth else here?
15:56:16 <cmart> nope
15:56:19 <DinaBelova> okay
15:56:22 <pafuent> If we want to get the Tempest..
15:56:31 <pafuent> thing on Infra...
15:56:52 <DinaBelova> pafuent, don't start speaking like cmart :) with "..."
15:56:53 <pafuent> We have contacts to speed up the reviews on that?
15:56:58 <cmart> hahahaahahahahahahaa
15:57:01 <pafuent> hahahaha
15:57:16 <DinaBelova> pafuent, if we'll have changes there
15:57:29 <DinaBelova> we can ask Sergey to take a look on them
15:57:34 <pafuent> Ok}
15:57:34 <DinaBelova> he's infra core
15:57:39 <cmart> OK..
15:57:40 <DinaBelova> okay
15:57:45 <cmart> I'll add him to the review..
15:57:52 <DinaBelova> have a nice weekend)
15:57:55 <cmart> (I think he is already there)
15:57:57 <cmart> you too!
15:57:59 <cmart> bye
15:58:02 <DinaBelova> #endmeeting