15:00:03 <bauzas> #startmeeting climate
15:00:04 <openstack> Meeting started Fri Apr 25 15:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <openstack> The meeting name has been set to 'climate'
15:00:09 <bauzas> hi all
15:00:34 <bauzas> who wants to take the mic ? :)
15:00:53 <bauzas> DinaBelova is around, but in another meeting
15:01:07 <bauzas> we will try to not leave her schizophrenic :)
15:01:43 <bauzas> (wind whisle)
15:02:07 <cmart> helloo!
15:02:15 <jay-lau-513> hi
15:03:07 <casanch1> o/
15:03:25 <bauzas> cool to see people here :)
15:03:29 <casanch1> :)
15:03:42 <bauzas> let's wait a few more minutes
15:04:40 <bauzas> DinaBelova, you there, still ?
15:04:49 <bauzas> scroiset is on day-off today
15:04:54 <bauzas> I'll speak for him
15:05:12 <bauzas> ok, anyway, let's start
15:05:25 <bauzas> DinaBelova's IRC should blink a few times :)
15:05:33 <bauzas> so, let's start
15:05:38 <DinaBelova> o/
15:05:38 <bauzas> as said, I'll chair this meeting
15:05:41 <bauzas> DinaBelova: \o
15:05:43 <DinaBelova> I'm half time here
15:05:55 <bauzas> oh, we lost pafuent
15:06:06 <cmart> he will be back soon
15:06:09 <bauzas> cool
15:06:20 <bauzas> nice, pafuent is back
15:06:22 <bauzas> let's start
15:06:29 <pafuent> o/
15:06:33 <bauzas> #topic new climate-core
15:06:34 <pafuent> Sorry the delay
15:06:56 <bauzas> this is a off-topic, but just to give a warm welcome to our new climate-core, pafuent
15:07:07 <casanch1> congratulations pafuent
15:07:12 <cmart> (h5)
15:07:23 <bauzas> your help will be appreciated
15:07:30 <pafuent> Thanks
15:08:05 <bauzas> pafuent, let us know if you need assistance with Gerrit
15:08:16 <bauzas> but I guess you'll be good at work ;)
15:08:45 <bauzas> congrats again
15:08:46 <pafuent> bauzas: I'll do.
15:08:59 <bauzas> so, let's give info here
15:09:15 <bauzas> #info pafuent new climate-core, with a total to 5 as of now
15:09:32 <bauzas> ok, next topic
15:09:38 <bauzas> the agenda
15:09:45 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Climate
15:09:54 <bauzas> #topic Action items from the last meeting + reviews queries
15:10:06 <bauzas> #link http://eavesdrop.openstack.org/meetings/climate/2014/climate.2014-04-11-15.00.html
15:10:15 <bauzas> we had no meeting last week due to various concerns
15:10:35 <bauzas> so, the actions are a bit old
15:10:44 <bauzas> but we have results
15:10:51 <bauzas> I'll speak on behalf of DinaBelova
15:11:00 <bauzas> so, Foundation finally validated our new name
15:11:07 <cmart> :D
15:11:16 <pafuent> :-D
15:11:17 <bauzas> let's enjoy our new name
15:11:21 <bauzas> Blazar !
15:11:41 <casanch1> :D
15:11:44 <cmart> ..and start changing all the strings in our code... :)
15:11:55 <bauzas> #info Blazar now official codename for Reservation Service (ex-Climate)
15:12:09 <bauzas> cmart: that will be something we need to plan
15:12:16 <bauzas> cmart: but I propose to wait for the summit
15:12:30 <bauzas> as the future of Blazar (ex-Climate) will be discussed there
15:12:35 <cmart> agree
15:12:43 <bauzas> and I don't want to confuse people
15:13:03 <bauzas> so, could we agree to leave on Climate until Summit ?
15:13:06 <bauzas> #help vote
15:13:11 <casanch1> +1
15:13:11 <bauzas> dammit
15:13:17 <jay-lau-513> +1
15:13:24 <bauzas> I never proposed a vote yet
15:13:24 <cmart> +1
15:13:34 <cmart> hahaa
15:13:44 <pafuent> We will need to update some bugs that I filled with Dina
15:13:50 <bauzas> #help startvote
15:14:03 <bauzas> #help
15:14:06 <bauzas> dammit
15:14:17 <bauzas> nevermind
15:14:46 <bauzas> #agreed Wait for changing repository to Blazar after Summit event
15:15:09 <bauzas> pafuent: we will need to define a clear process for the name
15:15:14 <bauzas> and possibly a code freeze
15:15:21 <bauzas> SergeyLukjanov could help on that process
15:15:32 <pafuent> Ok
15:15:32 <bauzas> as he did that for Sahara (ex-Savanna)
15:15:44 <bauzas> we also need to define a Gerrit maintenance
15:15:55 <bauzas> ideally, we should align with another maintenance
15:16:21 <bauzas> anyway, let's go to the next action
15:16:44 <bauzas> so, I'm replying to myself, yes I'll work on https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:17:16 <bauzas> at the moment, I'm working on https://blueprints.launchpad.net/climate/+spec/lease-state
15:17:26 <bauzas> but let's discuss this during open discussion
15:18:09 <bauzas> for scroiset, he took a look at the etherpad
15:18:26 <bauzas> I'll ask him to put comments next week if posible
15:18:38 <bauzas> any reviews queries ?
15:18:44 <jay-lau-513> does  https://etherpad.openstack.org/p/climate-resource-allocation-framework has a bp traced?
15:18:54 <bauzas> jay-lau-513: yey
15:19:19 <jay-lau-513> bauzas: I did not get it from etherpad. ;(
15:19:37 <bauzas> jay-lau-513: https://blueprints.launchpad.net/climate/+spec/new-resource-allocation-phase
15:19:49 <bauzas> that's a big bp
15:20:02 <bauzas> jay-lau-513: we will possible do baby steps
15:20:09 <bauzas> s/possible/possibly
15:20:14 <jay-lau-513> bauzas: not sure if new comers like me can help ;-)
15:20:29 <jay-lau-513> bauzas: anyway, I will have a try
15:20:47 <bauzas> jay-lau-513: the idea here is to provide the same workflow for all plugins
15:21:09 <bauzas> jay-lau-513: I would be glad to discuss with you about thay
15:21:15 <cmart> +1 jay-lau's  attitude :)
15:21:32 <bauzas> cmart: :)
15:21:34 <jay-lau-513> cmart thanks
15:21:43 <bauzas> comments are welcome in the etherpad
15:21:46 <bauzas> :)
15:21:52 <bauzas> #link https://etherpad.openstack.org/p/climate-resource-allocation-framework
15:22:41 <pafuent> Regarding pending reviews: https://review.openstack.org/#/c/87352/, https://review.openstack.org/#/c/87684/,  https://review.openstack.org/#/c/84158/, https://review.openstack.org/#/c/90206/, https://review.openstack.org/#/c/89412/
15:22:49 <bauzas> woah :)
15:22:56 <cmart> o_O
15:23:12 <pafuent> I forgot https://review.openstack.org/#/c/78309/
15:23:21 <bauzas> let's take a look at the whiteboard for 0.2
15:23:22 <cmart> I also have four of my own..
15:23:31 <casanch1> and a new one: https://review.openstack.org/#/c/90393/
15:23:33 <casanch1> :D
15:24:35 <bauzas> ok, I think we need to adapt 0.2 scope
15:24:47 <bauzas> so we could get priorities for reviewing
15:24:58 <bauzas> I leave an action for DinaBelova
15:25:11 <bauzas> (she's our PTL, she has duty for this :D )
15:28:24 <DinaBelova> bauzas, do what you want)))
15:28:32 <DinaBelova> I'll read the logs
15:28:37 <DinaBelova> and do what you want
15:29:42 <casanch1> bauzas: still there?
15:30:09 <cmart> (wind whisle)
15:32:20 <cmart> so...
15:32:50 <cmart> pafuent, you are core now, you should take the lead :)
15:34:21 <cmart> bauzas_!
15:35:32 <bauzas_> Internet trouble...
15:37:11 <pafuent> cmart: Did you had time to talk with skraynev about Tempest itegration?
15:37:35 <pafuent> cmart: I really want our safety net in place
15:38:06 <pafuent> cmart: Sorry, SergeyLukjanov
15:38:13 <cmart> pafuent: no, I haven´t. I'm waiting for his comments on the review..
15:38:30 <SergeyLukjanov> oops
15:38:34 <SergeyLukjanov> which CR?
15:38:42 <SergeyLukjanov> please, post a link
15:38:46 <cmart> https://review.openstack.org/#/c/87352/
15:39:36 <cmart> that's climate code on the contrib folder, but we should put code in Infra (according to pafuent)
15:39:59 <bauzas_> Hi
15:40:06 <pafuent> SergeyLukjanov: We will need an advice of how to implement a gate for blazar that runs our about to land tempest tests
15:40:14 <cmart> and I don´t know how that works :S. Maybe you can help us with that
15:40:35 <SergeyLukjanov> pafuent, I can you help with it
15:40:42 <bauzas_> do you see my pings ?
15:40:50 <casanch1> yes
15:40:52 <SergeyLukjanov> I'm on meeting atm
15:40:55 <cmart> bauzas_: yes!
15:41:43 <pafuent> And we need to get our actual devstack job as a voting one
15:42:00 <bauzas__> hi all
15:42:12 <bauzas__> sorry, seems I faced a Freenode issue
15:42:50 <bauzas__> where are we ?
15:42:53 <pafuent> We are talking about a new gate (or the same that we have) running our about to land tempest test
15:43:05 <pafuent> A voting gate
15:43:19 <bauzas__> on which topic ?
15:43:31 <pafuent> An ad-hoc one
15:43:36 <bauzas__> cool :)
15:44:07 <pafuent> The last thing was prioritize the reviews
15:44:31 <bauzas__> pafuent: yup, I was saying to check with DinaBelova about a milestone for 0.2.0
15:45:09 <DinaBelova> bauzas__, why it's still the first topic for the meeting?
15:45:31 <bauzas__> I had a connection issue
15:45:34 <bauzas__> and still facing
15:45:38 <DinaBelova> :(
15:45:40 <DinaBelova> heh
15:45:41 <bauzas__> I'm on the webchat
15:45:41 <DinaBelova> okay
15:45:50 <bauzas__> anyway, let's move
15:45:54 <bauzas__> time is running
15:47:16 <bauzas> I'm back
15:47:31 <bauzas> #topic Summit session status
15:47:41 <bauzas> sorry, we lost 20 mins here
15:48:25 <bauzas> so, for those who can attend summit, please join http://summit.openstack.org/cfp/details/142
15:48:28 <bauzas> #link http://summit.openstack.org/cfp/details/142
15:49:02 <bauzas> some discussions could be about Gantt and other projects integration
15:49:19 <casanch1> http://junodesignsummit.sched.org/event/a848270c309b10517d4d186fecaf768f#.U1qD716aH-A
15:49:27 <casanch1> that's the scheduled session
15:49:39 <bauzas> casanch1: yup
15:50:28 <bauzas> fyi, this sessions has been identified during scheduler meeting
15:50:39 <casanch1> I was working on this bp https://blueprints.launchpad.net/climate/+spec/basic-volume-plugin, and we agreed on discussing its implementation during summit. So we will just meet sometime or do we need to schedule somethig?
15:50:44 <bauzas> #link https://etherpad.openstack.org/p/Gantt-summit-sessions
15:51:15 <bauzas> casanch1: we will need to define some way to contact us during summit
15:51:27 <bauzas> let's discuss it over ML
15:51:28 <cmart> same for https://blueprints.launchpad.net/climate/+spec/tenant-reservation-concept
15:51:35 <bauzas> time is running fast :(
15:51:40 <casanch1> ok
15:51:46 <pafuent> And the same for the renaming thing
15:51:50 <bauzas> #topic Climate -> Blazar renaming
15:52:02 <bauzas> everything has been said before in the meeting
15:52:07 <bauzas> can we move to opens ?
15:52:12 <cmart> yes
15:52:15 <bauzas> ok
15:52:15 <pafuent> yes
15:52:18 <casanch1> ok
15:52:20 <bauzas> sorry for the hurry
15:52:26 <bauzas> #topic Open discussion
15:52:32 <bauzas> jay-lau-513: still there ?
15:52:39 <jay-lau-513> bauzas yes
15:53:03 <bauzas> ok, how can we help you ?
15:53:16 <jay-lau-513> bauzas  I tried to install climate today, but failed, does the devstack steps is correct or the latest?
15:53:24 <jay-lau-513> 2014-04-25 23:44:38.316 | ++ nova aggregate-create freepool
15:53:24 <jay-lau-513> 2014-04-25 23:44:38.996 | ERROR (NotFound): Not found (HTTP 404)
15:53:38 <bauzas> jay-lau-513: we're having this issue in CI
15:53:43 <cmart> that's the bug that pafuent solved.. I think
15:53:48 <pafuent> Yep
15:53:53 <bauzas> cmart: what is the review # ?
15:54:00 <pafuent> https://review.openstack.org/#/c/90206/
15:54:15 <bauzas> pafuent: ok, I'll review it as critical
15:54:21 <jay-lau-513> pafuent greate
15:54:42 <pafuent> bauzas: You are familiar with nova, please check if we need to fill a bug in devstack or nova
15:55:04 <bauzas> pafuent: I need to understand the impact
15:55:11 <bauzas> let's discuss it on Monday
15:55:18 <pafuent> bauzas: Ok
15:55:20 <bauzas> for the time being, I'll give +2 to the patch
15:55:37 <bauzas> jay-lau-513: most of the doc can be found https://wiki.openstack.org/wiki/Climate
15:55:42 <jay-lau-513> pafuent so once I apply your patch, the prolem will disappear?
15:55:47 <pafuent> Yes
15:56:02 <jay-lau-513> bauzas Yes, I already checked most of them :)
15:56:06 <bauzas> jay-lau-513: if you still have issues, you can take https://wiki.openstack.org/wiki/Climate/Installation_without_Devstack
15:56:07 <jay-lau-513> pafuent cool
15:56:24 <bauzas> thanks pafuent for the hotfix
15:56:33 <jay-lau-513> bauzas yes, I was following those steps :)
15:56:39 <pafuent> bauzas: You are welcome
15:57:05 <bauzas> folks, may I also ask you to quickly take a look at https://blueprints.launchpad.net/climate/+spec/lease-state
15:57:06 <bauzas> ?
15:57:16 <bauzas> you'll find how I'll implement states in Climate
15:57:47 <bauzas> any other topics to mention ?
15:57:50 <cmart> OK.. I have a bug related to that
15:57:52 <cmart> https://review.openstack.org/#/c/87684/
15:58:07 <cmart> bauzas, you found a bug on a merged code..
15:58:19 <cmart> I think that we should create that bug
15:58:34 <bauzas> cmart: ok, sure
15:58:35 <cmart> but what about the code on the review?
15:58:37 <bauzas> cmart: I agree
15:58:44 <bauzas> cmart: I'll change my vote to +2
15:58:45 <cmart> In fact, I have two reviews with the same issue
15:58:50 <bauzas> but please open a bug for this
15:58:57 <cmart> I can take care of that
15:58:58 <cmart> OK
15:59:06 <cmart> please, put the action to me
15:59:06 <bauzas> ok cool
15:59:31 <casanch1> I have another bug related to https://review.openstack.org/#/c/87684/
15:59:31 <bauzas> #action cmart to create a bug for using oslo timeutils
15:59:47 <casanch1> I'll contact you cmart for the bug you'll submit
15:59:55 <casanch1> to see if there's a problem with my pathset
15:59:56 <bauzas> sure thajks
16:00:01 <cmart> OK
16:00:03 <bauzas> guys, let's end up the meeting
16:00:07 <casanch1> ok
16:00:09 <jay-lau-513> thanks all for the help
16:00:09 <cmart> ok
16:00:09 <pafuent> Bye
16:00:13 <casanch1> bye!
16:00:14 <cmart> bye
16:00:14 <bauzas> sorry again about the connection troubles
16:00:17 <jay-lau-513> bye
16:00:18 <cmart> np
16:00:21 <pafuent> np
16:00:23 <cmart> bye
16:00:26 <bauzas> jay-lau-513: let's discuss on #openstack-climate
16:00:29 <bauzas> #endmeeting