14:00:14 <priteau> #startmeeting cloudkitty
14:00:15 <openstack> Meeting started Mon Sep  7 14:00:14 2020 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <openstack> The meeting name has been set to 'cloudkitty'
14:00:30 <priteau> #topic Roll call
14:00:36 <priteau> Hello everyone o/
14:01:18 <openstackgerrit> Rafael Weingärtner proposed openstack/cloudkitty master: Update lower-constraints  https://review.opendev.org/706358
14:01:46 <priteau> Welcome to Rafael Weingärtner who missed the last meeting
14:01:49 <rafaelweingartne> \o
14:02:03 <rafaelweingartne> Yes, sorry for that
14:02:34 <priteau> The agenda for today is:
14:02:37 <priteau> * Victoria release
14:02:37 <priteau> * Wallaby PTG plans
14:02:49 <priteau> #topic Victoria release
14:03:08 <priteau> This is a big week for the Victoria release
14:03:14 <priteau> * Feature freeze
14:03:19 <priteau> * Final release for client libraries
14:03:36 <priteau> * Victoria Community Goals Completed
14:03:43 <priteau> * Cycle Highlights
14:04:21 <priteau> Which means we need to finish merging all the code that we want to see in Victoria
14:04:50 <rafaelweingartne> I think we are almost there, we have only a few patches open
14:05:00 <rafaelweingartne> and most of them were already partially reviewed
14:05:11 <priteau> I went through most of the "code cleanup" ones
14:05:25 <rafaelweingartne> yes, me too
14:05:29 <priteau> A feature that I would like to see merged is the Monasca fetcher
14:05:33 <rafaelweingartne> and I also went through this one
14:05:44 <priteau> I need to dedicate some time to review it before Thursday
14:05:49 <rafaelweingartne> I already gave my +2 there
14:06:03 <priteau> It could be worth updating https://review.opendev.org/#/c/715623/ which is one of the few pending patches on the client
14:06:46 <rafaelweingartne> I can do that
14:06:55 <priteau> Thank you Rafael
14:07:02 <priteau> I am not sure about https://review.opendev.org/#/c/681660/
14:07:26 <Haunted330> US holiday today
14:07:51 <rafaelweingartne> on the feature side, we have me neither, I started checking it, but have not been able to finish it
14:08:02 <rafaelweingartne> ops, I mixed the sentences.
14:08:06 <priteau> I think I've only been using the v1 API so I don't know how well supported is all the v2 API stuff
14:08:21 <rafaelweingartne> we are using v2 already
14:08:53 <rafaelweingartne> but we felt the need to extend and improve somethings there
14:09:28 <rafaelweingartne> that is why I have the patch 708121there
14:10:17 <priteau> I was going to ask, what about these two patches from you? https://review.opendev.org/#/q/owner:%22Rafael+Weing%25C3%25A4rtner%22+status:open+project:openstack/cloudkitty
14:10:31 <priteau> They were submitted a long time ago, can you rebase them to make sure they still pass CI?
14:11:03 <rafaelweingartne> yes, I can
14:11:29 <rafaelweingartne> about the patch #681660, I am not sure what to do
14:11:39 <rafaelweingartne> if we review, do you think they will amend the patch?
14:11:49 <rafaelweingartne> would it be worth to take over it?
14:13:19 <priteau> I think we need to take it over. AFAIK Luka Peschke is not with Objectif Libre anymore and hasn't been contributing to OpenStack
14:13:46 <priteau> His last review was in March: https://www.stackalytics.com/report/users/luka.peschke@objectif-libre.com
14:14:32 <priteau> Same thing for Justin Ferrieu, no activity since March
14:14:34 <rafaelweingartne> yes, exactly
14:14:49 <rafaelweingartne> as we use v2, I will add this to my backlog then
14:15:21 <priteau> Thanks. We will need to release the client this week, probably Thursday
14:15:44 <priteau> We also have some prometheus collector bug fixes
14:16:00 <priteau> from "Ning Yao"
14:16:10 <priteau> Anyone here use Prometheus directly with CloudKitty?
14:16:37 <openstackgerrit> Rafael Weingärtner proposed openstack/cloudkitty master: Update hacking for Python3  https://review.opendev.org/750178
14:16:48 <mkarpiarz> I'm looking into this now, Pierre.
14:17:32 <priteau> mkarpiarz: Nice, let us know how it works when you've got some results to share
14:18:02 <mkarpiarz> Sure thing.
14:18:23 <openstackgerrit> Pierre Riteau proposed openstack/cloudkitty master: add qty mutate in prometheus collector  https://review.opendev.org/710496
14:18:35 <openstackgerrit> Pierre Riteau proposed openstack/cloudkitty master: fix empty metadata exception in prometheus collector  https://review.opendev.org/710502
14:18:39 <openstackgerrit> Pierre Riteau proposed openstack/cloudkitty master: fix response format 'total' for v2 dataframes api  https://review.opendev.org/710500
14:20:44 <priteau> I was taking a look at our CI jobs and unless I am mistaken, all jobs are using the Gnocchi collector
14:21:07 <priteau> For Wallaby one goal should be to have better coverage of the three different collectors
14:21:54 <rafaelweingartne> Agree
14:22:31 <priteau> For Victoria Community Goals, we don't have legacy jobs so that completes https://governance.openstack.org/tc/goals/selected/victoria/native-zuulv3-jobs.html
14:23:20 <priteau> For https://governance.openstack.org/tc/goals/selected/victoria/migrate-ci-cd-jobs-to-ubuntu-focal.html there is a submitted patch which doesn't pass CI checks
14:23:22 <priteau> https://review.opendev.org/#/c/739317/
14:23:45 <priteau> And it conflicts with newer commits, I can rework it
14:24:07 <priteau> Anything else to highlight for the Victoria release?
14:24:36 <rafaelweingartne> No
14:25:12 <priteau> Let's talk about Wallaby then
14:25:16 <priteau> #topic Wallaby PTG plans
14:25:42 <priteau> As you probably know, the PTG is happening from October 26 to October 30
14:25:54 <priteau> Anyone is welcome, registration is free
14:26:18 <priteau> #link https://www.openstack.org/ptg
14:26:20 <rafaelweingartne> yes, We will prepare something to discuss new features for the Wallaby version
14:26:30 <rafaelweingartne> I am not sure though, if that is the moment to discuss them
14:26:56 <priteau> One caveat is that I very likely won't be available for this event
14:27:18 <priteau> The reason is that I am expecting our second child to arrive just at that time
14:28:15 <rafaelweingartne> No problem :)
14:28:17 <rafaelweingartne> Congrats!
14:28:24 <priteau> Thanks
14:28:33 <priteau> Even if we have a separate discussion earlier so I can attend, I think we should book some slots to encourage discussions with the broader community
14:29:21 <priteau> Who is likely to be involved, and is there any date and time that works better for you?
14:29:24 <openstackgerrit> Rafael Weingärtner proposed openstack/python-cloudkittyclient master: Update hacking for Python3  https://review.opendev.org/715623
14:29:27 <rafaelweingartne> yes, I agree
14:29:33 <priteau> FYI possible times are visible at https://ethercalc.openstack.org/7xp2pcbh1ncb
14:29:39 <rafaelweingartne> I planned to discuss the dates via email. Would that work for you?
14:30:07 <rafaelweingartne> I did not understand that spread sheet :)
14:30:22 <rafaelweingartne> What are the names Austin, Bexar and so on?
14:30:24 <priteau> We can discuss via email if you prefer
14:30:29 <priteau> OK, let me explain
14:30:41 <priteau> First, there are three groups of timezones
14:30:59 <priteau> 4-8 UTC, 13-17 UTC, 21-1 UTC
14:31:43 <priteau> Austin, Bexar etc. are the names of the Zoom meetings rooms provided by the OpenStack Foundation
14:31:50 <openstackgerrit> Merged openstack/cloudkitty master: Add py38 package metadata  https://review.opendev.org/723344
14:32:08 <rafaelweingartne> Ah, I see
14:32:14 <rafaelweingartne> now it is clearer
14:32:20 <priteau> We can pick any room, doesn't matter
14:32:30 <priteau> The only thing to watch out for is potential conflict
14:33:08 <priteau> For example, I know there might be people in the Scientific SIG who are interested by CloudKitty (though I don't know if they would join the PTG discussions)
14:33:56 <openstackgerrit> Rafael Weingärtner proposed openstack/cloudkitty master: Switch to newer openstackdocstheme and reno versions  https://review.opendev.org/731954
14:34:15 <priteau> We can follow up by email but we have to register soon so the schedule is finalised
14:34:17 <rafaelweingartne> I see
14:34:24 <priteau> By end of this week
14:34:28 <rafaelweingartne> ok, will do that
14:35:54 <priteau> We should also find out if there are logs of earlier PTG discussions
14:37:22 <priteau> Nope, I cannot find any
14:37:50 <priteau> I looked on the wiki from https://wiki.openstack.org/wiki/PTG/Ussuri/Etherpads all the way to Pike
14:39:34 <priteau> For the next meeting we should start making a list of discussion topics
14:39:57 <priteau> We'll need to review existing specs and see which ones we would like to push forward
14:40:17 <priteau> Anything else for Wallaby?
14:40:28 <rafaelweingartne> yes, I think we should have something like a fixed topic to review not just specs but also RFEs, right?
14:40:50 <rafaelweingartne> normally, for other projects such as Neutron and Keystone, I start with an RFE
14:41:32 <priteau> On some other projects I've worked on it starts with a blueprint entry, but yes same idea
14:41:43 <priteau> Actually good point, we should do a bug triage as well
14:42:18 <priteau> And decide what to do about bug trackers, there are lots of open bugs on launchpad (and you can still open new ones), but the official tracker for CloudKitty is Storyboard
14:42:33 <rafaelweingartne> hmm
14:42:49 <rafaelweingartne> I think we will review that, and do some cleanup then
14:43:05 <priteau> Yes, and prevent opening new bugs on Launchpad if we want to stick with Storyboard
14:43:26 <rafaelweingartne> how do we do that?
14:44:35 <priteau> I don't know yet :)
14:45:13 <priteau> We probably need to get admin access to the cloudkitty launchpad project
14:45:43 <rafaelweingartne> I would say so
14:45:58 <openstackgerrit> Merged openstack/cloudkitty master: Add Python3 victoria unit tests  https://review.opendev.org/722987
14:46:03 <priteau> I will look into that
14:46:13 <rafaelweingartne> ok, thanks
14:46:15 <priteau> #action Recover access to Launchpad project
14:48:21 <priteau> The response for PTG is actually September 11th at 7:00 UTC
14:48:31 <priteau> So in practice September 10 (Thursday)
14:48:42 <rafaelweingartne> ok
14:49:15 <priteau> #action Request time for the PTG by September 10
14:49:21 <priteau> #topic AOB
14:49:30 <priteau> Anything else you would like to discuss today?
14:49:38 <rafaelweingartne> no
14:51:46 <priteau> Let's finish early then :)
14:52:21 <priteau> Just before we finish
14:52:38 <priteau> mkarpiarz: LuisRmz: rafaelweingartne: what are your preferred meeting times for the PTG?
14:53:32 <priteau> mkarpiarz and LuisRmz, you're both in Europe right?
14:53:42 <rafaelweingartne> 14 UTC works fine for me
14:53:54 <rafaelweingartne> I am on GMT-3
14:54:42 <priteau> That's what I assumed
14:56:31 <priteau> OK, let's wrap up
14:56:34 <priteau> Bye everyone
14:56:37 <priteau> #endmeeting