14:02:11 <rafaelweingartne> #startmeeting cloudkitty
14:02:12 <openstack> Meeting started Mon Nov 16 14:02:11 2020 UTC and is due to finish in 60 minutes.  The chair is rafaelweingartne. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:15 <openstack> The meeting name has been set to 'cloudkitty'
14:02:31 <priteau> jopdorp: it's here :-)
14:02:36 <jopdorp> great :)
14:02:40 <rafaelweingartne> Hello guys, sorry for the delay. Let's start the CloudKitty meeting
14:02:46 <rafaelweingartne> Roll count
14:03:04 <jopdorp> o/
14:03:05 <priteau> o/
14:03:41 <rafaelweingartne> \o
14:04:02 <rafaelweingartne> #topic Review priorities
14:04:50 <rafaelweingartne> Do you guys have some review priorities to ask for?  I might have missed some emails, but I did not receive any requests in the past weeks or so
14:05:51 <priteau> Indeed it's been quiet on the code front. I am just recently back from paternity leave and have not quite yet caught up with everything
14:06:45 <jopdorp> There are some specs I am open to write or implement regarding billing integration with moneybird and/or a rating page that looks more like an invoice
14:07:00 <jopdorp> And maybe to look at the elasticsearch driver
14:07:46 <rafaelweingartne> jopdorp: that would be awesome
14:08:11 <jopdorp> i remember seeing a blueprint a while ago about billing integration
14:08:48 <rafaelweingartne> priteau: there are some follow ups from the PTG meeting that I will try to work on as well. Specially, the project awareness topic.
14:08:58 <priteau> Is moneybird a paid solution? There's not much information on the english website
14:09:34 <jopdorp> yes
14:09:52 <rafaelweingartne> We need to write down some success use cases to demonstrate for the public how people are leveraging CloudKitty as the bedrock of their billing chain
14:10:33 <jopdorp> so we use it with gnocchi a the srouce, elasticsearch driver for the storage and moneybird for billing
14:10:35 <priteau> I can talk with people managing clouds where we've set up cloudkitty
14:10:57 <jopdorp> priteau: we work with mark and isaac
14:11:05 <priteau> jopdorp: I know :-)
14:11:24 <rafaelweingartne> jopdorp: what is the idea behind this moneybird integration? If the system (moneybird) generate invoices, why can't it consume CloudKitty API instead?
14:12:03 <jopdorp> I'm not sure I understood the answer correctly
14:12:44 <jopdorp> I made a django app that consumes the cloudkitty api, with a react frontend that can  get the summary for a time period from cloudkitty
14:12:50 <rafaelweingartne> Why does CloudKitty need a driver/integration with MoneyBird? Would CloudKitty consume its API? Or, would CloudKitty push data to it?
14:12:56 <jopdorp> the uses the moneybird api to create an invoice
14:13:43 <jopdorp> we might create a driver architecture so people can choose the billing system cloudkitty should itnegrate with
14:13:55 <jopdorp> invoice*/finance system
14:14:00 <priteau> rafaelweingartne: I guess that MoneyBird cannot be customised, so we need to push data to it, hence the need for some glue between cloudkitty and the billing system
14:14:00 <rafaelweingartne> That is a good topic, we discussed that in the PTG
14:14:10 <jopdorp> sorry to have missed that
14:14:11 <rafaelweingartne> #link https://etherpad.opendev.org/p/cloudkitty-ptg-wallaby
14:14:36 <rafaelweingartne> One of the discussions reached the conclusion that "Invoicing is out of the escope of Cloudkitty. The invoice system should instead consume it (CloudKitty).""
14:15:15 <jopdorp> i see
14:15:16 <jopdorp> ok
14:15:18 <jopdorp> https://review.opendev.org/#/c/708121/
14:15:28 <jopdorp> is this also about something like a per-instance usage summary?
14:16:13 <rafaelweingartne> jopdorp: it can be, we extended that API, to allow operators/integrators to customize the usage/rating reports
14:16:49 <jopdorp> I might have a look at the elasticsearch clieant part for custom fields
14:17:11 <jopdorp> https://review.opendev.org/#/c/708121/3/cloudkitty/storage/v2/elasticsearch/client.py
14:17:34 <rafaelweingartne> that would be awesome
14:17:43 <jopdorp> okay I'll put it in my todo
14:17:44 <rafaelweingartne> I just implemented it for the backends we were using
14:18:03 <jopdorp> should i commit it as part of that review?
14:18:54 <rafaelweingartne> I would rather create a new commit, and add it as depending on https://review.opendev.org/#/c/708121
14:19:02 <jopdorp> will do
14:19:04 <rafaelweingartne> At least, to me, it facilitates the review process
14:19:10 <priteau> +1
14:19:19 <jopdorp> I might need some help with how to do that
14:19:22 <priteau> Smaller commits are easier to review
14:19:37 <rafaelweingartne> exactly
14:19:37 <jopdorp> never did that before, I'm quite new in participating as a dev in the openstack community
14:20:43 <rafaelweingartne> if you need some assistance, just ping me
14:20:49 <jopdorp> okay!
14:21:10 <priteau> https://docs.openstack.org/contributors/code-and-documentation/index.html
14:21:21 <jopdorp> thanks
14:21:47 <priteau> It's very lengthy so in particular check:
14:21:52 <priteau> * Account Setup
14:22:04 <priteau> * Setting Up Your Gerrit Account
14:22:11 <jopdorp> ui do have a gerrit account
14:22:26 <jopdorp> just the step of making a review depend on another review
14:22:30 <jopdorp> not sure how to do that
14:22:32 <priteau> oh, that's easy
14:22:38 <priteau> https://docs.openstack.org/contributors/code-and-documentation/patch-best-practices.html#depends-on-tag
14:22:42 <jopdorp> https://docs.openstack.org/contributors/code-and-documentation/patch-best-practices.html#patch-chains-depends-on-tag-and-gerrit-topics
14:23:23 <jopdorp> Depends-On:  Id4dd83d0703ec0dff32510e6dd1d2dad9b181306
14:23:25 <jopdorp> in the commit message?
14:23:55 <jopdorp> that would be the change id of the other change
14:24:05 <rafaelweingartne> yes
14:24:09 <jopdorp> ok thanks
14:24:29 <rafaelweingartne> I normally use the full URL, but I guess that is not needed
14:25:01 <jopdorp> https://review.opendev.org/#/c/708121 ?
14:25:14 <rafaelweingartne> that is how I have been doing so far
14:25:21 <jopdorp> will do it like that
14:25:55 <priteau> You can use either
14:26:01 <jopdorp> cool
14:26:08 <priteau> you can also skip the '/#/c' part from the URL
14:30:19 <rafaelweingartne> Moving on
14:30:24 <rafaelweingartne> #topic Wallaby release
14:30:30 <rafaelweingartne> We should start discussing the new features that we would like to see in Wallaby, so we can work towards them.
14:31:12 <priteau> My priority is not so much a feature but figuring out why we are seeing issues using metadata with Monasca
14:31:45 <rafaelweingartne> I guess that we are not going to define them today, but it would be interesting to start thinking and taking notes of the things we want to see in this release.
14:31:47 <priteau> I don't think there is a bug report about it, I need to confirm it's not a configuration issue
14:32:03 <rafaelweingartne> #action create a list with possible features we would like to see in Wallaby
14:32:33 <rafaelweingartne> priteau: if you need some help, let me know if I can help you somehow
14:33:05 <priteau> thanks, I will let you know if needed
14:35:13 <priteau> I'd also like to see more testing of different backends
14:36:17 <rafaelweingartne> +1
14:37:12 <jopdorp> +1
14:37:36 <jopdorp> oh there is something that we faced
14:37:46 <jopdorp> that is the pricing tab in the new instance form in horizon
14:37:56 <jopdorp> it always states 0$
14:38:14 <jopdorp> i think that's because we only have metered costs, no one time costs or something like that
14:38:20 <jopdorp> no startup costs
14:38:38 <jopdorp> so i was thinking about creating a toggle to remove it
14:38:51 <jopdorp> in the cloudkitty-dashboard config
14:39:58 <rafaelweingartne> Maybe that is a bug?
14:40:11 <rafaelweingartne> I thought CloudKitty did not support one time charging yet
14:40:59 <rafaelweingartne> jopdorp: could you investigate into that, and then open a bug report if that is the case?
14:41:06 <jopdorp> yes
14:42:06 <rafaelweingartne> awesome, thanks!
14:42:56 <jopdorp> i think it is about overrides.py and _launch_details_price.html
14:43:27 <jopdorp> https://opendev.org/openstack/cloudkitty-dashboard/src/branch/master/cloudkittydashboard/overrides.py
14:43:47 <jopdorp> https://opendev.org/openstack/cloudkitty-dashboard/src/branch/master/cloudkittydashboard/dashboards/project/rating/templates/rating/_launch_details_price.html
14:44:51 <rafaelweingartne> that looks like it
14:49:56 <rafaelweingartne> Now, I open for general questions and topics that people might have.
14:49:59 <rafaelweingartne> #topic AOB
14:50:13 <rafaelweingartne> I will leave it open for more 5 minutes before closing the meeting
14:50:35 <jopdorp> well
14:50:44 <jopdorp> I'm open to becoming a core reviewer in the cloudkitty project
14:50:59 <jopdorp> we rely on it
14:51:11 <jopdorp> and cloudkitty needs to stay alive!! :D
14:51:42 <rafaelweingartne> jopdorp: I do not know how this invitation process works. Maybe Pierre can guide us here
14:51:59 <jopdorp> priteau: suggestions?
14:53:31 <priteau> jopdorp: have you done cloudkitty reviews so far?
14:54:49 <jopdorp> no
14:54:59 <jopdorp> suggestions for changes to look at?
14:56:42 <priteau> Sorry, I have to go
14:57:16 <rafaelweingartne> jopdorp: I would start here https://review.opendev.org/#/q/status:open+project:openstack/cloudkitty
14:57:34 <jopdorp> I'll have a look
14:57:46 <rafaelweingartne> Normally, any OpenSource project works like the following. People start contributing, and then, after sucessfull and continous contributions
14:58:22 <rafaelweingartne> the contributors are invited to become core reviewers/committers or other positions in the project
14:59:19 <rafaelweingartne> I will have to leave as well
14:59:21 <rafaelweingartne> Thank you guys for participating. Have a nice week.
14:59:27 <rafaelweingartne> #endmeeting