14:01:58 <rafaelweingartner> #startmeeting cloudkitty
14:01:58 <opendevmeet> Meeting started Mon Nov 28 14:01:58 2022 UTC and is due to finish in 60 minutes.  The chair is rafaelweingartner. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:58 <opendevmeet> The meeting name has been set to 'cloudkitty'
14:02:00 <rafaelweingartner> Roll count
14:02:30 <priteau> o/
14:02:31 <rafaelweingartner> \0
14:03:23 <mkarpiarz> Hi1
14:04:25 <rafaelweingartner> #topic deprecate ElasticSearch support in favor of OpenSearch
14:04:39 <rafaelweingartner> The patch https://review.opendev.org/c/openstack/cloudkitty/+/864412 has been merged
14:04:46 <rafaelweingartner> Therefore, we have put the announce out there
14:04:50 <rafaelweingartner> do we need to do something else?
14:05:31 <priteau> We may want to announce it on the ML
14:05:45 <rafaelweingartner> Wasn't it before?
14:07:14 <priteau> There was a message from you about Monasca
14:07:34 <rafaelweingartner> I see, I might have mixed up things then
14:07:42 <priteau> It was also mentioned in your Antelope summary
14:07:55 <priteau> But I expect few people read it
14:08:01 <rafaelweingartner> yes, I agree
14:08:08 <rafaelweingartner> we need a separated and specific email for that
14:08:29 <priteau> Maybe we should make a bit more progress on the OpenSearch support first
14:08:38 <priteau> At least get it running in devstack
14:09:03 <rafaelweingartner> I thought that iw as already being used there
14:09:19 <rafaelweingartner> I thought that it was already being used there
14:09:19 <priteau> What do you mean?
14:09:40 <rafaelweingartner> in devstack, because of Kolla-ansible adoption of OpenSearch
14:09:58 <priteau> devstack != kolla-ansible
14:10:10 <priteau> They are entirely different projets
14:10:15 <priteau> projects
14:10:15 <rafaelweingartner> I know, but I thought kolla-ansible was used there
14:10:23 <priteau> No
14:10:35 <rafaelweingartner> I might have mistaken, just because we use kolla-ansible in our labs
14:10:56 <rafaelweingartner> sorry for the mistake then
14:11:24 <priteau> Currently we install ES ourselves using our devstack plugin: https://opendev.org/openstack/cloudkitty/src/branch/master/devstack/plugin.sh#L304-L314
14:11:41 <priteau> By we, I mean the cloudkitty CI/CD
14:12:02 <rafaelweingartner> I see
14:12:47 <rafaelweingartner> In theory, we could just change that, right?
14:13:03 <rafaelweingartner> to use OpenSearch, and if they are both compatible, everything else would be fine
14:13:03 <priteau> Plus verify that it still works ;-)
14:13:14 <priteau> So I would like to see a bit more progress on opensearch testing, before we announce to the whole world that we are dropping it
14:13:24 <priteau> *that we are dropping ES*
14:13:53 <rafaelweingartner> ok
14:14:04 <rafaelweingartner> Noted here
14:14:06 <priteau> We could try to get it done during the next two weeks?
14:14:13 <mkarpiarz> Will we need to add OpenSearch support to Devstack first then?
14:14:14 <rafaelweingartner> I guess so
14:14:20 <priteau> And if it works fine, we can announce before the end of the year
14:14:39 <priteau> mkarpiarz: we absolutely need to test with opensearch in devstack, this is our CI/CD gate
14:15:52 <mkarpiarz> Yes, but can we switch to a different plugin or do we have to write the OpenSearch plugin first?
14:16:15 <priteau> There is no other plugin to switch to. This is cloudkitty's only plugin
14:16:29 <rafaelweingartner> I guess it is compatible from what we discussed in the last meetings. Therefore, it would be a matter of changing in DevStack and then checking to see what happens
14:16:45 <priteau> Note that Elasticsearch install is only a small part of the devstack plugin, all the other stuff stays valid.
14:16:56 <mkarpiarz> I see.
14:17:38 <priteau> I guess there is another decision to take
14:18:46 <priteau> We have the storage backend type configured as [storage]/backend
14:18:59 <priteau> Currently, influxdb or elasticsearch
14:19:09 <priteau> Do we need to have an "opensearch" option too?
14:19:20 <rafaelweingartner> hmm
14:19:29 <rafaelweingartner> for now for testins we would not need
14:19:31 <priteau> Even if the code is the same, I would guess yes. Otherwise it would be confusing.
14:19:45 <priteau> Of course, but for shipping in the release
14:19:45 <rafaelweingartner> however, after the deprecation, we should create OpenSearch
14:19:59 <rafaelweingartner> and log a warning message for people using ElasticSearch type
14:20:04 <rafaelweingartner> and then, we remove it in B release
14:20:27 <priteau> So in Antelope, we would have the two options: elasticsearch and opensearch. And then in B, just openseaerch
14:21:15 <rafaelweingartner> exactly
14:22:00 <priteau> I can try to make some progress on testing during the coming cycle.
14:22:07 <priteau> I mean, two weeks cycle.
14:22:12 <priteau> Until the next meeting
14:22:14 <rafaelweingartner> That would help
14:24:58 <priteau> #action Pierre to update the devstack plugin to use OpenSearch
14:24:58 <rafaelweingartner> I guess that is all about opensearch. Do you guys have something else to add?
14:26:04 <priteau> No
14:27:00 <mkarpiarz> I'll install OpenSearch in my kolla-ansible test environment and see how this goes.
14:27:47 <priteau> mkarpiarz: the upstream support has not landed yet: https://review.opendev.org/c/openstack/kolla-ansible/+/856610
14:28:50 <rafaelweingartner> I see, thanks
14:28:52 <mkarpiarz> That's fine. I'll simply replace the ElasticSearch container with the OpenSearch one.
14:28:55 <mkarpiarz> https://opensearch.org/docs/latest/opensearch/install/docker/
14:29:24 <rafaelweingartner> So, moving on to the next topic.
14:29:24 <mkarpiarz> This should tell us whether the change is likely to "just work". :)
14:29:26 <rafaelweingartner> #topic Monasca deprecation
14:29:40 <rafaelweingartner> I sent some emails to the community regarding this topic, but I got no feedback
14:29:47 <rafaelweingartner> therefore, I am assuming that nobody is using it
14:29:52 <rafaelweingartner> So, shall we move with the process?
14:30:28 <mkarpiarz> I think so.
14:30:37 <priteau> +1
14:31:28 <rafaelweingartner> Ok, so, I will add that in my list here
14:33:04 <rafaelweingartner> Next topic
14:33:10 <rafaelweingartner> #topic CloudKitty API reference docs (https://docs.openstack.org/cloudkitty/latest/api-reference/index.html) to https://docs.openstack.org/api-ref/
14:33:17 <rafaelweingartner> Do we need to do something there?
14:33:34 <rafaelweingartner> I mean, I recall and email from Mariusz, but I am not sure about the conclusion
14:34:34 <mkarpiarz> If we are OK with not changing v1 docs, then I'm ready to submit my changes for a review.
14:34:45 <rafaelweingartner> I am ok with it
14:35:05 <priteau> I am afraid I don't know the answer for this one
14:35:35 <mkarpiarz> OK, I'll do it then and we can have a discussion in the comments.
14:36:27 <rafaelweingartner> ok
14:36:28 <rafaelweingartner> thanks!
14:37:48 <rafaelweingartner> so, moving on
14:37:49 <rafaelweingartner> #topic Target review of the meeting
14:38:00 <rafaelweingartner> #link https://review.opendev.org/c/openstack/cloudkitty/+/862824
14:38:45 <rafaelweingartner> It is a patch that I proposed, to add a description option in the rating definition
14:38:54 <rafaelweingartner> Could you guys review it?
14:42:10 <mkarpiarz> The code looks good to me.
14:43:24 <priteau> Reviewing now
14:44:50 <rafaelweingartner> thanks!
14:44:57 <priteau> Please check comments
14:47:41 <rafaelweingartner> Checked
14:47:50 <rafaelweingartner> I would not expect the value to be replicated in the backend
14:48:12 <rafaelweingartner> I am using the same method to store it as the "alt_name"
14:48:31 <rafaelweingartner> I never checked thouhg in Influx how this data is persisted
14:48:34 <rafaelweingartner> have you guys checked?
14:51:07 <mkarpiarz> OK, I'll add this patch to my test environemnt and report back on how it looks in Influx.
14:52:01 <rafaelweingartner> thanks!
14:52:19 <rafaelweingartner> The other one, #link https://review.opendev.org/c/openstack/cloudkitty/+/861908
14:52:27 <priteau> It is stored in the datapoint itself: https://review.opendev.org/c/openstack/cloudkitty/+/862824/1/cloudkitty/dataframe.py
14:52:54 <rafaelweingartner> I have not had time to work on it to add tempest tests for it
14:52:54 <priteau> So I assume you will see it in every dataframe object in influxdb, and in every document in ES
14:53:56 <rafaelweingartner> Since we are running out of time, I would like peole to check these two #https://review.opendev.org/c/openstack/cloudkitty/+/864269 and #https://review.opendev.org/c/openstack/cloudkitty/+/864578
14:54:03 <rafaelweingartner> they are important fixes for CloudKitty
14:54:12 <mkarpiarz> OK
14:54:17 <rafaelweingartner> one is an optimization to reduce the memmory footprint when loading scope IDs
14:54:29 <rafaelweingartner> and the other is a fix for pyscripts that were not working for over 3 years
14:55:39 <mkarpiarz> I just want to say 864578 didn't fix PyScripts in my test environment.
14:56:28 <rafaelweingartner> What is the problem you are having?
14:56:33 <rafaelweingartner> I am using it
14:57:12 <opendevreview> Rafael Weingartner proposed openstack/cloudkitty master: Add description option to a rating metric definition  https://review.opendev.org/c/openstack/cloudkitty/+/862824
14:57:28 <mkarpiarz> Yeah, for me the code never enters the PyScripts constructor so this might be something with my setup.
14:57:41 <opendevreview> Rafael Weingartner proposed openstack/cloudkitty master: Optimize Gnocchi fetcher  https://review.opendev.org/c/openstack/cloudkitty/+/864269
14:57:52 <mkarpiarz> With either my metrics or the script.
14:58:00 <mkarpiarz> *metrics.yml
14:58:43 <priteau> mkarpiarz: You have enabled the pyscripts plugin?
14:58:44 <opendevreview> Rafael Weingartner proposed openstack/cloudkitty master: Optimize Gnocchi fetcher  https://review.opendev.org/c/openstack/cloudkitty/+/864269
15:00:03 <priteau> I will try to review these patches before the next meeting
15:00:27 <rafaelweingartner> ok, thanks!
15:00:39 <opendevreview> guest proposed openstack/cloudkitty master: CREATE INDEX idx_tenantid_begin_end ON rated_data_frames (tenant_id,begin,end)  https://review.opendev.org/c/openstack/cloudkitty/+/865435
15:00:52 <rafaelweingartner> I guess that is all for today
15:00:52 <mkarpiarz> Yes, the plugin is enabled and the script I'm using is the one mentioned in docs.
15:00:59 <rafaelweingartner> do you guys have something else to add?
15:01:07 <mkarpiarz> https://docs.openstack.org/cloudkitty/latest/user/rating/pyscripts.html
15:01:13 <rafaelweingartner> mkarpiarz: the docs example would not work
15:01:19 <rafaelweingartner> I updated the docs in my patch as well
15:01:35 <priteau> There is this patch submitted by Olivier Chaze that we should review.
15:01:48 <rafaelweingartner> yes, I am reviewing it
15:02:19 <priteau> Looks like he needs some help with writing a DB migration
15:02:49 <rafaelweingartner> I guess so
15:04:07 <priteau> I left comments for him.
15:04:19 <rafaelweingartner> cool, thanks
15:04:24 <rafaelweingartner> I guess that is all then
15:04:26 <rafaelweingartner> Thank you guys for participating. Have a nice week.
15:06:08 <mkarpiarz> Thank you!
15:06:33 <rafaelweingartner> #endmeeting