23:00:13 <vnod> #startmeeting cloudpulse
23:00:14 <openstack> Meeting started Thu Jun  4 23:00:13 2015 UTC and is due to finish in 60 minutes.  The chair is vnod. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:00:18 <openstack> The meeting name has been set to 'cloudpulse'
23:00:44 <vnod> #topic rollcall
23:01:34 <vnod> vnod o/
23:02:40 <pradeech> here
23:03:30 <pksingh__> is this cloudpulse meeting?
23:03:44 <vnod> yes.
23:03:56 <vnod> we are waiting for few more folks
23:04:03 <pksingh__> vnod: ok thanks :)
23:05:09 <vnod> hello guys
23:05:24 <vnod> this is our first meeting, we will start with some intro
23:05:38 <vnod> #topic introduction
23:06:14 <vnod> I am Vinod, interested in provide light weight health API to applications and operator
23:07:15 <pradeech> Pradeep here. interested in getting to know what cloud pulse is, and how useful it will be
23:07:51 <Ajay_> Ajay here. Interested in monitoring solutions for openstack since i test HA and things break
23:08:10 <vnod> pksingh what are your areas of interest ?
23:08:59 <pksingh__> i basically interseted in how its going to work, means what it is and how will it ork
23:09:33 <vnod> hello Jinay
23:09:53 <sdake_> hey guys sorry i'm late
23:10:02 <sdake_> o/
23:10:16 <Jinay> Jinay here..looking forward to know what cloudpulse is and how useful would it be for HA testing?
23:11:03 <vnod> ok. thanks guys lets move to announcements
23:11:17 <vnod> #topic announcements
23:11:45 <vnod> we are starting new project and starting to looking for people to join core team
23:13:12 <sdake_> i'm in for the core team
23:13:16 <sdake_> atleast for 3 month commitment
23:13:29 <vnod> thanks sdake_
23:13:40 <pksingh__> vnod: i would like to be part of the core team
23:14:07 <vnod> thanks pksingh_
23:14:17 <vnod> thanks pksingh__
23:15:08 <vnod> #topic Healthcheck API
23:15:33 <vnod> Implement basic API to create test, run test and query result
23:15:46 <vnod> blueprint:
23:15:55 <sdake_> there are probably some blueprints that need to roll out of this
23:16:09 <vnod> https://blueprints.launchpad.net/cloudpulse/+spec/cloudpulse-api-handler
23:16:49 <sdake_> that needs to be broken up into seprate blueprints imo
23:17:20 <vnod> sdake_ agreed,
23:17:40 <sdake_> i'm thinking at bare minimum a wsme api handler
23:17:50 <sdake_> i'll take an action to file a blueprint for that
23:18:02 <vnod> sdake_ thanks
23:18:15 <vnod> Implement datamodel
23:18:20 <vnod> https://blueprints.launchpad.net/cloudpulse/+spec/datamodel
23:18:34 <vnod> I have assigned this to myself
23:19:08 <vnod> Spells out the db table structure for CRUD operations on the test-data
23:19:35 <sdake_> needs multiple blueprints as well
23:20:18 <pksingh__> sdake_: agreed
23:20:37 <sdake_> one of them will be alembic
23:20:45 <sdake_> i'll take an action to file that blueprint
23:20:56 <sdake_> vnod type #action sdake file alembic blueprint
23:21:06 <sdake_> that way I remember later whe nI look at the logs :)
23:21:08 <vnod> #action sdake file alembic blueprint
23:21:23 <vnod> and one more for conductor (all write access to db)
23:21:34 <vnod> any volunteers for conductor ?
23:21:52 <pksingh__> vnod: is there any blue print for that
23:22:07 <vnod> not yet
23:22:22 <pksingh__> vnod: i would like to handle this
23:22:40 <sdake_> we need another blueprint, the db impelmentation - i'll take that
23:23:04 <vnod> thanks pksingh__ sdake_
23:23:18 <sdake_> blueprint title might be db-backend
23:23:31 <sdake_> vnod use #action sdake to file db-backend blueprint
23:23:42 <vnod> sdake_ I have started implementation for db and sql-alchemy
23:23:56 <sdake_> vnod nice, then you take that :)
23:24:00 <vnod> based on the datamodel blueprint
23:24:03 <sdake_> we will need to integrate that with alembic
23:24:09 <vnod> sdake_ yes
23:24:17 <sdake_> these should all be separate blueprints
23:24:31 <sdake_> and use the data model as the master blueprint - launchpad supports dependencies
23:24:44 <vnod> #action pksingh__ to file conductor
23:24:58 <vnod> ok moving to next blueprint
23:25:01 <pksingh__> vnod: thanks :)
23:25:06 <vnod> operator tests
23:25:16 <Ajay_> I can work on that Vinod
23:25:28 <vnod> blueprint: https://blueprints.launchpad.net/cloudpulse/+spec/operator-tests
23:25:36 <vnod> thanks Ajay_
23:26:37 <vnod> #topic python CLI
23:27:00 <vnod> steven martinelli asked us to python-openstack client
23:27:00 <sdake_> need a shell and an object implemtnation for each object
23:27:12 <vnod> we need blue prints for that
23:27:17 <vnod> any volunteers
23:27:21 <sdake_> i don't know how to tackle that one ;)
23:27:31 <sdake_> lets integrate with osc clients later?
23:27:46 <pradeech> I can work on that
23:28:08 <sdake_> is osc a plugin model or something?
23:28:18 <vnod> pradeech thanks, can you file a blueprint
23:28:28 <sdake_> i'd like to have discussion on this point
23:28:32 <sdake_> does anyone know how osc works
23:28:47 <sdake_> pradeech?
23:28:50 <vnod> sdake_ we need to investigate that part, I will leave it to pradeech
23:28:53 <pradeech> vnod yes. will do it
23:29:05 <sdake_> wfm ;)
23:29:32 <sdake_> anytime someone has an action, #action it :)
23:30:06 <sdake_> the log will provide a nice way to check actions in the next weekly meeting and check on progress
23:30:14 <vnod> type #action pradeech file blueprint openstackclient
23:30:26 <sdake_> leave out the type part ;)
23:30:43 <vnod> copy and paste :)
23:30:44 * sdake_ throws peanuts from the gallery :)
23:30:54 <vnod> #action pradeech file blueprint openstackclient
23:31:23 <vnod> ok moving to next BP
23:31:28 <vnod> API tests
23:31:39 <stevemar> sdake_, dtroyer and i could answer any osc related questions (we can circle back to the topic)
23:32:06 <vnod> stevemar thanks
23:32:07 <sdake_> stevemar will do off line - i'm not sure what best practice is with osc, I thought it involved making a python-xyzclient and then integrating that in osc
23:32:26 <sdake_> stevemar is that not bp?
23:32:46 <stevemar> sdake_, thats the right idea, i dont want to interrupt you guys, i'll be around when the meeting ends
23:32:56 <sdake_> now is a good time to discuss it imo :)
23:33:06 <sdake_> that way there is a record
23:33:07 <vnod> ok. lets do it now
23:33:18 <sdake_> teach us the wisdom stevemar ;)
23:33:29 <sdake_> or knowledge rather ;-)
23:34:06 <sdake_> stevemar if you could give us a 3-5 minute description of what to do here, that would be fantaistic :)
23:34:38 <stevemar> sure sure
23:35:14 <stevemar> so we're trying to push folks to create osc plugins instead of copying and pasting the shell.py/cli.py that's been going around since novaclient 0.1 :)
23:35:38 <stevemar> you would still need to create python-cloudpulseclient
23:35:51 <stevemar> to perform all the API calls and such, like the other clients
23:35:56 <sdake_> we have the repo but its empty
23:36:04 <stevemar> but instead of bundling your own shell, you can use OSC
23:36:17 <sdake_> so osc becomes the shell then?
23:36:18 <stevemar> the benefits are 1) we handle authorization, and 2) consistency across all projects
23:36:23 <stevemar> yep
23:36:30 <sdake_> and we still have a python language binding?
23:36:34 <stevemar> yes sir
23:36:51 <vnod> ok, we have some code for cloudpulseclient, it looks like we can reuse it
23:36:51 <sdake_> nice
23:36:57 <stevemar> you still create the commands... we can't handle all the commands for all projects
23:37:00 <sdake_> pradeech did you have any Qs while we are grilling stevemar :)
23:37:23 <stevemar> but you just create entry points in setup.cfg and openstackclient is smart enough to pick it up
23:37:46 <pradeech> sdake_ I will reach out stevemar after the meeting for any other questions
23:37:59 <stevemar> congressclient is using it https://github.com/openstack/python-congressclient/#client-for-standalone-congress
23:38:02 <sdake_> nice thanks for helping us do it right stevemar
23:38:04 <pksingh__> sorry guys i got disconnected somehow
23:38:10 <stevemar> zaqar is using it too
23:38:35 <sdake_> stevemar just as a side note, we probably need to do the same thing with magnum
23:38:38 <vnod> pksingh__ we are discussing Openstackclient CLI
23:38:40 <sdake_> we can talk later about taht :)
23:38:57 <stevemar> sorry to spam, but a bit more info and real samples...
23:39:06 <sdake_> spam awa y:)
23:39:14 <vnod> stevemar thanks for helping out
23:39:15 <stevemar> heres a sample setup.cfg which indicates the entry points: https://github.com/openstack/python-congressclient/blob/master/setup.cfg#L26-L31
23:39:35 <stevemar> those are analogous to 'commands'
23:39:57 <stevemar> so to run congress_policy_create, you run it as "$ openstack congress policy create"
23:40:06 <stevemar> here's the code it invokes: https://github.com/openstack/python-congressclient/blob/master/congressclient/osc/v1/policy.py#L62-L78
23:40:22 <stevemar> and here's the entire plugin: https://github.com/openstack/python-congressclient/blob/master/congressclient/osc/osc_plugin.py a whopping 54 lines :)
23:40:34 <vnod> ok got it
23:40:39 <sdake_> nice
23:40:44 <sdake_> glad we got that on the record
23:40:52 <stevemar> the only issue we've hit so far is naming things
23:40:56 <sdake_> that should help pradeech emmesnly
23:40:59 <pradeech> thanks stevemar
23:41:21 <stevemar> swift came before docker, and they both use the word 'containers', that got icky :(
23:41:49 <stevemar> but things can have more than 1 word for a name, like 'security group' or 'access tokens'
23:41:52 <stevemar> anywho
23:41:59 <stevemar> thats just over 5 mintues :)
23:42:06 <sdake_> nice timebox :)
23:42:06 <vnod> thanks stevemar, any questions to stevemar, otherwise we can move to next blueprint
23:42:38 <vnod> next blueprint: API tests
23:43:01 <vnod> Anand shanmugam volunteered for this, he can't make it (india timezone)
23:43:07 <vnod> should be there next week
23:43:19 <sdake_> woudl you mind adding an action for him since he communicated it offline
23:44:01 <vnod> #action anshanmu file blueprint api-tests
23:44:21 <vnod> ok, we have covered all blueprints
23:44:29 <vnod> any questions on blueprints so far ?
23:44:31 <sdake_> nice time for some beer and peanuts
23:45:06 <vnod> all for that
23:45:34 <vnod> #topic opendiscussion
23:45:58 <sdake> after we get these blueprints filed, I assume peopel will start working on them?
23:46:02 <sdake> or what is the next step
23:46:07 <sdake> do they need to be approved first
23:46:28 <vnod> yes, can we use gerrit review ?
23:46:41 <sdake> cool so should wait for approvel from the ptl?
23:46:48 <sdake> typically projects put the blueprint in discussions tate
23:46:52 <vnod> no any core can approve
23:46:56 <sdake> peopel add the whiteboard
23:47:00 <sdake> but  Ithink we are in agreement they should be worked on
23:47:03 <pksingh__> is there any time limit for the implementation?
23:47:04 <vnod> and we can discuss in IRC
23:47:14 <vnod> pksingh__ good question
23:47:26 <sdake> time liits in open source lol
23:47:27 <vnod> we want the basic functionality to be done by Libery L1
23:47:39 <sdake> june 25th for those watching at home
23:47:50 <vnod> but conductor can be added later
23:47:56 <sdake> IMO l2 seems more realistic :)
23:48:00 <pksingh__> vnod: ok :)
23:48:12 <sdake> for basic functionality
23:48:30 <sdake> for this round of blueprints tho, I agree with vnod, l1 is doable lets do it :)
23:48:33 <vnod> sdake L1 is stretch goal, but lets try the basic functionality
23:49:10 <vnod> ok any other topic ?
23:49:26 <sdake> i have quick q
23:49:35 <sdake> will we be thinking of adding healthchecking cross-service long term?
23:49:40 <sdake> eg, have nova check its own health
23:49:57 <vnod> yes. that is covered in the API-tests blue print
23:50:16 <sdake> what I mean is add an api to the nova apis to check its health
23:50:26 <sdake> not rely on existing apis
23:50:35 <sdake> someone from the community had this idea onthe ml
23:50:38 <sdake> and I think its a good one
23:50:41 <sdake> clealry not in liberty timeframe
23:50:49 <sdake> but long term project goal
23:50:51 <vnod> No, we are relying on nova service-list neutron net-list etc..
23:50:56 <vnod> for L1
23:51:04 <sdake> agree with l1/l2/l3 objectives
23:51:06 <sdake> talking long term
23:51:13 <vnod> but long term we need to work with community to get those health apis
23:51:15 <sdake> eg whatever is in M
23:51:36 <vnod> are there blueprints for other openstack services for health
23:51:45 <sdake> nope
23:51:48 <sdake> we would hae to do that work
23:52:00 <vnod> ok
23:52:00 <sdake> but there woudl be high value in it
23:52:10 <sdake> something to keep in mind as you fearlessly lead us :)
23:52:23 <vnod> sdake agreed, we should get those blueprints in
23:52:33 <sdake> i htink now is too early for those blueprints
23:52:43 <sdake> but its alway sgood to know whereyour headed
23:52:50 <vnod> hmm.
23:53:17 <sdake> ok thanks i'm done with my questions :)
23:53:28 <vnod> thanks sdake
23:54:01 <vnod> for folks, we are available on #openstack-cloudpulse
23:54:17 <vnod> IRC channel
23:54:27 <vnod> feel free to shoot your questions there
23:54:40 <vnod> thanks everyone for coming to our cloudpulse.
23:55:05 <vnod> #endmeeting