17:01:28 <reed> #startmeeting community
17:01:29 <openstack> Meeting started Mon Apr 20 17:01:28 2015 UTC and is due to finish in 60 minutes. The chair is reed. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:32 <openstack> The meeting name has been set to 'community'
17:01:57 <reed> so let's start with a pat on the back :)
17:02:13 <reed> #info Q1 2015 community activity report is out
17:02:24 <reed> #info thank you Daniel for the hard work
17:02:25 <mrmartin> where?
17:02:51 <dizquierdo> #info thank you Stefano for the hard work :)
17:03:09 <dizquierdo> this is under the activity_board repo
17:03:22 <reed> #link http://superuser.openstack.org/articles/openstack-breaks-a-new-record-for-active-contributors
17:03:40 <reed> lots of interesting facts and data
17:03:46 <mrmartin> oh ok, I saw that
17:03:54 <dizquierdo> feedback is more than welcome
17:04:14 <dizquierdo> tips to improve, new numbers of interest for you, etc
17:04:15 <reed> I have on my todo list to reach out to johnthetubaguy to talk about Nova's time to merge and get his feedback :)
17:04:23 <dizquierdo> great
17:04:31 <reed> and mikal too
17:04:31 <dizquierdo> that would be awesome to have feedback from devs
17:04:41 <reed> yep
17:05:02 <reed> so, moving on the next topic
17:05:35 <reed> did we have any previous action item agreed?
17:05:41 <reed> I don't think so, right?
17:05:56 <dizquierdo> reed, you mean as next topic for this meeting?
17:06:11 <reed> dizquierdo, yes
17:06:24 <reed> It hink we can move to the next topic safely
17:06:24 <mrmartin> https://wiki.openstack.org/wiki/Community/MeetingAgenda
17:06:25 <dizquierdo> reed, we're updated the puppet recipes, that could be one
17:06:45 <reed> #topic Askbot upgrade path
17:07:00 <reed> mrmartin, what's the status?
17:07:13 <mrmartin> ok, for askbot I made the initial staging-askbot infra patch
17:07:38 <reed> #info mrmartin made the initial staging-askbot infra patch
17:07:43 <mrmartin> this one: https://review.openstack.org/#/c/172880/
17:08:03 <mrmartin> and we're a littlebit stucked with this: https://review.openstack.org/#/c/171066/
17:08:12 <reed> #link https://review.openstack.org/#/c/172880/
17:08:28 <mrmartin> so let's join and vote down: Joshua's -1 :)
17:08:36 <reed> mrmartin, what's the problem with 171066?
17:09:19 <mrmartin> We got a -1, because Joshua not agrees with pinning the askbot theme to actual stable release
17:09:31 <mrmartin> but expect this, it is ok.
17:09:32 <reed> mrmartin, are the two patches dependent on each other?
17:09:36 <mrmartin> no
17:09:41 <reed> ok
17:09:45 * johnthetubaguy wonders if he can answer questions
17:09:52 <reed> so let's do one thing at the time
17:10:08 <reed> johnthetubaguy, I'll email you, it's not time sensitive
17:10:10 <mrmartin> this theme patch is required to keep the ask.o.o's theme stable, so Evgeny can start do commit theme changes
17:10:18 <johnthetubaguy> reed: perfect
17:10:47 <reed> #info patch https://review.openstack.org/#/c/171066/ is required to keep the ask.o.o's theme stable, so Evgeny can start do commit theme changes
17:11:04 <mrmartin> reed: the staging patch contains the environment, expect the askbot deployment, I'm working on that, because we need to consume github repo here as we discussed before.
17:11:31 <reed> #action reed to comment on 171066 and ask for quick solution
17:11:54 <mrmartin> I'll try to push 172880 tomorrow on infra meeting
17:12:14 <reed> #action mrmartin to push 172880 tomorrow on infra meeting
17:12:24 <reed> indeed, mrmartin, things need to accelerate
17:12:42 <mrmartin> and we have a small issue with the ask.o.o puppet and the vamsee-solr repo
17:12:57 <mrmartin> this one: https://review.openstack.org/#/c/171600/
17:13:38 <mrmartin> it's a bit complex story, but finally, I need to contrib back to vamsee-solr to give a permanent solution
17:13:49 <mrmartin> I made a pull request: https://github.com/vamsee/puppet-solr/pull/22
17:13:57 <reed> #info hit a small issue with the ask.o.o puppet and the vamsee-solr repo, mrmartin working on a fix https://review.openstack.org/#/c/171600/
17:14:03 <reed> #link https://review.openstack.org/#/c/171600/
17:14:07 <mrmartin> so when it gets an approval, I can close the 171600
17:14:19 <reed> #link https://github.com/vamsee/puppet-solr/pull/22
17:14:22 <reed> gotcha
17:14:28 <reed> thanks
17:14:38 <mrmartin> and as I know, we successfully finalized this ask.o.o redis issue
17:14:56 <reed> so to be clear, for the upgrade you only need 171066 to merge?
17:15:10 <reed> mrmartin, yes, the redis issue seems to be solved
17:15:39 <mrmartin> so if the 171066 merged, we'll get a clean staging-askbot environment with database and puppet, so if it is very urgent
17:15:51 <mrmartin> we can start to deploy askbot github manually (just the code)
17:15:59 <reed> cool
17:16:00 <mrmartin> until the auto-deployment arrives
17:16:30 <mrmartin> for auto-deployment I'm working on a similar little middleware that we are using for groups portal and openstackid
17:16:44 <reed> #info once 171066 merged, we'll get a clean staging-askbot environment with database and puppet, so if it is very urgent we can start to deploy askbot github manually (just the code) until the auto-deployment arrives
17:16:57 <reed> #info for auto-deployment mrmartin is working on a similar little middleware that we are using for groups portal and openstackid
17:17:04 <reed> gotcha, thanks
17:17:12 <mrmartin> anyway, do we have any urgent ask.o.o production issue?
17:17:16 <reed> ok, that's great
17:17:47 <reed> mrmartin, nothing urgent, but there are a lot of small bugs that I'd like to address asap, so getting the staging done is urgent
17:17:59 <mrmartin> ok.
17:18:05 <reed> next topic?
17:18:28 <reed> #topic Infratization of Activity Board
17:18:44 <reed> dizquierdo, what's the current status here?
17:19:01 <dizquierdo> reed, mrmartin we've been working on migrating the previous puppet recipes
17:19:08 <dizquierdo> to a more openstack-focus
17:19:12 <dizquierdo> https://wiki.openstack.org/wiki/Community/MeetingAgenda
17:19:18 <dizquierdo> but I'd say that we need some help here
17:19:29 <dizquierdo> those are the recipes to install all of the tools
17:19:39 <reed> I'd like to start from this spec: https://etherpad.openstack.org/p/activity-infratization-spec
17:19:41 <mrmartin> allright, I'm here, ping me during working hours
17:19:58 <dizquierdo> ah ok mrmartin :), thanks
17:20:03 <reed> is that ready to submit to infra? IIRC that was the first thing to complete, right?
17:20:30 <dizquierdo> reed, I'd like mrmartin to check that in first place
17:20:32 <mrmartin> it is in much better form
17:20:34 <dizquierdo> if he does not mind doing this
17:20:39 <mrmartin> so I'll review that tomorrow
17:20:44 <mrmartin> if nothing urgent comes in
17:20:56 <reed> #info mrmartin to review https://etherpad.openstack.org/p/activity-infratization-spec
17:21:00 <reed> #undo
17:21:00 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x8f6f450>
17:21:06 <reed> #action mrmartin to review https://etherpad.openstack.org/p/activity-infratization-spec
17:21:14 <dizquierdo> thanks a lot mrmartin, dpose and I should be around, and we can improve those
17:21:57 <reed> mrmartin, it doesn't have to be perfect, just good enough to be submitted for review on infra-specs without being laughed at
17:21:59 <reed> :)
17:22:02 <dizquierdo> and the following step would be to add another recipe to install Automator, the tool to run all of the tools
17:22:07 <mrmartin> yes I know, they will break it apart
17:22:20 <dizquierdo> that's my concern, not to annoy a lot infra team :S
17:22:42 <mrmartin> the infra team will throw us into a deep well, but we will climb back
17:22:49 <dizquierdo> :)
17:22:54 <reed> it can be a WIP for a while, too
17:23:01 <dizquierdo> yep
17:23:04 <reed> ok
17:23:10 <mrmartin> yeah, we need to make it a priority effort somehow
17:23:12 <reed> any other action items?
17:23:16 <mrmartin> but it will take time
17:23:52 <dizquierdo> not regarding to puppetization
17:23:54 <mrmartin> ok, I have some groups portal thingy
17:23:55 <reed> mrmartin, I'll take care of the priority settings for activity board infratization, no worries about that
17:24:13 <reed> let's get the spec ready asap: not urgent but it's important
17:24:15 <mrmartin> so we had a security update on a drupal module again
17:24:25 <reed> mrmartin, are you changing topic?
17:25:17 <mrmartin> #topic groups portal
17:25:19 <mrmartin> can I?
17:25:27 <reed> are we finished with activity board?
17:25:28 <reed> dizquierdo, anything else to be aware?
17:25:32 <reed> I have one more question on this: are you guys working on the 'traditional' release report?
17:25:39 <dizquierdo> yep reed, that's all
17:25:57 <dizquierdo> reed, you mean the report about orgs working on the OpenStack projects?
17:25:58 <mrmartin> sorry :)
17:26:17 <reed> dizquierdo, right, what Bitergia usually produces for your blog
17:26:27 <reed> and we relay extensively from our side :)
17:26:36 <dizquierdo> I'd like to have a release about that for sure
17:26:37 <dizquierdo> yep
17:26:39 <dizquierdo> :)
17:26:48 <dizquierdo> reed,
17:26:48 <reed> dizquierdo, cool, let me know about the timing so we coordinate
17:26:52 <dizquierdo> the deadline is on the 30th right?
17:27:01 <dizquierdo> sure, I'll let you know
17:27:25 <reed> dizquierdo, that's the week of the release as of today
17:27:31 <dizquierdo> according to https://wiki.openstack.org/wiki/Releases
17:28:09 <dizquierdo> reed, I reword the question, when should that blog post be ready?
17:29:06 <reed> oh, I don't know
17:29:17 <reed> I guess it'sup to you
17:29:39 <dizquierdo> hehe, ok, I'll use the 30th that seems to be the official release
17:30:30 <reed> cool
17:30:35 <dizquierdo> :)
17:30:55 <reed> dizquierdo, can you help me pull the list of contributors?
17:31:03 <dizquierdo> reed, sure
17:31:07 <reed> cool
17:31:21 <reed> #action reed and dizquierdo to coordinate offline to pull the list of contributors to Kilo
17:31:25 <reed> ok
17:31:27 <reed> next topic
17:31:35 <reed> #topic groups portal status
17:31:42 <mrmartin> ok
17:31:43 <mrmartin> so
17:32:05 <mrmartin> we had a module sec update, and the release is rolled out
17:32:29 <mrmartin> and I made this csv contact export for the marketing team, so now they can start to prepare the Bday party
17:32:33 <reed> #info a couple of security updates were rolled out to the groups portal
17:32:49 <reed> #info mrmartin created a csv export of contacts for the marketing team
17:33:05 <mrmartin> we don't have a GUI report there, but the goal had been reached, so anyone with a proper admin right can do the export
17:33:14 <reed> mrmartin, re the bday party, we need to make more people register to the portal as administrators of the groups
17:33:28 <mrmartin> yes, that was the exact problem the came up
17:33:28 <reed> the process currently is:
17:33:36 <reed> - administrator logs in
17:33:56 <reed> - click on "join us" to become a member of the group
17:34:21 <mrmartin> and somebody need to approve
17:34:21 <reed> - Send an email to *someone with high rights* and ask to be promoted to administrator of the group
17:34:43 <reed> can we make this process easier?
17:35:06 <reed> like a button saying 'Are you the administator? DO THIS"
17:35:17 <mrmartin> the question here, how can you identify who is a group admin?
17:35:19 <reed> with DO THIS something like click a button and a process starts automatically
17:35:33 <mrmartin> what you think about creating tokens
17:35:35 <reed> like we do now, with email checks
17:35:45 <mrmartin> and sending those tokens for every organizer who not registered yet
17:35:58 <reed> ah, I see ...
17:36:05 <reed> looks complicated
17:36:05 <mrmartin> and when he clicks on the link embedded on his email, drupal automagically do the process
17:36:05 <mrmartin> ?
17:36:24 <reed> we are sending an email requesting people to do something
17:36:25 <mrmartin> the problem here, that he *must* login
17:36:38 <reed> exactly, so let's keep it simple
17:36:45 <mrmartin> and a new user must be created first with his openstackid token
17:36:54 <mrmartin> that's the initial step we cannot skip
17:37:05 <reed> we are contacting group admins and we're going to sponsor their party if they complete the signup steps on the portal
17:37:30 <reed> the first step is easy: sign up on the portal
17:37:30 <mrmartin> this token / email thing is not complicated
17:37:41 <mrmartin> and I can redirect them to the login form
17:37:42 <reed> it is, forget about the token
17:38:12 <reed> I think it would just be simple enough to have a button for admin on the groups home page
17:38:47 <mrmartin> ok, but how can you identify the group admin?
17:38:52 <mrmartin> by email address?
17:39:08 <mrmartin> you can do it only, when he used the same email address for his openstack.org profile registration
17:39:21 <reed> email address, yes, it's fine
17:39:49 <mrmartin> we were working a lot with Tom to cleanup the original json file, but I'm still not sure it is 100% perfect
17:39:51 <reed> the token would have the same issue, right? you send it to one email address
17:40:15 <mrmartin> yes, but we are sending to an email address enlisted in groups.json
17:40:35 <mrmartin> but, we could check how much those accounts exists in openstack.org profile db
17:41:12 <mrmartin> if I make a list from those guys, can Sebastian or somebody else whether those emails are matching for real-life profiles?
17:41:18 <reed> the marketing team is sending an invite to the emails in the CSV
17:41:27 <mrmartin> if yes, it is easier to match the group organizers
17:41:53 <mrmartin> and I can write a little code that automatically joins this guy based on email address to his own group on first login
17:41:54 <reed> why do you think we need so much security? we never did this before
17:42:05 <mrmartin> it is not security
17:42:21 <reed> oh, I think I see what you mean now
17:42:32 <mrmartin> it is about they are using the same email address that we have in groups.json, and he registered as an o.o profile
17:42:38 <reed> you want to make sure that the email in the json file has a correspondent id on o.o
17:42:50 <reed> gotcha, that makes sense
17:42:50 <mrmartin> yeah it can be a problem, if this two email is not matching
17:43:05 <mrmartin> if we have a matching email address, we can do a lot of actions at groups side
17:43:15 <mrmartin> and even I can ease the registration process
17:43:27 <reed> ok, so next order of business is to talk to Tom about this and have him check
17:43:29 <mrmartin> so he don't need to join to the group and promoted by someone to be an organizer
17:43:52 <reed> we have the .csv list of emails, sebastian may be able to check how many of those are *not* on openstackid
17:43:53 <mrmartin> so if have an around 90% match, that's great
17:44:22 <reed> mrmartin, let's write a quick summary
17:44:43 <mrmartin> if you check the group status report, you can see, we have a process level of 63%
17:44:44 <reed> #action reed to write a summary of this discussion and send it to community list
17:44:51 <mrmartin> but Africa is totally missing
17:45:20 <mrmartin> but a lot of work required for North America and Asia
17:45:44 <mrmartin> I could move Cyprus back to EU now :)
17:45:47 <reed> are those not very active groups?
17:46:02 <reed> Cyprus should be Europe :)
17:46:10 <mrmartin> yeah it can be an issue, with Erwan we tried to reach out all of the group leaders
17:46:34 <mrmartin> but we still have some black-holes, so we need to work on this
17:46:36 <reed> you can leave them there as placeholders until someone active shows up
17:46:59 <reed> that's why I wanted to have a button that says: "I would like to administrate this group"
17:47:05 <mrmartin> yeah, I don't want to remove groups
17:47:29 <mrmartin> for example in Czech Republic, I see that they are doing meetups, just guy was not answering, maybe our emails lost in a spam filter or something
17:47:30 <reed> click on the button, Tom gets an email and a conversation starts
17:47:59 <reed> ok, let's move the chat to the email
17:48:05 <mrmartin> so we can't automate that, it is an administration task that is manual
17:48:05 <mrmartin> but
17:48:24 <mrmartin> what I'm working on, but still not landed in dev, this is the email notification / messaging
17:48:45 <mrmartin> so Drupal have this privatemsg module, and on my dev environment I can send messages between users and roles
17:49:00 <mrmartin> and can send message to anyone
17:49:18 <mrmartin> it have only a single bug with matching of user names
17:49:27 <mrmartin> and the UX is a bit messed up in the actual theme
17:49:45 <mrmartin> so if I solve this issue, we have a properly working messaging system there
17:49:55 <reed> sounds good
17:50:07 <mrmartin> the Commons solved that with a custom module, that not fits our model
17:50:25 <mrmartin> because it requires an approval before accepting messages (they call it trusted messages)
17:50:36 <reed> spam
17:50:55 <reed> alright, sounds like we have plenty of work to do :)
17:50:59 <mrmartin> yeah exactly, but I'm not afraid of spam, because we have openstackid, and everybody linked to an o.o profile
17:51:15 <mrmartin> and I want to remove this manual recipient selection
17:51:31 <mrmartin> so I like to put a "send me a message" link to the profile page of a user
17:51:45 <mrmartin> and implement the "send a message to group members"
17:51:55 <mrmartin> and the "send message to organizers" use cases.
17:52:08 <reed> cool
17:52:29 <mrmartin> if you check meetup.com, the messaging there is very sofisticated, I don't like to implement that in the first round, but this three basic use case can work.
17:52:30 <reed> mrmartin, can you please document these use cases, have an estimate of work required
17:52:32 <reed> ?
17:52:52 <mrmartin> on meetup.com you can even select specific user list to accept messages, or send messages to active members.
17:53:05 <mrmartin> yes, I'll write an etherpad for that
17:53:10 <reed> thanks
17:53:29 <reed> ok anything else?
17:53:36 <mrmartin> commons messaging was not implemented this and I pulled out my hair until I find out how they rewrite to core messaging modules :)
17:53:58 <reed> #action mrmartin to document use cases for inter-portal communication
17:54:05 <mrmartin> so that's the reason that I don't have long blonde hair
17:54:12 <mrmartin> ok
17:54:14 <reed> arrgh
17:54:17 <mrmartin> so that's all
17:54:18 <mrmartin> sorry :)
17:54:21 <reed> cool, thanks
17:54:27 <reed> #endmeeting