17:04:10 <wshao> #startmeeting compass-dev
17:04:11 <openstack> Meeting started Wed Jul  8 17:04:10 2015 UTC and is due to finish in 60 minutes.  The chair is wshao. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:15 <openstack> The meeting name has been set to 'compass_dev'
17:04:25 <wshao> o/
17:04:33 <rockyg> o/
17:05:11 <rockyg> you want to discuss the tc vote when more people turn up?
17:05:29 <wshao> #info Let's discuss the feedbacks from TC review on Compass relevance to OpenStack and its 4 opens
17:05:44 <wshao> yes, let's wait for shuo and others
17:06:02 <rockyg> #topic TC review of Compass application
17:06:18 <rockyg> I can't change topic, but you can.  It goes into the minutes
17:06:33 <wshao> ok.
17:06:53 <wshao> #topic TC review of Compass application to OpenStack
17:07:03 <rockyg> cool, huh?
17:07:23 <rockyg> ping them on the mailing list, maybe?
17:08:01 <wshao> Shuo will be in soon
17:08:19 <rockyg> ah.
17:11:00 <rockyg> So, I think we should record here a couple of the action items we got from the TC meeting.  That way, those who miss this will be able to review
17:11:49 <wshao> rocky: please share the feedbacks
17:12:44 <wshao> item 1) Project scope is too general. Not openstack-specific
17:12:47 <rockyg> So, the committee is worried about a number of things
17:12:59 <wshao> ok go ahead.
17:13:11 <rockyg> Use #info, on these, if you can.
17:13:18 <wshao> ok.
17:13:29 <wshao> #info Project scope is too general. Not openstack-specific
17:13:30 <xiaodongwang> hi
17:13:37 <rockyg> As wshao said The scope seems to be more than OpenStack.
17:13:52 <rockyg> But, really I think we are OpenStack + ecosystem.
17:13:53 <wshao> I have explained that the foucs is still OpenStack, we need to adjust our web page to reflect this
17:14:20 <rockyg> We need to show that we deploy the foundation of openStack with the User apps on top
17:14:41 <rockyg> 2) not integrated enough in OpenStack
17:15:03 <rockyg> We duplicate recipes now in OpenStack.  But, they weren'
17:15:12 <rockyg> t there when we started.
17:15:20 <wshao> They give an example of our user management, and think it should use Keystone
17:16:00 <wshao> so how shall we address this?
17:16:03 <rockyg> So, we should participate in the now OpenStack chef/puppet/ansible projects to get what we need, then, if necessary, add a recipe to customize
17:16:39 <rockyg> Also, we don't use any oslo libraries.  They would like to see that.
17:16:39 <wshao> in particular, we need to estimate the scope of work to support community version of chef cookbooks.
17:17:21 <rockyg> ansible project is just getting started, so we should have someone join that effort.
17:17:50 <rockyg> The key is to eliminate duplication across OpenStack projects.
17:17:54 <Shuo> rockyg: is there an open OpenStack ansible community?  Here is what I understand ....
17:17:58 <wshao> #info To address the concern of overlapping, we can watch and join OpenStack chef/puppet/ansible projects
17:18:42 <rockyg> Yes, there is a new ansible effort with a repo.
17:19:36 <rockyg> looking for it now.
17:19:51 <wshao> #action Follow up on openstack ansible efforts
17:20:48 <Shuo> we are trying to have a compass-adapter that enable Ansible + Docker based deployment, i.e., enabling microservicing the OpenStack compoments.
17:20:53 <wshao> on user auth and keystone, it is debatable is an installer of OpenStack should use standalone keystone
17:21:05 <rockyg> #link http://git.openstack.org/cgit/openstack-infra/ansible-puppet/
17:21:10 <wshao> does anyone know if Fuel supports keystone of its fuel-web application?
17:21:12 <Shuo> if the Ansible community shares that vision, we'd love to have this as a joint effort.
17:21:49 <rockyg> Right now, ansible is focused with puppet.  We could work with them to also do chef
17:22:05 <Shuo> wshao: no as I understand.
17:22:08 <wshao> Shuo: kolla team seems to discuss on Ansible earlier on this channel.
17:22:11 <rockyg> Oh, and Fuel applied for project status yesterday.
17:22:33 <dstanek> rockyg: i thought you were talking about OSAD when you mentioned ansible
17:22:40 <rockyg> Are there places where using oslo libs make sense?
17:22:46 <wshao> rockyg: they seems to indicate it allows overlaps in 'Big Tent'
17:23:02 <rockyg> dstanek, OSAD?
17:23:05 <wshao> if Fuel is accepted, will that make it difficult for Compass to be accepted?
17:23:32 <rockyg> wshao, it should not, but we have a higher bar to meet.  They are all over the dev ML
17:23:46 <dstanek> rockyg: the ansible roles and playbooks to install OpenStack - http://git.openstack.org/cgit/stackforge/os-ansible-deployment/
17:23:58 <rockyg> Ah!  Yes!
17:24:13 <rockyg> thanks for the link!
17:24:17 <Shuo> dstanek: we looked at OSAD, and I love that idea. but we really would like to see docker based component than direct-lxc based. If that can be discussed, that's the most applausible direction we want to go to.
17:24:40 <rockyg> It can't be discussed if we don't participate
17:24:49 <rockyg> So, we need to join the discussion.
17:25:04 <wshao> rockyg: agreed.
17:25:05 <dstanek> Shuo: my goal is the use their roles outside of lxc - for example, deploying keystone on a cloud node
17:25:26 <wshao> ok. move to the nexdt point on "open community"
17:25:27 <dstanek> they hang out in #openstack-ansible
17:25:30 <rockyg> Also, the containers world splintering and moving to open containers
17:25:55 <wshao> they want to see improvement in this area. Any ideas on specific steps toward a more open community?
17:25:57 <rockyg> So, wshao #topic open community
17:26:17 <Shuo> dstanek: brilliant! love the reusable code base idea.
17:26:24 <wshao> #topic improvment on open community
17:26:31 <rockyg> #topic needs to be first word on the line.
17:26:48 <rockyg> See, Shuo you need to hang out on Openstack-ansible ;-)
17:27:05 <rockyg> So, open community.
17:27:31 <Shuo> dstanek: indeed, we might be able to help building the dockerfile that generating the docker-image if we can come up with a specific proposal together
17:27:40 <rockyg> This meeting is where planning for compass should happen.  That way anyone can participate
17:28:34 <wshao> ok. we will use this for future planning meeting
17:28:38 <rockyg> Or, on an irc channel.  We asked what to use and we should use #openstack-compass.  We need to create it and get infra to put a record bot on it
17:29:08 <wshao> we already created #openstack-compass
17:29:25 <rockyg> Cool.  we just need to file a patch to get it recorded then
17:29:40 <rockyg> Also, status updates should go to dev mailing list
17:30:01 <rockyg> So, milestones, releases, etc
17:30:08 <wshao> #action I will replace syscomass with openstack-compass in current gerrit hooks notifications
17:30:12 <Shuo> rockyg and wshao: stop me if I make to more specific-item-based discussion rather than a more procedural/adminstrative one, please. But we'd love to have OSAD as one of our Compass-Adapter if the vision / proposal come into certain consensus
17:31:41 <wshao> Shuo: yes, we will follow-up on that. ideally, the compass-adapter itself should not host the cookbooks or ansible, but rather, the adapter configs and meta data etc
17:31:45 <rockyg> Shuo, do you want the action item to go out to openstack-ansible and get the discussion rolling?  Once it is more definite, it needs to be put out on the dev mailing list for the whole community to comment
17:32:37 <wshao> #action (Shuo) Follow up on openstack-ansible  and figure out a plan for joining the dev and  future Compass integration
17:32:51 <Shuo> rockyg: yes, I'd love to have that technical conversation if dstanek (and the team ) is open.
17:33:17 <wshao> ok I put that AI on you, Shuo.
17:33:21 <rockyg> Shuo, and also, a "spec" could be proposed to stackforge/os-ansible-deployment that is the basic design spec
17:33:40 <rockyg> Then it can be discussed through the review process.
17:33:54 <Shuo> great, wshao and rockyg.
17:35:06 <dstanek> Shuo: i'm not really part of that team. i just use their work
17:35:12 <rockyg> Something we need to do to make IRC more accessible for everyone is to stand up a proxy-server/forwarder type IRC server.  Quassel has one
17:35:39 <rockyg> dstanek, please tell us more about yourself and what you do/focus on in OpenStack
17:35:56 <dstanek> Shuo: i just noticed you guys because you said Keystone
17:36:17 <wshao> #info  to summarize on open community, we need to use mailing list for dicussions, use #openstack-compass for technical discussion and community building, use official weekly irc meeting for project planning. and of course, in recruiting more developers
17:36:21 <dstanek> rockyg: i'm a keystone core and play with other bits and parts
17:36:44 <rockyg> Good example of what a proxy server can do.  If it sees a word you tell it to look for, it will notify you :-)
17:36:53 <dstanek> i work for Rackspace and the team i report to there started the OSAD project
17:37:03 <wshao> dstanek: question on keystone being used for installer auth, do you support that idea?
17:37:33 <wshao> it was suggested that we should adopt keystone in our user management
17:38:48 <dstanek> wshao: what do you mean by installer auth? are these users a part of the could?
17:38:53 <dstanek> *cloud
17:39:04 <wshao> no. not part of the cloud
17:39:23 <wshao> Compass is to install OpenStack in data center. similar to Fuel.
17:39:25 <rockyg> Actually, the project is to *install* the cloud, so until that happens, keystone would need to be stand-alone
17:39:59 <dstanek> who creates the users? and can you give me an example of a user?
17:40:02 <rockyg> So, a DC admin is the prospective user of Compass
17:40:15 <dstanek> i've only used root and myself (both unix users) to install a cloud
17:41:18 <dstanek> and you manage a DC admin user account in compass?
17:41:20 <rockyg> Right.  So, you as a superuser would install compass, open it and use it to install an openstack cloud on your bare metal
17:41:48 <wshao> dstanek: the reason we added simple user management is to allow different users to create different 'cloud'. i.e. different openstack clusters.  Current user mgmt is very primitive. Original thought is to expand it later to integrate with LDAP.
17:41:49 <Shuo> dstanek: I think wshao got the feedback that saying something like "if you don't use KeyStone as auth for your installation process, you may not be part of the BigTent project"? wshao, would you mind restating that specific feedback/comment since dstanek is from the KeyStone community here?
17:42:22 <rockyg> Once compass is installed, the original "admin" who installed it, can add other people who can use compass to configure bare metal
17:42:30 <wshao> Shuo: pretty much as you stated.
17:42:48 <rockyg> This is one of the reasons the keystone issue seems a bit wierd to us.
17:43:34 <rockyg> I guess we could use keystone once Compass is installed to manage the compass admins
17:43:49 <dstanek> i sorta agree with using keystone, especially once you say you want to integrate with LDAP (and eventually add even more keystone-like features)
17:44:46 <rockyg> Yeah, if we're going to be interfacing to a number of identity/auth protocols, we *should* use keystone.  Much easier.
17:44:54 <dstanek> since keystone is usually used for cloud users though i'm not sure how it all works together. never looked into this area before
17:45:09 <sdake> hey guys, could one of your core reviewer guys contact me after your meeting is concluded?
17:45:28 <sdake> thanks :)
17:45:34 <wshao> sdake: sure
17:45:42 <rockyg> wshao, wanna make an action item?
17:46:08 <wshao> an action item on keystone?
17:46:48 <wshao> #action (wshao) Figure out the right strategy on user management and relationship to keysone.
17:47:29 <rockyg> to contact sdake after the meetin:-)
17:47:53 <wshao> #info comments on static MIB data and older versionof web code still in master branch of compass-web
17:48:07 <wshao> #action (wshao) contact sdake
17:48:33 <wshao> #topic static MIB data in compass-core and older versionof web code still in master branch of compass-web
17:48:42 <rockyg> Yes, it seems we *really* need to clean up the repositories before we get them moved.
17:48:53 <wshao> I will address these two issues.
17:49:40 <wshao> #action (wshao) clean up older version in the repo. Figure out SNMP MIB data issue and eventually move it out of the repo
17:49:45 <rockyg> We want the repositories in good, working shape with no old cruft so we don't drag old dead-ends with us
17:50:19 <wshao> agreed. let's clean up on that.
17:50:48 <rockyg> Well, I think it can be in the repo, but more like a contrib dir, or a vendor dir or something.  Like linux does hw drivers
17:50:51 <wshao> I think we have covered most comments/feedbacks from the review. Anything else?
17:51:05 <rockyg> Reviews and reviewers
17:51:25 <wshao> rockyg: mib should not be in compass-core. perhaps in adapters repo.
17:51:41 <rockyg> We all need to be using gerrit to review each others' code and we need core reviewers.
17:51:53 <wshao> #action to invite more reviewers
17:52:34 <rockyg> We need to follow the best practices more closely.  So -1 on not enough comments, -1 on no test, -1 if style is not good
17:52:59 <wshao> #info We need to follow the best practices more closely.  So -1 on not enough comments, -1 on no test, -1 if style is not good
17:53:01 <rockyg> And all comments to make these better need to be in the gerrit review.
17:53:41 <rockyg> How many people here have actually officially reviewed a patch?
17:53:46 <xicheng> should mibs exist in repos at all?
17:53:49 <wshao> rockyg: we have some pre checks in place today, but yes there are rooms for improvements
17:54:02 <wshao> xicheng: mibs should not be.
17:54:10 <xicheng> it could be a zip on s3
17:54:59 <wshao> ok time is almost up. Any other major items?
17:55:07 <rockyg> xicheng, part of becoming part of OpenStack is that all related work needs to be on the openstack servers.
17:55:47 <xicheng> i see. but mibs seem to me are libraries.
17:56:15 <rockyg> so, we have a library repository?  Or???
17:56:30 <wshao> rockyg: mib could be considered as an external dependency, which can be hosted elsewhere. e.g, iso image for base OS for Cobbler.
17:56:30 <rockyg> We can ask other folks on IRC how they do it or look at Fuel
17:56:48 <rockyg> Cool.
17:56:54 <xicheng> OK
17:56:55 <wshao> yes, I take the action item on MIBs
17:57:33 <wshao> ok, anything else? or i will end this meeting.
17:58:09 <rockyg> I think this is a wonderful start.  We won't get more developers if we don't post to the ML, so announce the meetings and the IRC channel and anything else you think is important for other developers to know.
17:58:32 <wshao> yes, will do
17:58:49 <wshao> #action Introducing compas to ML.
17:59:04 <rockyg> Oh, and build status should go to the IRC channel.  We should all be monitoring it.  (that proxy host ;-)
17:59:24 <rockyg> Good meeting.  Thanks, guys!
17:59:43 <Shuo> thanks
17:59:43 <xicheng> Thanks.
17:59:44 <wshao> yes, it was on syscomass, i will change it to #openstack-compass
17:59:54 <wshao> #endmeeting