18:04:11 <pballand> #startmeeting CongressTeamMeeting
18:04:12 <openstack> Meeting started Tue Nov 19 18:04:11 2013 UTC and is due to finish in 60 minutes.  The chair is pballand. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:04:15 <openstack> The meeting name has been set to 'congressteammeeting'
18:04:32 <pballand> #topic Intro to Congress
18:05:05 <pballand> Since I don't know how many people are here, I want to keep the intro brief, and allow people to introduce themselves
18:05:49 <pballand> The brief intro is: A few of us have been working on policy for some time, and feel that it fills an important need in OpenStack
18:06:21 <pballand> We've proposed a service (initially named "Congress") and posted some POC code and overview
18:06:26 <pballand> #link https://wiki.openstack.org/wiki/Congress
18:06:45 <pballand> with that, let's see who (if anyone) is here
18:06:49 <pballand> #topic Participant intros
18:07:47 <banix> Hi, This is Mohammad Banikazemi
18:08:21 <pballand> I'll go first: my name is Peter and I work at VMware; I want to see congress facilitate declaring business logic in a way that can facilitate customers needs in the cloud
18:08:50 <banix> I am mainly interested in Policies for networking but thought should here a bit about Congress
18:08:58 <pballand> Hi Mohammad
18:09:30 <pballand> anyone else around?
18:09:44 <banix> Hi
18:09:48 <thinrichs> Hi.   My name is Tim Hinrichs.  I recently started working at VMWare.  Before that I spent 10 years on policy languages.
18:10:55 <pballand> ok - I know there is another working group for networking policy, so we don't want to replicate that here
18:11:42 <pballand> at the last conference, we discussed some things that make sense to do at a level above networking, with potential merging in the future
18:12:18 <pballand> banix: does that sound reasonable to you?
18:12:22 <banix> yeah; Makes sense. I was thinking at some point here may be some interactions
18:13:03 <banix> so I just want to be aware of where you guys are heading and if there are things to sync/discuss in future
18:13:15 <pballand> ok, since it appears to be just the three of us, it seems we should move on to future work
18:13:19 <thinrichs> I agree it makes sense to keep in touch with the other effort.
18:13:31 <pballand> #topic Initial use cases
18:13:32 <thinrichs> I was going to participate in the Thur networking policy irc meeting.
18:13:47 <banix> sounds good
18:14:08 <pballand> it seems that the networking group is focused on using policy for connectivity and service modeling
18:14:33 <pballand> so, while we expect congress can cover that, it seems we should steer clear for our initial use cases
18:14:48 <banix> I agree
18:14:57 <thinrichs> Yep.
18:15:05 <pballand> also, while congress could satisfy RBAC and ABAC use cases, it seems there is overlap with Keystone
18:15:28 <pballand> I think that still leaves substantial space where we can focus for now
18:16:06 <pballand> the demo use case in the code is out of Neutron: only allow tenants that share a group with the network owner to share networks
18:16:28 <thinrichs> I think the class of use cases we want to focus on are those that bridge OS components.
18:16:43 <pballand> are there other use cases that people would like to propose?
18:16:51 <pballand> thinrichs: I agree
18:17:22 <thinrichs> The demo draws from 3 sources: Nova, Neutron, and a group-management system.
18:18:33 <pballand> #agreed Initial Congress use cases should focus on cross-component policy rules
18:19:08 <pballand> okay, I don't think we're going to get much further without a larger community - does this time work for you banix?
18:19:35 <banix> yes it does
18:20:37 <pballand> can we take as an action item to come up with at least 2 more use cases that illustrate the cross-component focus?
18:21:04 <pballand> thinrichs: it seems you may be well-positioned for this
18:21:08 <thinrichs> Sounds good to me.
18:21:47 <pballand> okay, lets focus on that for next time, and we'll see how this develops
18:22:05 <pballand> does anyone have something else they want to dicuss?
18:22:10 <pballand> #topic open discussion
18:23:05 <thinrichs> There's been some discussion about making Congress a part of Keystone.
18:23:05 <pballand> ok, I'll see both of you in Thrusday's meeting :)
18:23:24 <thinrichs> Okay.  See you then.
18:23:30 <banix> bye :)
18:23:52 <pballand> thinrichs: yes, my thought is to focus on items clearly outside of Keystone, until we have someone from Keystone as part of the discussion
18:24:46 <pballand> I think we should end there for this week, and pick up with the use cases next week
18:24:52 <thinrichs> Sure.
18:24:52 <pballand> thanks for joining
18:25:05 <pballand> #endmeeting