00:00:42 <thinrichs> #startmeeting CongressTeamMeeting
00:00:43 <openstack> Meeting started Thu Sep 10 00:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:46 <openstack> The meeting name has been set to 'congressteammeeting'
00:01:06 <thinrichs> Who is here today?
00:01:16 <masahito_> I'm here
00:01:19 <RuiChen> hi everybody
00:01:27 <pballand> hi
00:01:34 <Yingxin> hi
00:02:05 <alexsyip> Here.
00:02:11 <thinrichs> Hi all!
00:02:29 <thinrichs> #topic Liberty release
00:02:59 <thinrichs> We're still in feature freeze, since we've yet to cut our first release-candidate.
00:03:19 <thinrichs> But I think that just today we have our first candidate.
00:03:29 <thinrichs> Here's the list of bugs we came up with during the first round of testing.
00:03:38 <thinrichs> #link https://bugs.launchpad.net/congress/+bugs/?field.tag=liberty-rc
00:03:55 <thinrichs> You'll see that all but the ceilometer driver bug has been committed.
00:04:36 <thinrichs> Before I forget—RuiChen, you're assigned to the ceilometer bug.  Any progress.
00:04:41 <thinrichs> ?
00:05:14 <RuiChen> yes, https://bugs.launchpad.net/congress/+bug/1492306
00:05:16 <openstack> Launchpad bug 1492306 in congress "Ceilometer datasource errors on poll" [Medium,New] - Assigned to Rui Chen (kiwik-chenrui)
00:05:27 <RuiChen> I think it is duplicate one
00:06:28 <RuiChen> https://bugs.launchpad.net/congress/+bug/1435620
00:06:29 <openstack> Launchpad bug 1435620 in congress "ceilometer_driver bug" [Medium,New]
00:07:41 <thinrichs> RuiChen: agreed.  I just marked the one without the libertyrc tag as a duplicate.
00:08:01 <RuiChen> I will try to fix it today, but if others have some idea for it, i can assige this bug to him
00:08:46 <thinrichs> It's probably just that ceilometer's client/api has changed since we built the driver.
00:09:14 <thinrichs> I don't think any of the people here wrote the original ceilometer driver.
00:09:56 <thinrichs> RuiChen: Go ahead and try to fix it today.
00:10:07 <RuiChen> yeah, I will
00:10:12 <thinrichs> If you don't figure it out, put what you found into the comments of the bug.
00:10:16 <thinrichs> I'll look at it in the morning.
00:10:38 <thinrichs> I think I'll cut the release candidate tomorrow morning whether we fix the ceilometer bug or not.
00:10:57 <thinrichs> I expect we'll end up with more bugs as clients get changed in the last couple weeks of the release cycle.
00:11:09 <thinrichs> Once we cut the RC, we can open master back up.
00:11:22 <thinrichs> And end feature freeze.
00:11:37 <thinrichs> #link https://wiki.openstack.org/wiki/Branch_Model
00:11:39 <thinrichs> For more info.
00:12:12 <thinrichs> One thing we should ALL be doing is manually testing Congress to find bugs.
00:12:24 <thinrichs> That's how we got that initial list of 10 to fix.
00:13:00 <thinrichs> We should also be running tempest tests to do sanity checks on our datasource drivers.
00:13:09 <thinrichs> You'll need to do that manually since we disabled them for the gate.
00:13:30 <thinrichs> (If you recall, they were too flakey to have as gating tests, and we haven't gone back to fixing them.)
00:13:49 <thinrichs> Questions/comments?
00:14:03 <zhenzanz> I guess some tempest cases are skipped in the code?
00:14:49 <zhenzanz> should we bring them back if we want to run locally and manually?
00:15:00 <thinrichs> zhenzanz: yes.  It seemed that on the (slow) machines running gate tests, they failed fairly often.
00:15:26 <thinrichs> zhenzanz: yes—you just need to remove the @skipbecause decorator to reenable them.
00:16:01 <thinrichs> While we're on the topic of tempest, we've started getting failures on tempest tests that aren't relevant to Congress.
00:16:22 <thinrichs> https://review.openstack.org/#/c/221518/
00:16:39 <thinrichs> There the tempest-gate tests failed b/c of a glancev1 test.
00:16:59 <thinrichs> Perhaps it's time we figure out how to build a tempest plugin.
00:17:10 <thinrichs> I would assume we have better control over the tests that get run.
00:17:20 <thinrichs> We had someone volunteer to teach us at the last IRC.
00:17:32 <thinrichs> Would anyone want to sign up for that?
00:18:38 <zhenzanz> I'd like to sign up for it, thanks
00:18:56 <thinrichs> zhenzanz: Great!
00:19:14 <thinrichs> If you check last week's logs you can find the IRC handle of the person who volunteered to help.
00:20:30 <thinrichs> Any other questions/comments?
00:21:15 <thinrichs> #topic Tokyo summit
00:21:39 <thinrichs> alexsyip: want to give us an update on the Hands On Lab?
00:22:01 <alexsyip> I created a virtualbox image with devstack on it.
00:22:19 <alexsyip> It’s setup with bridge networking, and horizon works through the VM’s ip address.
00:22:48 <alexsyip> We can do a similar handson to vancouver.
00:22:53 <alexsyip> We can add something for triggers.
00:23:15 <alexsyip> Does anyone know how to setup the environment inside of devstack for this handson?
00:23:22 <alexsyip> There were a couple VMs and a couple networks.
00:23:40 <thinrichs> We tried to do a brain dump and put it at the end of the lab.
00:24:18 <thinrichs> #link https://docs.google.com/document/d/1lXmMkUhiSZYK45POd5ungPjVR--Fs_wJHeQ6bXWwP44/pub
00:25:34 <alexsyip> Can I create those through horizon ?
00:26:13 <masahito_> alexsyip: I think yes
00:26:23 <alexsyip> ok I’ll try that.
00:26:42 <thinrichs> alexsyip: I don't know why not.
00:26:54 <thinrichs> alexsyip: anything you need from us?
00:27:04 <alexsyip> not right now.
00:28:26 <thinrichs> That was all I had for the summit.  Anyone have anything else?
00:29:49 <thinrichs> #topic Working use cases
00:30:04 <thinrichs> I've been getting emails from someone who is trying to learn about Congress.
00:30:46 <thinrichs> They're asking for 5-6 *working* use cases (e.g. with rules, datasources, and nova/neutron/etc. set up).
00:30:48 <qwebirc50555> I enabled a quota policy across domain level on top of nova
00:31:21 <qwebirc50555> will create a review
00:31:41 <thinrichs> qwebirc50555: are you Himanshu?
00:31:51 <qwebirc50555> this is Su Zhang from Symantec
00:32:02 <qwebirc50555> We talked during the mid cycle meeting
00:32:04 <thinrichs> qwebirc50555: Hi Su.
00:32:12 <thinrichs> I remember you.  Just didn't recognize your handle.
00:32:36 <qwebirc50555> I will learn how to change name here.
00:32:54 <thinrichs> qwebirc50555: perhaps we can use your policy as a use case for Himanshu.
00:33:07 <qwebirc50555> sounds great
00:33:18 <thinrichs> What I'm trying to figure out is if there's a way to have a handful of usecases that are always up and ready for people to try out.
00:33:54 <thinrichs> Could we maybe put together a VM that's all set up and post it somewhere?
00:34:18 <thinrichs> Like we're doing for the HOL perhaps.
00:34:22 <qwebirc50555> sounds good
00:34:30 <qwebirc50555> I already have one for my use case
00:34:37 <thinrichs> Then we wouldn't need to worry about the instructions getting out of sync with the current tip of master.
00:34:57 <thinrichs> People could explore a few use cases without using the bleeding edge congress.
00:35:02 <thinrichs> Thoughts?
00:35:48 <thinrichs> We could even do a video showing the different use cases.
00:36:00 <qwebirc50555> good idea
00:36:45 <thinrichs> Would someone want to volunteer to work on that?
00:38:09 <thinrichs> #action zhenzang will spearhead tempest plugin development
00:38:20 <thinrichs> (Forgot to record that earlier.)
00:38:27 <qwebirc50555> by the way, we are planing to migrate the ceilometer policy into our environment. However, we do not have ceilometer api enabled but stores all of the data into a database.
00:38:51 <thinrichs> How about this?  qwebirc50555: would you want to post your VM somewhere with the working use case?
00:38:53 <shivharis> can this task be achievable by a newbie? I can give it shot
00:39:18 <qwebirc50555> sure. I can do that
00:39:38 <thinrichs> shivharis: If you're familiar with devstack and the other services, it might be doable.
00:40:00 <thinrichs> But maybe it'd be good to do some simpler tasks first.
00:40:10 <shivharis> i am very familar with neutron - wrote my first plugin 3 years ago
00:40:32 <shivharis> so devstack is not an issue
00:40:46 <thinrichs> shivharis: ok, let's give it a try then.
00:41:05 <shivharis> ok, i'll sign up then
00:41:15 <shivharis> will need help off and on
00:41:16 <thinrichs> shivharis: maybe we can start with qwebirc50555's VM or alexsyip's VM, which already have 1 use case ready.
00:41:26 <shivharis> ok
00:41:30 <alexsyip> I have a blank devstack VM
00:41:52 <shivharis> virtualbox based?
00:42:02 <alexsyip> Yeah, I need to figure out how to make an image.
00:42:12 <qwebirc50555> Mine VM is vmware fusion based
00:42:21 <qwebirc50555> but my code is easy to install
00:42:30 <alexsyip> I think virtualbox is probaly better
00:42:32 <alexsyip> It’s free
00:42:32 <qwebirc50555> if you already have a box then i can install it easily
00:42:36 <alexsyip> not everyone has fusion.
00:42:40 <shivharis> dont worry that will is not be a problem - i can do images etc. I would prefer virtualbox since it is free and more folks can use it
00:43:08 <shivharis> i like fusion - but virtualbox is widespread
00:43:16 <qwebirc50555> me too
00:43:19 <qwebirc50555> fusion is more stable
00:43:29 <zhenzanz> maybe you can just export as ovf and then import it into virtualbox
00:43:37 <thinrichs> Just throwing this out there—any utility in doing this with containers instead of vms?
00:43:54 <shivharis> wow.. that is a good idea
00:44:02 <qwebirc50555> I can put my code somewhere with an install doc
00:44:13 <qwebirc50555> cool
00:44:31 <shivharis> i think lets get something done - then think big?
00:44:39 <thinrichs> shivharis: agreed.
00:45:07 <thinrichs> #action shivharis will spearhead the construction of a VM/container to illustrate several use cases
00:45:14 <thinrichs> shivharis: Thanks for stepping up!
00:45:28 <shivharis> np. would love to participate
00:45:53 <zhenzanz> for containerize, we can contribute it into kolla
00:46:16 <qwebirc71560> thanks
00:46:17 <thinrichs> shivharis: hit us up on the mailing list for help getting started
00:46:36 <shivharis> thinrichs: will do
00:46:41 <thinrichs> That's the last of my agenda items.
00:46:46 <thinrichs> #topic open discussion
00:46:54 <thinrichs> Or Status updates
00:49:11 <thinrichs> If no one has anything to discuss, we'll end early.
00:49:40 <thinrichs> shivharis: Your handle looks familiar but I can't place it.
00:49:47 <thinrichs> Have we met in person before?
00:50:03 <shivharis> I am very active in ML2
00:50:08 <shivharis> I am the bug czar there
00:50:15 <shivharis> ML2/neutron
00:51:09 <thinrichs> Got it.
00:51:10 <shivharis> i attended one congress meeting in Vancouver
00:51:17 <shivharis> maybe there..
00:51:33 <shivharis> mostly busy in neutron
00:51:38 <thinrichs> What's brought you over to Congress?
00:52:01 <shivharis> i like the idea - congress is very useful
00:52:44 <thinrichs> Great!  Sometimes people come with specific use cases in mind.  Just wondered if there was something like that for you.
00:53:40 <shivharis> no nothing in particular - but it has great potential
00:54:18 <thinrichs> +1
00:54:29 <thinrichs> Anyone have anything else to discuss?
00:55:24 <thinrichs> I'll send out an email when we lift feature freeze—hopefully tomorrow.
00:55:43 <thinrichs> Even after that my priority will still be finding/fixing bugs in liberty.
00:56:25 <thinrichs> I'll try to give new features a look, if the reviews aren't too time-consuming.
00:56:28 <RuiChen> +1 for great potential :-)
00:56:41 <thinrichs> Let's end a few minutes early tonight.
00:56:45 <thinrichs> Thanks all!
00:56:53 <RuiChen> #action RuiChen fix bug https://bugs.launchpad.net/congress/+bug/1492306
00:56:54 <openstack> Launchpad bug 1492306 in congress "Ceilometer datasource errors on poll" [Medium,New] - Assigned to Rui Chen (kiwik-chenrui)
00:57:01 <shivharis> thanks, bye all
00:57:14 <masahito_> bye
00:57:22 <RuiChen> bye
00:57:29 <thinrichs> #endmeeting