00:01:27 <thinrichs> #startmeeting CongressTeamMeeting
00:01:28 <openstack> Meeting started Thu Oct  1 00:01:27 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:01:32 <openstack> The meeting name has been set to 'congressteammeeting'
00:02:06 <ramineni> hi
00:02:08 <masahito> Hi. I'm back.
00:02:15 <alexsyip> Hi all
00:02:20 <ekcs> hi
00:02:30 <RuiChen> hi, all
00:02:46 <thinrichs> Here's my agenda…
00:03:10 <thinrichs> 1. Liberty update
00:03:18 <thinrichs> 2. Kilo issues
00:03:31 <thinrichs> 3. Monasca requested discussion time in Tokyo
00:03:42 <thinrichs> 4. HOL
00:03:46 <thinrichs> 5. Status updates
00:03:56 <thinrichs> Anything else?
00:04:29 <su_zhang> just some open questions
00:04:45 <thinrichs> su_zhang: I'll make a note.  Let's save those for the end
00:04:47 <masahito> questions about tokyo design summit
00:05:06 <su_zhang> and some suspicious bugs
00:05:18 <su_zhang> sounds good
00:05:29 <thinrichs> masahito: let's do those questions during the HOL portion.
00:05:33 <thinrichs> #topic Liberty
00:05:41 <masahito> thinrichs: got it.
00:05:46 <thinrichs> Here is the most recent bug list.
00:05:56 <thinrichs> #link https://bugs.launchpad.net/congress/+bugs/?field.tag=liberty-rc2
00:06:29 <thinrichs> There's 1 in progress but zhenzan has the code in review.
00:06:42 <thinrichs> #link https://review.openstack.org/#/c/228706/
00:07:08 <thinrichs> There are a few comments to address it seems.
00:07:16 <thinrichs> I did try it out, and it fixed the problem for me.
00:07:32 <thinrichs> I did another round of manual testing this week, and nothing jumped out at me.
00:07:49 <thinrichs> So once that last patch lands, I'll probably cut release candidate 2.
00:08:13 <thinrichs> BTW, there's a new bug in that list.
00:08:18 <thinrichs> #link https://bugs.launchpad.net/congress/+bug/1501097
00:08:18 <openstack> Launchpad bug 1501097 in congress "Data source drivers allow execution of client methods not declared executable" [Undecided,New] - Assigned to Madhu Mohan Nelemane (mmohan-9)
00:08:26 <thinrichs> Madhu: are you here?
00:09:12 <thinrichs> Doesn't look like it.  But it seems that zhenzan's changes should address that one.
00:09:22 <ekcs> I filed the bug, btw, so I can also answer any questions about it.
00:09:38 <thinrichs> ekcs: do you think that's a release blocker?
00:10:09 <thinrichs> and/or does zhenzan's change address it?
00:10:15 <ekcs> um i don’t know. depends on the target standard of liberty release
00:10:28 <ekcs> it doesn’t stop anything from working.
00:10:44 <shelleea007> hello all
00:10:55 <thinrichs> shelleea007: hi.
00:11:07 <thinrichs> shelleea007: we're in the midst of discussing the liberty release.
00:11:33 <shelleea007> ok, I'm interested in learning more about Congress' implementation
00:11:33 <thinrichs> ekcs: does zhenzan's change address that bug, since it doesn't include any method starting with an underscore?
00:12:11 <thinrichs> shelleea007: Great!  We usually have new people introduce themselves and explain why they're interested in congress at the end of the meeting.
00:12:16 <ekcs> no, it doesn’t address the bug. the bug is that no matter what the actions list is (even empty), all methods are allowed via api.
00:12:45 <ekcs> in fact that’s why tests had been passing even before the empty action list bug was patched
00:13:28 <shelleea007> ok, I've lurked in the last meeting, and I was tardy to this both times. So, I figured I would say something this time. i will go back to lurking for the time being
00:13:32 <thinrichs> Got it.  That definitely sounds like we could let it go for liberty.
00:13:45 <ekcs> ok.
00:14:28 <thinrichs> shelleea007: feel free to pipe up as part of the normal flow of the meeting
00:14:39 <thinrichs> Any other questions/comments about liberty?
00:15:08 <thinrichs> #topic Kilo
00:15:13 <thinrichs> On to Kilo then.
00:15:37 <thinrichs> We've got patches into the stable/kilo branch where unit tests are passing
00:15:49 <thinrichs> I wanted to test out the tempest tests just as a sanity check.
00:16:19 <thinrichs> So I tried to run devstack and use the stable/kilo branches of all the projects.
00:16:37 <thinrichs> I got some fatal errors when it tried to install congress.
00:16:55 <thinrichs> I haven't gone back to dig into them, but the question we need to answer is whether it's worth doing.
00:17:15 <thinrichs> It would be nice if our kilo release worked well with the kilo devstack.
00:17:16 <su_zhan__> depends on what are the errors, right?
00:17:59 <thinrichs> Fair enough.
00:19:15 <thinrichs> I just tried rerunning stack.sh and my VM ran out of disk.
00:19:26 <su_zhan__> got u
00:19:29 <thinrichs> So maybe I'll try to resurrect the problem and post to the ML.
00:19:35 <su_zhan__> then we can just use unittest I suppose
00:19:35 <thinrichs> Or someone else could try the same thing.
00:20:09 <su_zhan__> when we use "openstack congress datasource table schema show" I will have to use datasource id
00:20:12 <thinrichs> su_zhan__: the point is that kilo congress doesn't run with kilo devstack properly
00:20:17 <su_zhan__> data source name won't work
00:20:53 <thinrichs> If someone else wants to try it out, you just switch to the stable/kilo branch of devstack before running stack.sh
00:21:08 <thinrichs> Anyone want to volunteer?
00:21:12 <su_zhan__> I can give it a try
00:21:20 <thinrichs> su_zhan_: great!
00:21:48 <thinrichs> Next up is Monasca and the Tokyo summit.
00:21:52 <thinrichs> #topic Tokyo
00:22:03 <thinrichs> Monasca requested a meeting to talk about integrating with Congress.
00:22:06 <thinrichs> #link https://wiki.openstack.org/wiki/Monasca
00:22:12 <su_zhan__> by the way, where is the congress tempest script located
00:22:13 <su_zhan__> ?
00:22:24 <thinrichs> su_zhan__: let's take that offline
00:22:29 <su_zhan__> okay
00:22:51 <thinrichs> I thought we should think about what we're using our 3 meeting times for in Tokyo.
00:22:52 <su_zhan__> Can I attend remotely?
00:23:18 <thinrichs> If we have a free one, we could use it to talk to Monasca; otherwise, we can meet with them outside our allocated meeting times.
00:23:18 <su_zhan__> There should be an option of attending the discussion remotely
00:23:40 <thinrichs> su_zhan__: I don't know what kind of remote attendance is available.
00:23:45 <thinrichs> Anyone know?
00:23:56 <su_zhan__> I will be a remote attendance
00:24:06 <su_zhan__> I won't go to tokyo
00:24:33 <thinrichs> su_zhan__: Let's both of us look into remotes for the design conference.
00:24:49 <thinrichs> Do people have suggestions for topics to discuss in our 3 slots in Tokyo?
00:24:52 <su_zhan__> okay
00:25:19 <masahito> I have topics.
00:25:44 <su_zhan__> how about our quota policy implementation?
00:25:57 <thinrichs> masahito: what did you have in mind?
00:26:33 <thinrichs> su_zhan__: might we generalize that a bit to…gating other openstack projects using Congress?
00:26:46 <su_zhan__> makes sense
00:26:53 <masahito> thinrichs: I contacted OPNFV folks who think to use Congress in their infra.
00:27:39 <thinrichs> masahito: are you thinking of a cross-project meeting where they attend and talk about their use cases?
00:28:00 <RuiChen> thinrichs, I member you have a topic about
00:28:36 <masahito> They need some new features in Congress to satisfy their use case, so they want to explain their feature if possible.
00:28:43 <RuiChen> keystone and congres policy integrated, you will show it in design summit ?
00:29:05 <thinrichs> RuiChen: I never made enough progress on that to show.
00:29:17 <masahito> thinrichs: OPNFV is not one of OpenStack project. It isn't need to be cross project.
00:29:32 <thinrichs> RuiChen: Did some design but no implementation.
00:30:44 <thinrichs> I was also thinking we might want a session on the distributed architecture
00:31:09 <thinrichs> I don't know how long each of our meetings are.  Last summit they were 45 minutes.
00:31:10 <ramineni> +1
00:31:40 <ramineni> thinrichs: is there any spec proposed for distributed architecture, to go through?
00:32:01 <thinrichs> So we've got OPNFV, congress gating, Monasca, distributed arch
00:32:02 <su_zhan__> did we do any integration between congress and mistral?
00:32:27 <thinrichs> ramineni: Let me find the spec.  Our mid-cycle meetup a couple months back was devoted to the new arch.
00:32:35 <su_zhan__> I saw mistral is mentioned in the wiki page. It seems like mistral is highly relevant to policy enforcement.
00:33:04 <thinrichs> ramineni: all the blueprints starting with dist- are for the new arch
00:33:06 <thinrichs> #link https://blueprints.launchpad.net/congress
00:33:39 <thinrichs> su_zhan__: no work on mistral that I know of, though the HP integration with Murano was moving in that direction
00:34:17 <su_zhan__> are you talking about this one? https://wiki.openstack.org/wiki/PolicyGuidedFulfillment#Proposed_Approach
00:34:27 <thinrichs> Other than these 4, are there other topics for our meeting?
00:34:30 <thinrichs> OPNFV, congress gating, Monasca, distributed arch
00:34:38 <thinrichs> su_zhan__: yes
00:34:46 <su_zhan__> I am also very interested in mistral integration. Do you know who is in charge of this project at HP?
00:35:21 <thinrichs> su_zhan__: I think that project was deprioritized at HP.  Ping me offline and I'll dig out the right people to ask
00:35:31 <su_zhan__> okay
00:37:04 <thinrichs> So do we think we can fit those 4 topics into 3 meetings, or should we schedule external time with Monasca?
00:37:31 <thinrichs> masahito: do you know how long the OPNFV discussion will take?
00:37:41 <thinrichs> It might make sense to split that meeting between OPNFV and Monasca
00:38:45 <thinrichs> Since it's getting late, I'll follow up with masahito offline.
00:38:47 <masahito> I'm not sure exactly, but I think it can be split.
00:38:55 <thinrichs> masahito: okay
00:39:14 <thinrichs> I'll tell the Monasca team that we'll talk with them for half of one of our meeting times.
00:39:31 <thinrichs> #action thinrichs will schedule meeting with Monasca
00:39:37 <thinrichs> Next topic is the HOL.
00:39:39 <thinrichs> #topic HOL
00:39:53 <thinrichs> alexsyip: how's the HOL coming?
00:40:02 <alexsyip> I have a new version ready to go.
00:40:30 <alexsyip> https://goo.gl/W0Rhcv
00:40:34 <alexsyip> Pleae give it a try.
00:40:43 <alexsyip> This version uses a GUI console.
00:40:50 <alexsyip> So you don’t have to use the network at all.
00:41:06 <thinrichs> Did anyone else run into the problems I did?
00:41:12 <thinrichs> Was it something weird with my virtualbox setup?
00:41:35 <ramineni> thinrichs: alexsyip: iva file i downloaded last time , while importing im getting following error While starting virtual box VM
00:41:35 <ramineni> VT-x is disabled in the BIOS for all CPU modes. (VERR_VMX_MSR_ALL_VMXON_DISABLED)
00:41:51 <ramineni> any idea how to resolve it?
00:42:24 <alexsyip> ramineni: you get this from virtual box before importing my the congress-hol.ova file?
00:42:36 <alexsyip> Oh, while importing.
00:42:45 <ramineni> alexsyip: no, import is succesful, while starting the vm
00:42:47 <alexsyip> I never saw that error.
00:43:05 <alexsyip> It fails to start ?
00:43:14 <ramineni> alexsyip: its in power off state in virtual box now
00:43:17 <ramineni> yes
00:43:19 <ramineni> :(
00:43:35 <alexsyip> Let me try something.
00:43:55 <alexsyip> I see a checkbox for VT-x.  I can try to uncheck it and see what happens.
00:44:22 <thinrichs> What scares me a bit is that these problems aren't consistent across VirtualBoxes.
00:44:23 <alexsyip> Can you uncheck it and try to start it ?
00:44:44 <alexsyip> thinrichs: what error did you encounter ?
00:44:46 <ramineni> alexsyip: where is the checkbox?
00:44:51 <thinrichs> Is there a preferences file for VirtualBox that we can include?
00:44:55 <alexsyip> Settings/ CPU/ acceleration
00:44:57 <thinrichs> alexsyip: let me find the email
00:45:10 <ramineni> alexsyip: thanks, will try it out
00:45:11 <alexsyip> settings/ system/ acceleration
00:46:06 <thinrichs> alexsyip:
00:46:08 <thinrichs> #link http://lists.openstack.org/pipermail/openstack-dev/2015-September/075650.html
00:46:25 <alexsyip> thinrichs: those are network problems.
00:46:34 <thinrichs> And those should disappear now?
00:46:36 <alexsyip> The new image is setup to not use the network at all.
00:46:41 <thinrichs> Sounds good.
00:46:45 <alexsyip> Yeah, that was the goal of the new vm.
00:46:57 <thinrichs> Let's all try out the HOL.  We want to find all the hiccups before giving it to 50 people.
00:46:59 <ramineni> alexsyip: acceleration tab is greyed out, couldnt access it
00:47:10 <alexsyip> hm.
00:47:15 <alexsyip> maybe it’s related to the hardware you’re using.
00:47:16 <thinrichs> masahito: did you have any other questions about the summit?
00:47:16 <ramineni> alexsyip: may be something is not supported by my machine
00:47:32 <alexsyip> I’ll prepare another VM with out that check and see if that makes it work.
00:47:43 <ramineni> alexsyip: sure, thanks
00:48:15 <masahito> thinrichs: nothing.
00:48:39 <thinrichs> Ok.
00:48:50 <masahito> If someone wants to some info about Tokyo, please contact me.
00:49:22 <thinrichs> masahito: thanks for the offer!  I'm sure people will at least take you up on restaurant recommendations once we're there.
00:49:46 <masahito> thinrichs: sounds good!!
00:49:54 <thinrichs> Last thing on my agenda before open discussion.
00:50:00 <thinrichs> We have a couple of new people.
00:50:23 <thinrichs> ramineni: would you like to tell us who you are and why you're interested in Congress?
00:50:36 <ramineni> thinrichs: sure
00:50:52 <ramineni> thinrichs: Iḿ Anusha , I work for NEC
00:50:57 <su_zhang> welcome
00:51:34 <su_zhang> ramineni: is your office located at bay area?
00:51:42 <thinrichs> ramineni: Welcome!  Anything in particular you're hoping to do with Congress?
00:51:50 <ramineni> thinrichs: iḿ new to congress but not to openstack though :) , congress is very useful for cloud env, so want to explore the same
00:52:17 <su_zhang> ramineni: what's your previous experience on top of openstack?
00:52:19 <masahito> ramineni: welcome in Congress team.
00:52:31 <RuiChen> ramineni, Welcome
00:52:35 <ramineni> thinrichs: no, for now just want to want to understand more , how easy to use in production env
00:52:56 <ramineni> su_zhang: no, im from India
00:53:09 <thinrichs> We have 1 other new person.
00:53:11 <su_zhang> oh, good morning then
00:53:21 <ramineni> thinrichs: su_zhang, masahito, RuiChen: thanks :)
00:53:27 <thinrichs> shelleea007: want to introduce yourself and say why you're interested in congress?
00:53:38 <shelleea007> sure, I can do that.
00:54:11 <su_zhang> ramineni: just realized we've linked already
00:54:16 <shelleea007> My name is Shellee and I work for HP, for cloud security. I am also part of the OSSG
00:54:49 <su_zhang> welcome. shelleea007
00:54:51 <shelleea007> I'm interested in Congress for compliance and auditing capabilities and implementation.
00:55:09 <shelleea007> thanks.
00:55:16 <thinrichs> shelleea007: Welcome! That's a great use case.
00:55:18 <su_zhang> shelleea007: that's exactly what I want to do at Symantec
00:55:37 <thinrichs> We'd love to have more ideas about how and where Congress can be useful along those lines.
00:55:49 <shelleea007> It was mentioned at the OSSG meetup a few weeks ago and I took an action item to look into it and hopefully contribute
00:56:20 <shelleea007> There seem to be multiple use cases for it in this realm.
00:56:30 <thinrichs> One that that would be really helpful is if you have some policies that operators want to enforce or at least monitor.
00:56:40 <thinrichs> Then we could see how to use Congress in those cases.
00:56:44 <mshindo_> all: let me intro myself, too.
00:56:45 <shelleea007> exactly.
00:56:55 <thinrichs> We have a google doc full of use cases that you could contribute to.
00:56:57 <RuiChen> shelleea007, we have same focus on auditing capabilities :-)
00:56:57 <thinrichs> Linked off the wiki
00:57:05 <mshindo_> I'm Motonori Shindo, works for VMware, based in Japan
00:57:19 <thinrichs> mshindo_: welcome!
00:57:24 <mshindo_> interested in policy language in Congress
00:57:34 <masahito> mshindo_: welcome!
00:57:35 <thinrichs> mshindo_: do you have something specific to use Congress for?
00:57:39 <shelleea007> thinrichs: awesome. Do you have a link to that google doc handy?
00:57:44 <mshindo_> 'cause I used to love Prolog a lot :-)
00:57:57 <shelleea007> lol
00:58:06 <thinrichs> shelleea007: here's the gdoc
00:58:07 <thinrichs> #link https://docs.google.com/document/d/1ExDmT06vDZjzOPePYBqojMRfXodvsk0R8nRkX-zrkSw/edit
00:58:15 <shelleea007> thank you!
00:58:25 <thinrichs> mshindo_: then you'll feel right at home here!
00:58:27 <mshindo_> 3 mins left, looking forward to seeing you guys all at Tokyo
00:58:44 <masahito> shelleea007: this wiki has any info and links.
00:58:49 <masahito> #linke https://wiki.openstack.org/wiki/Congress
00:58:51 <mshindo_> still exploring where I can contribute
00:58:53 <su_zhang> btw, I just implemented the "security group management" policies and will add it into the doc.
00:59:16 <thinrichs> Any other new people here that want to intro in 1 minute?
00:59:26 <shelleea007> masahito: Thank you! Any and all information is helpful.
00:59:34 <thinrichs> We're about out of time.
00:59:55 <thinrichs> Again let's finish off that last bug and test, test, test the liberty release.
01:00:27 <thinrichs> shelleea007, mshindo_, ramineni: don't hestitate to reach out with questions, comments, etc.
01:00:36 <thinrichs> Either on the mailing list or on #congress.
01:00:40 <thinrichs> Thanks all!
01:00:50 <masahito> bye
01:00:58 <RuiChen> good start point for new contributors http://congress.readthedocs.org/en/latest/readme.html
01:01:04 <RuiChen> bye
01:01:08 <thinrichs> #endmeeting