00:02:17 <thinrichs> #startmeeting CongressTeamMeeting
00:02:18 <openstack> Meeting started Thu Nov 26 00:02:17 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:02:21 <openstack> The meeting name has been set to 'congressteammeeting'
00:02:21 <thinrichs> ekcs: hi
00:02:25 <thinrichs> Who else is here for Congress?
00:02:31 <ramineni> hi
00:03:47 <thinrichs> It's possible there are some US people missing b/c tomorrow is a holiday.
00:03:58 <alexsyip> Hi
00:04:15 <thinrichs> Here's my agenda for today…
00:04:18 <thinrichs> 1. gate issues
00:04:24 <thinrichs> 2. distributed arch status
00:04:27 <thinrichs> 3. python3 status
00:04:32 <thinrichs> 4. midcycle meetup
00:04:42 <thinrichs> 5. installer issues
00:05:03 <thinrichs> Anything else?
00:05:55 <thinrichs> Let's get started.
00:05:58 <thinrichs> #topic gate issues
00:06:10 <thinrichs> ramineni: thanks for fixing the gate breakages!
00:06:15 <thinrichs> ramineni: are they all fixed at this point?
00:06:33 <ramineni> thinrichs: yes :)
00:06:44 <ramineni> thinrichs: but we have to fix in syable branches
00:07:00 <ramineni> thinrichs: because of the plugin model, we are breaking stable branches
00:07:28 <ramineni> thinrichs: i think we have to use plugin model only if its master in project-config
00:07:32 <thinrichs> ramineni: right.  I guess we need different devstack jobs for the older branches
00:07:49 <ramineni> thinrichs: yes,
00:08:10 <masahito> Hi! sorry, i'm late.
00:08:17 <thinrichs> ramineni: are you comfortable doing that?  You've been doing great modifying project-config so far!
00:08:20 <ramineni> thinrichs: other projects used if ZUUL_BRANCH , option , Ill check that , to include in asme job
00:08:32 <thinrichs> masahito: hi!  We're talking about the gate breakages that ramineni has been fixing.
00:08:51 <ramineni> thinrichs: yes, I will check
00:09:12 <masahito> thinrichs: got it. thanks.
00:09:21 <thinrichs> ramineni: I'd lean toward having a couple of separately specified and simple jobs, rather than one large, complex job
00:09:51 <thinrichs> For example, I'd probably pull the old devstack job out of git, rename it as a new job, and use that job for the older branches
00:09:52 <ramineni> thinrichs: so we will have seperate job for kilo and liberty?
00:10:07 <thinrichs> ramineni: that's probably the simplest to maintain going forward.
00:10:27 <ramineni> thinrichs: ya , that should work , we will disable tempest on them anyway right
00:10:39 <thinrichs> What I don't understand though is whether that will work given that they're disabling the old way of doing things at Mitaka1
00:11:35 <ramineni> thinrichs: yes, iḿ wondering too, they use devstack master branch everytime
00:11:36 <thinrichs> If devstack gate suddenly stops supporting the mechanism where we copy files from congress into devstack, having a job that does that for kilo/liberty won't work
00:12:14 <ramineni> thinrichs: yes, ill check that , may be infra team should be able to help right
00:12:18 <ramineni> ?
00:12:22 <thinrichs> Do they expect us to backport the devstack plugin mechanism to all the old branches?
00:12:38 <thinrichs> ramineni: great!  The infra team will definitely know the answer.
00:12:52 <thinrichs> ramineni: let me know if you need help
00:13:02 <ramineni> thinrichs: if devstack also uses stable branches , it shouldnt be problem
00:13:15 <ramineni> thinrichs: sure, will check
00:13:54 <thinrichs> That's true.  They supposedly check out the proper branches for devstack and the other systems.  So it might just work.
00:14:32 <thinrichs> As for the gate breakages, I tried to go through and recheck them all earlier today.
00:14:40 <thinrichs> So hopefully the -1s from Jenkins are real again.
00:14:43 <thinrichs> Anything else for the gate breakages?
00:15:09 <thinrichs> Next up: distributed architecture
00:15:10 <ramineni> thinrichs: till yesteday , it wa ok . i havent checked after that
00:15:25 <ekcs> I see some -1’s turning to 1 after recheck.
00:16:08 <thinrichs> Almost forgot...
00:16:09 <thinrichs> #action ramineni will work on devstack gating for kilo/liberty branches
00:16:18 <thinrichs> #topic distributed arch
00:16:32 <thinrichs> pballand, masahito: how is the DseNode work progressing?
00:17:49 <masahito> Isn't pballand in here?
00:18:03 <ekcs> masahito: doesn’t seem like it.
00:19:17 <masahito> Ok. We figured out the cause of the problem pballand hit last meeting.
00:20:11 <thinrichs> I see 2 reviews on DseNode, but both are marked as WIP:
00:20:15 <thinrichs> #link https://review.openstack.org/#/c/247232/
00:20:23 <masahito> It looks like oslo.message's bug or a constraint for the fake driver.
00:20:26 <thinrichs> #link https://review.openstack.org/#/c/247231/
00:20:44 <thinrichs> masahito: what do you mean by "constraint"
00:20:46 <thinrichs> ?
00:22:23 <masahito> constraint means that oslo.message usually support multi message-topic but the fake driver which is designed for testing doesn't support multi message topic.
00:23:58 <masahito> I'm not sure whether this is on purpose by oslo team or not. so I used "constraint".
00:24:07 <thinrichs> masahito: understood.  So if we're relying on a feature that the fake driver doesn't have, it sounds like we should either (i) add that feature to the fake driver or (ii) not use the fake driver to unit test.
00:24:28 <masahito> thinrichs: right.
00:25:15 <ekcs> masahito: how can we find out whether it’s a bug or a limit by design?
00:25:45 <thinrichs> I'll talk with pballand offline to figure out what he's planning here.
00:25:58 <masahito> pballand tries to use name space instead of topic in the message now.
00:26:25 <ekcs> thinrichs: got it.
00:27:00 <masahito> ekcs: We can ask it oslo teams and read codes in github too :)
00:27:06 <thinrichs> masahito: are you saying there is a simple fix here?
00:28:50 <masahito> thinrichs: I'm not sure the details of the bug itself, but oslo has 2 layer about the message.
00:29:52 <thinrichs> #action thinrichs will talk with pballand offline
00:30:22 <masahito> thinrichs: topic and namespace. pballand used topic to divide control bus but the driver doesn't work well. now trying another one.
00:30:52 <thinrichs> masahito: sounds like the right approach to me
00:31:29 <thinrichs> Let's move on, esp. since pballand isn't here.
00:31:44 <thinrichs> #topic python3 status
00:31:48 <thinrichs> ekcs: how are we doing?
00:31:53 <ekcs> The datalog bits are ready for review: #link https://review.openstack.org/#/c/248946/
00:32:34 <ekcs> I’m now working on the other bits. Most remaining errors are in datasources and api. But I think it’ll be relatively smooth saling after datalog, which was the hardest part.
00:34:36 <thinrichs> ekcs: Great!  I'll try to review that after the meeting.
00:35:50 <thinrichs> BTW I should mention that I'm on vacation tomorrow through next Tuesday.  I'll be trying to make it a proper vacation and only do urgent work.  So I probably won't review or merge code until Wed next week.
00:36:14 <ekcs> thinrichs: got it.
00:36:26 <ekcs> anyway that’s all I have on py3 for now.
00:36:38 <ekcs> reviews appreciated.
00:36:50 <thinrichs> ekcs: thanks!  It'll be good to get us moved over finally.
00:37:03 <thinrichs> #topic mid-cycle meetup
00:37:18 <thinrichs> Has anyone thought about the topics we might cover during the mid-cycle meetup?
00:39:19 <ekcs> thinrichs: I thought the topics suggessed last time sound good.
00:39:48 <thinrichs> Last time we thought about discussing (i) distributed arch, (ii) how to apply the distributed arch for HA, (iii) integration with monasca
00:40:38 <ekcs> right, and potentially generalizing iii.
00:40:51 <thinrichs> ekcs: right.
00:41:18 <thinrichs> So that'll be the topic unless someone suggests something else in the time between now and the summit.
00:41:33 <thinrichs> #topic installation issues
00:42:19 <thinrichs> bryan_att and I spent a good amount of time trying to get the ansible installer working for Congress for an existing OpenStack installation
00:43:13 <thinrichs> I haven't heard if he was successful
00:43:18 <bryan_att> hi thinrichs, just saw that
00:43:30 <thinrichs> bryan_att: did you ever get that working?
00:43:35 <bryan_att> meant to join the call but working on the ansible installer still
00:43:42 <bryan_att> i got it to work thru at least once
00:43:56 <bryan_att> but a number of issues with python packages, e.g. oslo
00:44:00 <thinrichs> It was clear that we should spend some time making the installer rock-solid for people.
00:44:28 <bryan_att> that would be great
00:44:41 <bryan_att> i plan to develop puppet and fuel plugins to install it
00:44:50 <dims> bryan_att : folks over at #openstack-oslo can help with any oslo issues
00:44:56 <thinrichs> bryan_att: when you get something working if you could contribute it to the repo, that'd be great!
00:45:12 <bryan_att> sure will, also my test driver webapp
00:45:29 <bryan_att> allows you to explore the api interactively
00:45:32 <thinrichs> bryan_att: fuel/puppet plugins would ge great too!
00:46:20 <bryan_att> ok, figured most folks were on holiday, but I'll send a message if I get really stuck
00:47:13 <bryan_att> what's the latest stable version based upon, liberty or kilo?
00:47:41 <thinrichs> bryan_att: We're definitely going on holiday.
00:47:50 <bryan_att> OPNFV is getting near to having liberty included in their B release, so I will be moving to that asap. it will i hope address the python lib issues
00:48:25 <thinrichs> bryan_att: that sounds good.  Kilo is tough to support at this point.  It was our first actual release.
00:48:34 <bryan_att> good, thanks
00:50:13 <thinrichs> That does it for my agenda today.
00:50:17 <thinrichs> #topic open discussion
00:50:21 <thinrichs> Anyone have anything else?
00:50:35 <bryan_att> one item - about datalog features
00:50:49 <bryan_att> any plans to support pattern matching for string values?
00:51:17 <thinrichs> bryan_att: you mean regexp matching?
00:51:25 <bryan_att> e.g. to create a rule that is specific to a VM/image or class of them, using a name rather than the IDs
00:51:50 <bryan_att> not necessarily regexp, but starting easy with string match or substring
00:52:01 <bryan_att> with some simple wildcards
00:52:22 <bryan_att> but if regexp comes easy, why not
00:52:25 <thinrichs> bryan_att: exact string matching is already there.  no wildcards.  string manipulation is there too.
00:52:51 <thinrichs> Just string-concatenation and string-length support today
00:53:12 <bryan_att> so if I as able to assign IDs that had some semantic value, I could do a substring match?
00:53:17 <thinrichs> I don't think regexps would be too tough, at least checking whether a string matches a regexp
00:53:42 <bryan_att> I'll write up what I am thinking of and send to the list
00:54:27 <thinrichs> You could construct new strings from existing strings (either in the data or hard-coded in the policy) and check if the new string is equal to say the name of a server.
00:54:51 <thinrichs> But you can't check if a string contains within it some substring.
00:54:56 <thinrichs> Sending to the ML is a great idea.
00:55:01 <bryan_att> will do
00:56:11 <thinrichs> Anything else for today?
00:56:44 <thinrichs> Let's call it then.
00:57:26 <thinrichs> Happy Thanksgiving and safe travels for those of you on the road this weekend!
00:57:38 <thinrichs> #endmeeting