00:02:10 <thinrichs> #startmeeting CongressTeamMeeting
00:02:10 <openstack> Meeting started Thu Apr  7 00:02:10 2016 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:02:13 <openstack> The meeting name has been set to 'congressteammeeting'
00:02:24 <thinrichs> bryan_att: I saw your email but didn't have time to dig into it.
00:02:53 <bryan_att> OK, just want to put it on the agenda for some followup
00:02:54 <thinrichs> masahito: hi
00:03:04 <thinrichs> bryan_att: we'll do it first
00:03:13 <thinrichs> in case you need to run off
00:03:24 <ramineni_> hi
00:03:25 <bryan_att> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/091591.html
00:03:43 <thinrichs> ramineni_: hi
00:03:48 <thinrichs> bryan_att: thanks for the link.
00:04:04 <thinrichs> Here's my agenda for today….
00:04:08 <thinrichs> 1. bryan_att's email
00:04:12 <thinrichs> 2. Mitaka release
00:04:20 <thinrichs> 3. stable/liberty and stable/kilo
00:04:26 <thinrichs> 4. Austin summit
00:04:33 <thinrichs> Anything else?
00:05:44 <ekcs> hi sorry I'm late. had trouble connecting.
00:05:48 <thinrichs> ekcs: I was dragging my feet hoping you'd join
00:06:09 <thinrichs> #topic bryan_att's email
00:06:19 <thinrichs> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/091591.html
00:06:32 <bryan_att> OK, I don't know who has ready this yet. But I can summarize.
00:06:37 <thinrichs> bryan_att: Great
00:06:44 <bryan_att> The Policy tab for the OpenStack Dashboard depends upon plugin files being copied to the Horizon install folders.
00:07:03 <bryan_att> For my LXC-based install, that wont work.
00:07:12 <bryan_att> I am trying to work around that for now by installing Congress directly into the Horizon container (this is the way JOID installs Horizon).
00:07:19 <bryan_att> I am stuck on the process is for copying the Congress plugins and activating them.
00:07:39 <bryan_att> The DevStack guide is not working for me. Is there some other source of the process doc?
00:08:03 <bryan_att> btw this is a real deployment, not devstack.
00:08:20 <thinrichs> bryan_att: First off, it's great to hear about these issues first hand.  So thanks.
00:09:05 <thinrichs> bryan_att: I don't know the details of the Horizon integration.
00:09:14 <thinrichs> The person responsible hasn't been around for a while.
00:09:23 <bryan_att> OK, I just need to know who to reach out to. And how anyone has gotten this working outside devstack.
00:09:27 <thinrichs> I can try to track that person down.
00:09:38 <bryan_att> Does anyone use the horizon integration?
00:09:45 <bryan_att> (in production or testing)
00:10:13 <bryan_att> I have a reliable install that doesn't include the horizon part, and I was just trying to get it working.
00:10:27 <thinrichs> I don't have contacts for that.
00:10:46 <bryan_att> if it's not an important part of the project goals, I will skip it for now and come back later.
00:10:49 <ekcs> I have used congress outside devstack, but I haven't tried horizon. maybe I should.
00:11:01 <thinrichs> bryan_att: I'll send an email to the original developer of the Horizon plugin and include you.
00:11:22 <masahito> for the issue #2, python-congressclient must be installed in the Horizon container.
00:11:32 <bryan_att> thanks, I would like to figure it out, and even suggest corrections to the install/docs for this.
00:11:38 <thinrichs> Clearly we should also take a look at whether our Horizon plugin works the way it should.
00:11:41 <bryan_att> OK, thanks that was not clear.
00:12:06 <thinrichs> Is that common for a Horizon plugin to require the python-client?
00:12:06 <bryan_att> I'm wondering why a CLI client needs to be installed there, but that is a design choice to understand better.
00:12:28 <masahito> Horizon uses pythonclient to call OpenStack APi
00:13:05 <thinrichs> masahito: so Nova's pythonclient is required for its horizon plugin too?
00:13:12 <masahito> yes.
00:13:17 <bryan_att> OK, that part makes sense. Rather than implement that again thru python in the horizon plugins.
00:13:43 <masahito> I think Nova and other main Service's client is listed in Horizon's requirements.txt
00:13:54 <thinrichs> masahito: yep—just checked.
00:14:24 <thinrichs> Could someone look into whether our Horizon plugin is up to date with what Horizon recommends today?
00:14:40 <thinrichs> (We recently upgraded our devstack and tempest plugins.  Perhaps it's time for Horizon too.)
00:14:43 <ramineni_> thinrichs: i have it working last time
00:14:51 <ramineni_> thinrichs: through plugin
00:14:59 <ramineni_> thinrichs: i can check again
00:16:00 <thinrichs> ramineni_: great!
00:16:09 <thinrichs> ramineni_: Can you also think through bryan_att's case, where he's installing Horizon in a separate container?
00:16:22 <thinrichs> ramineni_: Maybe figure out what the procedure is in that case (at least hypothetically)?
00:16:38 <thinrichs> ramineni_: and then respond to bryan_att's email?
00:16:44 <ramineni_> thinrichs: ok,
00:17:04 <bryan_att> yes, how to do cross-container copying of the files and executing the django comands is unclear to me.
00:17:18 <bryan_att> but one step at a time
00:17:32 <ramineni_> bryan_att: may be you could try installing the client for the start as masahito suggested?
00:17:58 <bryan_att> I am doing that, and will let you know. I think it did not help.
00:18:13 <ramineni_> bryan_att: oohok
00:18:20 <bryan_att> goed for now. I will watch for an update from the author and in the meantime work on my non-horizon install. I'm also working to demo Congress at the OPNFV summit, illustrating various use cases for policy. And demoing how to add an OpenStack service to OPNFV in the process.
00:18:38 <bryan_att> I'll post a video of the demos.
00:19:16 <thinrichs> bryan_att: cool!  Let us know if you need any help
00:19:31 <bryan_att> will do
00:20:09 <thinrichs> Next topic…
00:20:12 <thinrichs> #topic Mitaka release
00:20:30 <thinrichs> Seems we're all set for Mitaka.
00:20:46 <thinrichs> I ran through some basic sanity checks for our latest release candidate, and all looked well.
00:21:02 <thinrichs> There were some emails about the release process that went out late last week.
00:21:37 <thinrichs> We didn't have the right job set up, so we weren't generating tarballs and having them uploaded to the right place.
00:21:52 <thinrichs> But that's been fixed, so everything looks good, as far as I know.
00:22:10 <thinrichs> Any questions/comments?
00:22:13 <ekcs> That's great!
00:23:02 <thinrichs> It's the first release we've done that's been managed by the release-team.
00:23:58 <thinrichs> I tried to make it official by adding a tag to the Congress project, but I'm told they're making some changes to the semantics of that tag at Austin.
00:25:08 <thinrichs> If nothing further, we can move onto the next topic.
00:25:46 <thinrichs> #topic stable branches
00:26:18 <thinrichs> ramineni_: are we ready for a stable release for either liberty or kilo?  There were some outstanding changes we were waiting on
00:26:42 <ramineni_> thinrichs: ya , liberty we can do
00:27:02 <ramineni_> thinrichs: kilo is supported?
00:27:59 <thinrichs> ramineni_: kilo is still supported.  I don't remember how long we're supposed to support each release.
00:28:21 <ramineni_> thinrichs: i thought 2 releases , so it should be mitaka and liberty
00:28:38 <ramineni_> thinrichs: but anyway , we didnt have any changes for kilo i guess
00:29:57 <thinrichs> ramineni_: kilo had the weird 2015.1.0 based releases.
00:30:08 <thinrichs> So at this point, I guess it makes sense to just worry about the last 2.
00:30:20 <thinrichs> I think maybe it's longer for security-related bugs.
00:30:30 <ramineni_> thinrichs: oohok
00:30:41 <thinrichs> So we should just do a stable/liberty release then.
00:30:55 <thinrichs> #action thinrichs will do a stable/liberty release
00:31:12 <thinrichs> #topic Austin
00:31:23 <thinrichs> Who is headed to Austin?
00:31:35 <ekcs> I am.
00:31:41 <thinrichs> I am
00:31:47 <masahito> I am
00:31:55 <ramineni_> me too ..almost
00:32:04 <thinrichs> Almost?
00:32:30 <ramineni_> plan not confirmed yet .. :)
00:32:45 <ramineni_> but it should be through this week
00:32:58 <ramineni_> so, 90% coming
00:33:10 <ekcs> great!
00:33:12 <thinrichs> ramineni_: good luck!  It'd be great to see you again
00:33:27 <thinrichs> Shall we plan on a group dinner again?
00:34:11 <ramineni_> +1
00:34:12 <thinrichs> Let's go with yes.
00:34:31 <masahito> sounds nice.
00:34:35 <thinrichs> ekcs: do you know Austin at all?  (I'm assuming neither masahito nor ramineni know it.)
00:34:36 <ekcs> that'd be great. I could organize it if it makes sense.
00:34:55 <ekcs> hmm no never been there.
00:34:56 <ramineni_> thinrichs: yep, no idea at all
00:35:06 <bryan_att> I'll be there
00:35:17 <masahito> I've never been there.
00:35:18 <ekcs> closest I've gotten as san antonio.
00:35:34 <thinrichs> I don't know Austin either.
00:35:37 <ekcs> bryan_att: great!
00:36:02 <thinrichs> ekcs: if you want to organize the dinner, that'd be great!
00:36:18 <ekcs> thinrichs: cool.
00:36:29 <thinrichs> bryan_att: It'll be great to see you in person.  And of course, you're welcome to come to dinner too.
00:36:54 <thinrichs> ekcs: Maybe something that's especially Texan would be good.  BBQ?
00:37:03 <bryan_att> thanks - I'll try to bring some blueprint ideas based upon what I've learned.
00:37:14 <thinrichs> ekcs: or Mexican?
00:37:39 <thinrichs> bryan_att: looking forward to your ideas
00:38:21 <ekcs> thinrichs: haha yea I can talk to friends from the area. should I solicit prefs and votes on ML? or pretty much just decide among us then announce?
00:38:32 <ekcs> ramineni_: you're vegetarian right?
00:38:49 <ramineni_> ekcs: no, just wont eat beef and pork
00:38:49 <thinrichs> ekcs: Decide among us and then announce.
00:39:11 <thinrichs> Any other dietary restrictions?
00:39:21 <thinrichs> or preferences?
00:39:25 <ekcs> ramineni_: got it.
00:39:27 <ekcs> thinrichs: got it.
00:40:16 <thinrichs> Ok, now that we've got the important stuff out of the way (dinner)…
00:40:32 <thinrichs> there are a number of talks on Congress…
00:40:56 <thinrichs> You can search for congress from the schedule page:
00:40:57 <thinrichs> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=congress
00:41:40 <thinrichs> The results include our 4 working sessions on Wed.
00:42:01 <thinrichs> It also includes masahito and fabiog's talks on Thursday, and 2-3 other relevant talks.
00:42:39 <thinrichs> There's also a potential talk on the policy-based scheduler idea for Nova that is scheduled for Tuesday @noon, as part of a Dell sponsored session.
00:43:22 <thinrichs> Anything else I'm forgetting?
00:43:54 <thinrichs> For the 4 working sessions, the topics are there in the schedule:
00:44:14 <thinrichs> 1. Integration with other OpenStack projects (Monasca and Nova are on the list).  Other ideas?
00:44:50 <thinrichs> 2. Taking stock of our progress in the distributed architecture.
00:44:59 <thinrichs> 3. Working out last details of the distributed architecture
00:45:27 <thinrichs> 4. Looking at the application of the distributed arch to achieve high availability and query throughput
00:45:34 <ekcs> If we have keystone people who want to talk about it, we could discuss the keystone integration the person on #congress asked about.
00:46:08 <thinrichs> ekcs: right—I think that was not someone from Keystone, but rather someone deploying OpenStack.
00:46:13 <thinrichs> Let me check my notes.
00:46:26 <ekcs> thinrichs: right.
00:47:00 <thinrichs> My notes say jaugustine was from AT&T
00:47:06 <thinrichs> bryan_att: do you know a jaugustine?
00:47:18 <bryan_att> No
00:47:50 <ramineni_> ekcs: thinrichs: what was about keystone integration.. may be i missed it?
00:48:10 <ekcs> thinrichs: schedule sounds great. I also had DA and HA+HT on top in my mind.
00:48:21 <thinrichs> Here's the exchange.  Let's see if I can paste it into the IRC…
00:48:23 <thinrichs> jaugustine
00:48:23 <thinrichs> 1:44 Hi all, I've just learned about OpenStack Congress and am wondering if it would be able the help enforce some policies for Keystone.
00:48:23 <thinrichs> thinrichs
00:48:23 <thinrichs> 1:45 jaugustine: that'd be great!
00:48:23 <thinrichs> 1:45 Did you have some particular policies in mind?
00:48:24 <thinrichs> jaugustine
00:48:24 <thinrichs> 1:49 Our policy would be limiting a user's requests (invalid login), on X attempts and then block for X time.
00:48:25 <thinrichs> jaugustine
00:48:25 <thinrichs> 1:53 I'm open to suggestions if there's a better way out there. It seems like a Congress policy most closely fits with allowing Keystone to remain stateless while also allowing us to prevent user lockout.
00:48:26 <thinrichs> thinrichs
00:48:26 <thinrichs> 1:56 jaugustine: so you're thinking that on every failed attempt, Keystone will push some data to Congress, and on the next attempt Keystone will ask Congress what to do.  Is that right?
00:48:27 <thinrichs> jaugustine
00:48:46 <ramineni_> oohok, thanks
00:49:44 <thinrichs> It's worth spending time before the summit remembering what state we're in with the distributed architecture.
00:50:07 <thinrichs> Ideally we'll all start pushing some code again before then so it's fresh in our minds (and so we make progress).
00:50:13 <thinrichs> Sound good?
00:50:20 <ekcs> thinrichs: got it. I'm hoping to wrap up a couple patches on that before the summit.
00:50:45 <masahito> thinrichs: good
00:51:02 <ramineni_> ok
00:51:02 <thinrichs> It's 3 weeks away, so we've got time to get ramped back up.
00:52:21 <thinrichs> Let's do an open discussion for the last few minutes.
00:52:24 <thinrichs> #topic open discussion
00:52:31 <ekcs> yup. i think we may be able to run congress with inmem transport on new arch by the end of the sessions.
00:52:57 <thinrichs> ekcs: cool!  That would be fantastic.
00:53:00 <ramineni_> thinrichs: FYI KiloSecurity-supported (EOL: 2016-05-02)
00:53:33 <thinrichs> ramineni_: thanks!  Makes me feel better.
00:53:53 <thinrichs> One thing I've heard a bit about on the ML is the openstack documentation.
00:54:10 <thinrichs> Right now our docs are posted on readthedocs, not on the official openstack documentation.
00:54:22 <thinrichs> #link https://congress.readthedocs.org/en/latest/
00:55:09 <thinrichs> We should take a look at moving over to the official documentation
00:55:11 <thinrichs> #link http://docs.openstack.org/
00:55:58 <ramineni_> thinrichs: actually i submitted one change releated to this in project config https://review.openstack.org/#/c/289719/1
00:56:53 <thinrichs> ramineni_: do you know how that works?  I assume there's some format we should be using.
00:57:01 <thinrichs> Are the docs already being published somewhere?
00:57:03 <ramineni_> http://docs.openstack.org/developer/congress/
00:58:03 <thinrichs> We're not listed on the projects page…
00:58:04 <thinrichs> http://docs.openstack.org/developer/openstack-projects.html
00:58:51 <ramineni_> thinrichs: oh, let me check that how to get it done
00:59:26 <thinrichs> ramineni_: great!  Didn't expect this would already be done.
00:59:41 <thinrichs> ramineni_: Do you know if there are other Guides we should create, other than the developer docs?
01:00:42 <ramineni_> thinrichs: not sure
01:00:46 <thinrichs> Out of time for this week.  I'll be on #congress for a bit longer.
01:00:58 <thinrichs> Thanks all!  I'm looking forward to seeing you all in Austin!
01:01:02 <thinrichs> #endmeeting