00:06:06 <ekcs> #startmeeting CongressTeamMeeting
00:06:07 <openstack> Meeting started Thu Sep 15 00:06:06 2016 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:06:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:06:13 <openstack> The meeting name has been set to 'congressteammeeting'
00:06:49 <ekcs> Anyway here are the agenda items I have. Anything to add?
00:07:05 <ekcs> 1. RC1
00:07:10 <ekcs> 2. Outstanding bugs
00:07:13 <ekcs> 3. Status
00:08:21 <ekcs> #chair ekcs_
00:08:22 <openstack> Current chairs: ekcs ekcs_
00:09:41 <ekcs_> Ok so RC1 is due this week. I think thinrichs will release to today or tomorrow. Any pressing changes that should be merged before then?
00:10:31 <masahito> do you know deadline of release note?
00:11:30 <masahito> we've not written releasenote about new architecture.
00:11:44 <ekcs_> Hmm good question. I’m not totally sure, but it shouldn’t be a problem to change release notes in intermediate RC’s right?
00:12:04 <ekcs_> hmm maybe we should get a draft of that in.
00:12:11 <masahito> I think so.
00:12:57 <ekcs_> ok I can look into that. #action ekcs will look into release notes for RC1
00:13:24 <ekcs_> If possible I’d like to get this merged for RC1. #link https://review.openstack.org/#/c/369750/3
00:13:40 <ekcs_> but it hasn’t been reviewed yet so maybe that won’t happen.
00:13:54 <ekcs_> it’s important because congress fails to start under python3 without it.
00:14:16 <masahito> ok, I'll check it.
00:14:36 <ekcs_> Thanks! anyway I guess we can move on to the next topic.
00:14:50 <ekcs_> #topic outstanding bugs
00:15:58 <ekcs_> We have quite a few new bugs. Thanks for all the testing effort! Are there any notable bugs we’d like to discuss?
00:16:58 <aimeeu> I added more info to the bug entry for #link https://bugs.launchpad.net/congress/+bug/1620868
00:17:00 <openstack> Launchpad bug 1620868 in congress "Stack trace returned to end-user" [Medium,In progress] - Assigned to Aimee Ukasick (aimeeu)
00:17:57 <aimeeu> but perhaps not as important as other bugs because it's not likely to happen that often
00:18:19 <ekcs_> Got it. Thanks for doing so much work on it!
00:18:36 <aimeeu> so I think if I can't fix it, you all can help after Newton has been released
00:18:38 <ekcs_> I’m not following closely. But it seems we’re making progress, though ultimately still mysterious?
00:19:34 <aimeeu> yes - the problem is with the entire policy_engines/agnostic.py namespace "error" reporting, both CLI and API pass traceback to the user
00:19:50 <aimeeu> resorted to using pdb command line debugger
00:20:22 <ekcs_> Right. Hopefully we can figure it out before final RC, but it’s not highest priority since it doesn’t affect functionality.
00:20:33 <ekcs_> clarifying this bug: https://bugs.launchpad.net/congress/+bug/1602837
00:20:34 <openstack> Launchpad bug 1602837 in congress "Policy UI (Horizon): Unable to get policies list (devstack)" [High,In progress] - Assigned to Aimee Ukasick (aimeeu)
00:20:46 <ekcs_> things work fine as long as we avoid keystone v3 right?
00:21:11 <aimeeu> It doesn't work in keystone v2 either
00:21:38 <aimeeu> thinrichs verified that on 31 Aug
00:22:36 <aimeeu> workaround is to use the API or CLI; I'll take a look at it again tomorrow
00:22:57 <aimeeu> I think it's been broken for quite a while
00:23:08 <ekcs_> ok got it. that’s more serious then. Seems like something we definitely want fixed before final RC. I’ll see if I can help too.
00:24:07 <ekcs_> So to prioritize our time and resources, I created a new release milestone newton-rc2 on launchpad.
00:24:37 <ekcs_> I’ll be tagging all the bugs that we can aim to fix before final RC with that tag.
00:24:49 <aimeeu> ok
00:25:10 <ekcs_> It’d be great if everyone else can take a look to and see if some things should be tagged that I missed or vice versa.
00:25:37 <aimeeu> I've also found bugs that are related to each other
00:25:59 <ekcs_> #action ekcs will tag bugs for rc2
00:26:06 <aimeeu> so I'll add notes to the entries in launchpad
00:26:26 <ekcs_> aimeeu: perfect. anyhting you want to talk about now?
00:26:42 <aimeeu> nope - that's it for me
00:26:53 <ekcs_> ok great. let’s move on to statuses then?
00:27:25 <ekcs_> #topic status
00:27:38 <ekcs_> masahito: would you like to start us off on status?
00:27:50 <masahito> sure
00:28:07 <masahito> I'm working on the bug. https://bugs.launchpad.net/congress/+bug/1622865
00:28:09 <openstack> Launchpad bug 1622865 in congress "control bus sends 3 hb message in one loop" [Medium,New] - Assigned to Masahito Muroi (muroi-masahito)
00:28:29 <masahito> I think I can push a patch for it today.
00:28:57 <masahito> and also testing dse2 system especially about heartbeat stuff.
00:29:03 <masahito> that's from my side.
00:30:21 <ekcs_> That’s great! Looked like a mysterious bug to me, but I’m glad to hear you’ve got a handle on it!
00:30:52 <ekcs_> aimeeu: do you have anything to add on status?
00:31:06 <aimeeu> Nothing more for me
00:31:15 <ekcs_> got it.
00:31:37 <ekcs_> Here’s thinrich’s status: After 15ish devstack installs, I've not successfully set up multiple devstacks to talk to each other.  Had some trouble with my laptop crashing, which didn't help.
00:32:10 <aimeeu> I can feel his frustration
00:32:34 <ekcs_> Yea… I guess it’s expected to be hard though. doing multiple devstacks talking for the first time.
00:32:49 <ekcs_> And for me.
00:32:53 <ekcs_> After a lot of wrangling with infra issues, I've finally gotten a basic haht tox test working. Will now work on adding more comprehensive testing, which should not be hard in comparison. #link https://review.openstack.org/#/c/358927/
00:33:32 <ekcs_> Once I have that under control, I can give a lot more time to other testing and fixing bugs.
00:34:05 <masahito> great!
00:34:28 <ekcs_> I’ve already mentioned the python3 startup bug I’d like to get merged before RC1. And there is another bug fix in review. That’s all from me.
00:35:00 <ekcs_> #topic open discussion
00:35:13 <ekcs_> Anything else we should talk about?
00:36:42 <ekcs_> masahito: since we have some time, I figure I’d bring this up and see if yo uhave any thoughts.
00:37:07 <ekcs_> #link http://logs.openstack.org/32/369132/1/check/gate-congress-dsvm-api/d97ddb4/logs/stackviz/#/stdin
00:37:40 <ekcs_> I’ve been seeing this doctor failure in tempest every once in a while. not frequent and always goes away on recheck. any ideas?
00:39:14 <masahito> hmm... I didn't see it before.
00:39:47 <masahito> Initializing event table looks fail.
00:40:10 <masahito> I try to reproduce it in my local.
00:40:36 <ekcs_> ok great!
00:41:09 <masahito> btw, I didn't know the UI showing us gate log
00:41:38 <ekcs_> Oh yea it’s great. I didn’t realize it was there until the top level test results went missing for a while.
00:41:44 <ekcs_> so I was forced to find an alternative.
00:42:22 <ekcs_> The other things I’d mention real quick is that on this patch: https://review.openstack.org/#/c/369750/3
00:42:43 <ekcs_> The thing I’m not totally sure about is whether we need to support an eventlet server being stopped and started.
00:43:06 <ekcs_> You guys know if there is actual case for that?
00:43:43 <ekcs_> By delaying the node creation to the harness, the eventlet_server module no longer has access to the DseNode to stop the node in case the eventlet server is stopped.
00:44:26 <ekcs_> But I don’t think it matters. Just throwing it out so if someone knows otherwise they can tell me or comment on the patch.
00:44:29 <ekcs_> Thanks!
00:45:36 <masahito> If we implement graceful-shutdown, we could need the feature.
00:46:24 <ekcs_> Ah good to know. What does graceful-shutdown do? kill an eventlet server without exting the process?
00:47:13 <ekcs_> And is there a case when the Congress API server would be called to gracefully shutdown without exiting the process?
00:47:25 <masahito> I'm not sure what eventlet server is in charge of now.
00:47:49 <masahito> ah.. eventlet server only works for API now?
00:48:03 <masahito> In that case, it sounds no usecase.
00:48:37 <ekcs_> eventlet server still does non-API stuff. But it’s only in the API case that I can’t stop the node.
00:49:12 <ekcs_> in eventlet server there is regular Server and APIServer classes.
00:49:53 <ekcs_> I guess we can discuss over gerrit. Thanks for the note on graceful shutdown though!
00:50:20 <ekcs_> Anyway I don’t have anything else to discuss. Lots of testing and bug fixing still, but it’s exciting that we’re very close to newton release and finally releasing the distributed architecture that’s over a year of work.
00:50:41 <ekcs_> anything else or should we end early?
00:50:53 <aimeeu> I don't have anything else to add
00:51:40 <ekcs_> ok then let’s end it. See you all next week!
00:51:48 <ekcs_> #endmeeting