00:02:01 <masahito> #startmeeting congressteammeeting
00:02:02 <openstack> Meeting started Thu Nov 17 00:02:01 2016 UTC and is due to finish in 60 minutes.  The chair is masahito. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:02:05 <openstack> The meeting name has been set to 'congressteammeeting'
00:02:13 <ramineni_> hi
00:02:26 <masahito> ramineni_: hi
00:03:03 <masahito> today's agenda:
00:03:11 <masahito> 1. PTG
00:03:22 <masahito> 2. status update
00:03:36 <masahito> anything else?
00:03:45 <ramineni_> gate issues?
00:04:19 <masahito> ramineni_: ok
00:04:21 <ekcs> we could talk about which patches we’re trying to merge for ocata-1 release.
00:04:54 <masahito> ekcs: got it.
00:05:02 <masahito> 3. gate issue
00:05:09 <masahito> 4. ocata-1
00:05:42 <masahito> #topic PTG
00:06:27 <masahito> we needs to decide how many days we have in PTG.
00:06:56 <masahito> two days or three days
00:07:58 <aimeeu> on the mailing list it sounded like the team was fine with 2 days
00:08:02 <ramineni_> 2 days would be good i guess
00:08:02 <masahito> it looks like most of us prefer 2 days meeting
00:08:34 <ekcs> +1 (as in 2 days makes sense to me too; not as in 2 + 1 = 3)
00:09:05 * aimeeu thanks ekcs for the explanation
00:10:01 <masahito> thinrichs also prefers 2 days in the mail
00:10:49 <masahito> so we choose 2 days session in PTG :-)
00:11:06 <ekcs> great
00:11:13 <aimeeu> +1
00:11:28 <masahito> move on next.
00:11:42 <masahito> #topic gate issue
00:13:13 <masahito> ekcs: ramineni_: sorry, I don't catch up recent gate issue. Could you tell us the current issue?
00:13:25 <ramineni_> last week we were seeing multiple gate issues - 1.tempest variable deprecation 2. HA timeout 3. doctor tempest
00:13:47 <ramineni_> i have submitted one patch https://review.openstack.org/#/c/397013/
00:14:18 <ramineni_> merged it , to actually clear the queue of our review.. hope change sounds good
00:14:55 <ramineni_> still we are seeing occasional HA timeout though
00:15:14 <ekcs> thanks ramineni_
00:15:42 <ekcs> so that patch takes care of the deprecated variable.
00:15:49 <ekcs> can you say a little bit about what the other changes do and why?
00:15:51 <masahito> ramineni_: thanks.
00:15:59 <ramineni_> and HA timeput a lil bit
00:16:34 <ramineni_> datasource sync period actually previously its not replaced .. 2 times its added in config file
00:17:52 <ekcs> got it.
00:18:02 <ramineni_> so always the latest variable is datasource_sync_period= 30
00:18:16 <ekcs> good catch!
00:18:58 <ramineni_> and added  synchronize policies in get_status , to get the latest status in first iteration
00:20:07 <masahito> so still remaining issues are 2 and 3?
00:20:39 <ramineni_> masahito: 2 is partially fixed as we are able merge patches now.. 3 is still there
00:21:12 <masahito> ramineni_: got it. I try to check 3.
00:21:16 <ramineni_> i think ekcs raised bug for 3 , may be you could take a look at it
00:22:04 <masahito> yup. I think I should take care it.
00:22:21 <ramineni_> masahito: ekcs: should we consider increasing build timout in gate job?
00:23:06 <ekcs> great work resolving gate so we can merge patches!
00:24:18 <ekcs> ramineni_: I don’t have an opinion on that now. thoughts are: 1. does it happen a lot. 2. can we make things run faster.
00:24:19 <masahito> ramineni_: any test hits timeout in gate?
00:24:47 <ekcs> and I haven’t looked into it to have knowledge on those questions.
00:25:22 <ekcs> ramineni_ what do you think?
00:25:31 <ramineni_> ekcs: masahito: ok, lets see for a week then .. if it happens a lot again, we can think about it then?
00:25:48 <masahito> ramineni_: Agreed
00:25:54 <ekcs> sounds good.
00:25:56 <ekcs> one more thing:
00:27:57 <ekcs> on the synchronize policy, I wonder if there is another place to trigger the sync instead or another way to do it without having to sync on every get status.
00:29:59 <ekcs> people may expect get status to be a fairly cheap read-only action. syncing all policies may be expensive.
00:30:39 <masahito> ekcs: I think so.
00:31:11 <ramineni_> ekcs: i tried syncing only one policy , but it didnt help HA .. as sometimes its a datasource policy
00:31:43 <ramineni_> ekcs: do you have anything on mind on where to place it?
00:32:55 <ekcs> got it. i haven’t thought it all through, but perhaps trigger (rpc) the sync on change (adding/deleting policy; adding/deleting DS), rather than on read.
00:33:58 <ramineni_> ekcs: but that doesnt help if multiple peś are there?
00:34:28 <ramineni_> ekcs: you mean broadcast?
00:34:37 <ekcs> yea broadcast.
00:34:44 <ekcs> another thought is perhaps we don’t need to sync to memory to report status. maybe we just need to read the policy from DB to report status. with one status being the policy is in DB, but hasn’t been sync’ed to memory.
00:35:30 <ekcs> probably something I need to think through more carefully after ocata-1.
00:36:12 <ramineni_> ok, sure, ya Iĺl also think about it
00:36:29 <ekcs> oh and since we’re on the subject, what about this other patch on ha test?
00:36:36 <ekcs> https://review.openstack.org/#/c/397645/
00:37:23 <ramineni_> :)
00:37:47 <ekcs> so primary sync period is left at 30s?
00:37:58 <ramineni_> when i see the HA failure , timeout happens in the very initial stage itself, trying ti get status from primary itself
00:38:16 <ramineni_> ya, primary sync happens at 30s as we set in devstack
00:38:23 <ekcs> got it.
00:38:41 <ekcs> thanks!
00:38:46 <ekcs> I don’t have anything else on gating.
00:39:24 <masahito> ok, move on next topic.
00:39:37 <masahito> #topic ocata-1 release
00:40:23 <masahito> to release ocata-1 we need to pick patches ready to merge the milestone.
00:40:56 <ekcs> here are the open patches: https://review.openstack.org/#/q/project:openstack/congress+status:open
00:41:24 <masahito> My opinion is adding patches related to aodh datasource seems to be good.
00:43:22 <ekcs> agreed. maybe each of us with patches open can say which ones we want to merge before ocata-1?
00:43:47 <ekcs> for context, we pretty much need to merge things today to make it for ocata-1.
00:44:32 <ekcs> so essentially things that are ready and maybe just need a quick review.
00:45:08 <thinrichs> Sorry I'm late all.  Meeting in city ran later than expected
00:45:46 <thinrichs> My 2 changes can go in.  They've been just waiting on gate.
00:45:50 <ekcs> hi thinrichs !
00:45:56 <masahito> thinrichs: hi
00:46:19 <ramineni_> ekcs: regarding https://review.openstack.org/#/c/393567/
00:47:32 <ramineni_> any idea why is it still throwing error
00:47:36 <ekcs> ramineni_: i looked into it some more.
00:48:03 <ekcs> the warning saying aodh not found happens only early in the test. I think it’s just because aodh wasn’t ready.
00:49:01 <ekcs> more example in the non-replicated tempest logs, the message doesn’t come up from 16:16 till the end (16:22+)
00:49:19 <ekcs> similar in the replicated pe test.
00:49:44 <ramineni_> ekcs: oohk, then should be fine
00:50:54 <ekcs> I think those patches should be mergeable today if looks fine to people. I’ll update it real quick to use info rather than debug as ramineni_ suggested.
00:51:05 <ramineni_> ekcs: ok sounds good then
00:51:18 <ekcs> masahito: what about this one? https://review.openstack.org/#/c/397096/
00:52:52 <masahito> oh. the bug was assigned to ocata-1.
00:53:42 <ekcs> do you think we can/should merge it today?
00:53:45 <masahito> I think it's ready to ocata-1.
00:54:09 <ekcs> great! anything else for ocata-1?
00:55:26 <ekcs> #action Let's review these patches and try to merge them today if possible. (Not a big deal if some get delayed and miss ocata-1)
00:55:31 <ekcs> #link https://review.openstack.org/#/c/397096/
00:55:31 <ekcs> #link https://review.openstack.org/#/c/393420/
00:55:31 <ekcs> #link https://review.openstack.org/#/c/394258/
00:55:33 <ekcs> #link https://review.openstack.org/#/c/393977/
00:55:33 <ekcs> #link https://review.openstack.org/#/c/393567/
00:55:36 <ekcs> #link https://review.openstack.org/#/c/397796/
00:55:36 <ekcs> #link https://review.openstack.org/#/c/397096/
00:56:00 <masahito> ekcs: thanks the link and wrap up.
00:56:28 <masahito> last 4 mins.
00:56:44 <masahito> #topic open discussion
00:57:42 <thinrichs> Quick note: I attended the policy meeting this morning, where they're talking about the state of policy.json in OpenStack and whether we could improve it.
00:57:54 <thinrichs> Good attendance, over 10 people for sure
00:58:18 <masahito> thinrichs: sounds big meeting.
00:58:18 <thinrichs> Learning about congress is an action item for next week.
00:58:43 <ekcs> awesomeness!
00:58:47 <ramineni_> great :)
00:58:49 <thinrichs> Discussion of having a backend (Apache fortress or similar) came up.  I suggested Congress
00:59:25 <thinrichs> Learned something new about policy.json...
01:00:49 <masahito> oh, running out meeting time.
01:01:42 <masahito> thanks all. let's review patches, and then good evening/morning/night!
01:02:02 <masahito> #endmeeting