00:02:17 <ekcs> #startmeeting congressteammeeting
00:02:17 <openstack> Meeting started Thu Jan 26 00:02:17 2017 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:02:22 <ekcs> hi thinrichs
00:02:22 <openstack> The meeting name has been set to 'congressteammeeting'
00:03:24 <ekcs> hi all! hope everyone’s having a good week.
00:03:29 <ekcs> the items i have are pretty simple.
00:03:35 <aimeeu> hi all
00:04:23 <ekcs> - Ocata-3
00:04:23 <ekcs> - Ocata RC1
00:04:24 <ekcs> - Ocata patches
00:04:25 <ekcs> - Ocata bugs
00:04:26 <ekcs> anything else?
00:04:45 <thinrichs> Planning for PTG
00:05:39 <masahito> hi all. sorry, late.
00:06:33 <ekcs> ok great.
00:07:52 <ekcs> first just a quick announcement: congress client for ocata was released on Monday. If there’s any really important change we need to release we could still do that today or tomorrow.
00:08:21 <ekcs> #topic Ocata-3
00:09:49 <ekcs> Ocata-3 is due this week. I expect to tag a hash for release today.
00:09:56 <ekcs> There’s been a fair amoutn of activity on master over the past week.
00:10:40 <ekcs> Let’s see how much we can get merged by end of today (UTC) and we can run some final quick tests and tag the release.
00:10:58 <ekcs> does that make sense? any comments or thoughts?
00:11:34 <ekcs> is there anything that MUST go into Ocata-3?
00:11:34 <masahito> make sense
00:12:54 <thinrichs> We're trying to merge as many things into master as we can today?
00:13:54 <thinrichs> Happy to review.  I presume only some of the changes in master are ready to go in though.
00:13:59 <thinrichs> Maybe the top half of this list?
00:14:00 <thinrichs> https://review.openstack.org/#/q/project:openstack/congress+status:open
00:14:43 <ekcs> there’s no particular rush for today. but it’s helpful to merge when ready. and all the better if included in O3.
00:14:55 <thinrichs> Maybe stopping at the Jan 23 commits?
00:16:55 <ekcs> makes sense.
00:17:28 <ekcs> ok we can discuss specific patches later. but let’s move on if there are no Ocata-3 MUSTs.
00:17:44 <ekcs> #topic Ocata RC1
00:18:10 <ekcs> just another reminder that we’re on a very abbreviated schedule. and RC1 is due next neek.
00:18:47 <ekcs> so please keep that in mind in planning and bug fixes.
00:19:28 <ekcs> what’d be a good cut-off day for merging changes for RC1?
00:20:41 <thinrichs> Typically we do it the other way around: we cut RC1 as soon as all the known blocking bugs are fixed.
00:21:13 <thinrichs> Then we do another round of testing, and if we find no release-blockers we're done.  Otherwise, we fix the bugs, cut RC2, and do it again.
00:22:10 <thinrichs> The devil is in the details of defining what a 'release-blocking bug' is
00:22:20 <ekcs> i see. that makes sense.
00:24:01 <ekcs> I guess we can go through the bugs and target all the must-fix bugs for RC1.
00:24:52 <ekcs> and discuss evyr launchpad if we’re not sure. does that make sense?
00:26:34 <thinrichs> sure
00:26:47 <masahito> got it.
00:27:24 <ekcs> #action go through bugs and target for RC1. https://bugs.launchpad.net/congress/+bugs?orderby=-importance&start=0
00:27:52 <ekcs> ok then let’s move on.
00:27:56 <ekcs> #topic PTG planning
00:28:38 <ekcs> I haven’t though very much about PTG planning. But I guess we should at least start coming up with what needs to be done in the planning.
00:28:58 <aimeeu> I've added items to the etherpad.
00:29:00 <thinrichs> Quick scan of the High priority bugs—I'd say most of those will either not be fixed in Ocata3 or are in review and in good shape.
00:29:25 <thinrichs> Someone have the PTG etherpad link handy?
00:29:38 <aimeeu> https://etherpad.openstack.org/p/congress-ptg-pike
00:29:45 <thinrichs> aimeeu: thanks!
00:30:14 <ekcs> thanks!
00:30:31 <thinrichs> There's a ton of stuff already there
00:30:34 <thinrichs> thanks aimeeu!
00:30:41 <thinrichs> (and whoever else contributed)
00:31:01 <aimeeu> bryan_att has copious notes from Barcelona
00:31:29 <aimeeu> I need to do some cleanup of his notes and prioritize
00:31:49 <ekcs> yea that’s great for how many topics we have.
00:32:43 <aimeeu> so it's pretty much going to be 2 days of free-form discussion, right? no plans to divide up the day to cover specific topics (which might be limiting)
00:33:05 <ekcs> next step is divide up the things we want to discuss into a rough schedule/agenda for the two days?
00:33:34 <ekcs> aimeeu: there’s no need for strict sessions, but it’s probably still helpful to have some idea which topics we’ll discuss on which day
00:33:43 <aimeeu> I agree
00:34:34 <ekcs> ok i’ll work on that and have something we can discuss next meeting.
00:34:47 <aimeeu> thanks ekcs!
00:35:12 <ekcs> #action ekcs organize PTG topics
00:35:34 <ekcs> #action everyone interested add to PTG topics https://etherpad.openstack.org/p/congress-ptg-pike
00:35:52 <ekcs> anything else we should discuss now on PTG?
00:36:18 <aimeeu> are most of you planning to fly home on Friday?
00:36:47 <thinrichs> Yep.  First thing in the morning if I remember right
00:37:16 <ekcs> I’m staying till Saturday.
00:37:35 <ekcs> Getting in Sunday and staying till saturday.
00:37:43 <aimeeu> Same here
00:37:45 <masahito> I'll leave there on Saturday
00:38:51 <ekcs> ok then.
00:39:01 <ekcs> let’s move on  = )
00:39:13 <ekcs> #topic Ocata patches and bugs
00:39:41 <ekcs> any patches that need discussion so we can make progress?
00:40:30 <ekcs> any bugs we want to discuss? regarding priority or root causing or whatever.
00:40:43 <aimeeu> has anyone stacked very recently using ocata master?
00:41:03 <aimeeu> I stacked twice today and doesn't seem to be installing correctly in DevStack
00:41:09 <aimeeu> wondering if it's me or an issue
00:41:23 <thinrichs> aimeeu: what's the symptom?
00:41:27 <ekcs> aimeeu: I think I last stacked a week ago.
00:41:47 <aimeeu> The congress dashboard doesn't appear in the openstack dashboard for one
00:42:14 <aimeeu> I need to try some CKI calls
00:42:20 <aimeeu> s/CKI/CLI
00:44:23 <masahito> aimeeu: I stacked when I start devstack without aodh service.
00:45:06 <ekcs> aimeeu: that’s weird hmm. so dashboard worked just didn’t show congress stuff?
00:45:27 <aimeeu> correct - no congress dashboard
00:46:03 <aimeeu> devstack should have installed the python-congressclient too, right?
00:47:07 <ekcs> aimeeu: for me it does. and cloned the congressclient repo into /opt/stack/.
00:47:52 <aimeeu> hmmmm no congress anything in /opt/stack - rechecking my local.conf
00:47:53 <ekcs> anyway that’s strange cuz I don’t see any dashboard changes over the past week. i’ll let you knowwhen I stack again.
00:48:41 <aimeeu> ok - i'll start all over - fresh everything - maybe a spelling mistake
00:49:17 <ekcs> aimeeu: feel free to send me your local.conf for a look if you think it might help.
00:49:20 <thinrichs> The path /opt/stack usually has both congress/ and python-congressclient/, right?
00:49:33 <ekcs> thinrichs: that’s my experience.
00:49:38 <aimeeu> Thanks ekcs. It's been a long day.
00:50:06 <ekcs> unrelated: I ran into this very mysterious bug this week. #link https://bugs.launchpad.net/congress/+bug/1659440
00:50:06 <openstack> Launchpad bug 1659440 in congress "Erratic row list behavior with cross-policy rule" [High,New]
00:50:47 <ekcs> seems with certain rules in place, listing the rows of a policy table gives erratic and changing results. sometimes with more or fewer tuples. sometimes says table doesn’t exist.
00:51:18 <ekcs> could be a serious thing so i’m going to prioritize understanding it. just want to mention in case others have ideas on what to look for.
00:51:53 <ekcs> in this case, it specifically happened with this rule: u(x,y) :- q(x,y), NOT policy2:a(x,y)
00:52:37 <ekcs> could have something to do with our cross-policy reference fix not subscribing immediately. maybe some strange repeating interactions going on there.
00:54:07 <ekcs> anyway let’s go to open discussion.
00:54:12 <ekcs> #topic open discussion
00:54:24 <ekcs> just a fetw minutes left so shoot if you have anything  = )
00:55:05 <thinrichs> That's a CRAZY bug.
00:55:24 <ekcs> thinrichs: yea… = /
00:55:43 <thinrichs> If a table stops existing, that's pretty bad because it means the rule is missing too, right?
00:56:00 <thinrichs> Is there some sort of oscillation going on with the synchronization?
00:56:06 <thinrichs> I assume that's multi-PE
00:56:22 <ekcs> thinrichs: hmm i didn’t think to check the rule at the some time. but I never saw the rule not get listed.
00:56:34 <ekcs> thinrichs: but then rule listing is probably from DB not PE.
00:56:42 <ekcs> thinrichs: no the crazy thing is this is all-in-one.
00:56:48 <ekcs> single PE.
00:57:12 <thinrichs> We should definitely track that down.
00:57:28 <thinrichs> Can you replicate with another policy?
00:57:47 <thinrichs> Does that happen for ALL the tables in that policy or just the table with the cross-policy reference?
00:57:58 <ekcs> one more thought: please shoot PTG planning suggestions/requests/thoughts my way if anything come to mind.
00:58:16 <ekcs> thinrichs: that’s the next step for me is trying out all these different things
00:58:33 <ekcs> to get a really good grasp of what’s going on. I think it neverhappened with another table. only u.
00:58:53 <ekcs> so I suspect it’s something to do with that specific rule.
00:59:27 <ekcs> next step I’ll try to replicate in simplest form and see if I can find the exact boundaries of the problem.
00:59:30 <thinrichs> Ok.  I've never seen that before, but if u is suddenly missing that would point to the rule being removed from the in-memory PE rule-store.
01:00:06 <ekcs> anyway time’s up. thanks everyone and see you all next week!
01:00:18 <thinrichs> Only other thing I can think of is if there's some schema we're maintaining that gets out of sync
01:00:22 <thinrichs> Thanks all!
01:00:31 <ekcs> hmm. good thought.
01:00:33 <masahito> bye
01:00:35 <ekcs> #endmeeting