00:00:40 <ekcs> #startmeeting congressteammeeting
00:00:41 <openstack> Meeting started Thu Feb  2 00:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:42 <aimeeu> good day everyone!
00:00:44 <openstack> The meeting name has been set to 'congressteammeeting'
00:00:46 <ekcs> hi all!
00:00:53 <ekcs> Hope everyone's having a good week  = )
00:01:12 <ekcs> Here are the topics I have for today. Anything to add?
00:01:13 <ekcs> Topics
00:01:14 <ekcs> - RC1
00:01:15 <ekcs> - PTG topics
00:01:16 <ekcs> - PTG social activity
00:03:13 <ekcs> ok then lets dive in
00:03:36 <ekcs> #topic RC1
00:04:49 <ekcs> first an update on this crazy bug. https://bugs.launchpad.net/congress/+bug/1659440
00:04:49 <openstack> Launchpad bug 1659440 in congress "Erratic row list behavior with cross-policy rule" [Critical,Fix committed]
00:05:47 <ekcs> the synchronizer was adding and removing rules because somehow it kept adding the rule to the wrong policy or something like that. more details in the bug tracker.
00:06:35 <ekcs> I still don’t know the exact cause, but we’re fortunate that the issue seems to have gone away with a recent patch
00:06:46 <ekcs> https://review.openstack.org/#/c/416777/
00:07:23 <ekcs> other than that, does anyone have what they consider to be release blockers for ocata?
00:09:50 <ekcs> after reviewing the high priority bugs #link https://bugs.launchpad.net/congress, I didn’t find anything that was an absolute release blocker.
00:10:04 <ekcs> but there were a couple that I’d really like to get fixed.
00:10:10 <ekcs> #link https://bugs.launchpad.net/congress/+bug/1657556
00:10:10 <openstack> Launchpad bug 1657556 in congress "ceilometer_driver fail to poll HTTPInternalServerError" [High,New] - Assigned to Anusha (anusha-iiitm)
00:10:17 <ekcs> #link https://bugs.launchpad.net/congress/+bug/1658263
00:10:17 <openstack> Launchpad bug 1658263 in congress "head-only rule fails to make policy table" [Medium,New]
00:13:16 <ramineni_> ekcs: first one .. Need to just change except block to catch new exception right
00:13:29 <ramineni_> I can submit patch today for that
00:13:38 <ramineni_> Looks like simple one
00:14:12 <ekcs> ramineni_: yes i think so.
00:14:16 <ekcs> On the second bug, it just looks horribly broken to users because you create a rule a(1) and then congress says table a doesn’t exist. I think it’s a relatively simple fix, so I’d like to submit a patch for that today.
00:15:01 <ramineni_> When is RC release planned?
00:16:36 <ekcs> unfortunately we’re wokring against a very tight rc1 deadline, so it’d be great if we can prioritize reviewing and merging these last min patches by Feb 2 18:00 UTC, then I can do some final tests and tag for release before Feb 3 UTC.
00:16:57 <ekcs> RC1 is due Feb 2.
00:17:13 <ramineni_> Ok ..sure
00:17:27 <thinrichs> Hi all —sorry I'm late.  Meeting ran long
00:17:43 <ekcs> hi thinrichs !
00:18:24 <ekcs> we’re just talking about a couple quick things we’d like to try and fix and merge Feb 2 UTC (today).
00:19:01 <ekcs> there are also some outstanding patches in review.
00:19:25 <ekcs> masahito: does this patch look good to you? https://review.openstack.org/#/c/424505/
00:20:54 <masahito> yup
00:21:42 <ekcs> ok then let’s go ahead and merge that. thanks  = )
00:21:43 <masahito> I'll update the patch. I seemed to have an mistake.
00:22:53 <ekcs> let’s also review and try to merge these two patches asap for RC1:
00:22:57 <ekcs> #link https://review.openstack.org/#/c/424908/
00:23:02 <ekcs> #link https://review.openstack.org/#/c/427947/
00:24:00 <ekcs> I’ll submit my patch to #link https://bugs.launchpad.net/congress/+bug/1658263 in the next couple hours and tag you guys for review.
00:24:00 <openstack> Launchpad bug 1658263 in congress "head-only rule fails to make policy table" [Medium,New]
00:24:49 <ekcs> and ramineni_ you’ll try to submit a patch for #link https://bugs.launchpad.net/congress/+bug/1657556 for review? please tag us for that.
00:24:50 <openstack> Launchpad bug 1657556 in congress "ceilometer_driver fail to poll HTTPInternalServerError" [High,New] - Assigned to Anusha (anusha-iiitm)
00:25:18 <ramineni_> Sure .. Will do that
00:25:55 <ekcs> awesome thanks a lot!
00:25:59 <ekcs> any other thoughts on RC1?
00:28:56 <ekcs> Ok then. I think we’re in pretty good shape this release thanks to everyone’s work and early testing.
00:29:06 <ekcs> Hopefully we can actually release an RC1 this time that could be final RC  = p
00:29:24 <ekcs> #topic PTG topics
00:30:01 <ekcs> aimeeu and others have put down a lot of notes on PTG topics. #link https://etherpad.openstack.org/p/congress-ptg-pike
00:30:20 <ekcs> I have gone through and roughly organized them into categories.
00:30:30 <aimeeu> thanks ekcs!
00:30:32 <ekcs> testing, quality, maturity and maintenance (TQMM)
00:30:43 <ekcs> Features:Policy library
00:30:49 <ekcs> integration features
00:30:58 <ekcs> internal features
00:31:02 <ekcs> UI features
00:31:07 <ekcs> new concepts
00:31:22 <ekcs> may be a bit arbitrary but just a first cut.
00:32:25 <masahito> May I add a bit?
00:32:30 <ekcs> between now and the PTG, we can all add topics and respond to other people’s topics with comments and questions.
00:32:47 <masahito> It's no a git item.
00:33:03 <masahito> s/git/big/
00:33:44 <ekcs> and set ourselves up to be familiar with the topics and having gotten some clarification questions out of the way, so we can hit the ground running at the PTG.
00:33:52 <thinrichs> ekcs: +1
00:34:02 <ekcs> masahito: yes please. that’s what the etherpad is for.
00:34:15 <masahito> ekcs: thanks
00:34:38 <ekcs> any thoughts on PTG topics right now? if not we can continue the discussion next week.
00:37:16 <ekcs> alrite then =)
00:37:22 <thinrichs> I like the idea for pluggable proactive enforcement thru oslo.messaging
00:37:38 <thinrichs> The problem of proactive enforcement would be a great one to crack.
00:37:49 <thinrichs> I think it could substantially improve the update of Congress
00:38:00 <thinrichs> s/update/uptake/
00:38:40 <ekcs> thinrichs: proactive would be great.
00:39:07 <ekcs> i’m a little confused tho as to what exactly is meant by enforement thourgh oslo.messaging.
00:39:55 <ekcs> oslo-messaging has a mechanism that can be used to block an action in transit?!
00:40:12 <thinrichs> ekcs: I thought you added that.
00:40:36 <thinrichs> Who knows how oslo-messaging could be applied to do proactive enforcement?
00:40:49 <ekcs> i think aimeeu did. under barcelona notes, but I didn’t remember it from barcelona haha.
00:41:15 <aimeeu> I blame it on Bryan - they were his notes, so maybe we did discuss it a bit
00:42:13 <aimeeu> did that have to do with somehow reading in policy.json?
00:43:19 <ekcs> aimeeu: haha ok. it’d be great to understand better what he has in mind. I could shoot him an email.
00:43:53 <ekcs> anyway let’s move on then. we’ll come back to this if we have time at end of meeting. if not, please continue the discussion on etherpad =)
00:44:07 <ekcs> #topic Ocata QA
00:44:15 <ekcs> oh I forgot the mention back in RC1 topic. I've retargeted the QA tasks for ocata-final-rc which basically means ongoing for each RC. Also added the task for datasource node failover test masahito suggested. Any thoughts or questions about that?
00:44:27 <ekcs> #link https://bugs.launchpad.net/congress/+bugs?field.tag=qa
00:45:26 <ekcs> #topic PTG social activity
00:45:43 <ekcs> do we want to plan a dinner and/or activity at Atlanta?
00:45:55 <thinrichs> I always enjoy that
00:46:04 <masahito> +1
00:46:04 <ramineni_> +1
00:46:11 <ekcs> +1
00:46:16 <aimeeu> We could decide where to go one we are there - lots of restaurants within walking distance
00:47:27 <ekcs> thank aimeeu. I think we should at least nail down a day tho so it helps people with scheduling.
00:47:56 <ekcs> do people have a good enough idea of their schedules to talk about day and time now? or we should come back to it next week?
00:48:06 <aimeeu> agree - wed or thurs?
00:48:47 <thinrichs> Both days work for me
00:48:56 <ekcs> same here.
00:49:04 <ramineni_> I'm also ok with both
00:49:35 <masahito> both works for me
00:50:22 <ekcs> ok then. I guess it’s a matter of whether we prefer doing it middle of our work days or after our work days.
00:50:33 <ekcs> congress work days at least.
00:51:30 <thinrichs> Are there interesting non-restaurant activities nearby?
00:51:50 <thinrichs> We'll probably be eating lunches together anyway.
00:52:28 <thinrichs> So I'd imagine mid-day would be mainly interesting if it's an outdoor activity that we'd want to do in the daylight
00:52:35 <thinrichs> Hiking?
00:52:58 <ekcs> good point on non-restaurant acitivity.
00:53:21 <ekcs> oh when I say middle of our work days I meant between our work days. Wasn’t thinking about midday but that colud work.
00:53:38 <aimeeu> may be some ideas here:  http://www.atlanta.net/50Fun/by-neighborhood/
00:54:45 <thinrichs> Sorry.  Didn't get that we were picking the day.  Thu seems more like a celebration since the core working days are done.
00:55:17 <thinrichs> I'd lean toward Thu I guess.
00:55:54 <thinrichs> We're in the Downtown neighborhood?
00:56:14 <aimeeu> Yes
00:56:18 <ramineni_> Yes
00:57:09 <ekcs> i don’t have a strong preference either way on days. masahito ramineni_ aimeeu ? we don’t have to decide right now either.
00:57:26 <ekcs> would anyone like to volunteer to do a little bit of looking around and propose a couple ideas?
00:57:32 <aimeeu> no preference either
00:57:41 <ramineni_> When everyone reaching Atlanta
00:58:05 <ekcs> ramineni_: Sunday for me.
00:58:10 <thinrichs> I haven't organized an outing before.  I can look at some options.
00:58:36 <ekcs> ok thanks thinrichs .
00:58:51 <masahito> ramineni_: Monday for me.
00:59:04 <masahito> thinrichs: thanks
00:59:20 <ekcs> #action thinrichs look at some PTG outing options
00:59:42 <ekcs> ok then time’s about up.
00:59:54 <aimeeu> ramineni_: Sunday afternoon
01:00:12 <ramineni_> Ok . Im reaching Sunday afternoon
01:00:30 <ekcs> if you have a preference between wed and thu, please let us know next meeting.
01:00:41 <ekcs> see you all next week!
01:00:48 <thinrichs> Thanks all!
01:00:55 <masahito> thanks all
01:01:27 <ekcs> thanks all
01:01:28 <ekcs> #endmeeting