00:00:44 <ekcs> #startmeeting congressteammeeting
00:00:45 <openstack> Meeting started Thu Mar 16 00:00:44 2017 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:48 <openstack> The meeting name has been set to 'congressteammeeting'
00:01:01 <ramineni_> Hi
00:01:04 <ekcs> hi all!
00:01:58 <ekcs> thinrichs and masahito are not going to be here this week. And it doesn’t seem like we have a lot to talk about. So probably will be a short meeting. or just extra time for topics we don’t normally get to spend as much time on.
00:02:15 <ekcs> here are the topics we have put down for today. https://etherpad.openstack.org/p/congress-meeting-topics
00:02:20 <ekcs> feel free to add.
00:05:22 <ekcs> ok then.
00:05:37 <ekcs> #topic policy library
00:06:18 <ekcs> We’ve been adding policies to this google doc. #link https://docs.google.com/document/d/12f1VciulhT9yCYOc7jiulGiLT-tFpffLxNOpr-2QX2I/edit#heading=h.p2doj1gyu2x7
00:06:54 <ekcs> I added a couple policies similar to AWS.
00:07:49 <ekcs> Not much to say about it right now. Seems like we have at least a few generally useful policies. so that’s good news for the policy library.
00:08:50 <ekcs> One thing I noticed is that our cinder driver is missing some useful information about attachements and encryption. At some point I may need to take a look on how/whether we can add them.
00:08:57 <ekcs> so support this kind of policy. https://docs.google.com/document/d/12f1VciulhT9yCYOc7jiulGiLT-tFpffLxNOpr-2QX2I/edit#heading=h.17037zo2vy3t
00:09:30 <ekcs> anything else? =)
00:10:11 <ramineni_> That info is available in cinder v2
00:10:15 <ramineni_> ?
00:10:38 <ekcs> you mean from the client?
00:10:47 <ramineni_> Ya
00:11:22 <ekcs> I’m not totally sure. the info is available in horizon under volumes.
00:11:35 <ekcs> so right the next logical step is to see how it’s obtained from client/api
00:12:11 <ekcs> how do you usually go about finding out something like that? source code?
00:12:25 <ramineni_> Oohk ..Ya ..May be u can raise bug for it ..So that we don't forget to look into it later ?
00:12:39 <ramineni_> Ya . Or API guide
00:13:21 <ekcs> ok.
00:13:30 <ekcs> thanks.
00:14:48 <ekcs> ok then let’s move on.
00:15:43 <ekcs> #topic pike tasks
00:16:15 <ekcs> Some Pike tasks created here based on PTG discussions. https://bugs.launchpad.net/congress/+bugs?field.tag=pike-goal
00:16:34 <ekcs> I don’t have anything in particular to talk about. But we have some time for that.
00:18:07 <ekcs> ok moving on then =)
00:18:11 <ramineni_> If we were to add violation s panel in UI ..
00:18:17 <ekcs> oh ok.
00:18:24 <ekcs> uh huh?
00:18:50 <ramineni_> Did we agree to list only error s   table
00:19:28 <ramineni_> ?
00:19:35 <ekcs> I don’t think we decided on it. but that’s one option discussed. involving probably the least changes.
00:20:04 <ekcs> otherwise we need some way of designating a table as “violation”
00:20:20 <ramineni_> Ok .. ya
00:20:53 <ekcs> I personally think error or another reserved table name is a good first step for pike. but we didn’t exactly make a decision.
00:21:23 <ramineni_> Ya .. May be I will add the topic for next week .. we could discuss more on this when everyone available
00:22:01 <ekcs> other options: maybe each policy can have a metadata on which tables are violations. maybe we can just have modal rules that designate tables as violations. like violation[unsecured_vm] :-
00:22:07 <ekcs> or something. ok that’s a good idea.
00:22:41 <ekcs> btw I see that you have a couple patches for UI changes. thanks for jumping on that.
00:23:11 <ekcs> how familiar are you with django?
00:23:19 <ramineni_> Thanks
00:23:41 <ramineni_> Learning :)
00:24:07 <aimeeu> Hi ekcs and ramineni_  - joined late and am on mobile.
00:24:15 <ekcs> hi aimeeu !
00:25:11 <ramineni_> Ekcs : may be if you have some time .. you can test it out and let me know on the changes if they look good
00:25:24 <ramineni_> Hi aimeeu
00:25:33 <ekcs> ramineni_: haha ok. one reason I’m asking is thinking whether I should prioritize learning django for violations pane. or prioritize other tasks.
00:25:52 <ekcs> ramineni_: yup i’m setting up to test drive the changes.
00:26:10 <ekcs> ok then. anything else on pike tasks?
00:26:53 <ramineni_> Ok :) thanks
00:27:16 <ekcs> #action ekcs register task on cinder driver data: encryption, attachments
00:27:25 <ekcs> ok then.
00:27:31 <ekcs> #topic open discussion
00:28:13 <ekcs> not usre we have anything. but I’ll give us a couple minutes to see if there’s anything else we want to talk about.
00:28:54 <aimeeu> Nothing from me other than now  that the OPNFV release is done, I plan to start on my Congress stuff
00:29:15 <ekcs> aimeeu: awesomeness on opnfv.
00:29:35 <aimeeu> :)
00:29:43 <ekcs> one quick question, does the project pull congress from stable branch or from some packaged release?
00:30:13 <aimeeu> Stable branch
00:30:43 <aimeeu> In this release, Newton
00:30:49 <ekcs> ok great. so not too affected by update releases. thanks. we did just release an update to newton.
00:31:02 <ekcs> but that doesn’t affect opnfv then.
00:32:02 <ekcs> ok then. let’s wrap up for the day?
00:32:09 <aimeeu> Sounds good
00:33:07 <ramineni_> Yes .. Nothing from my side
00:33:10 <ekcs> alright then! have a great week ramineni_, aimeeu !
00:33:16 <ekcs> see you next week.
00:33:33 <ekcs> #endmeeting