18:00:39 <daneyon_> #startmeeting container-networking
18:00:40 <openstack> Meeting started Thu Aug 20 18:00:39 2015 UTC and is due to finish in 60 minutes.  The chair is daneyon_. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:45 <openstack> The meeting name has been set to 'container_networking'
18:00:54 <daneyon_> #topic roll call
18:01:00 <adrian_otto> Adrian Otto
18:01:06 <daneyon_> o/
18:01:10 <eghobo> o/
18:01:13 <Tango> Ton Ngo
18:01:46 <tfukushima> o/
18:02:03 <s3wong> Stephen Wong
18:02:33 <apuimedo> o/
18:02:36 <suro-patz> Surojit Pathak o/
18:02:45 <hongbin>18:02:49 <hongbin> o/
18:02:51 <daneyon_> I would like to wait a minute for others to join
18:03:27 <irenab> hi
18:03:39 <apuimedo> very well
18:03:55 <daneyon_> Thank you eghobo adrian_otto Tango tfukushima s3wong apuimedo suro-patz hongbin irenab for attending the meeting
18:04:05 <daneyon_> #topic Networking Spec Update
18:04:10 <daneyon_> #link https://review.openstack.org/#/c/204686/
18:04:35 <daneyon_> Looks like the spec is in a good state
18:05:03 <daneyon_> adrian_otto is going to review. If all goes well, he will merge the spec.
18:05:06 <daneyon_> yay
18:05:24 <daneyon_> Unless their are any questions about the spec, I would like to move to the next topic.
18:05:26 <adrian_otto> I'm ready to merge this. Should I +A the spec now?
18:05:55 <daneyon_> adrian_otto sounds good
18:06:01 <daneyon_> I have organized the spec work items into the following blueprints:
18:06:02 <eghobo> adrian_otto: +1
18:06:15 <daneyon_> The magnum client blueprint:
18:06:20 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/extend-client-network-attributes
18:06:24 <daneyon_> The magnum conductor blueprint:
18:06:30 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/conductor-template-net-update
18:06:34 <daneyon_> The api blueprint:
18:06:38 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/extend-api-network-attributes
18:06:42 <daneyon_> The heat templates blueprint:
18:06:46 <adrian_otto> spec is now approved for merge
18:06:47 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/heat-network-refactor
18:06:53 <daneyon_> The baymodel objects blueprint:
18:06:57 <daneyon_> #link https://blueprints.launchpad.net/magnum/+spec/extend-baymodel-net-attributes
18:07:04 <daneyon_> thank you adrian_otto
18:07:11 <daneyon_> I have posted a few WIP patches. They are far from complete, but I’m making progress.
18:07:18 <daneyon_> Feel free to review and provide feedback, with the understanding the patches are a WIP.
18:07:22 <daneyon_> heat templates:
18:07:26 <daneyon_> #link https://review.openstack.org/#/c/214762/
18:07:34 <daneyon_> client:
18:07:41 <daneyon_> #link https://review.openstack.org/#/c/215260/
18:07:53 <daneyon_> other combined blueprints:
18:07:57 <daneyon_> #link https://review.openstack.org/#/c/214909/
18:08:30 <daneyon_> i just wanted to share this info with the team. feel free to add any feedback in the bp/review
18:09:03 <daneyon_> unless their are any questions, I would like to proceed to the Kuryr Integration Brainstorming topic.
18:09:13 <daneyon_> i'll pause for a minute
18:09:52 <Tango> If others would like to help with the patches, how do they proceed?
18:10:33 <daneyon_> Tango I have yet to touch the label/labels aspect of the spec
18:11:07 <daneyon_> remember, label/labels will be used for passing driver-specific params to the network-driver
18:11:48 <daneyon_> and we would like to implement label/labels in way that the larger magnum system can take advantage of labels for other areas.
18:12:01 <Tango> I mean just general help not specific to label
18:12:10 <hongbin> daneyon_: It looks there is no BPs for tracking neutron/libnetwork/flannel integration. Do you have any plan for that?
18:12:50 <daneyon_> hongbin kuryr integration will be a follow-on bp
18:13:00 <hongbin> K
18:14:00 <daneyon_> Tago I would cherry pick the patches, create a new topic branch that depends on the WIP patches
18:14:15 <daneyon_> Tango is that acceptable to you?
18:14:46 <Tango> daneyon_: sure, I will follow up offline
18:15:08 <daneyon_> Tango OK
18:15:32 <daneyon_> one moment please
18:15:56 <daneyon_> i'm back
18:16:02 <daneyon_> next topic
18:16:08 <daneyon_> #topic Kuryr Integration Brainstorming
18:16:15 <daneyon_> #link https://etherpad.openstack.org/p/magnum-kuryr
18:16:36 <daneyon_> can everyone please open the etherpad
18:16:54 <daneyon_> i would like to take 10 minutes for everyone to review and add to the etherpad
18:17:15 <daneyon_> any questions/comments/concerns please include in the etherpad instead of irc
18:17:18 <apuimedo> very well
18:17:54 <daneyon_> if you have added anything to the etherpad, please make sure to include your irc handle in the Contributors section
18:18:45 <apuimedo> who is the dark blue?
18:25:34 <daneyon_> apuimedo that's me.. it should show in the contributors section.
18:25:44 <apuimedo> ah, cool
18:26:03 <apuimedo> I picked orange :-)
18:32:00 <daneyon_> eghobo adrian_otto Tango tfukushima s3wong apuimedo suro-patz hongbin irenab et al lets close out the etherpad brainstorming at UTC 18:35
18:32:44 <apuimedo> ok
18:33:48 <irenab> daneyon_, apuimedo : is it going to be converted into working items for kuryr/magnum?
18:35:42 <daneyon_> irenab eventually. right now i simply want our team's to have free form discussion, brainstorming, etc..
18:36:17 <daneyon_> irenab I could see the work items develop in the near future though
18:36:34 <daneyon_> irenab do you find that acceptable?
18:36:58 <daneyon_> eghobo adrian_otto Tango tfukushima s3wong apuimedo suro-patz hongbin irenab let's bring the discussion back to irc
18:37:01 <irenab> daneyon_: yes. I am just new to such kind of discussion :-)
18:37:13 <apuimedo> ok, sorry about that :P
18:37:18 <apuimedo> I was continueing :P
18:37:31 <banix> I think the main discussion has to happen (and has partially happened) in Neutron. The main work items are to be executed there.
18:37:38 <daneyon_> I would like everyone to keep an eye on the etherpad over the next week and add to it as you see fit
18:37:41 <apuimedo> yamamoto: welcome takashi
18:38:09 <apuimedo> daneyon_: very good idea. I'll try to review it twice a day
18:38:10 <daneyon_> #action everyone to continue contributing to the kuryr/magnum networking integration etherpad
18:38:58 <daneyon_> does anyone have questions about magnum/kuryr integration that are not being covered in the ep?
18:39:40 <daneyon_> apuimedo I know kuryr is focused on bare metal for initial support.
18:39:50 <irenab> I think its quite important if there is potentially missing functionality in docker, it should be mentioned
18:40:02 <apuimedo> daneyon_: that's indeed the case. The first release targets bare-metal
18:40:06 <daneyon_> is their a kuryr bp that we can track for kuryr inside vm's?
18:40:26 <apuimedo> while we work on the first release, we work on designing for VM containers for the Magnum integration
18:41:06 <apuimedo> daneyon_: not yet, since the main purpose of VM containers for us is the integration with Magnum
18:41:20 <apuimedo> we want to condense the output of the current etherpad into a blueprint
18:41:40 <banix> apuimedo: are you suggesting kuryr will work on core neutron features? I don’t see without Neutron additional features, kuryr being to move forward on this.
18:42:05 <daneyon_> apuimedo irenab banix it would be helpful to have a list of bp's, patches, etc.. that kuryr requires from neutron to support your initial relase, i.e. https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms
18:42:10 <apuimedo> banix: we'll work with and in Neutron where necessary
18:43:21 <apuimedo> as soon as we are done with this brainstorming we have to bring the topics in the neutron meetings. Those that have some bp/spec we should collaborate with, Those that don't we have to push
18:44:29 <irenab> apuimedo: +1
18:44:51 <daneyon_> irenab agreed everyone should follow the contributing guidelines of the upstream project (i.e. libnetwork). Reviews, bp's etc should reference the upstream commit, issue, etc..
18:44:52 <hongbin> I would suggest to list all the BPs/working items in the etherpad (both Magnum and Kuryr)
18:45:27 <Tango> hongbin: +1
18:45:33 <apuimedo> hongbin: and neutron ;-)
18:45:39 <hongbin> sure
18:45:40 <daneyon_> Is contributing upstream part of the kuryr mission?
18:45:59 <banix> kuryr is upstream :)
18:46:16 <apuimedo> we are part of the Neutron project, so doing in core neutron what belongs there is essential
18:46:17 <irenab> daneyon_: upstream == docker?
18:46:34 <apuimedo> as for Docker and COEs
18:46:47 <apuimedo> I don't like maintaining repos
18:46:56 <apuimedo> so as much as I can put on their repos
18:47:02 <apuimedo> we will
18:47:05 <apuimedo> :-)
18:47:06 <daneyon_> irenab yes docker, libnetwork, kubernetes, etc..
18:47:25 <apuimedo> I initially wanted kuryr to be in-tree in libnetwork
18:47:46 <apuimedo> I was quite disappointed when they closed libnetwork to other drivers
18:47:54 <apuimedo> and it worries me for swarm
18:48:06 <apuimedo> for Kubernetes I'm sure that if we need a plugin they will be welcoming
18:48:27 <apuimedo> Mesos also looks good in that aspect
18:48:35 <irenab> daneyon_: I think at minimum we should open issues, hopefully resolve them as well :-)
18:48:40 <daneyon_> apuimedo just something to keep in mind for the kuryr project... defining the scope. If you don't contribute to the upstream projects such as libnetwork, then you may run into issues adding support you need.
18:48:41 <apuimedo> adrian_otto: how is the mesos bay type coming along?
18:48:57 <apuimedo> daneyon_: we are opening issues in libnetwork
18:49:10 <apuimedo> and we'll contribute for the things we need if they let us
18:49:20 <daneyon_> irenab that's definitly needed.
18:49:37 <apuimedo> we are already operating in this way ;-)
18:49:37 <hongbin> apuimedo: A basic support of Mesos bay type is landed
18:49:44 <apuimedo> tfukushima can show ;-)
18:49:47 <daneyon_> apuimedo That's good to hear.
18:50:02 <apuimedo> hongbin: which containerizer does it use? The docker one made in C++ ?
18:50:08 <daneyon_> We are down to our last 10 minutes, so I would like to go to our next topic
18:50:11 <banix> hockeynut: where?
18:50:24 <banix> hongbin: where?
18:50:24 <apuimedo> daneyon_: very well. Thanks for having us!
18:50:28 <daneyon_> #topic Review Action Items
18:50:47 <hongbin> apuimedo: It used the build-in docker containerizer
18:50:50 <daneyon_> apuimedo yw
18:51:03 <apuimedo> ok, that's the C++ nowadays :-)
18:51:21 <daneyon_> apuimedo I will keep kuryr integration brainstorming on the agenda for next week. It would be helpful if someone from the kuryr team could join again.
18:51:31 * daneyon_ danehans to contact tcammann to ask for an updated vote on the net spec
18:51:36 <daneyon_> complete
18:51:49 <daneyon_> tcammann gave a +2 to the spec
18:51:56 * daneyon_ danehans to send a formal request to the kuryr team for participation in our next meeting on 8/20
18:51:59 <daneyon_> complete
18:52:21 <daneyon_> and thanks to everyone from the kuryr team for joining and for the continued collaboration.
18:52:29 * daneyon_ adrian_otto formally request the Neutron/Kuryr PTL submit a Kuryr design spec.
18:52:46 <adrian_otto> completed
18:52:51 <daneyon_> I saw that adrian_otto sent the message to the ML
18:52:55 <daneyon_> thanks adrian_otto
18:53:24 <daneyon_> and here is the kuryr design spec:
18:53:28 <daneyon_> #link https://review.openstack.org/#/c/213490/
18:53:35 <daneyon_> it's a wip
18:53:42 <eghobo> adrian_otto: who is Kuryr PTL?
18:53:48 <daneyon_> it would be great if everyone could review
18:54:11 <daneyon_> #action everyone review the kuryr design spec https://review.openstack.org/#/c/186617/
18:54:42 <daneyon_> eghobo I don't believe their community has performed a ptl vote yet
18:55:05 <daneyon_> #topic Open Discussion
18:55:57 <daneyon_> I thought the clear containers thing from Intel/Rkt is interesting
18:55:59 <daneyon_> #link https://coreos.com/blog/rkt-0.8-with-new-vm-support/
18:56:35 <daneyon_> adrian_otto i hope all is well with your family thing
18:56:59 <apuimedo> daneyon_: indeed. Would you say it is like hyper but for rkt?
18:57:00 <adrian_otto> thanks daneyon_
18:57:18 <daneyon_> adrian_otto pls let me know if you need any networking related updates for your silicon valley openstack meeting
18:57:43 <daneyon_> apuimedo that's kind of how i see it
18:57:59 <adrian_otto> daneyon_: Thanks, will do.
18:57:59 <apuimedo> daneyon_: in fact, sometimes I think that it would be much, much easier to network clearcontainers and hyper
18:58:11 <apuimedo> and make K8s and swarm use them
18:58:22 <daneyon_> adrian_otto any news from GOOG regarding magnum participation?
18:58:29 <apuimedo> it's soo much easier :P
18:58:36 <adrian_otto> not yet
18:58:48 <daneyon_> adrian_otto OK, thx
18:59:09 <daneyon_> Our time is up
18:59:31 <daneyon_> Thanks to everyone for joining and have a great rest of your week!
18:59:35 <daneyon_> #endmeeting