18:00:27 <daneyon_> #startmeeting container-networking
18:00:29 <openstack> Meeting started Thu Aug 27 18:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is daneyon_. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:33 <openstack> The meeting name has been set to 'container_networking'
18:00:56 <daneyon_> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda
18:01:05 <daneyon_> #topic roll call
18:01:09 <daneyon_> o/
18:01:15 <dane_leblanc> o/
18:01:17 <Tango> o/
18:01:18 <thomasem> o/
18:01:22 <suro-patz> o/
18:02:08 <daneyon_> Thank you dane_leblanc Tango suro-patz thomasem for joining
18:02:26 <daneyon_> Lets wait until :05 for toher to join then we'll proceed
18:05:13 <daneyon_> OK, let's move forward
18:05:16 <daneyon_> #topic Review/Discuss Kuryr Design Spec
18:05:24 <daneyon_> #link https://review.openstack.org/#/c/213490/
18:06:23 <daneyon_> Lets take until :15 for everyone to review the spec and reconvene
18:06:47 <daneyon_> i'll be monitoring irc for any questions
18:07:12 <daneyon_> But that doesn't mean I have all the answers ;-)
18:08:40 <daneyon_> keep in mind the spec is a wip
18:09:44 <Tango> So to visualize how we would use kuryr:  would it be an option in the new --network-driver parameter?
18:10:13 <Tango> as an alternate to something like "flannel"
18:12:53 <daneyon_> Tango yes
18:12:59 <daneyon_> and yes
18:13:06 <dane_leblanc> Tango: That's what I would think, where magnum would then be issuing the 'sudo docker network create...' commands for Kuryr
18:13:19 <daneyon_> and then pass any kuryr config params using labels
18:13:40 <daneyon_> same approach for all network drivers
18:14:54 <daneyon_> or the other option is to pass --network-driver libnetwork and specify libnetwork's native/remote driver using --labels
18:15:16 <daneyon_> what option does the team prefer?
18:15:43 <Tango> Sounds good, we probably need to experiment with it a bit to see what works
18:15:57 <daneyon_> Tango agreed
18:16:22 <daneyon_> anyone have question re: the kuryr spec?
18:16:37 <daneyon_> i'm sure you need more time to dive into it
18:16:48 <daneyon_> Please do so and provide you comments in the review
18:17:05 <thomasem> I'm a bit of a slow reader, so I'll just add comments as I see things.
18:17:17 <Tango> They don't seem to mention performance, I wonder if that would be important to some users
18:17:25 <daneyon_> as you can see from the spec, their are still a lot of questions that need to be answered and a lot of details that need to be sorted out.
18:17:41 <daneyon_> However, I think it's headed in a good direction.
18:18:12 <daneyon_> thomasem take your time. I just wanted to use this time to get the team moving forward with reviewing
18:18:25 <thomasem> yeppers
18:18:26 <thomasem> :)
18:18:43 <daneyon_> Tango it should mention performance, so pls add a comment in the review
18:18:54 <thomasem> I'm wondering what the mental model is around handling OpenStack credentials here.
18:19:00 <thomasem> for the Magnum side of things
18:21:00 <daneyon_> the spec references supporting Magnum use cases, where performance is a use case. However, it might be a good idea to be explicit in the spec
18:21:00 <daneyon_> unless their is more discussion on the kuryr spec, I would like to move forward.
18:21:01 <daneyon_> and I'll keep the kuryr spec on our agenda for next week b/c i think it's very important for us to stay involved.
18:21:01 <daneyon_> #topic Review Kuryr Integration Brainstorming EtherPad
18:21:01 <daneyon_> #link https://etherpad.openstack.org/p/magnum-kuryr
18:21:01 <daneyon_> I have added a few add'l notes
18:21:25 <daneyon_> the kuryr team called out keeping tabs on this etherpad  during their irc meeting
18:21:54 <daneyon_> the etherpad is a bit of a mess. It will get cleaned up soon.
18:22:38 <daneyon_> thomasem their are some good notes related to auth in the kuryr integration brainstorming ep
18:22:46 <thomasem> looking now
18:22:51 <daneyon_> thomasem thx
18:22:51 <thomasem> thank ya muchly!
18:23:17 <daneyon_> lets have everyone review the etherpad until :35
18:23:30 <daneyon_> I'll be monitoring irc for any questions
18:23:42 <daneyon_> but let's try to keep as much as possible in the ep
18:24:19 <daneyon_> pls put your handle under Contributors if you add to the ep
18:31:38 <daneyon_> t- 4 min
18:36:14 <daneyon_> OK, let's move on
18:37:05 <daneyon_> We'll keep this topic for next week
18:37:40 <daneyon_> i know we are all busy and it's nice having time during this meeting to dive into these efforts
18:37:48 <daneyon_> #topic Review Action Items
18:37:58 * daneyon_ everyone to continue contributing to the kuryr/magnum networking integration etherpad
18:38:15 <daneyon_> I have added to the ep and I know others have
18:38:19 <daneyon_> pls continue to do so
18:39:02 <daneyon_> Again, in the next week or 2, I'll start organizing the ep into actionable steps
18:40:04 <daneyon_> #action danehans to take action next week on organizing the kuryr etherpad into actionable steps
18:40:13 <daneyon_> an action for an action
18:40:16 <daneyon_> crazy
18:40:21 * daneyon_ everyone review the kuryr design spec https://review.openstack.org/#/c/186617/
18:40:35 <daneyon_> I have reviewed and commented on the kuryr design spec
18:40:38 <daneyon_> I know other have too
18:40:45 <daneyon_> pls continue to do so.
18:40:57 <daneyon_> those are the only actions from last week
18:41:01 <daneyon_> #topic Open Discussion
18:41:15 <daneyon_> I’ve been plugging away at the Magnum net spec bp’s and wip patches:
18:41:20 <daneyon_> #link http://eavesdrop.openstack.org/meetings/container_networking/2015/container_networking.2015-08-20-18.00.html
18:42:33 <thomasem> daneyon_: Has anyone been able to step up to help cover that work?
18:42:34 <daneyon_> i have a working setup where i can define --network-driver flannel or not specify a driver and the k8s coe uses flannel (b/c it's the default) using my wip patches
18:43:08 <daneyon_> I have been turning my attention towards labels so we can pass in params to the driver
18:43:29 <daneyon_> b/c without labels, only driver default settings will be applied
18:43:57 <daneyon_> thomasem a few people have contacted me saying they are going to test the wip patches
18:44:04 <thomasem> Gotcha
18:44:08 <daneyon_> It would be great if everyone could test
18:44:27 <Tango> Will do
18:44:32 <daneyon_> #action everyone test network-driver wip patches
18:44:38 <daneyon_> #link http://eavesdrop.openstack.org/meetings/container_networking/2015/container_networking.2015-08-20-18.00.html
18:44:58 <thomasem> daneyon_: Great. Thanks. Just got some work moved off my plate recently, so going to take a stab at whether I can finally get some time to actually work on this stuff.
18:45:09 <daneyon_> if you add to any of them, please make sure to include yourself as a co-author
18:45:11 <thomasem> And stop being *that* guy in the room.
18:45:31 <daneyon_> adding the network-driver attribute was not too bad. Labels is a whole different story
18:45:41 <thomasem> lol
18:45:50 <daneyon_> partially b/c magnum supports labels for pods
18:46:07 <thomasem> Well, are you wanting to include, like, validation and what-not for each driver?
18:46:09 <daneyon_> 1 moment pls
18:46:56 <daneyon_> I am reviewing Glance code as a reference model for labels
18:47:25 <thomasem> Ah
18:47:36 <daneyon_> Glance supports the --property <key=value> attribute that appears to be very similar to what we're trying to accomplish with labels.
18:48:02 <daneyon_> we need conductor to parse the labels being passed into heat parameters.
18:48:31 <daneyon_> thomasem no worries
18:48:41 <Tango> Heat has something similar also with --parameters
18:49:17 <daneyon_> thomasem i would like to validate the driver being supplied. I believe someone provided a comment on that very topic
18:49:24 <daneyon_> feel free to add
18:49:33 <thomasem> Gotcha
18:49:40 <daneyon_> atm, i would like to keep my focus on the label support
18:49:54 <thomasem> Yeah... I mean even a straight pass through is better than nothing at this point.
18:49:59 <daneyon_> Tango can you please provide a link
18:50:01 <thomasem> Fail-fast from validation is more a nice-to-have, really
18:50:06 <thomasem> :P
18:50:16 <daneyon_> agreed
18:51:23 <daneyon_> Tango if you can not find a link to what you;re referencing, pls send it to me by irc afterward
18:51:58 <Tango> Yep, I used to work around this code in Heat
18:52:21 <daneyon_> It will be easier to just pass along all the labels unparsed to heat and have heat fail the stack create if the labels are incorrect. But maybe I'm wrong.. just trying to investigate options
18:53:43 <daneyon_> We are running near the end of the meeting.
18:53:54 <daneyon_> Does anyone else have open discussion items?
18:54:10 <daneyon_> Otherwise, we'll close early and get back to work :-)
18:54:38 <daneyon_> OK
18:54:43 <daneyon_> That's a wrap.
18:54:48 <daneyon_> Have a great day!
18:54:57 <Tango> Thanks!
18:55:14 <daneyon_> #endmeeting