18:00:54 <daneyon_> #startmeeting container-networking
18:00:54 <openstack> Meeting started Thu Sep  3 18:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is daneyon_. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:58 <openstack> The meeting name has been set to 'container_networking'
18:01:08 <daneyon_> Agenda
18:01:09 <daneyon_> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda
18:01:24 <daneyon_> #topic roll call
18:01:40 <dane_leblanc> o/
18:01:47 <Tango> o/
18:01:52 <VikasC> o/
18:02:17 <s3wong> hello
18:02:27 <thomasem> o/
18:02:53 <adrian_otto> Adrian Otto
18:03:11 <daneyon_> Thank you adrian_otto dane_leblanc Tango VikasC s3wong thomasem for attending the meeting.
18:03:20 <daneyon_> #topic Review/Discuss Kuryr Design Spec
18:03:24 <manjeets_> Manjeet Singh bhatia
18:03:30 <daneyon_> #link https://review.openstack.org/#/c/213490/
18:03:41 <daneyon_> manjeets_ thanks for joining
18:03:47 <VikasC> Vikas Choudhary
18:03:52 <daneyon_> I have reviewed the spec several times
18:04:15 <daneyon_> I would like to take 10 minutes for everyone to review the latest patch set
18:04:29 <daneyon_> pls provide your comments in the review
18:06:29 <manjeets__> ._.
18:06:31 <daneyon_> My latest feedback revolves around support for the Kubernetes pluggable networking model. The spec is focused on libnetwork, but addresses support for Kubernetes. Unfortunately, Docker and Google are not on the same page with container networking.
18:06:58 <daneyon_> Let me find a link to k8s pluggable networking
18:07:51 <daneyon_> Lets reconvene at :15 after
18:08:50 <daneyon_> #link https://github.com/kubernetes/kubernetes/blob/master/pkg/kubelet/network/plugins.go
18:08:57 <Tango> The spec mentions having Kuryr as containerized Neutron plugin for deployment.  I wonder how it would be compatible across the different coe's we support
18:11:53 <daneyon_> Tango are you familiar with project Kolla?
18:12:07 <manjeets__> is kuryr still under construction ?
18:12:18 <Tango> daneyon_: Just at the high level
18:12:30 <daneyon_> manjeets__ yes, from a design and implementation standpoint
18:12:57 <daneyon_> manjeets__ this spec is what will set the stage for what kuryr is and is not
18:13:15 <daneyon_> work is being done to move the project along in the meantime.
18:13:30 <manjeets__> i clicked their documentation link it said not found http://docs.openstack.org/developer/kuryr
18:13:35 <manjeets__> ok
18:15:18 <daneyon_> Tango to your question, magnum coe's should not matter. Regarding "having Kuryr as containerized Neutron plugin for deployment", a project such as Kolla can deploy kuryr as a container instead of as a bunch of pkg's to a host.
18:15:47 <manjeets__> will there be a same network driver that will work for all kind of coe's . i see kuryr is for docker and flannel ( I assume for k8s) correct if wrong ?
18:15:53 <daneyon_> manjeets__ I would start here:
18:15:57 <daneyon_> #link https://github.com/openstack/kuryr
18:16:41 <daneyon_> manjeets__ take a look at my comment in the patch set and the kubernetes link I provided above.
18:17:12 <manjeets__> can you please resend i lost that sorry
18:18:17 <adrian_otto> Kuryr does not need to be the answer for all of Magnum's needs
18:18:41 <daneyon_> docker and kubernetes have their own pluggable networking model. kuryr will need to decide if it will focus only on Docker or both. It would be ideal if kubernetes' pluggable networking and Docker's libnetwork would merge, but that is not happening
18:18:42 <adrian_otto> but for the bay types that support libnetwork, it should be sure to work for our use cases
18:19:02 <daneyon_> k8s pluggable networking, implemented in the kubelet:
18:19:04 <daneyon_> ##link https://github.com/kubernetes/kubernetes/blob/master/pkg/kubelet/network/plugins.go
18:19:07 <daneyon_> #link https://github.com/kubernetes/kubernetes/blob/master/pkg/kubelet/network/plugins.go
18:19:45 <daneyon_> adrian_otto agreed.
18:20:05 <Tango> Is Docker's definition of service equivalent to Kubernetes' ?  They don't seem to be, but the spec seems to suggest they are.
18:20:11 <daneyon_> any other discussion related to the kuryr design spec?
18:20:34 <daneyon_> I suggest spending time after the meeting to review the spec in more detail.
18:21:25 <daneyon_> #action everyone to spend additional time reviewing the kuryr design spec in more detail.
18:22:01 <daneyon_> Tango you are correct. services in Docker != services in k8s
18:22:22 <daneyon_> Tango please provide feedback to your point in the review
18:22:24 <Tango> daneyon_: I will add some comments to the review
18:22:32 <daneyon_> Tango thx
18:22:45 <daneyon_> ok, next topic
18:22:48 <daneyon_> #topic Review Kuryr Integration Brainstorming EtherPad
18:22:55 <daneyon_> #link https://etherpad.openstack.org/p/magnum-kuryr
18:23:23 <daneyon_> The kuryr team has done a good job providing input to the etherpad
18:23:43 <daneyon_> I would like everyone to take 10 or so minutes reviewing the etherpad.
18:23:52 <daneyon_> pls provide any comments, etc.. in the etherpad
18:24:15 <daneyon_> pls make sure your handle is listed under contributors if you add anything to the etherpad
18:24:41 <daneyon_> let's reconvene at :35 past the hour.
18:25:46 <daneyon_> I will be working with gsagie from the kuryr team to clean up the etherpad into actionable steps in the next week.
18:33:14 <daneyon_> t- 2 min
18:35:04 <daneyon_> As with the kuryr design spec, the magnum/kuryr integration etherpad is a lot to digest in 10+ minutes. I encourage everyone to take time after the meeting to review the ep in more detail.
18:35:29 <VikasC> sure
18:35:30 <daneyon_> #action everyone to review the kuryr/magnum integration etherpad in more detail.
18:35:39 <daneyon_> thx VikasC
18:35:40 <thomasem> yep yep
18:35:54 <manjeets__> ok sure
18:36:12 <daneyon_> unless their are any question on the ep, i would like to proceed.
18:36:31 <daneyon_> Again, I will be working with gsagie from the kuryr team to clean up the etherpad into actionable steps in the next week.
18:36:46 <Tango> That will make the ep much easier to digest
18:36:58 <daneyon_> Hopefully during our next meeting, we will be reviewing a friendlier version of the ep :-)
18:37:09 <daneyon_> Tango agreed 100%
18:37:35 <daneyon_> #topic Review Action Items
18:37:48 * daneyon_ danehans to take action next week on organizing the kuryr etherpad into actionable steps
18:38:05 <daneyon_> This was discussed during this week's kuryr meeting.
18:38:33 <daneyon_> I will be contacting gsagie tomorrow and we will start working together to organize the integration bp.
18:39:14 <daneyon_> #action danehans work with gsagie to organize the integration ep before next meeting.
18:39:25 * daneyon_ everyone test network-driver wip patches
18:40:01 <daneyon_> since these are WIP patches, i have been making a lot of changes on a daily basis. Pls make sure you are using the latest patch sets
18:40:14 <daneyon_> Has anyone had a chance to test the WIP patches?
18:40:31 <daneyon_> If not, I will carry this action item forward.
18:40:46 <dane_leblanc> I've been testing some, not the latest as of today though.
18:40:53 <daneyon_> I am not too concerned if no one has tested them since they still need a fair bit of work
18:40:58 <VikasC> will do
18:41:00 <Tango> I only review so far.  Do we need to download all of them together to test?
18:41:46 <daneyon_> OK dane_leblanc. Pls get the very latest patch sets b/c they are definitly needed. I broke things over the last few days and think I have them in a working order again.
18:41:55 <daneyon_> Tango yes
18:42:06 <daneyon_> full functionality is still not there.
18:42:22 <daneyon_> I am working through the template defintions/entrypoints.
18:42:57 <daneyon_> I am trying to figure out the best way to pull the individual k/v pairs within the labels dict into heat params.
18:43:58 <daneyon_> seems like extra_params will not fit the alebls use case since we are not creating a new attr, but parsing an existing attr (i.e. lables dict), taking the keys from the dict and mapping them to heat params
18:44:25 <daneyon_> still trying to wrap my head around the set_param, get_param, etc.. methods in template_def.py
18:44:51 <daneyon_> but.. on a more positive note, I think most of the other func is there.
18:46:03 <daneyon_> you can see what my baymodel looks like here:
18:46:07 <daneyon_> #link https://gist.github.com/danehans/6aeb2984120ebb437e66
18:46:38 <daneyon_> as i try to pass flannel config params by using --labels
18:47:20 <Tango> Looks straightforward
18:47:29 <VikasC> agree
18:47:42 <daneyon_> the example above is only using the labels patch, that's why you do not see the network-driver attr
18:48:09 <Tango> right, I was just about to ask :)
18:48:14 <daneyon_> #action everyone test network-driver wip patches
18:49:09 <daneyon_> Tango :-) adding the network-driver patch is my next step after our meeting
18:49:21 <daneyon_> #topic Open Discussion
18:49:33 <daneyon_> Anyone have open discussion itmes?
18:49:48 <daneyon_> Otherwise we'll end the meeting a few minutes early.
18:50:16 <daneyon_> OK
18:50:26 <Tango> Did we have an entry on networking discussion for the design summit?
18:51:04 <daneyon_> ^ adrian_otto
18:51:34 <daneyon_> Tango I iadded abunch of stuff to the planning etherpad sdake put together last week
18:52:14 <Tango> It might be a good opportunity for a high bandwidth work session with the Kuryr folks
18:52:17 <daneyon_> adrian_otto do you know the latest on what magnum talks will be included for the design summit?
18:52:29 <daneyon_> s/talks/topics/
18:52:38 <adrian_otto> that's in progress now
18:52:52 <adrian_otto> I'm working out the room quantities with ttx
18:53:11 <daneyon_> #action danehans to coordinate with kuryr team on a design summit session.
18:53:22 <daneyon_> adrian_otto thx.
18:53:29 <adrian_otto> we should explicitly plan a joint session
18:53:48 <daneyon_> adrian_otto I'll also see what can be done with the kuryr team.
18:53:52 <adrian_otto> and probably also during part of our all day Friday meetup
18:54:12 <daneyon_> adrian_otto I took action on it. I'll have an update for our meeting next week.
18:54:38 <daneyon_> adrian_otto OK
18:54:54 <daneyon_> Any other open discussion?
18:55:24 <daneyon_> OK, thanks for attending and have a great rest of your week.
18:55:34 <daneyon_> #endmeeting