22:00:27 <adrian_otto> #startmeeting containers
22:00:28 <openstack> Meeting started Tue May 20 22:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:32 <openstack> The meeting name has been set to 'containers'
22:00:40 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2014-05-20_2200_UTC Our Agenda
22:00:45 <apmelton> o/
22:00:46 <adrian_otto> #topic Roll Call
22:00:47 <ewindisch> o/
22:00:48 <adrian_otto> Adrian Otto
22:00:52 <Slower> o/
22:00:57 <Slower> Ian Main
22:01:03 <apmelton> Andrew Melton, @Rackspace, Nova Libvirt-lxc support
22:01:13 <ravips> Ravi
22:01:22 <paulczar> Paulczar
22:01:24 <funzo> chris alfonso
22:02:09 <ewindisch> <- Eric Windisch. @Docker
22:02:19 <adrian_otto> we will do a round of introductions in a moment
22:02:24 <adrian_otto> since this is our first meeting
22:02:34 <adrian_otto> so you are welcome to jsut leave it at a wave right now if you prefer
22:02:57 <adrian_otto> I will chill for just a moment for additional attendees
22:03:03 <s1rp> Rick Harris @ Rackspace
22:04:59 <adrian_otto> #topic Welcome
22:05:06 <adrian_otto> Welcome everyone. The purpose of this team, and our regularly scheduled meeting
22:05:06 <adrian_otto> is to find common ground for supporting containers in OpenStack. Our first few
22:05:07 <adrian_otto> meetings will be to let us get a clear understanding of what our espective
22:05:07 <adrian_otto> interests are so we can work together to identify what options we want to
22:05:07 <adrian_otto> consider and reach a comfortable consensus we can all accept.
22:05:35 <adrian_otto> the meeting schedule alternates because we have stakeholders in numerous timezones
22:05:46 <adrian_otto> thank you for coming today to get us started.
22:05:57 <adrian_otto> #topic Announcements
22:06:06 <adrian_otto> We have an #openstack-containers IRC Channel
22:06:13 <adrian_otto> #link https://review.openstack.org/94041 Adding #openstack-containers IRC bot
22:06:39 <adrian_otto> the purpose of the channel is to have breakout discussions and in depth conversations that are logged
22:07:19 <adrian_otto> if there are action items from our meetings each week, this is when we would normally review those. I am skipping that because this is our first meeting.
22:07:30 <adrian_otto> #topic Introductions
22:07:33 <adrian_otto> I will start
22:08:06 <adrian_otto> in this section what I'd like to do is give members of the team an opportunity to introduce themselves, and say whay they work on and why they take an interest in Containers in OpenStack
22:08:17 <adrian_otto> this is totally voluntary
22:08:33 <adrian_otto> I'm Adrian Otto. I am a Principal Architect at Rackspace, and PTL for Solum.
22:09:05 <adrian_otto> I want container functionality, like what we get form nova-docker today, plus more to support CI/CD use cases for openstack end users
22:09:28 <adrian_otto> I hope to serve you all as a moderator and advocate for the OpenStack user community
22:09:37 <adrian_otto> who would like to go next?
22:09:39 <funzo> cool, thx adrian_otto
22:09:56 <funzo> I'll go :) I'm Chris Alfonso, I work with the OpenShift team at Red Hat
22:10:30 <funzo> I'm intersted in having first class container support in OpenStack for a number of reasons, but at the end of the day I want to run OpenSHift on OpenStack
22:10:39 <s1rp> Rick Harris, Dev @ Rackspace, would like to work on exposing more process-like container support via Nova
22:11:01 <Slower> I'm Ian Main, working at Red Hat.  Currently supporting nova docker integration but also interested in generic container support for openstack
22:11:23 <apmelton> I'm Andrew Melton, Software Developer at Rackspace. I'm working on improving libvirt-lxc support in Nova.
22:11:27 <paulczar> Paul Czarkowski,  not quite operator, not quite developer, but definitely not a devop at Rackspace on the Solum team.   My main interest is on application focused containers ( vs OS containers ) in openstack with a heavy slant towards Docker
22:11:38 <jeckersb> John Eckersberg here, also from the Red Hat openstack team, and also interested in generic container support for openstack :)
22:11:39 <ravips> I'm Ravi Sankar Penta from Red Hat and I wanna understand what exactly Containers project is going to solve? common wrapper for different container technologies?
22:11:59 <ewindisch> I’m Eric Windisch. I’m lead of OpenStack integration at Docker. As far as this group goes, I’m interested in containers that support microservices (process-level) and in creating new extensiosn that support containers-based use-cases
22:12:30 <ewindisch> I work at Docker and on the nova-docker driver, but I’m interested in sharing code with other Linux containers technologies whereever possible
22:13:14 <adrian_otto> awesome, everyone.
22:13:39 <adrian_otto> In the next section I have an etherpad where we can begin to record our interests:
22:13:52 <adrian_otto> you are welcome to drop in your introduction at any time
22:14:00 <adrian_otto> so please continue if you are still watching
22:14:12 <adrian_otto> #Topic Shared Interests
22:14:14 <adrian_otto> #link https://etherpad.openstack.org/p/containers Containers Etherpad
22:14:29 <adrian_otto> the purpose of this exercise is to surface what we might be tempted to argue about
22:14:38 <adrian_otto> not to actually have any debate yet
22:14:49 <funzo> adrian_otto: I disagree
22:14:50 <funzo> :)
22:15:03 <adrian_otto> heh
22:15:19 <adrian_otto> but I think it's important with any controversial subject to make your interests clear so we can arrive at compromise
22:15:28 <adrian_otto> rather than arguments that waste our time
22:15:57 <adrian_otto> I want you all to feel that this is a productive use of your time, and we will continue the meeting series for as long as we feel this is making a positive impact
22:16:19 <adrian_otto> so please take a moment to record in the etherpad whatever your sacred cows are.
22:16:41 <adrian_otto> so that we can know about them, respect them, and come up with sensible middle ground
22:17:42 <adrian_otto> good, I see that we are putting our controversial topics in, that's what we need to do at this stage
22:21:02 <paulczar> should we just +1 where people have already stated things we’re interested in ?
22:21:14 <adrian_otto> yep, this is free form
22:21:20 <adrian_otto> I do ask that you put your name in your color
22:21:34 <adrian_otto> looks like Eric and I are using the same color
22:22:55 <ewindisch> fixed
22:23:23 <adrian_otto> tx
22:23:31 <harlowja> alright, etherpad keeps on disconnecting :(
22:24:03 <adrian_otto> hi harlowja
22:24:18 <adrian_otto> did you wand to make a quick introduction for those who don't know you yet?
22:24:33 <harlowja> sureeee ;)
22:24:46 <harlowja> josh harlow, one of the tech leads @ yahoo openstack team :)
22:24:51 <harlowja> work on various things, haha
22:25:48 <ewindisch> it’s reflected in the doc, but I’m seriously concerned about the DefCore issues. The main reason that containers are struggling for adoption is because the DefCore effort is pushing the PTLs toward an uncertain future of what should and shouldn’t be supported… on the other hand, if we don’t get the drivers into “core projects”, then containers cannot be first-class citizens
22:26:13 <paulczar> for new arrivals - https://etherpad.openstack.org/p/containers Containers Etherpad
22:26:31 <adrian_otto> tx paulczar
22:26:51 <adrian_otto> ewindisch: Good, that;s something to record in the interests section
22:27:06 <adrian_otto> basically anything you think is worth arguing about, we should find a way to express
22:27:21 <adrian_otto> and then we can ask questions of each other to better understand them
22:35:01 <adrian_otto> Okay good, so the reason I'm asking you to help me articulate the pro/con of the various implementation options is to tease out what your interests are
22:35:57 <adrian_otto> we don't have to design an implementation plan right away, but let's continue filling out the for/against arguments for each to see which of them we should claim as an interest and put in our section at the top
22:36:04 <harlowja> sounds good
22:37:10 <s1rp> ewindisch: didn't sam alba have an initial spec for a CaaS?
22:37:31 <ewindisch> s1rp: there was a CaaS proposal at one point, yes. I think it came from the OpenShift guys, actually
22:37:41 <ewindisch> I didn’t really like it very much, to be honest.
22:37:43 <s1rp> ewindisch: ah gotcha
22:38:07 <s1rp> ewindisch: yeah, we had one meeting to discuss it and disbanded, so guess that was the consensus
22:39:41 <adrian_otto> ewindisch: you are welcome to post a reference to that today in our chat for future reference. Maybe on our next agenda we can bring a critique of that proposal, and see if there are ways it could be made more attractive.
22:40:51 <adrian_otto> ok, so we have 20 minutes remaining for today. I like the exercise we are trying now, and we should continue that. We also have some other business to take care of. So I will ask us to revisit this etherpad when we come back to Open Dicsussion
22:41:10 <adrian_otto> and if you know of other stakeholders, please pull them in and have them add to the etherpad
22:41:19 <ewindisch> it might be getting ahead, but I’d like to discuss some Cinder stuff at some point, maybe in open discussion
22:41:33 <adrian_otto> I will take an editorial pass through the etherpad and begin making it into wiki pages
22:41:49 <adrian_otto> ewindisch: good, let's get to that in a moment.
22:42:04 <adrian_otto> #topic Nova sub-team
22:42:53 <adrian_otto> I intentionally made this a non-nova team, not because I think it's a non-nova issue, but because I think it's important to look at containers from a wider perspective, and explore all possible options for including them
22:43:09 <adrian_otto> ok, I exaggerated. Not all *possible* options, but a number of viable options
22:43:32 <adrian_otto> and if there are other choices that we did not think of today, let's record those and consider them.
22:43:37 <adrian_otto> If we plan to also act as a Nova sub-team, one of us will need to attend the Nova meeting regularly to report our status. Volunteers who are already attending?
22:44:34 <adrian_otto> or if we don't have a natural first choice for this, would you like me to attend and represent us?
22:45:23 <ewindisch> adrian_otto: I’m okay with that...
22:45:24 <adrian_otto> wow those are loud crickets!
22:45:25 <ewindisch> also, Michael has made it clear that he wants the defacto driver-stakeholders to be in attendance.
22:46:04 <adrian_otto> yes, I expect a larger group the weeks we have a 1600 UTC meeting time
22:46:13 <adrian_otto> like next week
22:47:25 <adrian_otto> #agreed until further notice, adrian_otto will attend Nova team meetings to report status of the OpenStack Containers Team as a Nova sub-team (if desired by Nova stakeholdrs)
22:47:41 <adrian_otto> #topic Open Discussion
22:47:48 <ewindisch> Cinder -
22:47:54 <adrian_otto> there is a discussion point here from danpb
22:48:02 <adrian_otto> •	Examine/enumerate use cases / scenarios for containers which do not require cinder storage, to demonstrate that cinder should be considered optional for Nova driver inclusion (Daniel Berrange / danpb)
22:48:15 <adrian_otto> ewindisch: is that the topic you meant?
22:48:23 <ewindisch> not exactly.
22:48:32 <ewindisch> but it’s a good point that we should push on making it optional
22:48:42 <adrian_otto> ok, let's clear your subject first, and come back to Daniel's
22:49:05 <paulczar> +1 on that …  if we insist that everything in openstack behaves like things in openstack then containers will just look like vms
22:49:13 <ewindisch> I’ve looked at actually implementing it, regardless of the necessity
22:49:45 <ewindisch> getting devices into the containers is easy. The main problem is that all the volume backends need support, just like the neutron drivers
22:50:01 <ewindisch> the good news is that the code in libvirt will work for containers with few modifications…
22:50:17 <ewindisch> but we’d need to generalize that code and somehow do so in a way that is agreeable upstream with our drivers being out of tree
22:51:04 <adrian_otto> my understanding is that we have the libvirt stakeholders in the openstack community already
22:51:08 <ewindisch> but in general, it seems that the functionality isn’t hard to implement, even if the inner-container experience is different than on a VM
22:51:34 <adrian_otto> I'd like to track down which Stackers also work on libvirt so we can include them for guidance
22:51:59 <ewindisch> and the block devices aren’t USELESS inside a container, they’re just not mountable… there are things we might want to bring those block devices in for that don’t require SYS_CAP_MOUNT
22:52:50 <ewindisch> anyway, the point isn’t to delve into SHOULD we, but that it seems we CAN… at least on Linux.
22:52:55 <adrian_otto> ewindisch: for those not familiar with the drawbacks of SYS_CAP_MOUNT, why don't you explain the security concern about that
22:53:31 <paulczar> my thoughts is we push back on the cinder stuff and have nova agree it’s not path critical and we can focus on features that make sense for early adopters of the driver
22:53:39 <ewindisch> Linux capabilities prevent or allow from doing  things on the OS. If we allow mounting filesystems inside a container, we can easily break out of the container
22:53:54 <ewindisch> paulczar: I agree, but I want to separate the concerns…
22:54:13 <ewindisch> concern 1) can we implement cinder support and 2) must we implement cinder support
22:54:18 <adrian_otto> ok, we have about 5 minutes left
22:54:21 <grapex> ewindisch: My understanding is that as of a year back, libvirt had some rough spots when it came to running certain container technologies like OpenVZ. I talked to someone from parallels who was convinced the only way forward was to use libcontainers as a driver.
22:54:48 <ewindisch> I think #1 is “YES we can”
22:54:56 <ewindisch> grapex: that’s a whole other kettle of fish ;-)
22:55:17 <ewindisch> adrian_otto: do you want to move to #2, Daniel’s concern of “must we implement?"
22:55:49 <adrian_otto> yes, for a moment. In a couple of minutes I will call for agenda items for next Tues, and action items between now and then
22:56:11 <grapex> When we say optional, it means containers could use Cinder, but wouldn't have to- right?
22:56:30 <adrian_otto> I see no drawback in asking for homefwork from today's attendees to comply with Daniel's request to enumerate non-cinder use cases
22:56:52 <adrian_otto> we can put those into the etherpad, right?
22:57:01 <ewindisch> grapex: that’s my opinion. We should make them optional, where we can but don’t have to (I’m working on making it work, although we’d like not to HAVE to support cinder)
22:57:16 <grapex> ewindisch: Sounds fair.
22:57:36 <adrian_otto> ewindisch: +1. I'D like to be able to offer an option to support it
22:57:55 <ewindisch> back to DefCore @Cinder — an openstack installation with containers that doesn’t support Cinder won’t be allowed to use the trademark…
22:57:57 <adrian_otto> because we know there are use cases for it, and reasons that it is desired
22:58:09 <ewindisch> but, I don’t think  Nova should prevent us from merging just because of the DefCore perspective
22:58:21 <grapex> ewindisch: +1
22:58:33 <adrian_otto> so , for next week, I will post to the Meetings/Containers wiki page a skeleton agenda today
22:58:50 <adrian_otto> and you are welcome to add your items to that agenda
22:59:00 <adrian_otto> if you do not already subscribe to that page, I recommend it.
22:59:08 <adrian_otto> so that you get emailed when it is edited.
22:59:33 <adrian_otto> Thanks everyone for attending, and I will follow up with more between now and next meeting on the ML prefixed with [Containers]
22:59:39 <harlowja> sounds good to me
22:59:40 <adrian_otto> edit your mail filters as needed
22:59:42 <ewindisch> thank you Adrian for putting this together
22:59:53 <grapex> Thanks Adrian!
23:00:00 <adrian_otto> my pleasure. Thanks again everyone for your time and attention to this important subject.
23:00:06 <adrian_otto> #endmeeting