22:00:30 <erw> #startmeeting containers
22:00:31 <openstack> Meeting started Tue Jul 15 22:00:30 2014 UTC and is due to finish in 60 minutes. The chair is erw. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:35 <openstack> The meeting name has been set to 'containers'
22:00:39 <apmelton> o/
22:00:46 <thomasem> o/
22:00:46 <erw> Roll call
22:00:52 <thomasem> Thomas Maddox
22:00:58 <apmelton> Andrew Melton
22:01:00 <erw> Eric Windisch
22:01:30 <erw> that’s it?
22:01:42 <erw> alright.
22:01:47 <iqbalmohomed> Hello everyone
22:01:51 <erw> hello
22:02:03 <erw> #topic Announcements
22:02:12 <s1rp_> o/
22:02:22 <s1rp_> Rick Harris
22:02:30 <erw> anyone that shows up is welcome to announce themselves at any point.
22:02:43 <iqbalmohomed> Iqbal Mohomed, IBM Research
22:02:44 <erw> Announcing the mid-cycle meetup for July 28th-21st
22:02:51 <erw> *31st
22:03:07 <erw> Beaverton, Oregon (outside of Portland). Intel campus.
22:03:27 <erw> co-located with the Nova meetup, but note that we have one extra day.
22:03:38 <erw> don’t make a mistake and only book for the 30th… we’re staying until the 31st. :)
22:03:40 <erw> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040095.html
22:04:08 <erw> any questions / issues/ concerns with the mid-cycle?
22:04:46 <erw> okay then… if anyone has issues or concerns, bring it up in open discussion.
22:04:55 <erw> any other announcements?
22:05:02 <thomasem> What's the schedule looking like for the 31st? I have a flight out at 6PM that day.
22:05:25 <Guest80176> Maxim Nestratov, Parallels
22:05:49 <erw> thomasem: I believe we have a breakout room all week, so tbd.
22:05:57 <thomasem> Okay, cool.
22:06:06 <thomasem> If that's the case, then awesome
22:06:07 <thomasem> =]
22:06:09 <erw> thomasem: from the Icehouse mid-cycle, however, I’d say that we tend to get out by 5pm.
22:06:20 <thomasem> Ah
22:07:01 <thomasem> Wells, I'll have to keep that in mind. Might just have to bugger off a bit early.
22:07:26 <erw> sorry. I’m sure we’ll all have a better idea for the next meetup, after we do this one.
22:07:36 <erw> last call for announcements
22:07:47 <erw> #topic Review Action Items
22:07:52 <thomasem> Okey dokey
22:07:59 <erw> "Eric Windisch to check with Mikal for guidance on the best approach for submitting specification drafts for community discussion"
22:08:29 <erw> I spoke to Mikal, and he deferred to the mailing list and the mid-cycle meetup.
22:09:18 <erw> the mid-cycle is where Nova has, in general, decided to make this determination - as to where/when to take K specs
22:09:31 <erw> John Garbutt actually sent out an email just today about a similar topic. He wants to start discussing and locking down how K will handle specs.
22:09:46 <erw> Mikal suggests we sound-off in response to that thread
22:10:07 <erw> no other action items, and this segways to Status on Proposal Process
22:10:12 <funzo> o/ - late
22:10:17 <erw> (btw, our agenda is: https://wiki.openstack.org/wiki/Meetings/Containers)
22:10:29 <erw> #topic Status on Proposal Process
22:10:36 <erw> has anyone made progress on proposals?
22:11:49 <erw> last meeting, we were discussing the creation of an etherpad and individual efforts to create these specs
22:12:17 <erw> I volunteered to work on a spec, but I have not yet had the cycles to do it.
22:12:34 <erw> adrian_otto had also suggested he would work on a spec, but he is on PTO
22:13:05 <erw> if nobody else… then I will propose we link an etherpad for further collaboration offline
22:13:33 <erw> beuller?
22:13:38 <apmelton> +1 on the etherpad, it would allow people to contribute when they're free
22:13:45 <thomasem> +1 from me also
22:13:52 <apmelton> instead of at these specific times
22:13:53 <dguryanov> +1
22:14:01 <Guest80176> +1
22:14:04 <thomasem> Yep, it'll let us utilize our more productive cycles
22:14:19 <dguryanov> Let's create it right now, so all people here will have a link
22:14:28 <funzo> sure, makes sense
22:14:29 <erw> #link https://etherpad.openstack.org/p/containers-service-k-spec-discuss
22:14:34 <dguryanov> Thanks
22:14:38 <thomasem> perfect
22:14:46 <erw> lets have a moment to fill in some basics there
22:17:08 <erw> okay- done.
22:17:48 <erw> attendees: if you think someone might want to contribute to this spec process, please bring it to their attention and have them contact either Adrian Cole or myself.
22:18:17 <thomasem> Sounds good to me.
22:18:18 <erw> anything else?
22:18:59 <erw> #topic Open Discussion
22:19:17 <erw> so I’d like to also suggest we put together and etherpad of topics we’d like to discuss at the mid-cycle
22:19:55 <erw> I think the spec discussion will be a big part of that, but we can work on listing any other concerns, questions, etc that we might have as a group.
22:20:05 <thomasem> I added one regarding libvirt-lxc tempest test support to the main mid-cycle one... would that fit in both?
22:20:20 <adrian_otto> sorry to drop in late. I just have a moment to share one idea
22:20:22 <funzo> erw: https://etherpad.openstack.org/p/containers-service-juno-midcycle-topics
22:20:28 <erw> thomasem: it’s almost a good point that we might simply extend that one
22:20:42 <erw> (that is, if that was your point: it would be a good one)
22:21:20 <erw> adrian_otto: please.
22:21:25 <thomasem> Okay, yeah. I'll reference it.
22:21:27 <erw> should we decide/vote on our own etherpad, or sharing in NOva’s?
22:21:43 <thomasem> Oh, I think I see what you mean
22:21:44 <thomasem> lol
22:21:46 <adrian_otto> I had suggested that we meet on 7/31 after the Nova Meetup concludes. After discussing with Mikal, I think maybe we should not
22:22:10 <adrian_otto> we will get a dedicated breakout room for 7-28 - 7/30
22:22:24 <adrian_otto> but apparently Nova devs get grouchy after 3 days.
22:22:34 <erw> adrian_otto: you might have just scored me a free day in Portland
22:22:35 <adrian_otto> Might be counter-productive to try to meet too long
22:22:52 <thomasem> I don't think the main mid-cycle etherpad is too crowded to include our stuff, tbh: https://etherpad.openstack.org/p/juno-nova-mid-cycle-meetup
22:23:02 <thomasem> And it'll get more visibility
22:23:07 <adrian_otto> plus, I have a conflict that will prevent me from staying on the 31st.
22:23:24 <erw> thomasem: that’s virtually empty, but if it grows as it did last mid-cycle, I’d concur.
22:23:34 <adrian_otto> so I'll be there to help out the first 3 days.
22:23:34 <erw> lets link our etherpad from the main one
22:23:35 <thomasem> I see
22:23:38 <thomasem> okay
22:24:14 <erw> done
22:24:23 <thomasem> cool
22:25:01 <erw> adrian_otto: if we won’t do the 31st, could you send out an update to the ML?
22:25:05 <apmelton> I've got a question, how's parking/getting into the building going to work at the mid-cycle? have any of those details gone out
22:25:34 <adrian_otto> I know that, apmelton
22:25:44 <adrian_otto> the intel campus has lots of parking
22:25:52 <erw> apmelton: some of the detailed logistics were discussed during the Nova meetings, but I don’t think much of it has trickled out of there.
22:25:52 <adrian_otto> you just drive up, there is no perimeter gate
22:26:33 <apmelton> adrian_otto: sounds good
22:26:52 <adrian_otto> the event leads met by conference yesterday to address a list of concerns
22:27:12 <adrian_otto> there will be internet wifi for guests, lunch provided, coffee breaks.
22:27:30 <adrian_otto> three rooms, with a 4th that will be added for the Ironic+Nova joint discussions
22:27:54 <adrian_otto> so one room for Nova, another for Ironic, one for Nova+Ironic, and one for Containers
22:28:39 <adrian_otto> you check in in the lobby with the security desk, and there MAY be an Intel escort to bring you a short walk to the meeting room.
22:28:56 <adrian_otto> no red flags came up.
22:29:17 <apmelton> cool
22:29:21 <thomasem> Sounds good
22:29:30 <adrian_otto> ok, sorry to swoop and run, but time for me to go
22:29:40 <erw> adrian_otto: thanks. will you send that email?
22:29:42 <adrian_otto> thanks for chairing erw!
22:29:44 <erw> np
22:30:09 <adrian_otto> erw: yes, at my first opportunity, probably tomorrow
22:30:12 <erw> thanks
22:30:14 <erw> #action adrian_otto to send email amending dates of mid-cycle
22:30:33 <apmelton> take care adrian_otto
22:30:40 <erw> finally, just some update from the Docker side...
22:31:09 <erw> Ian Main and Chris Alfonso updated and tested the glance patch, so we can eliminate the docker-registry piece.
22:31:15 <erw> no other important news, otherwise.
22:31:28 <erw> anyone have anything else?
22:31:53 <apmelton> on the libvirt-lxc side of things, s1rp and I still have a few patches, but slow progress is being made on getting them merged
22:32:28 <apmelton> it seems like always, theres a burst of review activity then nothing
22:32:34 <apmelton> or the gate just isn't working :-/
22:33:16 <thomasem> Trying to find the links
22:33:57 <thomasem> https://review.openstack.org/#/c/106405/
22:34:09 <thomasem> https://review.openstack.org/#/c/102324/6
22:34:33 <thomasem> apmelton: You have that userns one handy?
22:34:39 <apmelton> thomasem: there's a bunch, we probably shouldn't link them all :)
22:34:44 <thomasem> oh okay
22:35:36 <erw> if you guys do need reviews, though, it’s okay to link them. Maybe not all of them
22:35:49 <thomasem> Or slap them on the etherpad
22:35:53 <erw> but I think it’s okay to link particaruly blocking issues that need eyes
22:35:59 <apmelton> what I really need reviews on is https://review.openstack.org/#/c/98888/
22:36:00 <erw> *particularly
22:36:05 <apmelton> it's the very base of the userns patch
22:36:07 <s1rp_> those two have been sititing a while so good to highlight
22:36:24 <apmelton> and I haven't heard anything from the reviewer who -1'd it
22:36:31 <apmelton> so I kinda need more opinions
22:36:48 <erw> apmelton: and I’m actually +2 on requirements, so I’ll take a look at that
22:37:02 <apmelton> thanks erw!
22:37:29 <erw> apmelton: yeah but Sean isn’t someone I’d want to cross. ;)
22:37:32 <erw> anyway...
22:37:34 <erw> anything else ? :)
22:37:45 <erw> if not, we’ll call it a wrap.
22:38:13 <erw> conversation can continue in #openstack-containers if desired
22:38:14 <erw> #endmeeting