22:00:50 <adrian_otto> #startmeeting containers
22:00:51 <openstack> Meeting started Tue Oct  7 22:00:50 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:54 <openstack> The meeting name has been set to 'containers'
22:01:03 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers Our Agenda
22:01:16 <adrian_otto> #topic Roll Call
22:01:20 <adrian_otto> Adrian Otto
22:01:46 <iqbalmohomed> Iqbal Mohomed, IBM Research
22:01:57 <mtesauro> Matt Tesauro
22:02:04 <adrian_otto> hey guys
22:02:20 <adrian_otto> something has just come up that requires me to leave the office for about 15 minutes.
22:02:32 <adrian_otto> Matt, would you be willing to lead the meeting today until I return?
22:03:21 <mtesauro> I'm a bit of a spectator - just trying to keep track of where containers are with OpenStack.  Not sure I know enought to be helpful
22:03:42 <mtesauro> I an open to trying but want to set expecations correctly.
22:03:44 <iqbalmohomed> We can also start a bit later Adrian
22:03:54 <adrian_otto> ok, so let's do this. Let's reschedule for 22:30 today
22:04:00 <iqbalmohomed> ok
22:04:04 <adrian_otto> I will leave the meeting open, and we will begin at that time.
22:04:10 <Slower> UTC?
22:04:19 <mtesauro> OK with me.
22:04:19 <adrian_otto> yes, that's 3:30 PM US/Pacific
22:04:29 * Slower likes pacific.. :)
22:04:35 <Slower> sounds good
22:04:40 <adrian_otto> and if you notice others join in the mean time, please let them know about the updated start time.
22:04:44 <Slower> ok
22:04:46 <adrian_otto> bbl
22:04:59 <Slower> how's magnum coming? I haven't looked at it in a week+
22:10:03 <nitin1_> hello everyone,
22:10:34 <nitin1_> adrian_otto: hi
22:13:57 <mtesauro> FYI:  The meeting got pushed back 30 minutes.
22:14:16 <mtesauro> will start at 22:30 UTC aka 3:30 PM pacific
22:18:00 <nitin1_> #openstack-containers
22:19:22 <nitin1_> mtesauro: Can you change the topic, it mentioned Roll call (Meeting topic: containers)
22:20:40 <mtesauro> Not sure if I know how to do that - adrian_otto generally runs the show
22:20:59 <mtesauro> I'm just waiting until 22:30 for the real meeting to start
22:21:35 <nitin1_> ok
22:32:38 <adrian_otto> let's proceed with our meeting
22:33:38 <adrian_otto> I saw mtesauro, nitin1_, Slower, and iqbalmohomed
22:33:49 <adrian_otto> you all ready to continue?
22:33:55 <mtesauro> I am still here and ready
22:35:25 <nitin1_> adrian_otto: yes
22:35:31 <adrian_otto> #topic Announcements
22:35:54 <adrian_otto> 1) LP Project
22:36:05 <adrian_otto> #link https://launchpad.net/magnum Launchpad Project for Magnum
22:36:42 <adrian_otto> we will set up milestones and blueprints here. Tasks will be handled with bug tickets using the "wishlist" status
22:37:05 <adrian_otto> so you are welcome to watch the bug queue if you want to follow that closely.
22:37:32 <adrian_otto> Any announcements from team members?
22:38:03 <mtesauro> Not from me.
22:38:05 <adrian_otto> (we have enough developers now asking to contribute that it's worth the administrative overhead to organize work into milestones)
22:38:18 <nitin1_> adrian_otto: right
22:38:27 <adrian_otto> #topic Review Action Items
22:38:43 <adrian_otto> adrian_otto to follow up about the Magnum project repo, and revise the config review as needed
22:39:13 <adrian_otto> The config repo was split causing a compulsory -2 on our initial submission to open an openstack code repo.
22:39:16 <nitin1_> is there any link for with the agenda of this meeting
22:39:31 <adrian_otto> so I resubmitted into the new project-config repo:
22:39:32 <adrian_otto> https://review.openstack.org/#/c/114044/
22:39:43 <adrian_otto> nitin1_: https://wiki.openstack.org/wiki/Meetings/Containers
22:39:56 <adrian_otto> Status: COMPLETE
22:40:14 <adrian_otto> next:
22:40:15 <adrian_otto> Summary of Gantt/Magnum discussion from 2014-10-01 1600 UTC
22:40:38 <adrian_otto> we held a chat in #openstack-containers last wednesday. Let me share the transcript with you.
22:41:01 <adrian_otto> Minutes: http://eavesdrop.openstack.org/meetings/containers/2014/containers.2014-10-01-16.01.html
22:41:09 <adrian_otto> Log: http://eavesdrop.openstack.org/meetings/containers/2014/containers.2014-10-01-16.01.log.html
22:41:30 <adrian_otto> high level overview is that we have alignment on the direction to take with Magnum and Gantt
22:41:38 <adrian_otto> there are no items of dispute
22:41:45 <adrian_otto> questions on this topic?
22:42:40 <adrian_otto> #topic Containers Service (Magnum) API
22:42:54 <adrian_otto> #link https://github.com/digambar15/magnum.git Source code from diga
22:43:02 <adrian_otto> diga has been iterating on this code a bit
22:43:18 <adrian_otto> this is the middle of the night in his timezone, so he extended his regrets.
22:43:41 <adrian_otto> My hope is to get this moved over to a project in Gerrit
22:44:02 <adrian_otto> so we can facilitate interactive review in the way we are accustomed to.
22:44:52 <adrian_otto> that depends on merge of https://review.openstack.org/126725
22:45:10 <adrian_otto> but if you have feedback in the mean time, you are welcome to share it in #openstack-containers
22:45:37 <adrian_otto> you are also welcome to join the magnum-drivers group in Launchpad, and file blueprints
22:45:57 <adrian_otto> any discussion on that?
22:46:26 <adrian_otto> #topic Open Discussion
22:46:53 <nitin1_> what about the nova docker driver
22:47:12 <Iqbalmohomed> question .. I read a post by erw .. some issue in nova-docker?
22:47:28 <adrian_otto> do you have a link to that thread?
22:47:33 <nitin1_> seems erw is not here
22:47:41 <adrian_otto> I'm not aware of concerns about that code
22:47:49 <nitin1_> ok
22:48:06 <Iqbalmohomed> an incompatibility from nova side .. any more info on that?
22:48:21 <adrian_otto> Slower, you still around?
22:48:53 <adrian_otto> Slower works/worked on that team and may know details
22:49:22 <Iqbalmohomed> other question was about nested containers in privileged containers. Adrian u mentioned some patches last week. do u have any pointers?
22:49:33 <adrian_otto> sorry, I don't
22:49:57 <Iqbalmohomed> cool .np
22:50:04 <adrian_otto> but I am willing to take an action item to try and identify them. I have a meeting with the Docker team later this week when I can ask about that
22:50:28 <Slower> yeah sorry
22:50:43 <Iqbalmohomed> that would be most appreciated Adrian
22:50:49 <adrian_otto> #action adrian_otto to attempt to identify Linux kernel patches that could enable use of nested containers in non-privileged mode
22:50:56 <Slower> Iqbalmohomed: I'm not sure which email you are referring to?
22:51:12 <Iqbalmohomed> it was a tweet on sept 30
22:51:30 <Slower> ah, I don't follow tweets so.. :)
22:51:35 <Iqbalmohomed> from era .. I saw it and was puzzled myaelf
22:51:52 <Iqbalmohomed> :)
22:52:10 <adrian_otto> ok, let's wrap up for today.
22:52:20 <adrian_otto> Thanks everyone for your schedule flexibility today.
22:52:41 <Iqbalmohomed> thanks!
22:53:01 <adrian_otto> our next meeting is 2014-10-14 at 1600 UTC. See you then!
22:53:06 <adrian_otto> #endmeeting