22:10:41 <adrian_otto> #startmeeting containers
22:10:41 <apmelton> sdake: I see the topic as well
22:10:42 <openstack> Meeting started Tue Jan 13 22:10:41 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:10:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:10:43 <sdake> it still says "Solum team meeting"
22:10:45 <openstack> The meeting name has been set to 'containers'
22:10:47 <thomasem> Looks like I'm back now
22:11:22 <adrian_otto> ok, this is a continuation of the following meeting:  http://eavesdrop.openstack.org/meetings/containers/2015/containers.2015-01-13-22.00.html
22:11:34 <adrian_otto> attendance in the prior record shall apply.
22:11:47 <adrian_otto> #topic Announcements
22:11:53 <adrian_otto> Mid-Cycle Meetup Planning
22:12:04 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054053.html Call for Feedback
22:12:20 <adrian_otto> please respond to the Doodle poll in the ML thread
22:12:33 <adrian_otto> to indicate if there is at least an 80% chance you will attend
22:12:54 <adrian_otto> so far we have 6 respondents, and 5 indicated they will attend on the earlier dates.
22:13:21 <adrian_otto> so I'm reluctant to call a meeting for 5 of us, but I hope that I'll get more input from you all to help decide
22:13:57 <adrian_otto> Release Readiness
22:13:59 <sdake> mabye a followup post to the ml in case people missed the first CFP
22:14:10 <adrian_otto> good idea
22:14:12 <jay-lau-513> my feedback is already there and I hope that I can attend remotely
22:14:28 <adrian_otto> #idea post a followup to the ML in case people missed the first CFP
22:14:38 <adrian_otto> yes, thanks jay-lau-513
22:14:46 <adrian_otto> we will do our best to accommodate
22:15:09 <adrian_otto> ok, so on the subject of Release Readiness
22:15:12 <jay-lau-513> adrian_otto great
22:15:27 <adrian_otto> we have a bunch of bugs that need to be closed prior to tagging a release.
22:15:39 <sdake> basically the only thing that works is bay create and pod create
22:15:42 <adrian_otto> #link https://bugs.launchpad.net/magnum Our Bugs
22:15:42 <sdake> everything else is busted
22:15:47 <sdake> all the delete operations don't work
22:15:55 <sdake> service create is busted
22:16:00 <sdake> rc create is busted
22:16:17 <jay-lau-513> I think yuanying has fixed the deleted issues for pod and service
22:16:29 <sdake> I just tested master - it is still busted
22:16:34 <adrian_otto> so please take a look at that list today, and let's see if we can make a judgement about whether we can quickly fix, or plan another announce date
22:16:35 <sdake> but atleast the correct names are passed now
22:16:36 <yuanying-alt> hmm
22:16:54 <sdake> the port is 192.168.x.z:None" instead of :8080"
22:17:07 <sdake> I think that is part of the problem
22:17:11 <adrian_otto> I'd like to resolve all Critical and High bugs
22:17:54 <adrian_otto> that gives us 10 actionable bugs on hand
22:18:02 <adrian_otto> in those severity levels
22:18:12 <adrian_otto> thoguhts?
22:19:16 <sdake> the bugs probably take 1-2 hours per bug
22:19:48 <sdake> I am a big fan of releasing on tuesdays, gives people the msot time to look at the code before they forget about it on the weekdn :)
22:20:14 <adrian_otto> agreed
22:20:43 <sdake> I'd suggest slipping until the 19th and tag as soon as all the bugs are fixed
22:20:46 <sdake> and then announce on the 20th
22:21:21 <adrian_otto> so my ask of all our contributors today id to find one of the criticals that you think you can resolve, if you can earmark time today or tonight to work on it, claim the bug by marking yourself as the assignee
22:21:27 <adrian_otto> and submitting a patch
22:21:45 <adrian_otto> tag it with Closes-Bug: NNN in your commit message
22:22:38 <sdake> maybe we should go through bug assignment in the meeting
22:23:15 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410444 magnum service create fails
22:23:16 <uvirtbot> Launchpad bug 1410444 in magnum "magnum service-create fails" [Critical,Confirmed]
22:23:39 <adrian_otto> #topic Blueprint/Task Review
22:23:45 <adrian_otto> irc://sendak.freenode.net:6667/#link https://bugs.launchpad.net/magnum/+bug/1410444 magnum service create fails
22:23:58 <sdake> all the blueprints are done yay [\o{
22:24:08 * adrian_otto applauds
22:24:57 <adrian_otto> symptom is: "No handlers could be found for logger "magnumclient.common.httpclient""
22:25:46 <thomasem> Sounds like it's trying to log the actual problem, but nothing was there to handle that logging. :P
22:26:10 <adrian_otto> taht would be a great comment to add to the bug
22:26:19 <adrian_otto> even if it's just a gut reaction
22:26:30 <adrian_otto> next we have: #1410447 https://bugs.launchpad.net/magnum/+bug/1410447
22:26:31 <uvirtbot> Launchpad bug 1410447 in magnum "replication controller creation fails" [Critical,Confirmed]
22:26:45 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410447
22:27:08 <thomasem> added
22:27:21 <adrian_otto> symptom is "ERROR: 'Client' object has no attribute 'rcs'"
22:27:37 <yuanying-alt> It has not implemented yet.
22:28:04 <adrian_otto> ok, in that case we should pull the feature prior to release
22:28:17 <jay-lau-513> I will try to make replication controller work
22:28:40 <adrian_otto> jay-lau-513
22:28:42 <yuanying-alt> it's good idea
22:28:46 <adrian_otto> I will assign you to this one, thanks
22:29:05 <adrian_otto> done.
22:29:08 <adrian_otto> Next one is...
22:29:19 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410448
22:29:20 <uvirtbot> Launchpad bug 1410448 in magnum "replication controller should require a bay id" [Critical,Confirmed]
22:30:01 <adrian_otto> jay-lau-513: I'm going to give this one to you also if that's ok
22:30:16 <adrian_otto> we can come back at the end if we have contributors looking for more work
22:30:24 <jay-lau-513> adrian_otto ok
22:30:40 <adrian_otto> next one is the quickstart, which I will fix.
22:30:50 <adrian_otto> after that we have:
22:30:52 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410507
22:30:54 <uvirtbot> Launchpad bug 1410507 in magnum "magnum bay-delete fails with error 400" [Critical,Confirmed]
22:31:18 <adrian_otto> another symptom surfacing as: No handlers could be found for logger "magnumclient.common.httpclient"
22:31:51 <adrian_otto> so this one and 1410444 probably get solved with a common fix (my wild guess)
22:32:05 <adrian_otto> volunteers for this one?
22:32:10 <hongbin> also
22:32:21 <hongbin> why not magnum bay-delete xxx
22:32:33 <hongbin> instead of magnum bay-delete --id xxx
22:32:41 <sdake> the clinet expect s--id
22:32:43 <sdake> dont ask me why
22:32:47 <sdake> its not ideal, but it is what it is
22:32:48 <hongbin> the --id is not necessary
22:32:51 <adrian_otto> that would be a good tech-debt bug
22:32:52 <sdake> it is something we can fix later imo :)
22:33:07 <hongbin> k
22:33:08 <adrian_otto> I will welcome that if you file it, I will put it as a wishlist
22:33:13 <adrian_otto> next, we have:
22:33:16 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410510
22:33:17 <yuanying-alt> I will fix it.
22:33:18 <uvirtbot> Launchpad bug 1410510 in magnum "magnum pod-delete fails with error 500" [Critical,Confirmed]
22:33:47 <adrian_otto> this is another: No handlers could be found for logger "magnumclient.common.httpclient"
22:33:48 <yuanying-alt> I think this issue is caused by old version of code.
22:33:59 <yuanying-alt> so I will check it.
22:34:06 <sdake> yuanying I pulled master and tried it
22:34:08 <sdake> with no luck
22:34:10 <adrian_otto> thanks yuanying-alt
22:34:13 <sdake> but maybe I had old bits somehow
22:34:44 <adrian_otto> if these can not be reproduced, then great, we can quickly close them out
22:35:10 <adrian_otto> that concludes the list of Critical
22:35:54 <sdake> if you cna't reproduce them, send me a private messag eand I'lll try to reproduce on my end with a fresh master and fresh db
22:36:02 <adrian_otto> the following few are severity: High
22:36:09 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1405356
22:36:11 <uvirtbot> Launchpad bug 1405356 in magnum "Tech Debt: Fix endpoint configuration on docker handler" [High,Triaged]
22:36:52 <adrian_otto> yuanying-alt: comments on this one?
22:37:16 <yuanying-alt> I have no idea.
22:37:29 <yuanying-alt> But I think
22:37:40 <yuanying-alt> docker container is created by bay.
22:37:52 <yuanying-alt> shoud be created by bay.
22:38:01 <sdake> maybe we can ignore this one for later
22:38:10 <sdake> do we need it to access  the rest api is the question
22:38:19 <sdake> eg like pod-create, that is something we need
22:39:08 <adrian_otto> ok, so we have the correct Importance assigned to this one?
22:39:54 <sdake> I errored on the side of caution with trriage
22:39:59 <sdake> but I wasn't sure about this one
22:40:25 <adrian_otto> ok, so unless I hear anything to the contrary, I will leave this one as-is
22:40:31 <adrian_otto> let's check the next
22:40:45 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1406539
22:40:46 <uvirtbot> Launchpad bug 1406539 in magnum "Request context is not set correctly" [High,Fix committed]
22:40:57 <sdake> Ithink we should be challennging high/critical bugs - if they are not really high critical
22:40:58 <adrian_otto> that one is fixed
22:41:16 <adrian_otto> next is:
22:41:18 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1410473
22:41:20 <uvirtbot> Launchpad bug 1410473 in magnum "If Heat templates not found, no reasonable error reported" [High,Confirmed]
22:41:32 <sdake> conductor implodes
22:41:34 <sdake> not ideal :)
22:42:25 <adrian_otto> so some additional checking logic could help here
22:42:55 <adrian_otto> and that concludes the top 10
22:43:35 <adrian_otto> so if you can help out, even just sharing your thoughts in comments, that would be very helpful
22:44:43 <adrian_otto> ok
22:44:55 <adrian_otto> #topic Discussion of introduction of the specs process to Magnum.
22:45:11 <adrian_otto> do we want to tackle this today, or defer this one out a week?
22:46:28 <adrian_otto> I suppose I can take a quick indication if active contributors feel that new contributions are discussed enough in BP or task(bug) tickets prior to submission for review?
22:46:41 <adrian_otto> If not, then a specs process could be a good way to address that concern
22:46:49 <adrian_otto> Thoughts?
22:46:55 <sdake> I have been using specs with different openstack projects
22:46:56 <apmelton> about all I can add is specs would be helpful for those new to the project to begin assisting in feature development
22:47:02 <sdake> I find it really heavyweight for where we are inthe project's development
22:47:38 <sdake> I think ML would be better place to discuss use cases and whatnot
22:47:43 <adrian_otto> I agree with sdake's sentiment on this
22:47:45 <apmelton> though blueprints are just as helpful
22:48:02 <adrian_otto> we have not leveraged the ML very much, and it would be a great place to have those discussions
22:48:02 <sdake> I think 6 mo down the road to specs make sense?  probably
22:48:07 <sdake> do they make sense today, not so much :)
22:48:23 <adrian_otto> any alternate viewpoints to consider on this subject?
22:48:38 <adrian_otto> I'm happy to revisit it again as often as we need to
22:49:04 <sdake> cool we made a decision yay :)
22:49:35 <adrian_otto> #agreed We will use the ML to discuss new feature ideas, and implementation options rather than a formalized specs process for now.
22:49:55 <adrian_otto> you are always welcome to use a WIP review as a discussion instrument as well
22:50:04 <adrian_otto> as long as you consider that work as displosable
22:50:37 <adrian_otto> #topic Open DIscussion
22:51:12 <sdake> I know I haven't been able to contribute much to Magnum since late december
22:51:18 <sdake> that will change starting feb 1st
22:51:23 <sdake> enjoy :)
22:51:49 <dims__> nice sdake! i've been lax a bit as well, hopefully get going again in a week or so
22:51:52 <adrian_otto> thanks sdake
22:52:13 <adrian_otto> have you all been happy with the velocity of review approvals.
22:52:15 <adrian_otto> ?
22:52:26 <sdake> review queue is moving fast imo :)
22:52:26 <adrian_otto> from my perspective they seem to be moving through pretty well
22:52:41 <dims__> yep!
22:52:47 <hongbin> agree
22:52:56 <adrian_otto> I've been voting for merging imperfect code with tech debt tracking
22:53:06 <jay-lau-513> pretty fast!
22:53:19 <adrian_otto> recent remarks I have left in place of #TODO comments… a request for a wishlist bug as well.
22:53:34 <adrian_otto> you *are* welcome to submit bugs against code that's not merged yet
22:53:45 <adrian_otto> I will just not mark that as triaged until after merge
22:53:48 <sdake> I think what magnum milestone #1 is is pretty sweet
22:53:57 <sdake> I think we are going to be challenged coming up with improvements from here on out
22:54:09 <sdake> so if you have ideas for improvements please file a blueprint
22:54:10 <adrian_otto> and if we end up abandoning a review, we can do the same for related bug tickets.
22:54:18 <adrian_otto> +1
22:54:58 <adrian_otto> I think we should take a moment to recognize the team's efforts.
22:55:16 <adrian_otto> progress here has been remarkable. Thanks so much for everything you have done to help us.
22:55:29 <sdake> ya this team rocks !
22:55:35 <sdake> reminds me of the heat team early on
22:55:57 <jay-lau-513> We need to attract more
22:56:04 <adrian_otto> it's one thing to have big ideas, and it's another to make them come to life.
22:56:06 <yuanying-alt> ^_^
22:56:18 <adrian_otto> jay-lau-513: our planned announcement will do that
22:56:24 <adrian_otto> I actually would like to share one thing
22:56:34 <jay-lau-513> Someone is asking me how to contribute, how to ramp up ;)
22:56:34 <adrian_otto> and I don't think he would mind if he were here
22:57:13 <adrian_otto> but Vish sent me an email this week recognizing our progress, and admitting that his position voiced in Paris was wrong, and that he is now wishing us the best for success.
22:57:13 <sdake> we need more blueprints for devs to take a crack at
22:57:34 <adrian_otto> and I think that's a huge testament to how well this team is performing.
22:57:34 <sdake> nice
22:57:39 <sdake> who is this vish cat
22:57:41 <sdake> the ironic ptl?
22:57:49 <jay-lau-513> cool!
22:57:54 <adrian_otto> :-)
22:58:14 <adrian_otto> so just a few minute left
22:58:29 <adrian_otto> I want to remind everyone that we have a critically important election underway
22:58:53 <adrian_otto> so if you ahve not yet voted, please leek for the reminder email in your inbox and use your personalized ballot link to vote
22:59:06 <jay-lau-513> adrian_otto I see you are a candidate board member :)
22:59:20 <adrian_otto> if we don't get a 25% turnout of the electorate, we can't make the bylaws amendments, which we really need
22:59:25 <adrian_otto> jay-lau-513: yes, sir.
22:59:37 <adrian_otto> so please take time to vote, we really need your participation in this one.
23:00:09 <adrian_otto> Our next meeting is 2015-01-20 at 1600 UTC. I'll see you all then. Watch the ML in the mean time.
23:00:17 <adrian_otto> #endmeeting