22:01:32 <adrian_otto> #startmeeting containers
22:01:33 <openstack> Meeting started Tue Jan 27 22:01:32 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:37 <openstack> The meeting name has been set to 'containers'
22:01:49 <jay-lau-513> jay
22:01:57 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-01-27_2200_UTC Our Agenda
22:02:01 <adrian_otto> #topic Roll Call
22:02:05 <adrian_otto> hi jay
22:02:06 <apmelton_> Andrew
22:02:08 <adrian_otto> Adrian Otto
22:02:11 <hongbin> Hongbin Lu
22:02:12 <achanda> Abhishek Chanda
22:02:26 <sdake> o/
22:03:50 <yuanying-alt> yuanying
22:03:54 <pradk> o/
22:04:26 <adrian_otto> Welcome everyone! ok, let's begin! (feel free to chime in at any time to be recoded in attendance today, if you have not yet)
22:04:34 <adrian_otto> #topic Announcements
22:04:41 <adrian_otto> (1) Last week we announced our first release of Magnum
22:04:51 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054848.html Magnum Release Announcement
22:05:07 <adrian_otto> congratulations to the team, and special thanks to everyone who contributed.
22:05:18 <sdake> most people already know, but I am headed to Cisco February 2nd :)
22:05:20 <adrian_otto> I also put it on my blog with a bit more information about who contributed
22:05:35 <adrian_otto> (2) sdake new job!
22:05:39 <sdake> yay :)
22:05:43 <adrian_otto> congratulations sdake
22:05:47 <achanda> congrats sdake :)
22:05:49 <jay-lau-513> congrats sdake
22:05:52 <pradk> yay! :)
22:05:58 <hongbin> congrats
22:06:25 <yuanying-alt> congrats!!
22:06:25 <adrian_otto> remember to patch stakalytics when your affiliation changes. there is a JSON file that you can tweak with your end date.
22:07:00 <adrian_otto> (3) adrian_otto will be away on vacation on 2015-02-17. Would someone like to volunteer to chair our team meeting that day? It will be a 1600 UTC meeting.
22:07:34 <sdake> yup
22:07:46 <adrian_otto> I have not yet recorded it on our Meetings wiki, so I will add that for us
22:07:50 <adrian_otto> thanks sdake
22:07:56 <sdake> oh I wa sssyaing yup to json
22:07:59 <sdake> but I'll be happy to chair
22:08:05 <adrian_otto> oh,
22:08:07 <adrian_otto> ok, sorry
22:08:11 <sdake> no sweat
22:08:11 <adrian_otto> thanks for agreeing
22:08:47 <adrian_otto> #agreed sdake will serve as chair on 2015-02-17 during adrian_otto's planned absence.
22:09:10 <adrian_otto> Note we have a planned release on 2015-02-16.
22:09:18 <adrian_otto> so I will find time to touch down and tag a release for us
22:09:46 <adrian_otto> I'll be sure to coordinate with those of you present that day in #openstack-containers. I will remind you again in a future team meeting.
22:10:16 <adrian_otto> (3) Mid-Cycle Meetup Planning - New Dates
22:10:24 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054053.html Call for Feedback
22:10:30 <adrian_otto> New dates added: http://doodle.com/ddgsptuex5u3394m
22:10:47 <adrian_otto> the dates we have are too contested by scheduling constraints
22:10:53 <adrian_otto> so I have proposed two new dates.
22:11:27 <adrian_otto> if there is an 80%+ chance you can attend a mid-cycle meetup in San Francisco, please be sure to fill out the poll *again*
22:11:45 <adrian_otto> I will continue to add dates until we can find something workable.
22:12:02 <adrian_otto> any more announcements form team members before we advance topics?
22:12:40 <adrian_otto> #topic Expectations for M2
22:13:06 <adrian_otto> the purpose of this topic is to make sure we are in agreement for the top priorities for our next release milestone
22:13:21 <adrian_otto> here are the top three themes that I suggest we focus on:
22:13:27 <adrian_otto> (1) Adding multi-tenancy
22:13:33 <adrian_otto> (2) Expanding test coverage
22:13:43 <adrian_otto> (3) Adding Features and Capabilities
22:14:15 <adrian_otto> there is actually more proposed in blueprints than we can reasonably expect to finish on one release milestone, so we will likely move some ahead into a future milestone
22:14:29 <adrian_otto> but those fall into the #3 bucket.
22:15:07 <adrian_otto> my rationale for putting multi-tenancy at the top of the list, is that's one of the key differentiators that makes Magnum compelling versus just tying the various bits together yourself
22:15:14 <adrian_otto> so I'd like to get that right, and get that in soon
22:15:38 <adrian_otto> we talked about test coverage early on, and have already made significant progress on that
22:15:49 <sdake> we are up to 70% unit test coverage which is heroic
22:15:53 <sdake> (we started at 0%) :)
22:16:07 <sdake> 85-90% is a good target tho
22:16:20 <adrian_otto> 80+% brings us to par with other projects in the OpenStack ecosystem
22:16:30 <sdake> ya typical projects are 85%
22:16:36 <adrian_otto> I agree that a 90% aspiration is great
22:16:43 <apmelton_> agreed
22:16:48 <adrian_otto> further on this topic….
22:17:08 <hongbin> Now I am writing tests for api
22:17:12 <adrian_otto> I will no longer me making anything with a +2 unless it has unit tests.
22:17:16 <hongbin> I may need help for the conductor
22:17:27 <adrian_otto> so expect to see "-1 need tests" if you are not doing tdd
22:17:37 <adrian_otto> (if you forget to add tests in the work you submit)
22:17:41 <sdake> agree, we shouldn't ack stuff unless it has tests (unless its a doc change)
22:17:51 <adrian_otto> yes, non code changes are different
22:17:59 <adrian_otto> changes to a requirements.txt file are different
22:18:08 <adrian_otto> but if you are adding python code, I expect tests.
22:18:23 <adrian_otto> then finally , the #3 theme is features
22:18:55 <adrian_otto> this is our chance to take a ton of very compelling features that our various components offer, and be able to surface them
22:19:20 <adrian_otto> the good news is that several of these features are T-shirt size small to add
22:19:36 <adrian_otto> so I have edited all blueprints that are pending start to add a size estimate
22:20:07 <adrian_otto> so please update blueprints accordingly in the whiteboard to replace my "please add a T-shirt size" remark.
22:20:17 <adrian_otto> does this request sound reasonable?
22:20:23 <sdake> yup
22:20:49 <jay-lau-513> yes
22:20:54 <adrian_otto> ok, if you disagree with this approach, you are welcome to voice a different opinion, or discuss with me privately
22:21:18 <adrian_otto> the reasoning here, is that we might have some features that have low impact, and large shirt size
22:21:25 <adrian_otto> and those are candidates for deferral
22:21:37 <adrian_otto> and we may have ones that are high impact and small size that we should expedite
22:21:39 <adrian_otto> ok.
22:21:57 <adrian_otto> any more thoughts on the guiding themes for this release?
22:22:13 <adrian_otto> ok, that brings us to our next topic…
22:22:17 <adrian_otto> #topic Blueprint/Task Review
22:22:25 <adrian_otto> #link https://blueprints.launchpad.net/magnum/milestone-2 M2 Blueprints
22:22:44 <adrian_otto> these are all the blueprints currently in play for M2
22:22:48 <adrian_otto> this is subject to change
22:22:59 <adrian_otto> today, I adjusted almost all of them to discussion state
22:23:17 <adrian_otto> the ones that were obviously already in progress should continue unchanges
22:23:27 <adrian_otto> s/unchanges/unchanged/
22:23:48 <adrian_otto> the ones marked as Dicussion should be sized, and I will work with you to approve each
22:24:06 <adrian_otto> I'd like a sense of confidence that this work is achievable in the allotted time
22:24:21 <adrian_otto> and if not, we will define additional milestones, and group them accordingly.
22:24:28 <adrian_otto> questions on any of these?
22:24:33 <sdake> we should bounce autoscale-bay
22:24:35 <adrian_otto> We can spend some time talking about a few
22:24:38 <sdake> that will be hard, and no owner
22:24:42 <adrian_otto> sdake: yes
22:24:51 <adrian_otto> that was at the top of my list for deferral
22:24:59 <adrian_otto> ok, I'll adjust that one
22:25:36 <sdake> I think https://blueprints.launchpad.net/magnum/+spec/ironic-heat-template will take two mini-cycles
22:25:42 <sdake> eg, milestone #2 and milestone #3 to finish
22:26:14 <adrian_otto> ok, any others to discuss now?
22:26:26 <adrian_otto> ok, ironic-heat-template
22:26:33 <apmelton_> docker backend one could be large as well
22:26:45 <apmelton_> if it involves new heat templates
22:26:46 <sdake> agree docker backend needs to be broken into more then one blueprint
22:27:00 <adrian_otto> ok, I will take that as an action
22:27:27 <adrian_otto> #action adrian_otto to break https://blueprints.launchpad.net/magnum/+spec/magnum-docker-backend-selection into multiple blueprints
22:28:18 <adrian_otto> sdake: how do you suggest we plan ironic-heat-template? Should we break it up as well?
22:28:31 <adrian_otto> does it have clean opportunity for division?
22:28:32 <sdake> possible, I really don't know what it involves
22:28:46 <sdake> ithink it will take a cycle to prototype and identif ythe work
22:28:49 <adrian_otto> ok, so maybe we need a research task on that
22:29:03 <adrian_otto> and we can link that to the BP while we decide how to target it
22:29:05 <sdake> ya, I assume that is what yuanying is working towards (prototype)
22:29:33 <yuanying-alt> yes
22:29:33 <adrian_otto> #action adrian_otto to follow up with yuanying about ironic-heat-template
22:29:55 <adrian_otto> yes == it can be split?
22:30:26 <yuanying-alt> I'm working towards prototype.
22:30:31 <adrian_otto> ok, got it
22:30:45 <yuanying-alt> maybe, but I can't be split it
22:30:47 <adrian_otto> please give some thought to what work items we can divide it into
22:31:12 <sdake> one thing that can come out as a separate work item is putting an l2/l3 agent in a container to run on the host
22:31:13 <adrian_otto> or, if it's something you are confident we will complete in a week or two, then there is no need to split it
22:32:10 <adrian_otto> no pressure on that for now, just give it some thought, and let's follow up on it when you are ready.
22:32:28 <adrian_otto> any other features that should be elevated or deferred?
22:32:53 <hongbin> One thing is
22:33:08 <hongbin> Writing magnum container-create to the guide
22:33:17 <hongbin> I think this is important
22:33:26 <sdake> that goes under the general goal of docs I think
22:33:27 <hongbin> since users may need to play with container
22:33:37 <hongbin> k
22:33:45 <sdake> we probably need a blueprint which identifies the docs we intend to write
22:33:46 <adrian_otto> we should have a blueprint for docs that is scoped to things in this coming release
22:33:53 <adrian_otto> yes, agreed
22:34:05 <adrian_otto> ok, I will open that one as well
22:34:09 <sdake> I think it makes sense to copy whatever docs the ironic cats figured they needed to write
22:34:18 <sdake> since they just went through incubation
22:34:30 <sdake> and that should be teh "bare minimum" documentation needed from an incubation perspective
22:34:34 <sdake> eve nthough incubation is going away
22:34:52 <adrian_otto> #action adrian_otto open a blueprint on docs for things to write for use with M2 release
22:34:59 <adrian_otto> sdake: yes, that would be a good guide
22:35:07 <adrian_otto> I will add that suggestion in the BP itself.
22:35:30 <adrian_otto> jay-lau-513: I have a question for you in https://blueprints.launchpad.net/magnum/+spec/override-native-rest-port
22:35:49 <adrian_otto> is that one actually Implemented?
22:35:53 <jay-lau-513> the left task is we need update heat template to enable api server port
22:36:08 <sdake> should udpate in larsks repo first
22:36:12 <sdake> then cherry pick
22:36:14 <jay-lau-513> right
22:36:17 <adrian_otto> ok, could you take a moment to update the whiteboard letting us know the remaining task(s)
22:36:22 <sdake> speaking of that, larsks has some other improvements which need cherry picking
22:36:23 <jay-lau-513> sure
22:36:28 <adrian_otto> if we have bug/wishlist tickets for those, link them too
22:36:41 <adrian_otto> sdake: whoot
22:36:43 <adrian_otto> tell us more
22:36:53 <apmelton_> I have a question about how we're handling the heat template
22:37:11 <apmelton_> is there a reason we went with cherry-picking it in versus a sub-repo?
22:37:19 <sdake> I dont know the details of larsks updates
22:37:28 <sdake> but his repo is straight forward enough to cherry pick the updates
22:37:53 <adrian_otto> ok, I will open a bug/task on that as well
22:38:16 <sdake> apmelton_ shoot
22:38:38 <apmelton_> my question was just "is there a reason we went with cherry-picking it in versus a sub-repo?"
22:38:43 <adrian_otto> #action adrian_otto to open a bug/task ticket for cherry-pick of updates in the larsks heat template code.
22:38:59 <sdake> no good reason
22:39:03 <sdake> how does a sub repo work
22:39:03 <adrian_otto> KISS
22:39:13 <sdake> ideally we don't want users to have to pull a secondary repository
22:39:30 <apmelton_> yea, I can't remember if you have to do anything after a git clone
22:39:43 <apmelton_> it may have required a second command like git sub-repo init
22:39:54 <apmelton_> anyways, it's not a biggy
22:39:59 <adrian_otto> apmelton_: what would you view as the advantages (besides the number of git calls)
22:40:15 <sdake> we wouldn't ideally have to cherry pick any longer
22:40:23 <sdake> less maint burden
22:40:35 <apmelton_> yea, you'd just change the commit of the sub-repo, add it, and push that up
22:40:37 <sdake> I want to make sure our users don't have to be git rocket scientists to use the rep otho :)
22:40:37 <adrian_otto> but that would also form a dependency on that other repo
22:40:51 <adrian_otto> so if it broke, out gates would start breaking
22:41:04 <adrian_otto> s/out/our/
22:41:20 <sdake> agree merging it in our tree is better - ithink it needs to go somewhere besides "/etc" tho
22:41:28 <jay-lau-513> we will have ironic template later, do we need another repo too? do we need to set repo for all templates?
22:41:36 <sdake> ie, magnum/magnum/teplates/fedora-atomic/*
22:41:43 <sdake> magnum/agnum/teplates/coreos
22:41:44 <sdake> etc
22:42:04 <jay-lau-513> Merging to one repo make things simple for users except maintain work for devs
22:42:39 <sdake> git cherry-pick does most of the work, so might as well just use that imo :)
22:42:55 <jay-lau-513> yup
22:43:38 <apmelton_> so, it was just a thought on my side, if what we're doing works fine now, no sense in changing it minimal gains
22:44:08 <adrian_otto> ok, thanks for raising it for discussion apmelton_
22:44:10 <jay-lau-513> sure, apmelton_
22:44:48 <adrian_otto> #topic Open Discussion
22:45:32 <adrian_otto> any other topics you'd like to cover today?
22:45:49 <hongbin> I have a question
22:45:56 <adrian_otto> ok
22:46:04 <hongbin> do we have any plan to integrate magnum to other openstack components?
22:46:18 <hongbin> e.g. glance, horizon, etc
22:46:29 <jay-lau-513> does anyone proposed a topic related to magnum/container for the coming summit?
22:46:35 <sdake> we should consider hirozn at some point
22:46:39 <adrian_otto> horizon integration definitely should be in our plan
22:47:00 <hongbin> k
22:47:02 <adrian_otto> the glance integration is potentially very ambitious
22:47:16 <sdake> so for ODS in May, will we have track space?
22:47:20 <apmelton_> adrian_otto: one thing we may want to consider is using glance to store the heat templates
22:47:25 <adrian_otto> because it would amount to putting considerable bunches of new features into glance
22:47:46 <apmelton_> I'm not sure if glance is still going toward the whole artifact storage instead of just images
22:47:46 <adrian_otto> apmelton_: yes, that's one is definitely one we should plan for
22:48:02 <adrian_otto> that's something we can check in on
22:48:44 <jay-lau-513> I recalled that heat team want to use swift to store templates, but not sure the status
22:48:46 <adrian_otto> but I'd be reluctant to set an intent to integrate container images with glance without first brining glance stakeholders into the vision
22:49:17 <sdake> ya imo that is a discussion we can have later, af ter we have basic functional system
22:49:26 <apmelton_> adrian_otto: at this point... I'd like to avoid it as we'd lose quite a bit of the benefits of the docker registry
22:49:33 <adrian_otto> it's probably worth starting a mailing list thread to include both teams, and get input on our initial frame of reference
22:49:44 <adrian_otto> apmelton_: yes, that's my worry
22:49:46 <sdake> ya email good - committing to implementing not ideal imo :)
22:49:49 <hongbin> k
22:50:00 <adrian_otto> it basically means re-implementing all the features of docker registry in glance
22:50:14 <hongbin> make sence
22:50:23 <adrian_otto> it's a discussion worth starting though
22:50:25 <hongbin> another candidate is ceilometer
22:50:50 <adrian_otto> hongbin: tell us more about why
22:50:50 <sdake> adrian_otto can you score us some track space at ODS?
22:51:01 <sdake> eg a room for 2-4 hours would be ideal
22:51:01 <adrian_otto> sdake: yes, certainly
22:51:23 <sdake> if there is that much space available
22:51:25 <sdake> I know space is tight
22:51:25 <hongbin> adrian_otto: ceilometer pull container metric
22:51:46 <apmelton_> ODS?
22:51:47 <adrian_otto> for the purpose of chargeback accounting?
22:51:53 <sdake> ODS = openstack developer summit
22:51:58 <apmelton_> ahhh
22:51:59 <hongbin> sort of
22:52:06 <adrian_otto> ODS is my new religion
22:52:07 <jay-lau-513> hongbin I think that we can possibly depend on cadvisor or cgroup
22:52:11 <apmelton_> hehe
22:52:13 <adrian_otto> I'd like you all to join
22:52:23 <adrian_otto> ;-)
22:52:29 <jay-lau-513> hongbin ceilometer is a bit heavy, might ;-)
22:52:40 <hongbin> jay-lau-513
22:52:45 <hongbin> I agree :)
22:52:47 <achanda> hongbin: do we have an usecase of someone looking to do metering or billing on magnum?
22:53:01 <adrian_otto> wll, I want to be clear on what the motivation is for ceilometer as an integration point
22:53:02 <achanda> IMHO ceilometer will make sense if that is true..
22:53:05 <apmelton_> even if we don't directly integrate with ceilometer, I think we should have notifications
22:53:15 <adrian_otto> it it for operational metrics, or usage accounting, or ??
22:53:17 <achanda> agreed
22:53:37 <sdake> we need ceilometer metrics in bays for autoscaling
22:53:48 <jay-lau-513> apmelton I like notifications
22:53:50 <adrian_otto> ok, so that's operational in nature
22:54:02 <achanda> sdake: ah yes
22:54:06 <hongbin> achanda: no right now. But in general, our lab interests on monitoring container
22:54:11 <jay-lau-513> apmelton 3rd party might want to integrate with magnum and notificaiton is very important
22:54:41 <apmelton_> jay-lau-513: agreed
22:54:52 <adrian_otto> so events like container start, container stop, pause/resume, container delete
22:55:00 <adrian_otto> notifications of those state change events
22:55:19 <adrian_otto> and those could be consumed for whatever purpose
22:55:23 <jay-lau-513> adrian_otto yup, this can help some integration work
22:55:30 <adrian_otto> that would be another potential point of differentiation for Magnum
22:55:38 <jay-lau-513> I add lots of notification in nova
22:55:47 <adrian_otto> to potentially make integrations like that much easier
22:56:15 <adrian_otto> this is a great topic to add to our mid-cycle discussion
22:56:21 <adrian_otto> I will take an action for that
22:57:00 <adrian_otto> #action adrian_otto to add ceilometer integration as a mid-cycle discussion topic.
22:57:10 <adrian_otto> lots for me to follow up on!
22:57:19 <sdake> say re midcycle
22:57:22 <adrian_otto> we should launch that as an ML topic too
22:57:24 <sdake> do we have an agenda proposed
22:57:35 <adrian_otto> sdake: not yet
22:57:37 <sdake> msybe we can make one via etherpad
22:57:59 <adrian_otto> as soon as we secure a date when we can get a quorum assembled, then we will contribute to an etherpad to set the agenda
22:58:05 <sdake> sounds good
22:58:25 <adrian_otto> and we can adapt it as needed
22:58:47 <adrian_otto> ok, we are winding down to the end of our allocated time today
22:59:07 <adrian_otto> our next meeting will be 2015-02-03 at 1600 UTC.
22:59:21 <adrian_otto> thanks everyone for attending today. I thought this was a really good meeitng.
22:59:37 <jay-lau-513> thanks bye everyone
22:59:39 <adrian_otto> see you next week, and in #openstack-containers until then.
22:59:43 <adrian_otto> #endmeeting