16:00:39 <adrian_otto> #startmeeting containers
16:00:40 <openstack> Meeting started Tue Feb  3 16:00:39 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:43 <openstack> The meeting name has been set to 'containers'
16:00:45 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-02-03_2200_UTC Our Agenda
16:00:49 <adrian_otto> #topic Roll Call
16:00:57 <apmelton> o/
16:00:57 <adrian_otto> Adrian Otto
16:01:00 <apmelton> Andrew Melton
16:01:00 <sew> Steven Wilson
16:01:06 <hongbin> Hongbin Lu
16:01:39 <prad> o/
16:01:39 <wkharold> ward harold
16:02:38 <adrian_otto> hello apmelton, sew, hongbin, prad, and wkharold
16:02:48 <adrian_otto> we will proceed in just a moment
16:02:48 <diga> Digambar Patil
16:03:24 <tartinette> hi
16:04:05 <adrian_otto> hello diga and tartinette
16:04:23 <diga> Hi Adrian
16:06:50 <adrian_otto> ok, welcome everyone. Let's begin!
16:06:53 <adrian_otto> #topic Announcements
16:07:07 <adrian_otto> 1) Welcome Hongbin to magnum-core
16:07:25 <hongbin> Thanks. It is my hornor to join the great team
16:07:28 <apmelton> congrats hongbin
16:07:37 <adrian_otto> Hongbin has been a consistent contributor and reviewer for Magnum, and has been recognized as a key member of our team
16:08:01 <adrian_otto> we trust Hungbin to help us with core reviewer responsibility
16:08:02 <diga> congrats hongbin
16:08:14 <hongbin> thx
16:08:37 <adrian_otto> so we are thrilled to add you, thanks!
16:08:42 <adrian_otto> 2) Reminder, next planned release date is 2015-02-16.
16:09:41 <adrian_otto> if we have any team members needing guidance to determine where their efforts may be best focused to help us reach this milestone, please chime in during Open Discussion today, in #openstack-containers at any time, or feel free to contact me individually.
16:10:06 <adrian_otto> 3) Reminder: adrian_otto will be away on 2015-02-17 for our 1600 UTC meeting. Our pro-tem chair will be sdake.
16:10:20 <adrian_otto> are there any other announcements from team members?
16:11:00 <adrian_otto> ok, proceeding...
16:11:03 <adrian_otto> #topic Review Action Items
16:11:12 <adrian_otto> (1) adrian_otto to break https://blueprints.launchpad.net/magnum/+spec/magnum-docker-backend-selection into multiple blueprints
16:11:23 <adrian_otto> thanks to help from apmelton, this is complete.
16:11:37 <adrian_otto> are there any questions about the breakdown of this work?
16:12:10 <apmelton> adrian_otto: I suppose we'll discuss which milestones for each piece during task review?
16:12:21 <adrian_otto> Yes, sir.
16:12:25 <apmelton> alrighty
16:12:34 <adrian_otto> ok, so we will revisit this one in a moment.
16:12:39 <adrian_otto> (2) adrian_otto to follow up with yuanying about ironic-heat-template
16:12:54 <adrian_otto> this is pending, so I will carry it forward
16:13:01 <adrian_otto> #action adrian_otto to follow up with yuanying about ironic-heat-template
16:13:11 <adrian_otto> (3) adrian_otto open a blueprint on docs for things to write for use with M2 release
16:13:29 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/m2-docs Documentation for M2
16:13:41 <adrian_otto> this is where we will track our documentation work items.
16:14:04 <adrian_otto> If you are able to contribute to any documentation efforts, let's be sure to mention them in this BP.
16:14:26 <adrian_otto> (4) adrian_otto to open a bug/task ticket for cherry-pick of updates in the larsks heat template code.
16:14:38 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1417642 Pull in updates from larsks heat template repo
16:14:53 <adrian_otto> (5) adrian_otto to add ceilometer integration as a mid-cycle discussion topic.
16:15:12 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-midcycle-topics Midcycle Discussion Topics
16:15:23 <adrian_otto> feel free to add to the topic list.
16:15:42 <adrian_otto> that concludes our action item review
16:15:57 <adrian_otto> #topic Mid-Cycle Meetup Planning
16:16:04 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054053.html Call for Feedback
16:16:23 <adrian_otto> so, I proposed new dates for the Midcycle that land in the following week
16:16:39 <adrian_otto> please take a moment to respond to the Doodle Poll
16:16:53 <adrian_otto> #link http://doodle.com/ddgsptuex5u3394m Select a date
16:17:02 <adrian_otto> we are looking for two consecutive days
16:17:46 <diga> I think we need to take a decision on this BP -  https://blueprints.launchpad.net/magnum/+spec/magnum-scheduler-for-docker
16:17:49 <adrian_otto> the Feb 23+24 and 25+26 are too contended for scheduling, so I proposed Mar 2+3
16:18:07 <adrian_otto> diga: We will address that in task review, one moment please.
16:18:20 <diga> ok
16:18:58 <adrian_otto> ok, so I look forward to your responses to the Mar 2-3 dates on the Doodle poll.
16:19:03 <adrian_otto> #topic Blueprint/Task Review
16:19:18 <adrian_otto> so, first I will call on apmelton, and second on diga
16:19:35 <adrian_otto> are there other team members who would like to discuss a work item?
16:20:15 <adrian_otto> ok, apmelton. Please begin on https://blueprints.launchpad.net/magnum/+spec/magnum-docker-backend-selection
16:20:57 <apmelton> at this point, I think https://blueprints.launchpad.net/magnum/+spec/docker-bay-heat-template is the only one I'd feel comfortable pulling in for M2
16:21:14 <adrian_otto> ok, let's take a look at that one
16:21:15 <apmelton> heat templates are pretty new to me, so there will be a bit of a learning curve
16:21:29 <adrian_otto> ok, so definitely touch base with sdake
16:21:39 <adrian_otto> he's a Heat expert, and can lend a hand with that
16:21:47 <apmelton> awesome, will do
16:22:12 <adrian_otto> you might also consider Randall Burt
16:22:32 <adrian_otto> he;s arguably one of the more talented engineers who have worked on heat and templates
16:23:02 <adrian_otto> rephrased. He is definitely talented, and very experienced in this subject matter.
16:23:27 <adrian_otto> LMK if you want additional Stackers who can help.
16:23:46 <apmelton> ok, I'll let ya know
16:24:14 <adrian_otto> I have set that blueprint as direction-approved
16:24:24 <adrian_otto> and set to m2 as the series goal.
16:24:47 <adrian_otto> anything more on this topic?
16:25:02 <apmelton> don't think so
16:25:04 <thomasem> o/
16:25:18 <adrian_otto> apmelton: will you be claiming that as the Assignee? It's currently set to None
16:25:26 <adrian_otto> hello thomasem
16:25:37 <apmelton> adrian_otto: sure, just assigned myself
16:25:57 <adrian_otto> ok, diga, you are up now. Let's discuss scheduling as a topic.
16:26:18 <adrian_otto> this is something we will also open for discussion on the ML to get wider input from the Nova/Gantt team
16:26:20 <diga> yep
16:26:50 <diga> yes
16:27:42 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-scheduler-for-docker Add schedulre for native docker support
16:29:03 <adrian_otto> our initial thinking on this topic was that the first scheduler (Gantt alternative) would allow the caller to specify a node to create a container on, or specify a node to not create a container on.
16:29:25 <apmelton> so, one thing to consider is that swarm does offer scheduling
16:29:28 <adrian_otto> we would implement a simple (pluggable) scheduling algorithm for sequential-fill
16:29:52 <adrian_otto> apmelton: yes, it has a naive scheduler
16:30:05 <wkharold> ditto for k8s, yes?
16:30:13 <adrian_otto> wkharold: yes, that's right
16:30:32 <apmelton> adrian_otto: when was the last time you checked out swarms scheduling?
16:30:39 <adrian_otto> ideally what we build (or integrate) for native docker would later be used for other container backeneds
16:30:46 <apmelton> browsing through the repo, it appears to actually have quite a few features
16:31:07 <apmelton> https://github.com/docker/swarm/tree/master/scheduler/filter
16:31:15 <adrian_otto> the key issue is how to manage the placement of containers within a pod on different nodes, based on some user-selected logic
16:31:52 <adrian_otto> oh, sweet, this is under active development again!
16:32:05 <adrian_otto> I am going to link that in the PB whiteboard… one sec
16:32:16 <diga> can I get some code from nova/cinder scheduler for initial implementation ?
16:32:16 <adrian_otto> s/PB/Blueprint/
16:33:41 <adrian_otto> diga: I think we should consider that as an option, yes
16:33:58 <diga> okay
16:34:02 <adrian_otto> we should view any work we do on scheduling in the short term as potentially disposable
16:34:26 <adrian_otto> so we don't need to be too picky about it
16:34:43 <diga> okay
16:35:22 <adrian_otto> one potential drawback of using Swarm is that we need to load and run the Swarmd binary (and associated agent), and place them properly.
16:35:49 <adrian_otto> whereas, if we used code from nova, it may be possible to leverage nova-compute as an agent
16:36:10 <adrian_otto> thoughts on this?
16:36:19 <hongbin> for swarm, is that possible to plug a custom filter?
16:36:44 <adrian_otto> we'll need to look at that code to find out
16:36:48 <diga> yes, using nova sch code is great advantage for us
16:37:04 <hongbin> k
16:37:54 <adrian_otto> we did get some feedback from the Nova team on the status of Gantt
16:38:19 <adrian_otto> they indicated that we should not expect movement on Gantt during the kilo release.
16:38:53 <adrian_otto> I am generally reluctant to suggest that we pick up development of Gantt because it really needs a bunch of high-risk code to be merged into Nova
16:39:05 <tartinette> hi
16:39:12 <adrian_otto> so that effort should really be driven by the Nova team who can make that happen.
16:39:34 <diga> yes
16:39:41 <adrian_otto> I worry that if we begin proposing code for Nova that's not a priority for the Nova team, that it will rot in perpetual review
16:39:49 <adrian_otto> and just be a waste of time on both ends
16:40:07 <wkharold> hongbin: a glance at the swarm filter code shows just four builtin filters, go doesn't support dynamic code loading so customer filters seem a long shot
16:40:19 <adrian_otto> so it's probably smarter to engage on that once it ascends in priority
16:40:43 <wkharold> s/customer/custom/g
16:40:55 <hongbin> wkharold: thx. I see
16:41:08 <adrian_otto> wkharold: thanks for checking on that
16:41:13 <wkharold> np
16:41:16 <adrian_otto> custom filters might not be that important
16:41:31 <adrian_otto> so let's be sure not to rule out an option because of that
16:41:49 <adrian_otto> I think we can all agree that it's definitely nice-to-have, but I'm not convinced that feature is essential
16:42:09 <tartinette> hi
16:42:09 <hongbin> make sense
16:42:12 <adrian_otto> if we have a filter scheduler that's reasonably complete, it's likely to be useful for most needs
16:42:37 <adrian_otto> tartinette: you are welcome to add in any time if you want
16:43:24 <apmelton> adrian_otto: I wonder how much we could get by with the constraint filter,, basically custom labels are applied to the docker daemon running, and then the user can filter based on those labels
16:43:44 <adrian_otto> #action adrian_otto to initiate an ML thread for discussion of native Docker scheduling support for Magnum
16:44:20 <adrian_otto> apmelton: I think that would work. Do you think that would be elegant from an end-user perspective?
16:44:48 <adrian_otto> seems pretty simple… add labels, then restrict on them.
16:45:10 <apmelton> yup, of course you couldn't have very sophicated filtering logic though
16:45:55 <hongbin> is that similar to something like affinity?
16:46:01 <adrian_otto> We could put a hook in (either in swarm or something of our creation) to allow for an external filter
16:46:18 <apmelton> hongbin: affinity is a separate filter in swarm
16:46:23 <adrian_otto> the API definition for that would likely be pretty simple
16:46:41 <hongbin> apmelton: I see
16:47:52 <adrian_otto> ok, I think this was a good start. We will get this discussion going ont he ML as well to poll input from other subject matter experts.
16:48:07 <adrian_otto> I took that as an action item earlier.
16:48:30 <diga> okay
16:48:42 <adrian_otto> any final thoughts on this before opening discussion to other work items?
16:49:06 <adrian_otto> any other work items that we should discuss today as a team?
16:49:27 <adrian_otto> ok, then I will open us up to all topics now…
16:49:35 <adrian_otto> #topic Open Discussion
16:50:55 <wkharold> anyone had issues being able to pull docker images after doing a devstack deploy per the quickstart? (feel free to tell me to take it offline is this is the wrong forum)
16:51:44 <adrian_otto> wkharold: your question is appropriate here
16:52:01 <apmelton> wkharold: docker images being pulled from the atomic nodes?
16:52:21 <wkharold> being pulled to the atomic nodes
16:52:40 <adrian_otto> wkharold: I encourage you to document your observations in a but ticket here: https://bugs.launchpad.net/magnum/+filebug
16:52:47 <adrian_otto> s/but/bug/
16:53:08 <wkharold> k, trying to reproduce this AM
16:53:14 <adrian_otto> There may be something we can learn from it to improve the quickstart instructions
16:53:23 <hongbin> I think it would be great for Magnum to provide API for image/snapshot management
16:54:03 <adrian_otto> hongbin: are you thinking of something generic, or something Docker backend specific?
16:54:13 <hongbin> generic
16:54:24 <hongbin> like nova image-list
16:54:35 <wkharold> do the glance people have any designs on managing container images?
16:54:51 <adrian_otto> wkharold: we have not explored that yet
16:55:07 <adrian_otto> that's something I will add to the midcycle as a potential design topic
16:55:08 <wkharold> seems like the ultimate place for it
16:55:30 <adrian_otto> hongbin: I think nova image-list was created before Glance existed
16:55:48 <adrian_otto> and it's probably still there for vestigial reasons
16:55:59 <adrian_otto> wkharold: agreed
16:56:30 <hongbin> adrian_otto: k. my thinking is
16:56:51 <diga> adrian_otto: not related question, is there any way to join online to midcycle meetup ?
16:56:51 <hongbin> in long term, we needs an abstraction to manage images for different container backend
16:57:28 <wkharold> like Rocket?
16:57:48 <hongbin> not sure what is Rocket
16:58:11 <wkharold> Docker alternative (sort of)
16:58:33 <hongbin> wkharold: I see
16:58:42 <adrian_otto> hongbin: CoreOS proposed a container format, and offered Rocket as a reference implementation
16:59:05 <wkharold> https://github.com/coreos/rocket
16:59:36 <adrian_otto> ok, time for us to wind down for today
17:00:22 <adrian_otto> Thanks to everyone for attending. Our next meeting is 2015-02-10 at 2200 UTC. I look forward to seeing you then!
17:00:25 <adrian_otto> #endmeeting