22:00:29 <sdake> #startmeeting containers
22:00:29 <openstack> Meeting started Tue Feb 24 22:00:29 2015 UTC and is due to finish in 60 minutes. The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:33 <openstack> The meeting name has been set to 'containers'
22:00:48 <sdake> #topic rollcall
22:00:54 <apmelton> Andrew Melton
22:00:55 <apmelton> o/
22:01:04 <sdake> magnum ftw [\o-----,
22:01:07 <daneyon_> Daneyon Hansen
22:01:12 <yuanying-alt> Yuanying
22:01:14 <Tango> Hi, Ton Ngo, new comer
22:01:18 <hongbin> Hongbin Lu
22:01:20 <sdake> hey welcome tango
22:01:23 <suro_> Surojit Pathak - joining new
22:01:29 <sdake> hey surojit
22:01:33 <sdake> lots of new cats - welcome!
22:01:40 <tcammann> hello
22:01:58 <sdake> suro and tango we normally have the other half join in our other weekly meeting on alternating weeks
22:01:58 <tcammann> Tom Camman
22:02:02 <sdake> hey Tom
22:02:17 <sdake> you guys can just \o you don't actually ahve to identify yourselves if you dont want :)
22:02:21 <sdake> #topic announcements
22:02:30 <sdake> Adrian will be back next week
22:02:36 <sdake> but next week is also the summit midcycle
22:02:42 <sdake> so there is no meeting scheduled via irc
22:02:58 <sdake> although for the midcycle there will be google hangout telepresence
22:03:05 <sdake> also.
22:03:20 <sdake> Mirantis is now actively competing with Magnum
22:03:35 <sdake> having two competitors in one open source project is a sign we picked the right tech ;-)
22:03:57 <sdake> #topic agenda
22:04:06 <wkharold> wkharold, late to the party
22:04:10 <sdake> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-02-24_2200_UTC
22:04:11 <daneyon_> any info why Mirantis is competing instead of contributing to Magnum?
22:04:12 <sdake> hey wkharold
22:04:26 <sdake> daneyon_ my suspicion is time to market
22:04:43 <sdake> but who knows, maybe the sky had a green tint in december ;-)
22:04:59 <sdake> anyone wish to add to agenda?
22:05:01 <wkharold> Mirantis, does what's right for Mirantis in my experience
22:05:36 <sdake> ok well that was so funny I had to cut and passte to my old c olleague there hope you dont mind :)
22:05:44 <wkharold> np
22:05:52 <daneyon_> wkharold: agreed. IIMO it looks better for OS if we're working together instead of competing.
22:06:04 <sdake> #topic blueprint review
22:06:12 <sdake> ok we have a slew of blueprints to get through
22:06:33 <sdake> first off I'd liek to discuss the prolifieration of tempaltes without them going upstream
22:06:56 <sdake> my suggestoin is people should try to get them into larsks repo, for the day that Mirantis wants to join the party we have started
22:07:12 <sdake> atm, everyorne is kind of jamming them into our repo
22:07:23 <sdake> I'm sure larsks would appreciate a community to develop around his templates
22:07:43 <sdake> so, whats our plan to get our work into his repo?
22:08:36 <sdake> crickets
22:08:38 <tcammann> Is it possible to get that repo into stackforge?
22:08:39 <sdake> ok here is what I propose
22:08:45 <sdake> well, that is a good idea
22:08:51 <daneyon_> cherry-pick and submit PRs to his repo?
22:08:54 <sdake> he does take pull requests
22:08:58 <wkharold> +1
22:09:12 <sdake> I hadn't thought of the stackforge idea
22:09:15 <sdake> I'll ask him about it
22:09:25 <sdake> I'd like to get to the point where we can just copy his full tree out and be good to go
22:09:26 <tcammann> We could pull changes from his repo
22:09:29 <wkharold> tho I'm not clear on who larsks is and what templates we're talking about
22:09:39 <tcammann> https://github.com/larsks/heat-kubernetes
22:09:41 <sdake> larsks is the cat who wrote all the templates magnum uses
22:09:58 <wkharold> got it, tnx
22:10:08 <sdake> and we hae gone and made coreos, ironic, and a few other variants
22:10:18 <wkharold> check
22:10:20 <sdake> we have 4 or 5 people working on templates
22:10:29 <sdake> nice they come from one source
22:10:39 <sdake> I'll hit larsks up and bring up the results at the next meeting
22:10:54 <sdake> ok now for blueprints
22:11:02 <sdake> keep in mind our deadline is the 27-29 of Feb
22:11:14 <daneyon_> sdake: why not have larsks add his templates to #link https://github.com/openstack/heat-templates
22:11:36 <sdake> daneyon_ I dont really like that repository, its not maintained very well
22:11:40 <tcammann> We wouldn't have +2s on that
22:11:46 <sdake> I know because I had to struggle to maintain it
22:11:49 <daneyon_> sdake: OK. thx
22:12:03 <sdake> ya tcammann has it right as well
22:12:13 <sdake> first the essential blueprints
22:12:23 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/ironic-heat-template
22:12:28 <sdake> still slow progress?
22:12:41 <yuanying-alt> template is finished
22:12:46 <yuanying-alt> but not integrated
22:12:49 <yuanying-alt> to magnum
22:12:56 <sdake> integrated and working by 29th?
22:13:16 <sdake> like 4 days :)
22:13:27 <yuanying-alt> ideally i need to multi template support
22:14:01 <sdake> what does that mean?
22:14:16 <sdake> integrate all the templatews?
22:14:26 <yuanying-alt> ironic template needs specific parameter
22:14:42 <yuanying-alt> Can i add it to baymodel simply?
22:14:46 <sdake> at baymodel or baycreatioin time?
22:15:00 <yuanying-alt> yes
22:15:09 <sdake> my theory about baymodel, is if your happy with it being permanent, baymodel is the place for it
22:15:26 <yuanying-alt> ok
22:15:31 <sdake> supporting update on baymodel will be huge time sink
22:15:41 <sdake> something to be done, maybe later ;)
22:15:50 <yuanying-alt> i see
22:15:51 <sdake> so good progress sounds like?
22:15:55 <yuanying-alt> yes
22:16:07 <sdake> nice getting closer to green ;)
22:16:07 <yuanying-alt> i change it to good progress
22:16:18 <sdake> https://blueprints.launchpad.net/magnum/+spec/magnum-bay-status
22:16:20 <sdake> not startedd
22:16:29 <sdake> I'm likely just to bump this one if there are not objections yuanying
22:16:42 <sdake> I don't think its all that essential anwyay, more like a medium
22:16:55 <sdake> thoughts?
22:17:07 <yuanying-alt> agree
22:17:14 <apmelton> yea... it would be nice, but at the moment you can just do a heat stack-list
22:17:21 <wkharold> that
22:17:37 <sdake> ya a bit hacky but works
22:17:38 <tcammann> +1
22:17:49 <hongbin> NP from me
22:17:50 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/python-k8sclient
22:18:03 <sdake> #action delisted magnum-bay-status from milestone #2
22:18:32 <sdake> I think this blueprint is dead inthe water because the upstream cat who was working on the library we were going to use obliterated his repostiroy
22:18:46 <sdake> so I guess I'll just keep it essential but move it to next milestone
22:19:06 <sdake> #action python-k8sclient kept essential moved to milestone #3 because of blockage on upstream
22:19:38 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/external-lb
22:19:48 <sdake> ok I've pretty much failed during kilo-2
22:19:53 * sdake sadfaces
22:20:02 <sdake> this will have to be bumped to k3
22:20:10 <sdake> but I'll definately tackle it, we needi t for 2015.1.0
22:20:44 <sdake> #action kept external-lb at essential but moved to milestone #3
22:20:59 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes
22:21:02 <sdake> wkharold your up :)
22:21:11 <wkharold> work tsunami
22:21:16 <sdake> slow progress, good progress, house on fire?
22:21:23 <wkharold> no progress, I suck
22:21:27 <sdake> ok its no problem
22:21:32 <sdake> I'll reset the started to not started
22:21:47 <wkharold> \sighs
22:22:09 <sdake> wkharold when you get a chance keep working on it, we have 1 month in our next dev cycle
22:22:17 <wkharold> k, will do
22:22:36 <sdake> The goood news is the essentials are out of the way
22:22:59 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/docker-bay-heat-template
22:23:09 <apmelton> that's implemented
22:23:59 <sdake> nice
22:24:31 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/introduce-coreos
22:24:51 <sdake> diga any word?
22:25:42 <sdake> well I know its good progress and not done, so I'll leave it there
22:25:45 <sdake> maybe it will maek it
22:25:55 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/magnum-docker-backend-selection
22:26:15 <sdake> nm that isn't scheduled
22:26:28 <sdake> #link https://blueprints.launchpad.net/magnum/+spec/magnum-scheduler-for-docker
22:26:46 <sdake> diga isn't here - I think he is in europe or something
22:27:10 <sdake> so I'll catch up with him when I seeh im around and get status on those two, but leaning towards kicking that one if schedule doesn't align
22:28:01 <sdake> #link looking good for milestone #2: https://blueprints.launchpad.net/magnum/milestone-2
22:28:23 <sdake> seems like our progress has slowed, but our commit count and review count are way up
22:28:30 <sdake> so I think we are just getting to problems that are harder to solve
22:28:58 <sdake> not sure why that m2-docs is on there
22:29:12 * sdake ever told anyone how much he despises launchpad?
22:29:16 <sdake> #topic open discussion
22:29:42 <wkharold> despising launchpad, +1
22:29:59 <apmelton> does anything actually like launchpad??
22:30:20 <wkharold> s/anything/anyone/ ?
22:30:24 <apmelton> yes
22:30:40 <wkharold> canonical types probably
22:31:15 <sdake> ok, well if there is nothing else
22:31:19 <sdake> I guess we can cionclude
22:31:28 <sdake> remember the midcycle is 2nd and 3rd of march
22:31:32 <wkharold> any word on remote participation in face-to-face?
22:31:32 <sdake> please be there, or be square ;-)
22:31:36 <sdake> youc an still sign up
22:31:45 <sdake> wkharold you will be able to use google groups
22:31:58 <wkharold> sweet
22:31:59 <sdake> Adrian was going to document how but he has been on pto for 2 weeks
22:32:17 <tcammann> I will dial in too
22:32:19 <sdake> I am sure he will tackle when he gets back
22:32:23 <wkharold> kewl
22:32:48 <sdake> oh, also, the chair of the BOD of OpenStack gave us a shout out in a asian conference
22:32:52 * sdake cheers
22:32:59 <wkharold> \claps
22:33:01 <apmelton> neato
22:33:46 <sdake> ok I'll end the meeting now
22:33:48 <sdake> thanks folks
22:33:49 <sdake> #endmeeting