16:00:32 <adrian_otto> #startmeeting containers
16:00:33 <openstack> Meeting started Tue Jun 23 16:00:32 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:36 <openstack> The meeting name has been set to 'containers'
16:00:46 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-06-23_1600_UTC Our Agenda
16:00:53 <adrian_otto> #topic Roll Call
16:00:57 <adrian_otto> Adrian Otto
16:00:59 <hongbin> o/
16:01:00 <jjlehr> o/
16:01:07 <Tango> Ton Ngo
16:01:12 <wznoinsk> \o/
16:01:14 <IlyaG> Ilya G
16:01:15 <tcammann_> hullo
16:01:19 <fawadkhaliq> Fawad Khaliq
16:01:20 <rpothier> Rob Pothier
16:01:21 <daneyon> here
16:01:23 <juggler_> Perry Rivera
16:01:30 <rbradfor> Ronald Bradford
16:01:31 <jjfreric> Jacob Frericks
16:01:42 <bradjones> o/
16:01:52 <apmelton> Andrew Melton
16:02:26 <thomasem> o/
16:02:34 <adrian_otto> hello hongbin jjlehr Tango wznoinsk IlyaG tcammann_ fawadkhaliq rpothier daneyon juggler_ rbradfor jjfreric bradjones apmelton thomasem
16:02:40 <thomasem> howdy
16:02:40 <juggler> o/
16:02:44 <diga> Digambar Patil
16:02:47 <daneyon> Good morning adrian_otto
16:03:05 <adrian_otto> sdake was planning to chair today, but will not be able to join us because he's attending to urgent dental care.
16:03:14 <adrian_otto> hello diga
16:03:24 <juggler> yowza
16:03:41 <diga> hi adrian_otto
16:03:43 <Tango> Thanks for taking time off your vacation to chair!
16:03:45 <adrian_otto> I'm on vacation, but was able to drop in to run this meeting.
16:03:50 <adrian_otto> thanks Tango
16:04:01 <daneyon> adrian_otto that's impressive
16:04:03 <eghobo> o/
16:04:08 <juggler> +1 adrian_otto
16:04:26 <adrian_otto> my internet access is not very impressive, so if I seem like I'm taking a *long* time to respond, that's why.
16:04:33 <daneyon> hopefully you can get back to enjoying your vacation
16:04:49 <adrian_otto> thanks guys
16:05:00 <adrian_otto> ok, we can start announcements...
16:05:19 <adrian_otto> 1) we now have a "Container Networking Subteam Meeting" initiated by daneyon
16:05:31 <adrian_otto> a first meeting is scheduled for 1800 UTC on Thursday 2015-06-24
16:05:46 <adrian_otto> the agenda is posted here...
16:05:53 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting
16:05:55 <daneyon> adrian_otto this review will need your +1 https://review.openstack.org/#/c/193694/
16:06:03 <adrian_otto> feel free to annotate the agenda
16:06:07 <daneyon> to lock in the date and time for the meeting
16:06:09 <wznoinsk> adrian_otto: is that 06-25 actually?
16:06:25 <daneyon> oops
16:06:29 <daneyon> yes, let me update it
16:06:40 <daneyon> sorry, I went back and forth on a few dates and times
16:07:05 <adrian_otto> daneyon: I voted +1 on https://review.openstack.org/193694
16:07:22 <adrian_otto> good catch wznoinsk
16:07:54 <adrian_otto> ok, any questions about the subgroup?
16:08:09 <daneyon> adrian_otto thanks and I have corrected the date to 6/25
16:08:34 <eghobo> sorry, what is subgroup?
16:08:35 <adrian_otto> any other announcements from team members?
16:08:51 <daneyon> Sorry all for not providing a longer runway for the meeting. Scheduling the meeting took a bit longer than i anticipated.
16:08:51 <adrian_otto> eghobo: it's an official working group that focuses on a specific topic
16:09:07 <eghobo> got it, thx
16:09:10 <adrian_otto> meetings are logged/archived
16:09:41 <adrian_otto> it's an opportunity to make directional decisions as a group and have interactive discussions outside the constraints of our main meeting
16:10:15 <adrian_otto> selecting times and dates for those proceedings is always hard with such a diverse group
16:10:32 <adrian_otto> ok, advancing to action items
16:10:36 <adrian_otto> #topic Review Action Items
16:10:43 <adrian_otto> 1) diga__ to follow up with ewindsich regarding Swarm+Mesos questions
16:10:46 <daneyon> The initial meeting will docus on this blueprint #link https://blueprints.launchpad.net/magnum/+spec/native-docker-network
16:10:52 <adrian_otto> diga: any status on this?
16:11:20 <diga> adrian_otto: I have mailed to ewindsich
16:11:26 <diga> waiting for his reply
16:11:39 <adrian_otto> please follow up
16:11:39 <daneyon> Then we will decide as a subteam if it makes sense to continue separate weekly meetings.
16:11:56 <diga> yes
16:12:00 <adrian_otto> #action diga to follow up with ewindsich regarding Swarm+Mesos questions
16:12:07 <adrian_otto> 2) jay-lau-513 Clarify human name generation algorithm plans in BP
16:12:23 <adrian_otto> I don't think jay-lau-513 is here today
16:12:42 * adrian_otto taking a moment to reference BP
16:13:25 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/auto-generate-name Auto generate Bay/BayModel Name
16:13:53 <adrian_otto> looks like this action should be carried forward
16:14:07 <adrian_otto> #action jay-lau-513 Clarify human name generation algorithm plans in BP
16:14:21 <adrian_otto> 3) adrian_otto to help Madhuri identify a resource on the Kubernetes team who can assist us with TLS feature implementation
16:14:27 <adrian_otto> #action adrian_otto to help Madhuri identify a resource on the Kubernetes team who can assist us with TLS feature implementation
16:14:41 <adrian_otto> I did not make contact with Madhuri, and she is not present, so carried that one.
16:14:49 <adrian_otto> 4) Tango to start and ML discussion to explain trouble with Magnum/K8s integration for LB (https://blueprints.launchpad.net/magnum/+spec/external-lb)
16:15:05 <adrian_otto> Tango: status here?
16:15:19 <Tango> I posted a question to Angus Lee, who wrote the code, but no response
16:15:33 <adrian_otto> so let's put this on the public ML
16:15:35 <sdake> o/
16:15:36 <sdake> gott adrop early
16:15:48 <adrian_otto> hi sdake
16:16:02 <Tango> I do want to get some input from the team on how to extend LB to other COE, will do some more homework and send to ML
16:16:18 <adrian_otto> Tango, ok, I will carry yours.
16:16:28 <adrian_otto> #action Tango to start and ML discussion to explain trouble with Magnum/K8s integration for LB (https://blueprints.launchpad.net/magnum/+spec/external-lb)
16:16:35 <adrian_otto> #action sdake to take results and create separate bugs per test case
16:16:46 <adrian_otto> ^^ that's from our last meeting's brainstorm session
16:17:07 <adrian_otto> any more discussion on action items?
16:17:23 <adrian_otto> #topic Blueprint/Bug Review
16:17:26 <adrian_otto> Tasks/Bugs
16:17:33 <adrian_otto> #link http://goo.gl/sIlYla High and Critical Priority Bugs
16:17:48 <adrian_otto> I don't think we have any orphans
16:18:17 <adrian_otto> but 9 of those bugs don't have patches yet
16:18:35 <adrian_otto> so if you own one of those, and need help with it, now is when you can call attention to it
16:18:49 <diga> yes adrian_otto
16:19:24 <adrian_otto> diga, you own this one: https://bugs.launchpad.net/magnum/+bug/1451118
16:19:25 <openstack> Launchpad bug 1451118 in Magnum "magnum throws db exception on failed bay deletion" [High,Triaged] - Assigned to Digambar (digambarpatil15)
16:19:35 <adrian_otto> did you need to ask for help with it?
16:19:44 <diga> I am not able to reproduce the bug
16:20:07 <diga> I will discuss with sdake & hongbin on this
16:20:11 <adrian_otto> ok, sdake, can you advise?
16:20:25 <sdake> i gave an exact reproducer in the bug
16:20:30 <sdake> diga_ did yo utry that reproducer?
16:20:30 <tcammann_> Think sdake had to leave a minute ago
16:20:39 <adrian_otto> I set the status to incomplete pending ability to reproduce
16:20:46 <sdake> i've got to jet around 9:40 i think
16:21:00 <diga> no, I will follow it
16:21:19 <adrian_otto> ok, marking back to Triaged again
16:21:21 <sdake> not although the reproducer is a bit unnatural, it would happen in a real environment
16:21:27 <sdake> not/note
16:21:42 <sdake> would/could
16:21:50 <adrian_otto> ok, any other high/critical bugs that need help to resolve?
16:21:54 <sdake> FUC MY TOOTH HURTS
16:22:07 * adrian_otto empathy
16:22:35 <juggler> adrian_otto I'll see if I can get 1451678 resolved and let you know if I need help
16:23:10 <adrian_otto> so my ask here is for each bug owner in these categories take a look and see what can be done to drive these closer to resolution
16:23:20 <adrian_otto> let's call on the team to assist if you get stuck
16:23:34 <adrian_otto> let's look at blueprints next
16:23:41 <adrian_otto> Blueprints
16:24:05 <adrian_otto> #link https://blueprints.launchpad.net/magnum Magnum Blueprints
16:24:28 <adrian_otto> I'm seeking updates on the Essential and High priority items, so I will call out each
16:24:42 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/async-container-operations apmelton
16:24:51 <adrian_otto> updates?
16:24:55 <apmelton> no updates, did we push taht to L2?
16:25:07 <apmelton> yea, it's L2
16:25:10 <adrian_otto> we may have. I will scope the view to L1
16:25:14 <adrian_otto> one moment
16:25:28 <apmelton> also, I'll be on vacation next week
16:25:37 <apmelton> so I'll likely miss the weekly meeting
16:25:41 <adrian_otto> ok, here is the L1
16:25:44 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-docker
16:25:50 <adrian_otto> that's yours apmelton
16:26:01 <apmelton> adrian_otto: that will need to be pushed to L2 as well
16:26:11 <adrian_otto> #Link https://launchpad.net/magnum/+milestone/liberty-1
16:26:23 <adrian_otto> #link https://launchpad.net/magnum/+milestone/liberty-1 Liberty-1 Blueprints
16:26:38 <adrian_otto> ok, re-targeting secure-docker
16:27:13 <adrian_otto> apmelton: need any assistance with that one?
16:27:26 <adrian_otto> (retargeted to L2)
16:27:27 <sdake> from last week depends on madhuri's work
16:27:47 <sdake> looks like guide put together by csco guy wasn't totally complete
16:27:58 <sdake> but yuanying filled in the gaps
16:28:03 <adrian_otto> https://blueprints.launchpad.net/magnum/+spec/add-periodic-task Add periodic task for magnum conductor
16:28:08 <apmelton> once I can get some time back on magnum, I'll likely be able to not only work on the docker piece but also help out on the k8s tls stuff as well
16:28:27 <adrian_otto> sorry, lagged. did not see your reply
16:29:02 <apmelton> sdake: is that guide linked on the BP
16:29:15 <adrian_otto> ideally I'd like to see new bugs linked to these top blueprints
16:29:22 <adrian_otto> to indicate our progress toward resolution
16:29:36 <sdake> apmelton its lined on our wiki i thin kapmelton
16:29:40 <sdake> send email to maduri for specifics
16:30:00 <sdake> adrian_otto did the lining so he should know where its lined from
16:30:19 <adrian_otto> yes, I think I uploaded it to the wiki site
16:30:20 <apmelton> sdake: I'll give it a one-over, thanks!
16:30:22 <adrian_otto> looking
16:30:26 <apmelton> https://wiki.openstack.org/w/images/7/7a/Certificate_Cookbook.pdf
16:30:32 <adrian_otto> yep, that's it
16:31:06 <adrian_otto> ok, any more on this one?
16:31:48 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/add-periodic-task Add periodic task for magnum conductor (Eli Qiao)
16:31:52 <adrian_otto> status?
16:32:05 <sdake> eli is in apac i think
16:32:07 <tcammann_> There are serveral patches up for review
16:32:13 <tcammann_> good progress
16:32:37 <hongbin> I think so
16:32:45 <adrian_otto> ok, thanks tcammann_. Should I update the implementation status to "Good Progress"?
16:33:07 <sdake> tcammann_ havey ou reviweed the patches and thin they are lamost doen?
16:33:11 <sdake> if so good progress maes sense
16:33:25 <hongbin> I think it makes sense. I have reviewed the patch
16:33:35 <sdake> hongbin wfm :)
16:33:44 <adrian_otto> updated, thanks
16:33:45 <tcammann_> Yep, the design seems correct, few tweaks need
16:35:00 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/mesos-bay-type Add support for mesos bay type
16:35:14 <adrian_otto> hongbin: status?
16:35:19 <hongbin> It is pending on reviews
16:35:49 <hongbin> After the patches landed, this BP can be considered done I think
16:35:57 <adrian_otto> ok, excellent
16:36:07 <hongbin> But need more BP for additional mesos feature
16:36:32 <hongbin> such as multiple master nodes, network, etc.
16:37:06 <adrian_otto> hongbin: acknowledged.
16:37:33 <adrian_otto> when you have time, please consider submitting additional BP's accordingly
16:37:44 <hongbin> adrian_otto: sure
16:37:58 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/mesos-bay-with-coreos Add support for mesos bay type (diga)
16:38:02 <adrian_otto> diga: status?
16:38:02 <diga> We have retargeted this BP to L2 in the last meeting, Need some discussion with ewindsich
16:38:13 <adrian_otto> ok, retargeting
16:38:22 <diga> yep
16:39:19 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/integrate-ci-metrics Integrate CI Metrics (rbradfor)
16:39:31 <adrian_otto> rbradfor: status?
16:40:02 <rbradfor> the work added to Zuul does not show up in each commit
16:40:57 <rbradfor> I need to reach out to the Infra team as to why. I want the default coverage test used by some other projects in place first. I have some work for creating a new gate for metrics, following this initial jenkins gate.
16:41:13 <rbradfor> unfortunately with a day job, have limited time at present.
16:41:18 <adrian_otto> that's currently marked as a medium, so I won't hound you on this one.
16:41:35 <adrian_otto> thanks for your work on this.
16:41:37 <rbradfor> ok, but keep on my case, I'd like to see it done.
16:41:55 <adrian_otto> ok, we can ask again next week (sdake to remember)
16:42:19 <adrian_otto> any other blueprints or bugs that should be discussed as a team today?
16:42:53 <adrian_otto> I don't think mismith is here today, correct?
16:43:00 <adrian_otto> I think this may have been left over from last week:
16:43:04 <adrian_otto> State of Magnum RDO packaging - (agenda item requested by mismith from Overstock)
16:43:09 <daneyon> adrian_otto the initial network subteam will focus on this bp #link https://blueprints.launchpad.net/magnum/+spec/native-docker-network
16:43:12 <adrian_otto> should we touch on that topic?
16:43:24 <sdake> i packaged magnum for rdo
16:43:26 <sdake> in coprs
16:43:27 <adrian_otto> daneyon: excellent
16:43:35 <sdake> i dont know if the systemd files work
16:43:38 <adrian_otto> #topic State of Magnum RDO packaging - (agenda item requested by mismith from Overstock)
16:43:39 <sdake> it needs testing by omeone that has a rdo setup
16:43:39 <daneyon> Are their any goals you have from the subteam's initial meeting tomorrow?
16:44:05 <adrian_otto> sdake, are you willing to track down mismith to see if the concern can be addressed?
16:44:13 <sdake> will do
16:44:14 <daneyon> I am targeting 7/22 to submit the spec for the BP (due to holiday/vacation schedule)
16:44:25 <adrian_otto> thanks, sdake… time for you to scoot?
16:44:35 <sdake> ya waiting on ride
16:44:41 <sdake> so i'm good to go until he is ready to go
16:44:45 <adrian_otto> kk
16:44:57 <adrian_otto> daneyon: that's good. My guadance….
16:45:14 <adrian_otto> find ways to break down the work into bite sized chunks
16:45:28 <adrian_otto> document each in unique BP's and/or wishlist tasks in the bug system
16:45:32 <daneyon> adrian_otto I believe that gives us ~ 10 days to approve the spec for L2
16:45:36 <sdake> what is the fibbonaci number after 21 daneyon ;)
16:45:43 <daneyon> lol
16:45:46 <adrian_otto> let's take the obvious low hang fruit first and go from there
16:45:56 <adrian_otto> sdake: ;-)
16:45:59 <adrian_otto> exactly
16:45:59 <juggler> that sounds like a tag :)
16:46:44 * sdake takes his words back :)
16:47:16 <adrian_otto> thanks daneyon for your help with that
16:47:29 <daneyon> adrian_otto yw
16:47:47 <adrian_otto> I'll advance to open discussion if you're comfortable with next steps there
16:48:15 <adrian_otto> #topic Open Discussion
16:48:26 <tcammann_> Any midcycle plans yet? adrian_otto you mentioned you were gonna send a mail out?
16:48:42 <adrian_otto> tcammann_: thanks for the reminder
16:49:03 <adrian_otto> the first things we need to decide are venue and a date range
16:49:07 <sdake> note midcycle for olla is 28th/29th (likely but not confirmed)
16:49:24 <adrian_otto> sdake: that's in the month of July?
16:49:25 <sdake> so daneyon and I will be unavaiable then
16:49:35 <sdake> yes uly
16:49:47 <adrian_otto> ok
16:50:04 <daneyon> anyone submit magnum-related talks for the upcoming design summit?
16:50:05 <sdake> waiting on facilities confirmation
16:50:24 <sdake> I wa planning to leave that to adrian
16:50:40 <adrian_otto> are there volunteers for hosting the midcycle. I expect we need conference facilities suitable for a group of about 30/
16:50:40 <sdake> but someone using magnum in production would make a geat talk :)
16:50:43 <Tango> If folks are willing to come to San Jose, we can host at the IBM Lab here.
16:50:44 <sdake> lets see if we can make that happen
16:51:08 <sdake> tango that sounds fantastic
16:51:14 <daneyon> +1 on SJ
16:51:17 <sdake> just make sure there are sodas in the morning ;)
16:51:29 <adrian_otto> we do have a high concentration of contributors in the bay area
16:51:35 <Tango> :) no beer though
16:51:44 <sdake> i would offer jsc at cisco but it took the stars to align to get a olla midcycle there
16:51:45 <juggler> lol
16:51:48 <eghobo> +2 for SJ
16:51:57 <daneyon> I could look into hosting it in Irvine CA if you would like
16:52:02 <adrian_otto> would any of our APAC contributors fly over for the midcycle if it were in San Jose, CA?
16:52:29 * ijw_ has nothing to do with the project but can offer SJC beer recommendations
16:52:43 <sdake> one thing to keep in mind, all companies have a 14 day cuttoff on travel reserations so need to hae a facility and date soon
16:53:04 <adrian_otto> ijw_: our last midcycle was at Rackspace in SFO where beer was on tap in our room with us.
16:53:22 <ijw_> adrian_otto: short of an IV that's going to be hard to top
16:53:24 <sdake> adrian_otto the joys of being a semi-startup ;)
16:53:38 <adrian_otto> indeed.
16:54:31 <tcammann_> Any provisional dates?
16:54:46 <adrian_otto> ok, so daneyon and Tango if you could check with your respective employers to see what's possible in San Jose and Irvine respectively, we can aim for date in accordance with availability.
16:54:55 * adrian_otto looks at calendar
16:55:52 <Tango> I do have management approval for hosting, once we have the date confirmed, we can make plan
16:56:11 <daneyon> adrian_otto I will look into the Irvine venue. Since we are hosting Kolla in SJ, I would need someone else to step up with the food, drinks, etc..
16:56:21 <adrian_otto> ok, I do have some date costraints
16:56:35 <sdake> irvine is cco facility?
16:56:36 <daneyon> adrian_otto I could also use some dates to work with
16:56:36 <adrian_otto> daneyon: ok, thanks.
16:56:53 <sdake> daneyon if so, I can tel you that is DOA :)
16:57:08 <sdake> tango's offer seems solid - lets go with that
16:57:09 <daneyon> sdake why is that?
16:57:11 <adrian_otto> looks like I will me in SFO on July 13-14
16:57:11 <rbradfor> do you have an initial 2-4 week period we can at least start with?
16:57:14 <sdake> tango can doule chec that
16:57:28 <sdake> tango and get confirmation from the bosses :)
16:57:45 <Tango> So we are looking at July 13-14?
16:58:25 <adrian_otto> Tango: I'll follow up with you, we'll need more time to work on details.
16:58:35 <Tango> Sounds good.
16:58:46 <adrian_otto> #action adrian_otto to circulate doodle poll for midcycle dates
16:59:07 <adrian_otto> ok, we have just a minute or so remaining for today's meeting
16:59:47 <adrian_otto> Our next (non-subteam) meeting will be Tuesday 2015-06-30 at 2200 UTC
16:59:54 <juggler> thx adrian... now go vacate! :)
16:59:55 <adrian_otto> thanks everyone for attending
17:00:00 <tcammann_> Thanks adrian_otto
17:00:16 <adrian_otto> #endmeeting