#openstack-meeting-alt: containers

Meeting started by adrian_otto at 22:00:28 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-07-14_2200_UTC Our Agenda (adrian_otto, 22:00:53)

  1. Roll Call (adrian_otto, 22:00:56)
  2. Announcements (adrian_otto, 22:04:17)
    1. http://lists.openstack.org/pipermail/openstack-dev/2015-July/069130.html Summary of our TLS Design Meeting (adrian_otto, 22:04:47)
    2. https://review.openstack.org/194905 Spec Review for TLS Support in Magnum (adrian_otto, 22:05:07)
    3. ACTION: adrian_otto to follow up with Barbican team to arrange assistance for integration with Magnum (adrian_otto, 22:06:55)
    4. https://wiki.openstack.org/wiki/Magnum/Midcycle Magnum Midcycle Details (adrian_otto, 22:10:23)

  3. Container Networking Subteam Update (adrian_otto, 22:14:04)
    1. https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting (daneyon, 22:14:51)

  4. Review Action Items (adrian_otto, 22:15:42)
    1. http://www.meetup.com/Docker-Online-Meetup/events/223796871/ (daneyon, 22:16:09)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-July/068993.html Magnum as a CA (adrian_otto, 22:17:04)
    3. ACTION: All core reviewers to review https://review.openstack.org/194905 (adrian_otto, 22:18:33)
    4. http://lists.openstack.org/pipermail/openstack-dev/2015-July/069402.html ML Thread for Hyper/Magnum Integration (adrian_otto, 22:19:16)
    5. https://wiki.openstack.org/wiki/Magnum/Midcycle Magnum Midcycle Details (adrian_otto, 22:19:39)

  5. Discuss Future of heat-coe-templates (adrian_otto, 22:20:01)
    1. http://lists.openstack.org/pipermail/openstack-dev/2015-June/068237.html ML Discussion (June) (adrian_otto, 22:20:07)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html ML Discussion (July) (adrian_otto, 22:20:12)
    3. https://github.com/openstack/magnum/tree/master/magnum/templates (daneyon, 22:27:41)
    4. AGREED: tcammann will move heat-coe-templates to the attic, and we will maintain the existing fork in the magnum tree for Magnum heat templates at https://github.com/openstack/magnum/tree/master/magnum/templates (adrian_otto, 22:30:41)
    5. ACTION: tcammann to move heat-coe-templates repo to project attic, and to relay our resolution on the ML thread: http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html (adrian_otto, 22:31:52)

  6. Keystone Support and Devstack Broken Gate (adrian_otto, 22:33:28)
    1. http://lists.openstack.org/pipermail/openstack-dev/2015-July/069398.html Problem Overview (adrian_otto, 22:33:59)
    2. https://blueprints.launchpad.net/magnum/+spec/magnum-keystone-v3 Keystone v3 API Support Blueprint (adrian_otto, 22:34:17)
    3. https://review.openstack.org/200835 Workaround for Devstack bug (adrian_otto, 22:34:44)
    4. https://bugs.launchpad.net/magnum/+bug/1474152 Tech Debt: Reverse temporary gate fix (adrian_otto, 22:34:59)

  7. Blueprint/Bug Review (adrian_otto, 22:36:05)
    1. https://blueprints.launchpad.net/magnum/+spec/hyperstack Power Magnum to run on metal with Hyper (adrian_otto, 22:36:23)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-July/068574.html Hyper Magnum Integration Discussion (adrian_otto, 22:37:15)
    3. https://blueprints.launchpad.net/magnum/+spec/objects-from-bay Obtain the objects from the bay endpoint (sdake) (adrian_otto, 22:40:13)
    4. https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes Secure the client/server communication between ReST client and ReST server (madhuri) (adrian_otto, 22:41:49)
    5. https://blueprints.launchpad.net/magnum/+spec/external-lb Support the kubernetes service external-load-balancer feature (sdake) (adrian_otto, 22:44:17)
    6. https://blueprints.launchpad.net/magnum/+spec/magnum-swarm-scheduling Provide container anti-affinity through swarm constraint filtering (diga) (adrian_otto, 22:52:44)
    7. https://blueprints.launchpad.net/magnum/+spec/secure-docker Secure client/server communication using TLS (apmelton) (adrian_otto, 22:54:29)

  8. Open Discussion (adrian_otto, 22:58:44)
    1. https://rbtcollins.wordpress.com/2015/07/12/bootstrapping-developer-environments-for-openstack/ (mfalatic, 22:59:50)


Meeting ended at 23:00:17 UTC (full logs).

Action items

  1. adrian_otto to follow up with Barbican team to arrange assistance for integration with Magnum
  2. All core reviewers to review https://review.openstack.org/194905
  3. tcammann to move heat-coe-templates repo to project attic, and to relay our resolution on the ML thread: http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html


Action items, by person

  1. adrian_otto
    1. adrian_otto to follow up with Barbican team to arrange assistance for integration with Magnum
  2. openstack
    1. All core reviewers to review https://review.openstack.org/194905
    2. tcammann to move heat-coe-templates repo to project attic, and to relay our resolution on the ML thread: http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html


People present (lines said)

  1. adrian_otto (160)
  2. sdake (40)
  3. sdake_ (39)
  4. daneyon (33)
  5. madhuri_ (19)
  6. tcammann1 (18)
  7. juggler (17)
  8. Tango (14)
  9. mfalatic (11)
  10. hongbin (7)
  11. eghobo (6)
  12. openstack (4)
  13. yuanying-alt (3)
  14. dane_leblanc (2)
  15. suro-patz (1)
  16. rods (1)


Generated by MeetBot 0.1.4.