16:00:08 <adrian_otto> #startmeeting containers
16:00:09 <openstack> Meeting started Tue Aug 4 16:00:08 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-08-04_1600_UTC Our Agenda
16:00:13 <openstack> The meeting name has been set to 'containers'
16:00:23 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-08-04_1600_UTC Our Agenda
16:00:27 <adrian_otto> #topic Roll Call
16:00:30 <adrian_otto> Adrian Otto
16:00:37 <jjlehr> o/
16:00:48 <Tango> Ton Ngo
16:00:57 <rpothier> o/
16:01:29 <mfalatic> o/
16:01:30 <brendenblanco> o/
16:01:42 <fawadkhaliq> o/
16:02:07 <dane_leblanc> o/
16:02:13 <jjfreric> jacob frericks
16:02:16 <eghobo> o/
16:03:12 <adrian_otto> hello jjlehr, Tango, rpothier, mfalatic, brendenblanco, fawadkhaliq, dane_leblanc, jjfreric, and eghobo
16:03:32 <daneyon> here
16:04:10 <adrian_otto> hello daneyon. Let's begin.
16:04:15 <adrian_otto> #topic Announcements
16:04:15 <wznoinsk1> o/
16:04:20 <adrian_otto> 1) Our Midcycle Meetup happens this week (tomorrow and Thursday). If you are attending in person, don't forget to register:
16:04:26 <adrian_otto> #link https://wiki.openstack.org/wiki/Magnum/Midcycle Midcycle Information
16:04:35 <adrian_otto> questions about the location, attendance, etc?
16:05:47 <adrian_otto> 2) adrian_otto will be out on 2015-08-25 due to travel to OpenStack Silicon Valley event. An alternate chair is needed for our team meeting on that day.
16:06:08 <adrian_otto> I will be in the air at the time we are scheduled to meet, and chairing from in-flight wifi = bad idea.
16:06:49 <adrian_otto> if you can help out with that, please ping me about it. Otherwise I'll follow up on this during our Midcycle or at our next week meeting
16:06:55 <daneyon> adrian_otto would you like me to address this topic or someone from neutron: Network: Neutron integration - Kuryr/flannel remote driver for libnetwork, flannel bridged mode
16:07:42 <adrian_otto> if you'd like to address that briefly
16:07:46 <adrian_otto> #topic Container Networking Subteam Update
16:07:50 <adrian_otto> you can do it now
16:08:17 <daneyon> OK, I just wanted to make sure I'm on the hook for the presenation.
16:08:48 <adrian_otto> #link http://eavesdrop.openstack.org/meetings/container_networking/2015/container_networking.2015-07-30-18.00.html previous Container Networking Subteam Meeting Minutes
16:08:54 <daneyon> We are starting to work with the kuryr team. Here is an therpad for our initial brainstorming: https://etherpad.openstack.org/p/magnum-kuryr
16:09:24 <adrian_otto> daneyon, we need to sort out the remote presentation logistics today. Let's plan to regroup with Tango to sort that out
16:09:36 <daneyon> Gal and/or Mestery will be attending the net subteam meeting later this week.
16:10:05 <adrian_otto> good, some high bandwidth discussion should help to advance us
16:10:11 <daneyon> I updated the networking spec and I think we now have support of the neutron/kuryr team. I'm in the process of making a few final updates and it should be done
16:10:43 <daneyon> adrian_otto sounds good re the remote logistics. It's pretty easy with webex.
16:10:52 <adrian_otto> I'd like to offer guidance for those of us here today, that if you vote -1 against a spec patch, please make your vote actionable. INdicate what exactly should change in order for you to reverse your vote.
16:11:27 <adrian_otto> but simply voting against a spec with the equivalent of "I don't like it" is not as helpful as an actionable remark.
16:11:51 <jjfreric> I agree, there's nothing more annoying than a -1 without a way to fix it
16:11:54 <daneyon> adrian_otto thx for adding that info. All, please take some time to cast your vote on the spec. It will be great to get the spec through and start the work to realize it.
16:11:57 <adrian_otto> use in-line comments to be specific.
16:12:28 <adrian_otto> #link https://review.openstack.org/204686 Magnum Container Networking Spec
16:12:47 <adrian_otto> also keep in mind that a spec is also a living document, so if we want to revise it after merge, that's still possible.
16:12:58 <daneyon> thx to everyone for your participation and support with the net spec
16:13:14 <adrian_otto> the reason for that is so we don't spend too much time making it "perfect" before getting people working on it
16:13:15 <daneyon> any net specific questions?
16:13:42 <daneyon> I encourage everyone to take a few minutes to check out the initial kuryr design: https://github.com/openstack/kuryr/blob/master/doc/source/design.rst
16:13:45 <daneyon> #link https://github.com/openstack/kuryr/blob/master/doc/source/design.rst
16:14:03 <adrian_otto> oh, that's new.
16:14:17 <daneyon> unless their are any questions, i'll hand it back to adrian_otto
16:14:44 <daneyon> adrian_otto, it is, I just did my first initial review and digesting the info.
16:14:57 <adrian_otto> Thanks daneyon
16:15:00 <daneyon> we will disuss the design in more detail during our net subteam meeting
16:15:05 <adrian_otto> #topic Magnum UI Subteam Update
16:15:06 <daneyon> adrian_otto yw
16:15:21 <adrian_otto> anyone working on this?
16:15:59 <adrian_otto> Bradley Jones is not present today, is he?
16:16:40 <adrian_otto> my key concern is that we don't have any blueprints here yet:
16:16:41 <adrian_otto> https://blueprints.launchpad.net/magnum-ui
16:17:10 <Tango> I have asked 2 core members from Horizon to join the UI discussion during the midcycle. They should be able to discuss more.
16:17:16 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-horizon-plugin Web Interface for Magnum in Horizon
16:17:24 <adrian_otto> that seems to have no activity either.
16:17:30 <bradjones> adrian_otto: I am here
16:17:48 <adrian_otto> oh wait
16:17:54 <bradjones> I have a list of BPs to add, I have been away past few days, will add them later today
16:17:57 <adrian_otto> #link https://review.openstack.org/188958 Web Interface for Magnum in Horizon
16:18:03 <adrian_otto> hi bradjones!
16:18:35 <bradjones> I have been working on BayModel too, should be up for review shortly
16:18:47 <adrian_otto> ok, so will you be able to join us next Tuesdat at 2200 UTC for a subsequent update?
16:19:01 <bradjones> adrian_otto: sure will be there
16:19:07 <adrian_otto> If we are going to get this in during the Liberty release timeframe, we need to get rolling on it
16:19:20 <bradjones> adrian_otto: agreed
16:19:25 <adrian_otto> ok, thanks
16:19:35 <adrian_otto> #topic Review Action Items
16:19:58 <adrian_otto> now last meeting was chaired by juggler, and he went a little cookoo with action items
16:20:07 <adrian_otto> but let's rush through these
16:20:10 <adrian_otto> 1) Libnetwork team / daneyon to coordinate meeting for possible integration solution
16:20:13 <adrian_otto> Status?
16:20:41 <daneyon> the kuryr team will be joining our regular subteam meeting to discuss
16:20:49 <daneyon> #link https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting
16:20:49 <adrian_otto> this may be obviated my Midcycle discussions, right?
16:20:54 <daneyon> it's on the agenda
16:20:56 <adrian_otto> Status: obviated
16:20:59 <adrian_otto> 2) daneyon to update the wiki for net subteam meeting
16:21:01 <adrian_otto> Status:
16:21:08 <adrian_otto> complete, I think
16:21:16 <daneyon> and an ep has been created to assist with brainstorming the integration details
16:21:19 <daneyon> #link https://etherpad.openstack.org/p/magnum-kuryr
16:21:20 <adrian_otto> I saw an update there. Was it the update this action refers to?
16:21:29 <daneyon> yes, both are complete
16:21:32 <adrian_otto> thanks daneyon
16:21:35 <adrian_otto> Status: complete
16:21:41 <adrian_otto> 3) apmelton to review snakeoil plugin and assist madhuri with integration
16:22:07 <adrian_otto> Status: unknown
16:22:35 <adrian_otto> 4) adrian_otto to table Hyper discussion to the ML or MidCycle
16:22:39 <adrian_otto> Status: complete
16:22:52 <adrian_otto> 5) sdake/tcammann to sync up on https://blueprints.launchpad.net/magnum/+spec/objects-from-bay at MidCycle
16:22:56 <adrian_otto> #action sdake/tcammann to sync up on https://blueprints.launchpad.net/magnum/+spec/objects-from-bay at MidCycle
16:23:04 <adrian_otto> 6) implement TLS and non-TLS support with insecure off by default
16:23:06 <apmelton> hey yall, sorry for being late
16:23:10 <adrian_otto> This should have been recorded as an #agreed rather than an #action
16:24:02 <adrian_otto> #agreed from 2015-07-28 team meeting: implement TLS and non-TLS support with insecure off by default
16:24:17 <adrian_otto> 7) establish tech debt ticket to remove insecure option
16:24:25 <adrian_otto> This was not assigned to anyone. Any volunteers?
16:24:35 <adrian_otto> or maybe this got done and I have not noticed?
16:24:54 <adrian_otto> #action adrian_otto to open tech debt ticket to remove insecure option
16:25:01 <adrian_otto> 8) Add Magnum UI update section to the agenda for future meetings
16:25:05 <adrian_otto> Status: complete
16:25:11 <adrian_otto> 9) All: Record MidCycle topics prior to the MidCycle: https://etherpad.openstack.org/p/magnum-liberty-midcycle-topics
16:25:19 <adrian_otto> Status: Informational.
16:25:27 <adrian_otto> 10) Contact adrian_otto for MidCycle agenda discussion topics via e-mail
16:25:37 <adrian_otto> Status: Informational, obviated by etherpad.
16:25:57 <adrian_otto> apmelton, do you have remarks for #3:
16:25:58 <adrian_otto> 3) apmelton to review snakeoil plugin and assist madhuri with integration
16:26:10 <apmelton> yea, I'd say it's started, but not complete
16:26:20 <apmelton> had a heck of a time trying to get barbican going with devstack, but it's going now
16:26:22 <adrian_otto> Status: Started
16:26:29 <adrian_otto> I will carry it forward for next week
16:26:36 <adrian_otto> #action apmelton to review snakeoil plugin and assist madhuri with integration
16:26:50 <apmelton> sounds good, I'm gonna try to have as much info as I can for the tls session(s) at the mid-cycle
16:27:08 <adrian_otto> Thanks apmelton
16:27:13 <adrian_otto> Any questions or concerns about any of the action items from last week?
16:27:26 <adrian_otto> #topic Blueprint/Bug Review
16:27:33 <adrian_otto> New Blueprints for Discussion
16:27:39 <adrian_otto> Team members may nominate new blueprints for discussion so they may be processed.
16:28:18 <adrian_otto> so if you have a BP in status "New" that you'd like to be considered for the current release (and you are coming with engineering resources to get it done) this is the place to raise it for consideration.
16:28:57 <adrian_otto> ok, so last week we talked about getting status for all the essential BP's on a wiki or etherpad that could be referenced at meeting time..
16:29:06 <adrian_otto> I did not coordinate that this week, sorry.
16:29:17 <adrian_otto> would you like to step through these?
16:30:11 <adrian_otto> if not, I'll pause for a moment, and you can ask about the ones you are interested in
16:30:38 <adrian_otto> I'm interested in https://blueprints.launchpad.net/magnum/+spec/external-lb
16:31:09 <Tango> I can give some update
16:31:33 <adrian_otto> Work Items section in the BP shows every work item as INPROGRESS or TODO
16:31:43 <adrian_otto> can any of those be marked complete?
16:32:03 <Tango> Previously I mentioned about 2 issues: image problem and debugging k8s
16:32:33 <Tango> the image problem has been resolved and I made the image/patches available for others to try k8s v1
16:33:04 <Tango> I have been debugging the backend, going through the logs and go code
16:33:24 <Tango> I tried the google container IRC and ML, but could not get much help there
16:33:57 <Tango> Now it's down to plowing through the code and adding more logging to see the error
16:34:16 <Tango> I will update the items on the bp
16:34:49 <adrian_otto> thanks, it would be great if we could keep those essential BPs updated regularly so we can peek in there and see what's happening
16:34:58 <Tango> yep, will do
16:35:01 <adrian_otto> thanks
16:35:35 <adrian_otto> ok, any other essential blueprints that made forward progress this week?
16:35:46 <adrian_otto> I know there was movement on our TLS/CA efforts
16:37:07 <adrian_otto> perhaps we'll hear more about that at the MIdcycle
16:37:19 <adrian_otto> let's look at the midcycle agenda topics
16:37:38 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-liberty-midcycle-topics Midcycle Agenda
16:37:50 <adrian_otto> #topic Midcycle Agenda Planning
16:39:05 <adrian_otto> it might be nice to do a team retrospective for the first half of the liberty release
16:39:34 <adrian_otto> discuss things like: How are we doing as a team? What should we start/stop/continue to make the team more effective, or more engaging to be part of?
16:39:51 <Tango> +1
16:40:06 <apmelton> agreed, I think that'd be a good idea
16:41:46 <adrian_otto> has anyone volunteered to give the Mesos bay type update?
16:42:30 <adrian_otto> I don't think Hongbin is attending, is he?
16:42:45 * adrian_otto takes a moment to look at the registration list
16:42:54 <Tango> He is coming to the midcycle, en route right now
16:44:13 <adrian_otto> he is on the registration list
16:44:22 <adrian_otto> ok, good, Tango
16:45:06 <adrian_otto> let's put names on each of these
16:45:59 <adrian_otto> who can speak to ironic integration?
16:46:33 <adrian_otto> https://github.com/openstack/magnum/blob/master/magnum/templates/heat-kubernetes/kubecluster-fedora-ironic.yaml
16:46:36 <adrian_otto> has three contributors
16:46:41 <adrian_otto> I'll volunteer Hongbin
16:47:34 <adrian_otto> ok, that looks good enough for now
16:47:45 <adrian_otto> feel free to make additional agenda suggestions in the etherpad
16:47:54 <adrian_otto> I will do my best to fit everything in
16:48:13 <adrian_otto> I did plan in "Parking Lot" time to discuss topics that come up in the coarse of our day
16:48:19 <adrian_otto> corse
16:48:32 <adrian_otto> spelling today, sheesh.
16:48:47 <adrian_otto> c o u r s e
16:49:00 <adrian_otto> #topic Open Discussion
16:49:28 <daneyon> any updated on when the goog team will start participating?
16:49:32 <daneyon> updates
16:50:31 <adrian_otto> daneyon: good question
16:50:38 <adrian_otto> I'll follow up with them right now
16:51:20 <daneyon> ok, thx
16:51:43 <suro-patz> don't we have a conflict of Network sub-team meeting and mid-cycle day2? Do we have a plan to merge?
16:52:02 <suro-patz> daneyon: adrian_otto: ^^
16:52:39 <sdake> morning
16:52:45 <adrian_otto> hi sdake!
16:53:12 <adrian_otto> I wanted to check to see if you are wiling to chair our team meeting on 2015-08-25?
16:53:31 <adrian_otto> I will be traveling in order to attend OpenStack Silicon Valley
16:53:47 <adrian_otto> oh, I will be giving a Magnum update in the keynotes at that event.
16:54:01 <adrian_otto> hopefully that gets recorded on youtube somewhere.
16:54:23 <jjfreric> ^ Looking forward to that!
16:55:51 <adrian_otto> #link http://sched.co/3nvy Containers: A Rapid-Fire Reality Check
16:57:11 <adrian_otto> jjfreric: will you be in our audience?
16:57:34 <jjfreric> Remote, yes :)
16:58:18 <daneyon> 2 min warning
16:58:32 <jjfreric> I'll be in and out throughout the day. I couldn't shake the daily commitments :)
16:59:03 <daneyon> suro-patz let me double check the schedules and i'll make changes if needed.
16:59:18 <adrian_otto> time for us to wrap up
16:59:43 <adrian_otto> our next team meeting is 2015-08-11 at 2200 UTC. See you then!
16:59:52 <adrian_otto> #endmeeting