22:00:54 <adrian_otto> #startmeeting containers
22:00:55 <openstack> Meeting started Tue Sep  8 22:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:58 <openstack> The meeting name has been set to 'containers'
22:01:02 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-09-08_2200_UTC Our Agenda
22:01:06 <adrian_otto> #topic Roll Call
22:01:07 <adrian_otto> Adrian Otto
22:01:08 <daneyon_> o/
22:01:11 <apmelton_> o/
22:01:12 <tcammann1> hullo
22:01:12 <rlrossit> o/
22:01:13 <dane_leblanc> o/
22:01:16 <sew1> o/
22:01:17 <suro-patz> o/
22:01:17 <eghobo> o/
22:01:18 <muralia> murali allada
22:01:19 <Tango> Ton Ngo
22:01:21 <ctrath> o/
22:01:28 <yuanying-alt> o/
22:01:28 <sew1> sew1: steven wilson
22:02:00 <humble_> o/
22:02:03 <humble_> wanghua
22:02:21 <adrian_otto> hello daneyon_ apmelton_ tcammann1 rlrossit dane_leblanc sew1 suro-patz eghobo muralia Tango ctrath yuanying-alt and humble_
22:02:26 <vilobhmm_11> o/
22:02:31 <dimtruck> o/
22:02:34 <muralia> hey hey
22:02:46 <hongbin> o/
22:02:54 <adrian_otto> hello vilobhmm_11 dimtruck and hongbin
22:03:05 <vilobhmm_11> hello !
22:04:07 <adrian_otto> #topic Announcements
22:04:19 <adrian_otto> I have one
22:04:32 <adrian_otto> I have a favor to ask of you all
22:04:56 <adrian_otto> I want a heat resource for magnum bays like this: https://review.openstack.org/193174
22:04:57 <rods> o/
22:05:03 <adrian_otto> hello rods
22:05:29 <adrian_otto> so please see if you can help get that code merged, or propose other code that's better, or adopt that patch, and submit a revision
22:05:49 <adrian_otto> this may not seem like a big deal, but it's pretty important
22:05:53 <humble_> I can help
22:06:01 <adrian_otto> cool, thanks
22:06:05 <hongbin> adrian_otto: I think heat is already in code freeze
22:06:08 <adrian_otto> the Solum team also wants this
22:06:17 <devkulkarni> +1 adrian_otto humble_
22:06:36 <adrian_otto> well, then let's find a way around that in a feature branch or something
22:06:52 <adrian_otto> that's my big ask for the day
22:07:04 <adrian_otto> that concludes announcements form me… any announcements from team members?
22:07:34 <muralia> I've opened 2 new blueprints. i'd like to discuss that during open discussion.
22:07:36 <adrian_otto> then I will hand it over to daneyon_
22:07:39 <adrian_otto> #topic Container Networking Subteam Update
22:07:42 <daneyon_> thx
22:08:01 <adrian_otto> muralia: ok, I will call on you
22:08:03 <daneyon_> dur last week's network subteam meeting, we covered the same topics as the prior week
22:08:16 <daneyon_> spent time going through the kuryr design spec
22:08:25 <daneyon_> i think we are providing good input
22:08:34 <daneyon_> and helping guide the spec
22:08:44 <daneyon_> i think the biggest news is...
22:08:58 <daneyon_> that i have all the magnum container networking model patches working
22:08:59 <adrian_otto> is kuryr going to materialize in the next month?
22:09:22 <adrian_otto> because it made it into the Summit program as vaporware, and it would be really great if it worked by then
22:09:26 <daneyon_> so i am now able to instantiate a k8s bay using the flannel network-driver and pass in heat params using labels
22:09:47 <Tango> daneyon_: +1
22:09:50 <daneyon_> i have successfully tested all 3 flannel params, changing their defaults through --labels and everything works
22:10:03 <adrian_otto> daneyon_: sweet!
22:10:12 <daneyon_> i need to clean up the reviews, tests and make sure i go through the review logs and address everyone's comments
22:10:30 <daneyon_> i'm hoping to pull WIP off the patches in the next 2 days
22:10:58 <daneyon_> dane_leblanc was a big help in getting the patches over the final hump
22:11:18 <daneyon_> kuryr is doing a virtual spring today and tomorrow
22:11:21 <daneyon_> i was unable to attend
22:11:38 <daneyon_> and i believe dane_leblanc has issues dialing in/using the g+ hangout
22:11:39 <adrian_otto> a virtual meetup?
22:12:02 <daneyon_> s/spring/sprint/
22:12:27 <daneyon_> they created the virtual sprint since they did not have a midcycle
22:12:36 <dane_leblanc> Yes, it wasn't clear to me what the starting time was, and the g+ hangout didn't seem to be started when I tried this morning
22:13:23 <daneyon_> otherwise gsagie and i are coordinating a meeting to clean up the magnum/kuryr integration etherpad.
22:13:35 <adrian_otto> ok, super! Any more for the Network Subteam?
22:13:35 <daneyon_> create bp's from the etherpad, etc..
22:13:40 <daneyon_> nada
22:13:49 <adrian_otto> Review Action Items
22:13:53 <adrian_otto> #topic Review Action Items
22:14:01 <adrian_otto> 1) adrian_otto to follow up with magnum-ui cores to inspire faster progress
22:14:07 <adrian_otto> Status: COMPLETE
22:14:25 <adrian_otto> (all cores got a nudge email saying we really need action)
22:14:42 <adrian_otto> if you care about seeing a magnum-ui component by Tokyo, now is the time to activate
22:15:04 <adrian_otto> Brad Jones will join a bit later to offer an update
22:15:13 <adrian_otto> 2) rlrossit Add documentation that clearly defines how to bump object versions, and reference the location of those instructions in related unit test errors so they can be easily located.
22:15:18 <adrian_otto> Status: COMPLETE
22:15:24 <adrian_otto> #link https://review.openstack.org/220539 Add documentation for testing objects
22:15:38 <adrian_otto> that concludes action items
22:15:42 <adrian_otto> #topic Blueprint/Bug Review
22:15:45 <rlrossit> thanks for the reviews on that guys :)
22:15:57 <adrian_otto> before I start, there are a lot of really old reviews in the review queue
22:16:11 <adrian_otto> and after I poked about 10 of them… I have decided this..
22:16:30 <adrian_otto> if I find a review that has no revisions in the past 7 days, I'm going to abandon it.
22:17:03 <tcammann1> 7 days is a bit extreme
22:17:06 <adrian_otto> so if for whatever reason you have code up for review that has not been revised or is otherwise not ready for merge, please comment on it to explain
22:17:11 <muralia> ya 2 weeks maybe
22:17:20 <adrian_otto> our review queue is rediculoius
22:17:34 <tcammann1> it does need a prune, I agree
22:17:50 <adrian_otto> so I've nudged a bunch, but right now it really needs a good whack
22:17:57 <tcammann1> +1
22:18:19 <adrian_otto> so for today adn tomorrow, that's what I'm planning
22:18:27 <hongbin> nova/heat has some way to auto abandon reviews with no activity
22:18:28 <adrian_otto> and after that we can go back to normal
22:18:38 <hongbin> We can figure out how to do that
22:18:45 <adrian_otto> there used to be auto abandon
22:18:52 <adrian_otto> and that got turned off due to a TC decision
22:19:02 <hongbin> k
22:19:03 <adrian_otto> and some projects have since re-added it
22:19:25 <adrian_otto> the difference is now that the PTL can abandon for you
22:19:40 <adrian_otto> so one thing I wnat to be very clear about
22:19:52 <adrian_otto> if I abandon your patch, that is NOT the same as a -2 vote
22:20:20 <adrian_otto> it just means that I'm making the decision that your patch should not be considered by other reviewers until it sees a revision.
22:20:32 <adrian_otto> and I'll do my best to explain that in the comment field when I do it
22:20:45 <adrian_otto> ok, on to updates...
22:21:08 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/objects-from-bay Obtain the objects from the bay endpoint (vilobhmm)
22:21:16 <vilobhmm_11> Object from Bay : https://review.openstack.org/#/c/213368/ (read/write path for replication controller) ; https://review.openstack.org/#/c/220344/2
22:21:34 <vilobhmm_11> since sdake has proposed this blueprint intitially
22:21:37 <vilobhmm_11> and he is not well
22:21:43 <vilobhmm_11> as I came to know in the morning
22:21:49 <vilobhmm_11> would appreciate one of the cores
22:22:06 <vilobhmm_11> to have a look at the patch and see if it satisfies the vision he had for the patch
22:22:12 <vilobhmm_11> blueprint
22:22:30 <vilobhmm_11> if so then I can submit patches for service/pods
22:22:45 <adrian_otto> sorry to hear about sdake
22:23:53 <adrian_otto> ok, looks like Hongbin has a series of good questions there in the review comments
22:24:12 <vilobhmm_11> that is for https://review.openstack.org/#/c/220344/2  adrian_otto
22:24:37 <vilobhmm_11> https://review.openstack.org/#/c/213368/ (read/write path for replication controller) and the patches for service/pods should be the answer for them IMHO
22:24:58 <hongbin> I forgot which one I have commented for :)
22:25:20 <vilobhmm_11> will be nice to work with hongbin on this…atleast if the proposed approach seems good
22:25:49 <hongbin> sure. I will get back to the reviews
22:25:54 <vilobhmm_11> hongbin : thanks
22:26:03 <vilobhmm_11> adrian_otto : thats it from my side
22:26:13 <adrian_otto> thanks Vilobh
22:26:29 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes Secure the client/server communication between ReST client and ReST server (madhuri) (apmelton_)
22:27:33 <apmelton_> nothing specifically on k8s, working through swarm at the moment...
22:28:04 <adrian_otto> in that case, let's update
22:28:04 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-docker Secure client/server communication using TLS (apmelton)
22:28:43 <adrian_otto> the full TLS implementation has been posted for review
22:29:01 <adrian_otto> tcammann1: you had a -2 vote on one related contribution that used a temp file
22:29:23 <adrian_otto> my suggestion was to merge it with technical debt. Thoughts?
22:29:54 <humble_> I think it works
22:29:56 <humble_> as glance
22:30:08 <humble_> have a driver to store image in file
22:30:21 <humble_> we can  change it to db later
22:30:25 <adrian_otto> https://review.openstack.org/207324
22:30:32 <adrian_otto> #link https://review.openstack.org/207324
22:32:16 <adrian_otto> apmelton_: any other update on TLS related work?
22:32:40 <apmelton_> nope
22:32:57 <apmelton_> I'm trying to figure out how to update the dependency tree for secure-docker
22:33:10 <adrian_otto> ok, do we feel like we are in a good situation with TLS support?
22:33:32 <adrian_otto> the only way I know is to check out the patches in the order you want them dependant
22:33:38 <yuanying-alt> one thing
22:33:43 <adrian_otto> and then check them in
22:33:57 <yuanying-alt> project-config isn't merged
22:33:58 <adrian_otto> by patching the first chekcout
22:34:07 <yuanying-alt> so please give +1 to it
22:34:10 <apmelton_> there we go
22:34:25 <adrian_otto> yuanying-alt: do you have a link to it?
22:34:32 <apmelton_> that WIP review on the whiteboard is what I'm working on right now
22:34:33 <yuanying-alt> #link https://review.openstack.org/#/c/216933/
22:34:41 <yuanying-alt> this needs core's +1
22:34:54 <adrian_otto> I did +1 it.
22:35:08 <adrian_otto> so did Hongbin
22:35:19 <adrian_otto> that should be enough, right?
22:35:46 <yuanying-alt> maybe,
22:36:05 <adrian_otto> looks to me like it just needs one more project-config core to +2,+A it
22:36:41 <adrian_otto> is project-config in feature freeze too?
22:36:54 <hongbin> no idea
22:37:20 <yuanying-alt> me too
22:37:22 <hongbin> dims__: do you have any idea?
22:38:57 <hongbin> My guess is no, since it is not under openstack namespace
22:39:56 <adrian_otto> #action adrian_otto to follow up with project-config cores to ask if we can arrange to merge https://review.openstack.org/216933
22:40:07 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/external-lb Support the kubernetes service external-load-balancer feature (Tango)
22:40:54 <Tango> I had a good chat with Angus, got some pointers, and emailed him the details on what I found
22:41:16 <adrian_otto> Tango: work items 5-8 are marked INPROGRESS. Is that still accurate?
22:41:23 <Tango> He said he has some time available in the next few days to help
22:42:06 <Tango> adrian_otto: There are patches for them
22:42:08 <adrian_otto> last week you indicated that there were upstream concerns in k8s
22:42:17 <adrian_otto> have those concerns been addressed?
22:43:05 <Tango> Hmm, not sure what I said
22:43:50 <adrian_otto> so are we close to having this working?
22:43:58 <adrian_otto> does it work in any test environments?
22:44:10 <Tango> But there are likely bugs that will have to be fixed and go into k8s repo
22:45:01 <adrian_otto> is there any help we should be pulling in besides Angus?
22:45:25 <adrian_otto> I'm worried because we have very little time remaining in this release cycle
22:45:30 <Tango> Angus feels that we probably will uncover some scenarios in Magnum that needs work
22:46:35 <Tango> Manjeet offered to help with some of the patches.
22:46:49 <adrian_otto> ok, one moment, let me pull him in
22:47:28 <Tango> This certainly would help to give me more time to debug the K8S side
22:47:59 <adrian_otto> hello manjeets_
22:48:09 <Tango> Having the V1 upgrade owrk mostly done is also a big help
22:48:09 <manjeets_> hi
22:48:18 <adrian_otto> Tango indicated he could use a hand from you on https://blueprints.launchpad.net/magnum/+spec/external-lb
22:48:37 <adrian_otto> can I assign you two an action to work together this week to break though and get this feature done?
22:48:54 <manjeets_> yes sure
22:49:05 <adrian_otto> #action Tango and manjeets_ to work together to complete https://blueprints.launchpad.net/magnum/+spec/external-lb
22:49:10 <Tango> Sure
22:49:16 <humble_> Tango: do you need help in v1 upgrade work
22:49:20 <adrian_otto> excellent. it's one of our essential blueprints, so we need to wrap it up ASAP
22:49:25 <manjeets_> I am preparing for move to san antonio this pls update it so that I can finish by friday
22:49:45 <hongbin> For the v1 upgrade, I do need help to test the patch
22:49:52 <hongbin> #link https://review.openstack.org/#/c/207299/
22:50:03 <adrian_otto> Manjeet is going to the OpenStack Innovation Center in San Antonio!
22:50:10 <humble_> hongbin: I will test it
22:50:17 <hongbin> humble_: thx
22:50:22 <adrian_otto> thanks humble_!
22:51:07 <adrian_otto> that's it for blueprints and bugs today… except for two form muralia that will be mentioned in Open Dicsussion
22:51:15 <muralia> thanks adrian
22:51:16 <adrian_otto> #topic Magnum UI Subteam Update (bradjones)
22:51:26 <bradjones> hi all
22:51:41 <bradjones> initial repo is still out for review
22:51:57 <bradjones> I have solved the requirements issues that were making jenkins do funny things :)
22:52:18 <bradjones> really need that patch to land ASAP so there is something in the repo
22:52:33 <bradjones> I have patches ready to push for both Bay and Baymodel table views
22:52:40 <adrian_otto> bradjones: my attitude about early commits in that repo is that they should be quick and dirty, and we should iterate on them to improve it.
22:52:51 <adrian_otto> let's not worry about making it perfect on our first try
22:53:21 <adrian_otto> !! sweet news about the table views
22:53:21 <openstack> adrian_otto: Error: "!" is not a valid command.
22:53:22 <bradjones> I think the patches I have ready will make a good starting point but certainly will need some iteration
22:53:31 <adrian_otto> sweet news about the table views
22:53:57 <hongbin> bradjones: I have +2 on the review
22:54:28 <bradjones> hongbin: great thanks
22:54:49 <bradjones> I will pester other cores to review tomorrow
22:54:54 <hongbin> #link https://review.openstack.org/#/c/211750/
22:54:59 <adrian_otto> thanks bradjones
22:55:29 <adrian_otto> yes, hongbin, that's the one we need to get merged, even if it has issues
22:55:40 <hongbin> agree
22:55:58 <adrian_otto> without the skeleton there, we are signaling to contributors not to consider working on it yet
22:56:08 <adrian_otto> so any -1's should just open bugs against it
22:56:08 <bradjones> the only thing that might still need to change is to move all tests to tox from run_test but even if we merge now we can change that after the fact
22:56:21 <adrian_otto> exactly
22:56:40 <adrian_otto> thanks bradjones for the update. We look forward to more from you soon!
22:56:45 <adrian_otto> #topic Open Discussion
22:56:51 <adrian_otto> muralia: you go now!
22:56:54 <muralia> Thanks.
22:56:57 <manjeets_> bradjones: i have one suggestion regarding your patch
22:57:09 <bradjones> manjeets_: fire away
22:57:22 <muralia> I create 2 new blueprint last week. they are pretty straight forward. I'd like everyone to take a look and to give feedback.
22:57:27 <muralia> this is the first one https://blueprints.launchpad.net/magnum/+spec/public-baymodels
22:57:42 <muralia> this is to support operator created, public baymodels
22:57:55 <manjeets_> https://review.openstack.org/#/c/211750/ commit message just says initial skelton repo can you brief introductory paragraph
22:58:05 <manjeets_> can you add*
22:58:21 <adrian_otto> looks great. I have approved the direction
22:58:36 <adrian_otto> you may submit patches against that BP
22:58:42 <muralia> the other is to make keystone pluggable, so operators who are still using keystone v2 can work with magnum. https://blueprints.launchpad.net/magnum/+spec/pluggable-keystone-model
22:58:47 <bradjones> manjeets_: sure I'll get on that, good suggestion
22:58:59 <adrian_otto> humm, that one might need more discussion
22:59:05 <humble_> I have started a ml to discuss keystone version problem
22:59:06 <adrian_otto> let's open an ML thread for that
22:59:15 <muralia> for the keystone one?
22:59:18 <adrian_otto> thanks humble_
22:59:24 <adrian_otto> yes, the keystone one
22:59:27 <muralia> sure
22:59:39 <humble_> I seems keystone want to deprecate v2 version
22:59:47 <adrian_otto> may need some more detailed explanation of various viewpoints/interests
22:59:49 <muralia> do blueprints need to be approved before i submit a patch?
22:59:57 <vilobhmm_11> yes thats what keystone cores replied in that ML conversation
23:00:06 <adrian_otto> sorry we did not have more time for open discossion today
23:00:35 <muralia> humble_ a lot of operators still use keystone v2. we at rackspace do.
23:00:36 <adrian_otto> Our next meeting is on Tuesday 2015-09-15 at 1600 UTC. See you all then!
23:00:37 <humble_> everyone can reply on the ml for this problem
23:00:47 <adrian_otto> #endmeeting